PDA

View Full Version : HLDS Problem: server was unable to contact auth server


Dark-Master
06-04-2007, 12:38 PM
I got this message after HLDSs started.

"Could not establish connection to Steam servers."

And this msg when the client connected to the server ... "server was unable to contact auth server" (Disconnected)

I knew that all those happened because of my server's connection.

I'm Co-Locating my server @ some ISP in Thailand that doesn't have direct International Internet Connection , they let their customer connect to International Site by using the proxy................so my server can't connect to Steam Server.

I've tried to use Socks/Proxy for HLDSs ...... but it's worked only for outgoing connection(like patching/updating) but they can't listen any incoming connection ......... so client can't connect to the server by this way.


The thing I need is .........

Is there anyway to disable the Auth Server Communication ?

If not ......... how can I make my HLDSs connect to steam server by Socks/Proxy and they are still ABLE to listen their port and let the clients to connect.

Or ............... Thebest way is switching to other Co-Location ISP ????:eek:


ps. sorry if my English is bad.

CG1
06-04-2007, 01:37 PM
Proxy servers don't allow inbound connectivity, they are similar to a NAT firewall. You can only disable Steam authentication by using LAN mode, but then you wouldn't be able to connect to it unless you were on the same subnet.

Dark-Master
06-04-2007, 04:38 PM
Thanks a lot ........ very clear answer.

Then..........I have to switch to other ISP:rolleyes: