PDA

View Full Version : Client.dll failed to init


sslice
07-04-2007, 12:50 AM
In an unmodified mod codebase compiled on MS VS2005, I get a strange when I try to run the mod. The client.dll failed to load in Init().. after putting it in the debugger I tracked it down to not finding the ISceneCacheFile interface. The gameinfo.txt is setup correctly with 215 as appid and with sourcetest and hl2 as search directories. After an hour or so with fiddling with the code, I tried using another mod's client.dll (Insurgency) to see if it would get any further, and it did... I find it strange that an unmodified codebase would act like this, though; this is straight from the Source SDK (Tried Mod From Scratch and Source Code Only). I also spent a good amount of time trying to search for someone else encountering the same problem, but found absolutely nothing.

Thanks to anyone who replies! I know this is a mess.

-James

John6000
07-04-2007, 09:50 AM
Try cleaning all Steams registry keys from the windows registry

sslice
07-04-2007, 10:20 AM
Wow, that worked! Very strange problem. Hopefully now anyone with the same problem can figure it out.

Thank you very much, John.

lesfundi
07-10-2007, 12:37 PM
how do you do that the cleaing proces?