PDA

View Full Version : chapter ttiles not displaying properly


Geowil
07-07-2007, 01:54 PM
followed this guide:

http://tutorials.moddb.com/106/complete-guide-for-customizing-a-single-/

my <modname>_english.txt



"lang"
{
"Language" "English"
"Tokens"
{
"CombineInsurrectionDemo_Chapter1_Title" "City 25"
}


In game it shows in the new game menu as "#combine insurrection demo chap (chapter title 1 would probably be the rest)."

dont understand why its not working for xD.

I tried inverting the tokens also, still didnt fix it.

Is this set somewhere else that might be conflicting with it?


ALSO, is there a way to get rid of that #hl2 box at the top of the new game menu?

Penumbra
07-09-2007, 07:24 AM
Are you sure you copied this file from an already existing language.txt?
You must copy it and only edit it with Notepad, since it must be in a uni-code format (instead of the 'normal' ASCII).

It should then work... (if it's in the proper directory :p )

Penumbra
07-09-2007, 07:28 AM
OH, and yes.

In game (when you opened the window in question), press <Ctrl>+<Shift>+<Alt>+<B> to open the VGUI editor. Here you can add and position basic VGUI objects.

For now, only press the 'save' button and close the game. In your resource directory, there should be a file called "NewGameDialog.res". Open it and find the commentary section (I think this is the bugger you're talking about). You delete or comment it out of the res file and the problem should be solved!

:cool:

Geowil
07-09-2007, 09:10 AM
ok, heres what i have so far. I remade the demo mod folder thinking it could be the name itself, so heres what i have now:

combineinsurrectiondemo_english.txt


"lang"
{
"Language" "English"
"Tokens"
{
"combineinsurrectiondemo_Chapter1_Title" "City 25"
}
}



titles.txt file:

version 1:


CHAPTER1_TITLE
{
"#combineinsurrectiondemo_Chapter1_Title"
}


version 2:


CHAPTER1_TITLE
{
"City 25"
}



the result:

http://i15.photobucket.com/albums/a367/Geowil/chapterissue.jpg

illl check out that vgui editor when i get hime from work today xD, thanxs for that, i just need to get the damn chapters working now lol.

Penumbra
07-10-2007, 05:24 AM
In your result there are spaces!!!!???!!!! :confused:

That's weird.. Check to make sure there are no whitespaces in the text files.

Geowil
07-12-2007, 07:10 PM
That's weird.. Check to make sure there are no whitespaces in the text files.

nope, just to be sure i deleted out the few 'spaces' from between the lang file and tabed it but still came out with the same result.

Marine
07-12-2007, 09:21 PM
dont, remove all tabs and try again

Geowil
07-13-2007, 08:58 PM
dont, remove all tabs and try again

this is how it looks now:



"combineinsurrectiondemo_Chapter1_Title""City 25"


i also tried it with the "City 25" first but still the same result.

Penumbra
07-14-2007, 05:40 AM
OK, try to create 2 tabs between the variable name and the value. I thought this was standard for the parser... Maybe it helps when tabs are applied.

So:
"combineinsurrectiondemo_Chapter1_Title" "City 25"

Geowil
07-14-2007, 08:17 AM
ok, i tried that, still shows up like that screen shot i took, also, i commented out the commentary block in the newgamedialog.res but its still showing the box... <.<

i think its not reading the folder correctly, should i try one from scratch and see?


ALSO, does the name of the lang file have to match the name of the mod folder exactly?

Geowil
07-14-2007, 09:18 AM
sorry for double posting but i finally got the ??????? to work xD.

it was looking for spaces in the file name and the lang file code.

so i changed the file name to

combine insurrection demo_english.txt


and the lag fine stuff to


"combine insurrection demo_Chapter1_Title" "City 25"


and the titles i set back to:


CHAPTER1_TITLE
{
#hl2_Chapter1_Title
}


but i still see that damn #hl2 box <.<

Penumbra
07-15-2007, 04:25 AM
In the res-file for the new game dialog, you can also set the visibility of the objects. Search for the commentary box and set visibility and enabled to 0.

This is instead of commenting it out... :cool: