PDA

View Full Version : Terrible mouse control in Deus Ex


Arctic-Cat
04-27-2008, 03:37 PM
This has been frustrating me as I know I've fixed this before, but it's been so long that I can't remember how. Basically, mouse control in this game is bad unless I enable Direct Input. The only problem with that is I cannot navigate the game menus to access my inventory and such as the mouse at this point remains frozen and won't move. It only works in-game itself.

Without Direct Input, the mouse has a hard time with diagonal movement, they feel labored and inconsistent. I have tried checking and using many things. Enhance pointer precision is off in Windows, Have tried the registry change to mouse curve fields, and have latest mouse drivers.

Not really worth mentioning system specs because it was built just a year ago. But I do use Windows XP SP2 and Razer Copperhead for the mouse. I can't play until I have a way to improve the response. If there is some way I can get the mouse to work in menus with Direct Input on, I would be set. What really gets me though is that I have played other UT engine games, including UT itself and they don't have this problem at all, even with Direct Input turned on.

spencer'
04-27-2008, 11:21 PM
I have this exact same problem, with the mouse feeling sluggish in diagonal movements. in a lot of old games, incredibly annoying.

Arctic-Cat
04-28-2008, 08:41 AM
I was actually quite successful with the game on the older computer, which uses same operating system, but a different mouse, which would be an old Microsoft Wheel Optical. I'm not quite sure if the Razer itself would be the problem but I'll have to modify some settings with it to see if it changes anything. Otherwise, I may just have to play it on the older system.

spencer'
04-29-2008, 02:41 PM
there's a way to make it work, but it'll turn off the mouse in menus (use the keyboard)

access the advanced options (in a game, press T to talk, erase the "say:" and instead write preferences, it'll bring you there, GOD that's ghetto) and in Display turn on DirectInput.

old games are so ridiculously stupidly-designed, I'll never believe it.

Arctic-Cat
05-01-2008, 07:48 PM
there's a way to make it work, but it'll turn off the mouse in menus (use the keyboard)

access the advanced options (in a game, press T to talk, erase the "say:" and instead write preferences, it'll bring you there, GOD that's ghetto) and in Display turn on DirectInput.

old games are so ridiculously stupidly-designed, I'll never believe it.

I'm already aware of this as I had mentioned in my first post. I cannot navigate my inventory using a keyboard. This unfortunately does nothing for me.

BababooeyHTJ
07-25-2009, 09:25 PM
I have to bump this.

I'm having the same problem. Directinput works fine for me in UT and Unreal but in Deus Ex I can't use my mouse in menus. Anyone know a workaround?

neuromancer
07-26-2009, 10:26 AM
There are no fixes aside from the DirectInput one.

If you have a Logitech mouse you can add the DeusEx.exe file to the Setpoint advanced game settings and make sure that Game Detection is enabled and the keep acceleration settings box is checked. For me it greatly reduces the acceleration effect though it doesn't remove it completely.

Seau
07-28-2009, 03:19 PM
This issue has indeed to do with mouse acceleration. In windows XP, there is no built-in option to completely turn of acceleration. However, the CPL mouse fix (http://www.techpowerup.com/downloads/763/CPL_Mouse_Fix.html) can turn off mouse acceleration forever for all games (only XP).

It made my Deus Ex playable. Be aware that this will turn off acceleration for ALL programs you run in the future. I think it is worth it, mouse acceleration means speed-dependent, unconsistent movement, your gaming will improve without it.

MisterCookie
09-25-2009, 12:18 AM
Is there a way to manage inventory with the keyboard? I've hit pretty much every button and can't figure out how to do it.

Reflection_
09-28-2009, 04:17 PM
It's like F1, F2, F3....one of those buttons

MisterCookie
10-01-2009, 12:02 AM
It's like F1, F2, F3....one of those buttons

So do those assign to a slot or something? Thanks for the reply; I'll try it out when I get home.

SarZ
10-05-2009, 03:35 AM
Cookie, I bet you're from the 'new' generation ? (Not a serious question) You need to use ALT with the underlined letter. So if you entered an ATM to hack it, ALT H will hack it, etc.. It used to be very common in the old games, but it still works in programs like Word. ALT S is still "save document" :-)
For the rest, TAB works too to switch from button to button. However, how to swap items in the inventory, I have no idea without the mouse. I guess your best bet is to use the mouse to get the inventory you want, and then activate the DirectInput option after.

Ben.EEeee
10-05-2009, 06:20 PM
I don't know if it's relevant but my mouse movement felt funny when my screen resolution did not fit my widescreen native resolution. I downloaded the DirectX 9/Open GL fix and everything became as smooth as when I first played this game when the internets was still young and Genghis Khan roamed the steepes.

Try this: http://kentie.net/article/dxguide/index.htm

Taikis
10-15-2009, 04:35 AM
The reason this happens in many old games is because many are based on the unreal engine. Damn you Unreal.

BababooeyHTJ
01-02-2010, 02:16 PM
The reason this happens in many old games is because many are based on the unreal engine. Damn you Unreal.

This doesn't happen when you enable Directinput with Unreal.

contracausal
02-16-2010, 03:00 PM
I commiserate with those experiencing "labored, inconsistent diagonal movement" in Deus Ex. Please try the following steps:

- Decrease the mouse polling rate. Newer gaming mice will often have the capability within their driver to adjust the polling rate. It may be set at something like 500/s; try decreasing it to the 80-125 range.

- Disable "enhanced pointer precision" in the Windows mouse settings and "pointer acceleration" in the mouse driver settings.

- Within Deus Ex, decrease the mouse sensitivity to "1," the lowest setting. Then, compensate as necessary by: a) increasing the pointer speed in the Windows mouse settings, or b) increasing the DPI in your mouse driver settings, or c) increasing the pointer speed in your mouse driver settings.

Please let us know if this does, or does not, help with your diagonal movement issue in Deus Ex.

Boltersdriveer
03-19-2010, 02:35 AM
I commiserate with those experiencing "labored, inconsistent diagonal movement" in Deus Ex. Please try the following steps:

- Decrease the mouse polling rate. Newer gaming mice will often have the capability within their driver to adjust the polling rate. It may be set at something like 500/s; try decreasing it to the 80-125 range.

- Disable "enhanced pointer precision" in the Windows mouse settings and "pointer acceleration" in the mouse driver settings.

- Within Deus Ex, decrease the mouse sensitivity to "1," the lowest setting. Then, compensate as necessary by: a) increasing the pointer speed in the Windows mouse settings, or b) increasing the DPI in your mouse driver settings, or c) increasing the pointer speed in your mouse driver settings.

Please let us know if this does, or does not, help with your diagonal movement issue in Deus Ex.

Amazingly, mine worked when I turned DirectInput off. It is a Microsoft X5 Sidewinder Gaming Mouse, FYI. Quite new. Didn't expect this option. Thought it was my Direct 3D 10 Driver that caused it. hehe.

ontelo
04-20-2010, 05:39 PM
Check that following settings are like this:

DeusEx.ini:
CaptureMouse=False

User.ini:
MouseSmoothThreshold=0.000000


Removed my jaggy mouse.

placeboing
04-25-2010, 11:34 PM
Hopefully someone finds a way to get the menu to work.

Daverwob
04-26-2010, 03:44 AM
Do you guys not read? CPL mouse fix WORKS, for every operating system. People have said so in this very thread, and there are a couple more threads about it on the main page.

oceanclub
06-24-2010, 05:15 AM
Do you guys not read? CPL mouse fix WORKS, for every operating system. People have said so in this very thread,

Actually, in the thread, it is said that it only works on XP:

"However, the CPL mouse fix can turn off mouse acceleration forever for all games (only XP)."

For Windows 7, there is a new fix available - the MarkC Windows 7 Mouse Acceleration Fix - but I haven't tested it myself yet, so buyer beware:

http://donewmouseaccel.blogspot.com/2010/03/markc-windows-7-mouse-acceleration-fix.html

EDIT: Just tested it - hurrah, it works! Definitely zero mouse acceleration now in Deus Ex on Windows 7 with MarkC's reg patch.


P.

sPIT_FireTUX
10-03-2010, 01:24 PM
Hi. I'm have a mouse problem but its on click. Sometimes I have to presse many times to make an action or shoot. Doing the same on keyboard, works fine.
Some idea?

P.s: I don't have the speed/movement or the menus problem and this problem just happen in this game.

Silphatos
10-09-2010, 02:25 PM
Check that following settings are like this:

DeusEx.ini:
CaptureMouse=False

User.ini:
MouseSmoothThreshold=0.000000


Removed my jaggy mouse.

This helped me a lot, thanks.

goldaryn
11-25-2010, 06:37 AM
i have had this issue on XP and 7 and fixed it in both

XP: google for WCAfix, run
7: use the custom exe on kentie.net (http://kentie.net/article/dxguide/)