PDA

View Full Version : Clean shutdown of srcds


zumbuschk
08-04-2008, 12:27 PM
Hi.

I just reinstalled srcds on Debian Lenny after a while and recognized that it's still not possible to shutdown the server cleanly. If I enter the "quit" command at the server command prompt I'll get a segmentation fault at line 344 in srcds_run. If the server was started without the "norestart" parameter the server is restarted after 10 seconds. I have to kill the process with CTRL+C. I don't have any additional plugins installed.

Is there any command to shutdown the server cleanly without triggering the restart procedure? The server should still restart on failure.

I start the server with the follwing command:

./srcds_run -debug -port 27016 -game cstrike -maxplayers 20 -insecure -nomaster +sv_lan 1 +mp de_dust

Kind regards

Kay Zumbusch

Raid-XT
08-31-2008, 02:51 AM
i think its because of the debug command.

my launch options ./srcds_run -console -game cstrike -port 27016 +ip mynetworkip +map de_dust2 +maxplayers 16 -tickrate 100 &
this way my server dont restart
and when i add the "-autoupdate" command ./srcds_run -console -autoupdate -game cstrike -port 27016 +ip mynetworkip +map de_dust2 +maxplayers 16 -tickrate 100 &
then the server reboots when i enter rcon quit, but i usually turn off the server thu my admin control pannel in my process list (i use webmin free web based server admin and SSH access)

grtz

Nathan D.
09-06-2009, 03:09 AM
Hi.

I just reinstalled srcds on Debian Lenny after a while and recognized that it's still not possible to shutdown the server cleanly. If I enter the "quit" command at the server command prompt I'll get a segmentation fault at line 344 in srcds_run. If the server was started without the "norestart" parameter the server is restarted after 10 seconds. I have to kill the process with CTRL+C. I don't have any additional plugins installed.

Is there any command to shutdown the server cleanly without triggering the restart procedure? The server should still restart on failure.

I start the server with the follwing command:

./srcds_run -debug -port 27016 -game cstrike -maxplayers 20 -insecure -nomaster +sv_lan 1 +mp de_dust

Kind regards

Kay Zumbusch

I'm having the same problem. Exact same line number as well. My start up command is:

./srcds_run -console -game cstrike +map maphere +maxplayers 24 -autoupdate +ip iphere -tickrate 100

Anybody got any ideas?

OS: CentOS 5.2 64Bit

cryptodan
09-06-2009, 06:15 AM
I use Ubuntu and I use exit to quit.

Nathan D.
09-06-2009, 06:18 AM
Exit quits for me and will restart the server but after 2 or 3 exits, the restart never completes and I have to stop and start the server manually again. I assume the error I'm receiving is the reason.

cryptodan
09-06-2009, 06:23 AM
Exit quits for me and will restart the server but after 2 or 3 exits, the restart never completes and I have to stop and start the server manually again. I assume the error I'm receiving is the reason.

srcds@capricorn:~/srcds/source$ ./srcds_run -game cstrike +map de_dust2 +ip 192.168.1.2
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
Network: IP 192.168.1.2, mode MP, dedicated Yes, ports 27016 SV / 27005 CL
Executing dedicated server config file
Incorrect price blob version! Update your server!
ERROR: mp_dynamicpricing set to 1 but couldn't download the price list!
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
appdatacache.cpp (311) : Assertion Failed: !"Implement me"
couldn't exec server.cfg
Adding master server 72.165.61.189:27011
Adding master server 68.142.72.250:27011
Connection to Steam servers successful.
VAC secure mode is activated.
exit
Sun Sep 6 12:21:46 GMT 2009: Server Quit

srcds@capricorn:~/srcds/source$ ps auxww | grep srcds
srcds 30702 0.0 0.0 4136 1548 pts/7 S 12:18 0:00 su srcds
srcds 30710 0.0 0.1 5956 3268 pts/7 S 12:18 0:00 bash
srcds 31210 3.0 0.0 2768 1032 pts/7 R+ 12:22 0:00 ps auxww
srcds 31211 0.0 0.0 3340 808 pts/7 S+ 12:22 0:00 grep srcds
srcds@capricorn:~/srcds/source$