PDA

View Full Version : L4D DS and Debian ?


dacaid
12-08-2008, 11:40 PM
Hi,
Got a fresh install of a debian on my dedicated.
Installed L4D in /home
Default settings for test (no server.cfg, doesnt work with one anyway)

Here is what i got :

login as: root

Debian GNU/Linux 4.0

root@ns203259:/home/l4dds/l4d# ./srcds_run -game left4dead +ip (hidden) -port 27017 +map l4d_dem_hospital01_apartment
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.
Failed to open bin/dedicated_i486.so (/lib32/libc.so.6: version `GLIBC_2.4' not found (required by bin/dedicated_i486.so))
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
mardi 9 décembre 2008, 08:33:16 (UTC+0100): Server restart in 10 seconds


Tried to figure out by myself searching threads around (RTFM philosophy), but the only topic found talks about AMD procs, whereas my dedicated is on a C2D proc :confused:

I tried apt-get install libc6 libc6_dev but it installed "2.3.6.ds1-13etch7" and 2.4 needed.

help plz?:(

dacaid
12-09-2008, 04:29 AM
Found on my own

need to update libc6

just search for lenny deposits, update your etc/apt/source.list
and run
apt-get install libc6