PDA

View Full Version : To fix missing lava textures on Therum


Sweetz
01-05-2009, 01:44 AM
---Update---
It appears this this is now fixed for fresh downloads of the game. It looks like they may removed the cached shader files mentioned below from the master download list.

However, it's possible the problem may still be encountered after installing the Bring Down the Sky DLC. Same solution applies.
---

This affects everyone with the Steam version of the game, so if a mod could sticky this so we stop getting posts about it I'd be thankful.

If, when you land on the planet Therum, you're seeing a bunch of black spaces, there is any easy task you can do to fix this.

Cause of Problem:
Mass Effect compiles and caches shaders into special files as needed while the game is running. The first patch for the game included some shader changes that necessitated the shaders being recompiled for the Therum textures to show up correctly. To recompile the shaders, you simply delete the cache files. For whatever reason (probably just a simple accident) when you download the Steam version of the game it already includes cached shader files built on the pre-patch version of the game (it shouldn't include them at all).


To Fix:
There's an automatic and manual way to correct the problem, they both ultimately have the same result of deleting the cached shader files.

To Automatically Delete the Files
On Windows XP: Assuming you have Steam installed to the default directory, navigate to folder: C:\Program Files\Steam\steamapps\common\mass effect\Binaries\ and run MassEffectConfig.exe. On the left hand sidebar, select the Repair option. Click the Delete Local Shader Cache Files button. That's it, you can close the config program and start the game normally.

On Windows Vista: For some reason the Repair option is not available by default in Vista. Navigate to the same folder listed above, and right click on MassEffectConfig.exe and select properties. Go the Compatbility tab activate the checkbox to run in compatiblity mode for Windows XP. Select OK and double-click the EXE as normal. Select Repair and Delete Local Shader Cache Files as above.


To Manually Delete the Files
The file you need to delete is in two different locations.
Delete the file named LocalShaderCache-PC-D3D-SM3.upk in the following directories:

<your user directory>\My Documents\BioWare\Mass Effect\Published\CookedPC\

C:\Program Files\Steam\steamapps\common\mass effect\BioGame\CookedPC\

Windows95
01-05-2009, 09:05 AM
Should also add that when your first launch Mass Effect after deleting the shaders, it will take a few minutes longer to load. Mass Effect needs to recompile the files, but it's a one time process. Don't get nervous if you hear your hard drive thrashing for a few minutes.

Good idea for a sticky though, every couple of threads seems to be about this problem.

Mromson
01-06-2009, 07:01 AM
This should certainly be stickied. It's quite an annoying bug that I don't really expect to be Patched anytime soon...

Sweetz
01-06-2009, 07:59 AM
This should certainly be stickied. It's quite an annoying bug that I don't really expect to be Patched anytime soon...
Not really something to patch, it's just an issue of those files being present. For some reason the Steam install of the game already includes cached shader files. They shouldn't be included, you'd want to them to be created at needed on people's individual machines.

I suspect this gives some insight to how Steam games are packaged. When you download Steam games they're already expanded into their normal directory structure like if you installed the disc version of the game. There's no active install process.

I'm betting the way Steam packages the game is that they actually install the disc version of game, monitor what changes it makes to the system and then they just package that and send it out as the Steam download.

So more than likely they installed the game, did some testing (at which point their own shader cache files were created), and then packaged that up at the Steam version. As a result, the Steam download includes shader cache files.

If anyone from Steam is reading this - you should remove the file LocalShaderCache-PC-D3D-SM3.upk noted above from the Steam install of the game.

Yoshiro
01-06-2009, 08:20 AM
Will sticky for you unless asked to remove. And Bioware or EA provided the build, so direct that at them. Valve uploads what is provided to them.

Sweetz
01-06-2009, 03:30 PM
Will sticky for you unless asked to remove. And Bioware or EA provided the build, so direct that at them. Valve uploads what is provided to them.
I don't really care about assigning blame. All it would take is removal of that file from the game's master file list. That's a 5 minute job and presumably Valve is in the best position to fix it. When something is a 5 minute fix, you don't waste time pointing fingers, you just take care of it.

Fatbubba
01-06-2009, 04:03 PM
Ah thanks for the fix. That one bugged me :)

Keirgo
01-07-2009, 03:31 AM
Yes, it worked!

Im so relieved its fixed, thank you so much Sweetz. Kudos!

shackanaw
03-15-2009, 09:55 AM
Does anyone know if this issue has been resolved yet? That is to say, have the files distributed on Steam been updated to remove the cached shader files, so new installs will not encounter this problem?

Skoll
03-21-2009, 08:12 PM
I still had this problem and I installed the game recently. The solution above worked great. I'm not sure a patch is likely to be released to resolve just this issue.

Goteki-45
03-21-2009, 08:22 PM
There is a patch being worked on, however. With any luck this issue will be one of the things resolved in it :P

Jugglerman
04-01-2009, 05:32 PM
Cool, thanks for the quick-fix.

Dark Fire
04-11-2009, 06:34 PM
I think this effects more than just the Steam version, I bought ME through D2D before it was on Steam and encountered a planet where most of the terrain was black and while traveling you would suddenly fall into a hole with what looked like a little patch of lava at the bottom.

I eventually got through that mission but it was a royal pain in the butt.

I don't recall the planet's name now but from your descriptions, it sounds like the same one.

GIJED
04-25-2009, 03:13 AM
Too bad i already went through Therum before seeing this.

rq60
04-28-2009, 02:33 PM
Too bad i already went through Therum before seeing this.

same here, just did this mission yesterday and it was very annoying. drove off a few cliffs cause i couldn't tell what were pits since everything was black. wish i had checked here for this fix.

should i still do this fix if i'm already passed that mission, does it affect any other part of the game?

veli64
08-08-2009, 08:11 AM
Thank you!

Dagizmo
11-07-2009, 09:42 PM
this also fixed a problem that is having the graphics look ugly even when it were on high, this fixed it =) thx!

ExaltedJim
11-08-2009, 07:36 PM
I can confirm that on Windows 7 you can run the MassEffectConfig.exe application to delete the local shader cache files via the Repair option.

Juc
11-29-2009, 10:55 AM
Is this an issue any more?

I just installed Mass Effect the other day via steam and had nothing in the way of black textures on Therum.

Gvaz
01-19-2010, 07:03 PM
It looks nothing like it does on the 360.

On the 360 it looks like lava, whereas on the pc it just looks like the lava is really low and half molten :|

themires
01-31-2010, 01:27 AM
i see no problem here. i just install the game it all works fine for me

eydeeb
01-31-2010, 03:03 AM
Is this an issue any more?

I just installed Mass Effect the other day via steam and had nothing in the way of black textures on Therum.

It has been fixed in the latest patch.

i see no problem here. i just install the game it all works fine for me

True, this is not a problem anymore.

SunfighterLC
01-31-2010, 08:10 AM
BTW its fixed for me now, but i had this issue too with a CD-version of the game. It was introduced with a patch.

Spectro87
08-28-2010, 03:20 AM
If you have low quality textures in-game, deleting this cache file will also fix that. It is not fixed in the patch. The thread title should be changed to reflect this.

RABicle
02-06-2011, 06:50 AM
Well now that I've done this, the game wont run at all. Awesome :(

int_civ
04-04-2011, 01:44 AM
Is there any way to fix the lack of texture around the eyes of most Turians? Aside from Garrus, most of the Turians have no textures around their eyes, so their eyeballs are just there in a sea of black. This is most obvious with Nihlus and Lork'Quin (sp? the one on Noveria).

The kind of fix listed in this thread looked promising, but alas, did not address this issue.

[edit]
To show what I mean, consider the following images:

Turian Councilor (http://img846.imageshack.us/img846/6506/turiancouncilor.jpg)

and

Garrus in helmet (http://cloud.steampowered.com/ugc/541763649785936916/1139B2791CE531FEE4D5F1C14B7A312075D68652/)

Despite the helmet, you can clearly see membrane around Garrus's eyes, while the Turian Councilor has no texture there.

Sweetz
05-23-2011, 10:57 AM
Is there any way to fix the lack of texture around the eyes of most Turians? Aside from Garrus, most of the Turians have no textures around their eyes, so their eyeballs are just there in a sea of black. This is most obvious with Nihlus and Lork'Quin (sp? the one on Noveria).
That's not really a "bug" - in the sense that I don't think that there's supposed to be a texture in there and it's not showing because of some problem, but rather that they just weren't designed with a texture there to begin with.

Someone might be able to fix that with TexMod and creating their own textures, but based on the limited roles these characters have in the game, I doubt anyone has deemed them worth the effort.

There is a mod for Garrus face being noticeably low-res compared to other characters' faces. You can find that easily enough doing a search.