PDA

View Full Version : sr2_pc.exe has stopped working


lazybones25
01-23-2009, 09:01 PM
Everytime i try to launch saints row 2 i get this message. "sr2_pc.exe has stopped working" Ive already sent in to steam support but they have yet to answer me back. Does anybody know how to fix this? Any help will be appreciated.

Jigoku
01-24-2009, 03:47 PM
I got that when I tried to use the XBOX360 Controller Emulator so that I could use my Logitech gamepad. Is this possibly the problem?

lazybones25
01-24-2009, 07:37 PM
I got that when I tried to use the XBOX360 Controller Emulator so that I could use my Logitech gamepad. Is this possibly the problem?

No I don't think this is the problem. Ive never even tried to use a gamepad with anything. Thanks for trying though.

lazybones25
01-28-2009, 01:07 PM
Can someone help?

Barbalute
01-28-2009, 06:55 PM
As a last resort you could always try reinstalling.

lazybones25
01-29-2009, 05:57 PM
As a last resort you could always try reinstalling.

I've already done that and it still says the same thing.

UntakenUsername
01-30-2009, 11:42 AM
I had this trouble with the XBOX360 pad plugged in, removed it solved part of the problem. However part way through the tutorial (still with XBOX360 pad removed) I get in a car and games craps out again.

Jebus! I've played some bad games and some buggy beta's and this is worse than them all ... COMBINED!

thegamepro
01-30-2009, 12:25 PM
Do you think you could give some of your system info?
GPU? CPU? MOBO? RAM? OS?

I'm thinking about getting this game and am not sure if it will run on my system.

MY PC:
GPU: 8800gts 320mb
CPU: q6600 @2.9ghz
RAM: 4GB (only 3 are usable)
MOBO: EVGA 680i sli
OS: Vista 32bit (all drivers are updated)

lazybones25
01-30-2009, 02:01 PM
My computer is a 64 bit vista. Could that be the problem?

cybson
02-03-2009, 02:38 AM
No, I am using vista x64 as well and I am running the game with no problems at all.

Dutchman_12
02-06-2009, 01:07 PM
I have the same problem. Do you already know the solution?
I hope you can help me

richada41
02-06-2009, 04:13 PM
Same problem as everyone else. I tried reinstalling the game and that didn't help.

Anyone know the answer? Did the latest patch screw things up?

lazybones25
02-07-2009, 10:39 AM
Nope, I still haven't fixed it. Tried THQ tech support but they were helpless. They told me to change my resolution or check if my system requiremtnts are right. They were and i dont see how changing the resolution would help it any way.

lazybones25
02-07-2009, 06:20 PM
Finally. Ive fixed it. Im not sure if this is you guys' problem but my problem was that i didn't have directx10 installed. If your having this problem you should try and do that.

richada41
02-08-2009, 12:47 AM
Lazybones are you on Vista? I googled DX10 and it said it was for Vista, but there were alphas around for XP.

sleeplessone
02-08-2009, 05:59 AM
Vista has DX10 by default or i am lead to believe it does.

I have expereinced random lockups while playing SR2.

unfortunally it locks up my entire PC and requires a hard reset.

I have finished the story so i will probably uninstall it now.

GigaByte GA-MA790FX-DQ6
AMD Athlon 64 x2 6400+
4 GB ram PC2-6400 (DDR2 800)
ATI Radeon HD 3870 512MB, catalyst 8.12
Creative X-Fi Xtreme Gamer Fatality Pro series PCI
Windows XP pro 32-bit SP3 and Windows 64-bit Ultimate SP1 ( separate installs on separate HDD for windows with separate installs or SR2)

its a shame it crashes so easily on my setup and so randomly.

Crashed points include
1) during a mission for story
2) during an activity or diversion
3) just walking, driving or flying with empty objectives
4) At plastic surgeon looking at my unlocks and choosing to change appearence.

Radio on or off doesnt make a difference to crash point.

If im unlucky the crash can happen a few minutes after starting a saved game or 1 hour+.

Reinstalling direct X from the supplied version with the game didnt seem to fix anything unless i need to install direct X everytime i start windows before i play SR2 which i have seen in a post somewhere. I believe it was on the community forum for SR2.

[EDIT]

The other thing is i cannot join a multiplayer game, I can see games , start my own game but not join. It just sits there saying "Waiting" while it trys to connect. It is not a firewall problem or other like Antivirus as i would not be able to host my own multiplayer game and join it if it was.

702Boy
02-10-2009, 12:18 AM
you use ne rall good with computers but i dont know how to fix this i just bought saints row to and install it and steam work fine and all the other games work fine but when i launch saints row 2 it pops up the the black game screen and then a message bock pops and says sr2_exe. or some thing wont work and then it closes out.

HELP...
idk my sysem i dont remember where to look...

nannal
02-15-2009, 03:27 PM
Same message over here boys. I had it running perfectly once, i closed it, opened it, clicked continue and then BAM, the error message, now i cant get past the menu, it all leads to the error message

richada41
02-27-2009, 01:16 PM
Anyone solved this problem yet?

azareal188
03-05-2009, 12:15 AM
Where do you go to download Directx 10 for Vista cuz Saints Row 2isnt working on my computer. I keep getting that sr2_pc.exe stopped working message.

Jigoku
03-05-2009, 01:05 AM
DX10 is an integral part of Vista ...

To update your DirectX version download this file and run it.

http://www.microsoft.com/downloads/details.aspx?familyid=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en

azareal188
03-06-2009, 01:31 AM
Its still giving me that error, do I need to disable something to get it wokring?

hecticbrother
04-14-2009, 12:28 PM
I was also having big trouble with this - after going through a lot of aggravation to get the game installed because of key issues I finally installed it. I was able to get to the menu screen and as soon as a new game got started it would crash out with 'sr2_pc.exe has stopped working' message.

Long story made short is that it took a clean installation of Windows for me to finally getting to play the game after I bought it 6 weeks ago. Yes, it's great fun and have quite decent framerates and virtually no stuttering between maps.

Details of the story so as not to make you think that I was lazy was that I tried the following to get sr2_pc.exe to play ball;

Installed from disc initially. First time got sr2_pc.exe etc.. error.

Uninstalled through Steam and allowed Steam to download the whole game all over again. sr2_pc.exe etc..

Uninstalled Steam, cleaned registry entries for it out and reinstalled Steam and through the Steam exe on the Saints Row DVD onto a completely different partition of a different hdd. sr2_pc.exe etc..

Installed very latest Direct X9 and X10 and nVidia drivers. sr2_pc.exe etc..

Altered every video option both in game and through nVidia control panel. sr2_pc.exe etc..

Changed GFX card (coincidentally, not to solve issue) and it still got sr2_pc.exe etc..

It took a hal.dll startup message before I bit the bullet and finally did a clean reinstall off OEM media. Tried to play the game once more before I gave up for good on it and no more message. I can finally do all the things I've read about for so long.. Now back to the sewage trucks :D

jake6191
04-14-2009, 09:21 PM
hello i got a question for ya hecticbrother what was the overall result you did to get your saints row 2 to finally work? cause mine still pops up the same problem I downloaded the most recent direct x and it still has the same problem for me, now i am wondering what did you initially do that made yours work cause I don't see what you did in your post if you can walk me through what you did would be much appreciated.

shade1978x
04-14-2009, 09:58 PM
This is why being a PC gamer is so damned hard. All the crap we have to go through to just play a damn game. It's sickening.

jake6191
04-15-2009, 12:36 PM
♥♥♥♥ I know I just want to play some ♥♥♥♥in saints row 2 for ♥♥♥♥ sakes its steams fualt for not getting the game goin the way it should! I am pist I either want it working or another 30 dollar game!

Celestatiune
12-29-2009, 09:40 AM
I had this game working perfectly on Vista 32 but it was failing to even load on Windows 7 64 bit. I thought it must have been that but after some brainstorming and reading about the Xbox controller issues I decided to install the latest drivers for all my components and unplug my iPod and my wireless mouse dock (that I normally don't use). The combination of all that seemed to help and stopped the error I was getting on startup.

So install manufactuer drivers for all your stuff even if it seems to be working because maybe the game doesn't like it. Hope that helps someone out there.

Fireslide
12-30-2009, 01:04 AM
I found it was the UAC messing stuff up on my Windows 7 Install. Couldn't get it working on Vista at all.

ripclaw666
12-31-2009, 03:30 PM
For me it was enough to change some of the SR2_PC.exe properties (at ...\Steam\SteamApps\common\saints row 2\sr2_pc.exe)

x Run as administrator
x Disable visual themes
x Run compatibility mode (XP SP3)

Naraesa
01-04-2010, 03:58 PM
Try this, this worked for me.

Your hard drive may be full on space, delete stuff you dont use and then de-frag.

Its worth a try. :)

HarryG321
01-10-2010, 11:21 AM
Thanks Ripclaw!

This worked for me, running Windows 7 64bit.

Try it out.

minam.senju
01-11-2010, 02:30 AM
I notice it will not work when 2 monitors are active when starting up the game. I had to disable one of them manually from the nvidia panel properties. Most games Steam does this for you automatically but for some reason that sr2 pc.exe did not want to launch that way. Simply put, this is another good example of bad programing, bad port to PC, lack of concern to the PC player and lack of beta testing. There should be a law against lazy PC ports.

:mad:

ZombieBobie
01-12-2010, 12:07 PM
The game crashes on launch if it loses focus. To fix it - simply click the "blackness" as it is trying to launch with your mouse - thus it keeps focus and launches.

That's why disabling a monitor helps for instance, and probably why running it with disabled visual themes helps.


Happened to me on Win7 64 on a Radeon 5870 graphics card running latest ATI drivers.

A similiar'ish issue happens with Lord of the Rings online, I believe its related to DX10's handling of fullscreen applications (and happens on both nvidia and ATI cards).

Zomborobo
01-14-2010, 07:44 AM
I got this message two but I am playing on win7. I have checked my drivers, system spec and reinstalled. I have run as admin, disabled visual themes and run compatibility mode. I NEED help please

Celestatiune
02-05-2010, 07:56 PM
I just reinstalled this again after building a new computer. Appparently some monitors can also crash it if you don't have the specific drivers for them, instead of just the PnP stuff.

larryhudson
03-07-2010, 02:44 AM
Another reason that this error message appears is that speakers aren't plugged in. Discovered that today :)

widden
07-02-2010, 05:00 PM
same issue
win7 x64 / i7/6GBRAM/HD5870
tried the tricks with the sr2_pc.exe,
HDD spaces is not an issue...and obviously latest directX is installed.

Any better ideas? Steam support sucks balls, THQ support isn't any better - what can one do?

Edit: I've got 3x24" monitors, might it cause the issue?
Edit2: nope, unplugged both side monitors, nothing.
What a POS...

Dangerously
07-02-2010, 08:04 PM
same issue
win7 x64 / i7/6GBRAM/HD5870
tried the tricks with the sr2_pc.exe,
HDD spaces is not an issue...and obviously latest directX is installed.

Any better ideas? Steam support sucks balls, THQ support isn't any better - what can one do?

Edit: I've got 3x24" monitors, might it cause the issue?
Edit2: nope, unplugged both side monitors, nothing.
What a POS...

Load the game from the Steam directory and not Steam itself. Ie.: C:\Program Files (x86)\Steam\steamapps\common\saints row 2\SR2_pc.exe Worked for me. If it still does not work, right click SR2_pc.exe choose "properties" then under compatibility, choose XP. Once in the game, select the correct resolution for the game then the crashing issue will go away. The reason for the crash that it looses focus if you have more than one monitor. Just unplugging is not enough. You would need to turn off multi monitor support through the ATI/Nvidia software also.

i_2_i
07-02-2010, 09:05 PM
My computer is a 64 bit vista. Could that be the problem?

vista sucks, 64-bit is worse :(

get the distribution that has both the 32-bit version and the 64-bit version.

install windows 7 32-bit now
save the windows 7 32-bit version for the future when you have more memory (at that point you will have to do a full install, no upgrade path from 32-bit to 64-bit)

also why 32 bit now, well you only have 4gb, windows 64-bit uses about 60% more memory than the 32-bit version just because it's 64-bit and all those memory pointers that were 32-bit in the 32-bit version are 64-bit in the 64-bit version and eat up a lot more memory. also windows 64-bit runs 32-bit software in a gateway, which slows things a little.

if you think that you are going to get more memory in the near future, before you upgrade your box, then install the 64-bit version, just keep in mind that some of your memory will be going into just running the 64-bit version, regardless 4 gb is plenty for both versions of windows, i'm just very specific...

just so that you know on my 8gb box i run windows 64-bit, on my 3-4 gb box i run windows 32-bit, windows 64-bit is using about 1.5 gb without me having anything but antivirus running, i've manually stopped/disabled all unnecessary services, like windows superfetch which does nothing but slow things down and eat your memory...

backup all your data, your files, your pictures, your movies, your music, your documents, your game saves, ect...

get windows 7 and do a clean install, wipe the drive, do a quick format, don't upgrade, do a clean install. i'm sorry, but should not take too long and when you are done you have a nice clean install and not problems.

instal antivirus
then install all the patches
then install all the drivers
then install all the software
ect...

nice and clean

widden
07-03-2010, 02:37 AM
Load the game from the Steam directory and not Steam itself. Ie.: C:\Program Files (x86)\Steam\steamapps\common\saints row 2\SR2_pc.exe Worked for me. If it still does not work, right click SR2_pc.exe choose "properties" then under compatibility, choose XP. Once in the game, select the correct resolution for the game then the crashing issue will go away. The reason for the crash that it looses focus if you have more than one monitor. Just unplugging is not enough. You would need to turn off multi monitor support through the ATI/Nvidia software also.
Thanks for the tip;
question tho: how do you turn off the multi-monitor support? (running ATI currently, as you can see above) I thought it's inherently in at driver level. I've tried everything else, including the compat mode.

Neverborne
07-03-2010, 08:08 AM
Disabling second monitor worked for me. Also worked for other Steam games I was having trouble with.

widden
07-04-2010, 05:03 PM
Well, I've unplugged the two side monitors, and it still didn't work; I need something else it seems :(

IdolNinja
07-04-2010, 07:00 PM
Well, I've unplugged the two side monitors, and it still didn't work; I need something else it seems :(

Unplugging is not the same as disabling. Try disabling your monitors in device manager instead.

widden
07-04-2010, 11:59 PM
Thanks for the tip, however, I've disabled them in the device manager, restarted the computer - the monitors are still active - this baffles me quite a bit...

IdolNinja
07-05-2010, 12:30 AM
Thanks for the tip, however, I've disabled them in the device manager, restarted the computer - the monitors are still active - this baffles me quite a bit...

Oops... my bad, I meant disabling through the catalyst control center, not device manager. You should have something that looks like this:
http://img821.imageshack.us/img821/4409/disabledisplay.jpg

widden
07-06-2010, 06:52 AM
Oops... my bad, I meant disabling through the catalyst control center, not device manager. You should have something that looks like this:
http://img821.imageshack.us/img821/4409/disabledisplay.jpg

Thanks for the tip again - sadly it does not work.
I've disabled the side monitors and run the sr2.exe, crash.
Then run in in compat mode - crash.
Run it as admin, disabled visual themes - crash.

I think this game will never work on this computer :(

deadman_uk
07-22-2010, 04:29 PM
Same problem here, sr2_pc.exe has stopped working. Only got the game 24 hours ago and I am gutted. The crashing happens randomly and I cannot find out the cause. I have updated DirectX, replaced the binkw32.dll with a newer version, changed compatibility mode and nothing helps. I have an error log here, can anyone make sense of it?

Version=1
EventType=APPCRASH
EventTime=129243139901552735
ReportType=2
Consent=1
UploadTime=129243139903623047
ReportIdentifier=b121c495-95e6-11df-83a1-00508dbec25e
IntegratorReportIdentifier=b121c494-95e6-11df-83a1-00508dbec25e
WOW64=1
Response.BucketId=1138359393
Response.BucketTable=1
Response.type=4
Sig[0].Name=Application Name
Sig[0].Value=sr2_pc.exe
Sig[1].Name=Application Version
Sig[1].Value=0.0.0.0
Sig[2].Name=Application Timestamp
Sig[2].Value=49904c37
Sig[3].Name=Fault Module Name
Sig[3].Value=sr2_pc.exe
Sig[4].Name=Fault Module Version
Sig[4].Value=0.0.0.0
Sig[5].Name=Fault Module Timestamp
Sig[5].Value=49904c37
Sig[6].Name=Exception Code
Sig[6].Value=c0000005
Sig[7].Name=Exception Offset
Sig[7].Value=008a328e
DynamicSig[1].Name=OS Version
DynamicSig[1].Value=6.1.7600.2.0.0.768.3
DynamicSig[2].Name=Locale ID
DynamicSig[2].Value=2057
DynamicSig[22].Name=Additional Information 1
DynamicSig[22].Value=0a9e
DynamicSig[23].Name=Additional Information 2
DynamicSig[23].Value=0a9e372d3b4ad19135b953a78882e789
DynamicSig[24].Name=Additional Information 3
DynamicSig[24].Value=0a9e
DynamicSig[25].Name=Additional Information 4
DynamicSig[25].Value=0a9e372d3b4ad19135b953a78882e789
UI[2]=c:\program files (x86)\steam\steamapps\common\saints row 2\sr2_pc.exe
UI[3]=sr2_pc.exe has stopped working
UI[4]=Windows can check online for a solution to the problem.
UI[5]=Check online for a solution and close the program
UI[6]=Check online for a solution later and close the program
UI[7]=Close the program
LoadedModule[0]=c:\program files (x86)\steam\steamapps\common\saints row 2\sr2_pc.exe
LoadedModule[1]=C:\Windows\SysWOW64\ntdll.dll
LoadedModule[2]=C:\Windows\syswow64\kernel32.dll
LoadedModule[3]=C:\Windows\syswow64\KERNELBASE.dll
LoadedModule[4]=C:\Windows\system32\DSOUND.dll
LoadedModule[5]=C:\Windows\syswow64\msvcrt.dll
LoadedModule[6]=C:\Windows\syswow64\USER32.dll
LoadedModule[7]=C:\Windows\syswow64\GDI32.dll
LoadedModule[8]=C:\Windows\syswow64\LPK.dll
LoadedModule[9]=C:\Windows\syswow64\USP10.dll
LoadedModule[10]=C:\Windows\syswow64\ADVAPI32.dll
LoadedModule[11]=C:\Windows\SysWOW64\sechost.dll
LoadedModule[12]=C:\Windows\syswow64\RPCRT4.dll
LoadedModule[13]=C:\Windows\syswow64\SspiCli.dll
LoadedModule[14]=C:\Windows\syswow64\CRYPTBASE.dll
LoadedModule[15]=C:\Windows\syswow64\ole32.dll
LoadedModule[16]=C:\Windows\system32\WINMM.dll
LoadedModule[17]=C:\Windows\system32\POWRPROF.dll
LoadedModule[18]=C:\Windows\syswow64\SETUPAPI.dll
LoadedModule[19]=C:\Windows\syswow64\CFGMGR32.dll
LoadedModule[20]=C:\Windows\syswow64\OLEAUT32.dll
LoadedModule[21]=C:\Windows\syswow64\DEVOBJ.dll
LoadedModule[22]=C:\Windows\system32\WSOCK32.dll
LoadedModule[23]=C:\Windows\syswow64\WS2_32.dll
LoadedModule[24]=C:\Windows\syswow64\NSI.dll
LoadedModule[25]=C:\Windows\syswow64\SHELL32.dll
LoadedModule[26]=C:\Windows\syswow64\SHLWAPI.dll
LoadedModule[27]=c:\program files (x86)\steam\steamapps\common\saints row 2\binkw32.dll
LoadedModule[28]=c:\program files (x86)\steam\steamapps\common\saints row 2\DfEngine.dll
LoadedModule[29]=C:\Windows\system32\VERSION.dll
LoadedModule[30]=C:\Windows\system32\iphlpapi.dll
LoadedModule[31]=C:\Windows\system32\WINNSI.DLL
LoadedModule[32]=C:\Windows\system32\X3DAudio1_4.dll
LoadedModule[33]=C:\Windows\system32\XINPUT1_3.dll
LoadedModule[34]=C:\Windows\system32\d3dx9_39.dll
LoadedModule[35]=C:\Windows\syswow64\IMM32.dll
LoadedModule[36]=C:\Windows\syswow64\MSCTF.dll
LoadedModule[37]=C:\Windows\system32\d3d9.dll
LoadedModule[38]=C:\Windows\system32\d3d8thk.dll
LoadedModule[39]=C:\Windows\system32\dwmapi.dll
LoadedModule[40]=C:\Windows\system32\DINPUT8.dll
LoadedModule[41]=C:\Program Files (x86)\Steam\GameOverlayRenderer.dll
LoadedModule[42]=C:\Windows\system32\CRYPTSP.dll
LoadedModule[43]=C:\Windows\system32\rsaenh.dll
LoadedModule[44]=C:\Windows\system32\uxtheme.dll
LoadedModule[45]=C:\Windows\system32\profapi.dll
LoadedModule[46]=C:\Program Files (x86)\Ray Adams\ATI Tray Tools\raphook.dll
LoadedModule[47]=C:\Windows\syswow64\PSAPI.DLL
LoadedModule[48]=C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9 a1e18e3b_9.0.30729.4926_none_508ed732bcbc0e5a\MSVC R90.dll
LoadedModule[49]=C:\Program Files (x86)\Xfire\xfire_toucan_43094.dll
LoadedModule[50]=C:\Windows\system32\MSIMG32.dll
LoadedModule[51]=C:\Windows\system32\MSVCR71.DLL
LoadedModule[52]=c:\program files (x86)\steam\steamapps\common\saints row 2\DXFreezerServer.dll
LoadedModule[53]=C:\Windows\system32\d3dx9_42.dll
LoadedModule[54]=C:\Windows\system32\aticfx32.dll
LoadedModule[55]=C:\Windows\system32\atiu9pag.dll
LoadedModule[56]=C:\Windows\system32\atiumdag.dll
LoadedModule[57]=C:\Windows\system32\atiumdva.dll
LoadedModule[58]=C:\Windows\system32\HID.DLL
LoadedModule[59]=C:\Windows\syswow64\WINTRUST.dll
LoadedModule[60]=C:\Windows\syswow64\CRYPT32.dll
LoadedModule[61]=C:\Windows\syswow64\MSASN1.dll
LoadedModule[62]=C:\Windows\system32\NLAapi.dll
LoadedModule[63]=C:\Windows\System32\mswsock.dll
LoadedModule[64]=C:\Windows\system32\DNSAPI.dll
LoadedModule[65]=C:\Windows\System32\winrnr.dll
LoadedModule[66]=C:\Windows\system32\napinsp.dll
LoadedModule[67]=C:\Windows\system32\pnrpnsp.dll
LoadedModule[68]=C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live\WLIDNSP.DLL
LoadedModule[69]=C:\Windows\System32\fwpuclnt.dll
LoadedModule[70]=C:\Windows\system32\rasadhlp.dll
LoadedModule[71]=C:\Windows\System32\wshtcpip.dll
LoadedModule[72]=C:\Windows\syswow64\CLBCatQ.DLL
LoadedModule[73]=C:\Windows\System32\MMDevApi.dll
LoadedModule[74]=C:\Windows\System32\PROPSYS.dll
LoadedModule[75]=C:\Windows\system32\AUDIOSES.DLL
LoadedModule[76]=C:\Windows\system32\avrt.dll
LoadedModule[77]=C:\Windows\SysWow64\XAudio2_2.dll
LoadedModule[78]=C:\Windows\SysWow64\xactengine3_2.dll
State[0].Key=Transport.DoneStage1
State[0].Value=1
FriendlyEventName=Stopped working
ConsentKey=APPCRASH
AppName=sr2_pc.exe
AppPath=c:\program files (x86)\steam\steamapps\common\saints row 2\sr2_pc.exe


Intel Core 2 Quad 9450 @3.2Ghz - 2x2GB Corsair XMS2 DDR2 (PC2-6400) 4-4-4-12 - XFX Radeon HD 4890 XXX 1GB - Abit IP35 Pro XE - Hitachi Deskstar 7K1000 750GB - Corsair HX Series 620W - Creative Sound Blaster X-fi XtremeMusic - Hyundai W240D-PVA 24" - Hauppauge WinTV HVR-4000 - Windows 7 Home Premium 64bit

widden
07-29-2010, 03:17 AM
Guys everyone with problems, keep buggering the supports.
The least they deserve from us is some work on trying to explain how this crap is supposed to worth any money.

Plus if you guys don't report problems they might thing we're isolated cases.

real4xor
07-29-2010, 08:56 AM
Correct me if I`m wrong, but wasn`t Saints Row 2 made in Nvidia`s era?

I mean, it might have some more trouble with ATI cards and settings.

widden
08-02-2010, 09:20 PM
Nope, I still haven't fixed it. Tried THQ tech support but they were helpless. They told me to change my resolution or check if my system requiremtnts are right. They were and i dont see how changing the resolution would help it any way.

yes, I'm getting similar responses from them, for weeks now they are sending me totally bs responses, and only after 3-4 days or more. They seem to try to wear me out, the nasty buggers.

Their latest was to run it as an admin...

dementedlullaby
01-01-2011, 07:31 PM
Can't get it running on my current PC with Win7 but can with my crappy Laptop running Win7. Both 64bit. Oh well, got the game free back when you could pre-order Dawn of War 2 Chaos Rising.

Still would be nice to see on my PC even if I do have the 360 version...

Edit : Found a fix for me at least.

Right click game, go to local files, view integrity of game cache. It should download a medium sized file through steam again.

Guess it missed something on the first download or something. After that no longer got an error on startup. I had no need to run in any compatibility mode or as admin.

Let us know if this fix works for you and if it does pass it along.

ChromeBallz
07-07-2011, 10:30 PM
Sorry for the necro, but it seemed appropriate.

Had the same problem, tried everything, untill i came across the second monitor thing.

Disabling is not entirely necessary, at least not for multimonitor ATI setups. I was able to get the game started by activating the eyefinity group (windows+p and select duplicate as a shortcut), which made the game think there was only one monitor.

After that it was able to boot up and i could select the right resolution (which you still have to do), after that you can switch back to whatever setup you had before.

So yes, you actually have to disable the monitors in the nvidia/ati control panel (or use eyefinity (or possibly surround for nvidia) to make your pc think it's just one monitor), then you can boot the game and select the correct resolution, after which it works properly.

chvogt
09-09-2011, 02:53 PM
I have Windows 7 64-bit. I got it working by right clicking on the SR2_pc.exe file and selecting 'Properties'. In the 'Compatibility' tab, I checked the 'Disable desktop composition'.

I have 2 monitors and I had to do this with another game also.

Hope this helps!

Betrix
10-13-2011, 05:04 PM
I have a dual monitor setup and the game crash as soon as it start, you must disable the second screen while playing or it will crash.

I was getting the sr2 error on crash and as soon as i disable my screen it start, after playing i turn my second screen back on and the game would start just fine but would crash at some point.

So here is your solution disable your second screen while you play and problem solve.

I try everything before that, upgrade driver and directx and nothing would do, this is the only solution i found that work 100%

Eufex
10-14-2011, 09:03 AM
Got this the other day with the THQ collection offer. Launched it today.. I get the sr2_pc.exe error when I try to start a new game. I've tried all the various fix solutions in this thread, but no luck! Same problem every time.

It's a bloody joke to be honest! I love PC Gaming, but crap like this just pisses me off!

Any other soulutions?

IdolNinja
10-14-2011, 10:28 AM
Got this the other day with the THQ collection offer. Launched it today.. I get the sr2_pc.exe error when I try to start a new game. I've tried all the various fix solutions in this thread, but no luck! Same problem every time.

It's a bloody joke to be honest! I love PC Gaming, but crap like this just jaratees me off!

Any other soulutions?

Have you gone through the SR2 PC FAQ? There are multiple causes and solutions for that crash detailed:
http://forums.steampowered.com/forums/showthread.php?t=1715922

Eufex
10-14-2011, 10:35 AM
Have you gone through the SR2 PC FAQ? There are multiple causes and solutions for that crash detailed:
http://forums.steampowered.com/forums/showthread.php?t=1715922

Yes. Tried everything - nothing worked.

donutdan4114
10-15-2011, 10:36 PM
I fixed this problem by doing the following:
Go to the game executable in windows explorer.
steampath/saints row 2/SR2_pc.exe

right-click on the file, and click Properties.
on the Compatibility tab, run the program in compatibility mode for Windows XP.
Also, "disable visual themes", and "disable desktop composition".

This fix worked for me.
I have two monitors using Windows 7.
Let us know if this works for you.

Lungford
10-16-2011, 05:54 AM
For me it was enough to change some of the SR2_PC.exe properties (at ...\Steam\SteamApps\common\saints row 2\sr2_pc.exe)

x Run as administrator
x Disable visual themes
x Run compatibility mode (XP SP3)

this worked for me

Eufex
10-16-2011, 08:53 AM
I fixed this problem by doing the following:
Go to the game executable in windows explorer.
steampath/saints row 2/SR2_pc.exe

right-click on the file, and click Properties.
on the Compatibility tab, run the program in compatibility mode for Windows XP.
Also, "disable visual themes", and "disable desktop composition".

This fix worked for me.
I have two monitors using Windows 7.
Let us know if this works for you.

This worked! Thank you very much sir. :)

IdolNinja
10-16-2011, 11:17 AM
Great to know. Adding it to the FAQ to help other users.

nuclearharry
10-17-2011, 07:10 AM
same problem as most of you guys i have tryed re installing verifying the cach and everything and it still wont open :S im on a 64bit windows 7

crp_tedbundy
10-17-2011, 10:37 AM
Originally Posted by ripclaw666
For me it was enough to change some of the SR2_PC.exe properties (at ...\Steam\SteamApps\common\saints row 2\sr2_pc.exe)

x Run as administrator
x Disable visual themes
x Run compatibility mode (XP SP3

This didn't work for me any other ideas?

IdolNinja
10-17-2011, 11:55 AM
same problem as most of you guys i have tryed re installing verifying the cach and everything and it still wont open :S im on a 64bit windows 7

Did you go through the SR2 PC FAQ?
http://forums.steampowered.com/forums/showthread.php?t=1715922

There are quite a few different things you can try in addition to the ones you mentioned.

crp_tedbundy
10-17-2011, 01:04 PM
ive been trying to find the settings.dat file like it says on the faq it shows it being
C:\Users\[profile name]\AppData\Local\THQ\Saints Row 2\settings.dat

but i cant get past my profile name in that there is no appdata folder and ive searched for anything to do with thq and saints row 2 and all i get is the desktop icon and the SR2 folder within the steam folder and theres no settings.dat file in there that i can find

IdolNinja
10-17-2011, 01:14 PM
AppData is a hidden folder. You can try one of the following:
* Manually type it in to the address bar when you are there at your profile
* In Control Panel, show hidden and system files/folders
* Type %AppData% in your Run bar

Also, if you're still on XP, the path is slightly different. It's something like:
c:\documents and settings\[profile]\Application Data\

thejackal
10-18-2011, 12:30 AM
I've logged 46 hours or so on this game before and just today I'm getting the stopped working error. I have tried all of the fixes mentioned earlier and even tried the newest GotR just in case. Nothing gets me past that failed screen. Trashed the settings, installed the one IdolNinja posted and nothing is helping. I've restarted the computer, verified the cache, downloaded three files that steam didn't like (probably the GotR files) and still aren't getting anywhere. Anybody have any suggestions?

thejackal
10-18-2011, 12:39 AM
Possibly stupid observation. I recently tried overclocking my system. I know what I set it to is stable (small steps) and even put the multiplier back to where it was and it didn't work, but I set it back to Auto (where it was in the first place). It's either what caused the problem or sheer luck. So, is overclocking out of the question entirely on this?

IdolNinja
10-18-2011, 12:51 AM
I know plenty of people who oc and sr2 runs just fine. It must be something else.

thejackal
10-18-2011, 08:18 AM
Just out of curiosity, are those people that are overclocking running the Power Tools to tweak the speed it's running at?

IdolNinja
10-18-2011, 10:05 AM
Just out of curiosity, are those people that are overclocking running the Power Tools to tweak the speed it's running at?

Yep. Except for the people that are oc'ing to 3.2Ghz to get it to run perfectly without Powertools.

thejackal
10-18-2011, 08:19 PM
Perfect. That is my next test, then. To run Power Tool and OC it back where I had it. Now, did those people see a frame increase in SR2 or did the Power Tools adjustment negate what they saw?

IdolNinja
10-18-2011, 08:34 PM
Perfect. That is my next test, then. To run Power Tool and OC it back where I had it. Now, did those people see a frame increase in SR2 or did the Power Tools adjustment negate what they saw?

You're going to see better framerates the closer you are to the original 360 cpu frequency. It doesn't matter whether that is achieved through Powertools or CPU oc'ing to hit 3.2Ghz. All that matter is how exact you can make it.

pyrotrojan
10-19-2011, 11:21 PM
Hey i installed and reinstalled. But the game still keeps crashing after it has been launched.

I am running Win 7 x64.

CPU: Intel Core i7 2.6ghz (oc 3.0)
GPU: SLI EVEGA GTS 250
MEMORY: Trip CHannel 6g (three 2g)

Has anyone found a definite problem with the game and hardware or is it THQ has bugs in there games which cause crashes. I just want to play SR2. D:

IdolNinja
10-19-2011, 11:49 PM
Hey i installed and reinstalled. But the game still keeps crashing after it has been launched.

I am running Win 7 x64.

CPU: Intel Core i7 2.6ghz (oc 3.0)
GPU: SLI EVEGA GTS 250
MEMORY: Trip CHannel 6g (three 2g)

Has anyone found a definite problem with the game and hardware or is it THQ has bugs in there games which cause crashes. I just want to play SR2. D:

Crashing on launch can be any one of a number of issues. Did you go through all the troubleshooting in the FAQ?
http://forums.steampowered.com/forums/showthread.php?t=1715922

Tillytony
10-25-2011, 05:03 PM
I had this problem.
I notice it will not work when 2 monitors are active when starting up the game. I had to disable one of them manually from the nvidia panel properties. Most games Steam does this for you automatically but for some reason that sr2 pc.exe did not want to launch that way. Simply put, this is another good example of bad programing, bad port to PC, lack of concern to the PC player and lack of beta testing. There should be a law against lazy PC ports.

:mad:
This fixed it for me. Iv repped you :D