PDA

View Full Version : Sid Meyer's Pirates Won't Work Anymore!


bloodwire
02-10-2009, 09:40 AM
Due to a crash I've reinstalled my system now with Windows X64 XP. But, the problem is that Pirates! won't start anymore, I click on the game in Steam, it says, preparing to start pirates, then the window closes and nothing else happens.

I was wondering if there is an issue with X64 and pirates and whether there is a workaround for this?

Tokey2000
05-28-2009, 07:47 AM
I have the same problem with an XP system.

Any fix for this?

Tried re-installing etc, but no good.

lance_
06-20-2009, 09:27 PM
Just bought the game and was disappointed when it wouldn't start.

Windows 7 64-bit here.

Dracor
06-22-2009, 02:45 AM
work perfectly fine in home premium vista

lance_
06-23-2009, 12:16 AM
It was the DLL issue that was sticked. At first I tried to regsrv the DLLs, which gave me errors that they were 32-bit, but sticking them in the program directory rather than system32 like the stickied thread says to worked.

-ReuF-
06-24-2009, 12:12 AM
Wont work on a vista 64-bit system!

seastar
07-24-2009, 02:22 AM
Works fine on my windows 7 ultimate 64bit

Aristaqis
09-17-2009, 10:37 PM
did anyone ever find a definitive answer for this issue on windows 7 64? I am having the same issue.

Khalem
09-30-2009, 04:29 AM
Not working for me either after upgrading to Windows 7 64bit

rugerx
10-28-2009, 10:12 AM
Guys.... look at the first post in this forum.

Its a sticky that explains which DLL's are missing.

Here is a direct link to the first post in this forum.....
LINK (http://forums.steampowered.com/forums/showthread.php?t=826355)

I cannot believe that this has not been fixed.

2 thumbs down for Valve. Great game though once you get it fixed.

tonyfordz
11-20-2009, 04:09 PM
Windows 7 Ultimate here, and same problem. I have never had problems with SMP ever before on steam so whats the deal?

Alkpaz2
02-07-2010, 03:32 AM
Works fine for me, Windows 7 64bit, 15GB RAM, GTX 295. Run Steam as Admin, this should work fer ya guys! ;)

maierhans
07-04-2010, 06:48 PM
Win XP SP3,
same issue here.
starts, but nothing happens.
sucks.
I have 40 games in my steamlist, all run smoothly.

sikboy1029
07-11-2010, 03:02 PM
Get the missing .dll files & place them in your pirates folder. I just got them out of another game folder on my PC. Just search C: drive for MSVCP71.dll & MSVCR71.dll and copy & paste them into your pirates folder.

knightreeker
08-05-2014, 12:36 PM
Perfect answer sikboy, worked like a charm.

Middendorf
08-23-2014, 01:34 PM
Has to be an issue with Steam version because I just installed and played it on Vista 64bit 2 days ago and it is the original disk version, just applied the 1.2 patch and played with no issues.