PDA

View Full Version : My Fallout 3 crash/freeze now is stable. [SOLUTION]


GoldenShadow
04-23-2009, 07:28 PM
I haven't played Fallout 3 for a while. I am getting back into it with the recent releases of DLC. In my first run through the game I was lucky to admit I didn't have a major problem then. I finished the game after 50 hours and had maybe half a dozen random crashes(not counting crashes caused by script errors and real game bugs)

Now, about half a year later, I was now plagued by crashing and freezing. I read that this problem is triggered once the game is patched up the the latest version, but this latest version is required to play the DLC, which I already paid for. Following my guidelines in my specs, I eventually eliminated crashing. All that was left was a stubborn game freeze that would occur anywhere from 5-30 minutes of play time. One time in less than a minute of me launching the game, and loading my save, it locked up as I pressed E to walk through the first door.
This is a freeze where the screen is locked up, but the sound keeps playing. no controls work, but I can alt-ctrl-del to use task manager to end task and resume using windows normally.

I finally found a solution that fixes this. I have played a solid 3 hour stretch with no crash or freeze.

Specs:

Motherboard: Abit FP-IN9 650i SLI chipset. I have the latest Nforce drivers from nVidia's website, not the vendor.

CPU: Core 2 Duo E7200 oc@ 3.08Ghz FSB 1300Mhz(2.53Ghz default) modest overclock which is stable under torture tests.

RAM: 4GB DDR2 I underclocked this from 800Mhz to 650Mhz to get a sync ratio of 1:1 and tighter 1T command timings.

Sound Card: Asus Xonar D2X I have the newest drivers from the Asus website, The GX feature is off.

Video Card: ATI Radeon 4870 newest drivers from ATI's site.

OS: Windows Vista x64 SP1. Fully updated via windows update.

Fallout 3: Steam version. I deleted all my local content and old save files then redownloaded everything from steam. I also downloaded the newest standalone patch (1.4)from Bethesda's website and installed it seperately. Setting all on Ultra with 4x AA @1360*768

I also noted that the game may crash on exit if I don't launch it from my steam game list. My Operation Anchorage and The Pitt DLC will not load because Fallout 3 is installed to a different hard drive. The reason is the DLC is by default downloaded to the xlive folders on your C: drive. I manually copied the data files into the fallout 3 data directory and used the game launcher to load them manually. This is the only work around that lets your game stay stable. I tried the symbolic link trick, but it involved me putting a symbolic link to my entire steam directory. I didn't want to mess with that can of worms. If you don't want to have to copy the data files for the DLC, then make sure you install Steam(and steam games) to your C: drive for the Fallout 3 DLC to load and function.

The FIX:

After all the research I did using google and experimenting with my game settings I have found a solution that works for me.
Just install the K-lite codec pack:
http://www.codecguide.com/download_kl.htm
I installed the standard version of 4.7.5
After that I noticed that there is an update to 4.7.8
http://www.codecguide.com/klcp_update.htm
I got that and installed it too on top of 4.7.5

update: a new version 4.8.0 is out now (April 30, 2009)

Rebooted my PC and planned to keep playing Fallout 3 until I crashed. I ended up going for over 3 hours. I call that a success.

Your codecs may be messed up for Fallout 3 by installing any software that uses multimedia. I've read that some people have problems with Fallout 3 after a fresh install of windows, so maybe the game just doesn't agree with the default codecs. Either way, this pack has fixed my freeze issue and I hope this posts helps you guys.

There may be additional problems on your PC. Old drivers, windows updates, game updates, corrupt saves, incompatible hardware, and bad overclocks causing the CPU and RAM to be unstable are other problems that need to be addressed first. If all of that stuff is in the green, try out the K-lite pack.
There is a tweak floating around on the internet about setting your pagedpoolsize to 400MB. I tried this tweaked setting, but it made no difference on my machine. Right now I am running at the default value of 0 and the game is working fine after I used the K-lite pack.

I recently made a thread about how I fixed the radio stutter on the pipboy.
http://forums.steampowered.com/forums/showthread.php?t=844931

I disabled the MAD filter codec after I installed the k-lite pack. That means my pipboy music went back to stuttering. I haven't tested to see if this codec was a cause of my game freeze issue though. I am not sure if its a problem or not. I want to keep playing with it off for a while to verify that my game is stable. I'll test it out later on when I'm satisfied with the current configuration's stability.

|TTU|VaD3rTM
04-24-2009, 03:54 PM
Yea i get ther same prob;em, It is SOOOOOOO anoying ill give this a try (is this for xp)?

GoldenShadow
04-24-2009, 04:15 PM
You can see if the k-lite codec pack works with XP, or if there is a seperate installer for XP. Mine was on Vista 64bit

doswelk
04-25-2009, 02:15 AM
Trying to follow your advice here, does anyone know whether I should download the US English or UK English version?

I live in UK but does that mean my copy of Fallout is as well?

|TTU|VaD3rTM
04-25-2009, 06:06 AM
I get less crashes now, Thanks

DRat
04-28-2009, 11:52 AM
Thanks!

Your approach to resolving this worked fine for me, since I had gotten to the point of doing two or three saves before going through any door to a different map, or exiting the game.

Too bad they had to hose it up again today - the automatic 1.5 update crashed while installing and now I'm missing some visuals, like flame from the flamer, missiles from the launcher, etc. I will try re-installing it again, and will turn off auto-update for sure!

GoldenShadow
04-28-2009, 01:12 PM
I autoupdated to 1.5 and the installer didn't crash and I was able to load up my save file.

Steell
04-28-2009, 10:25 PM
I've found that disabling "Full Scene Reflections" and "Full Detail Reflections" in the Water Options has fixed almost all of my crashing problems (VATS still crashes randomly when my character starts firing, but i think that's unrelated).

wssymes
04-29-2009, 08:37 AM
I installed the codec and the crashes have stopped. I did have one crash which involved the 1.5 patch not installing correctly. I restarted the game and it played just fine. Hmmm.

I have a question though...what is it about the codecs that causes the game to stop freezing? I am not understanding why this should work.

cocokiwi
04-29-2009, 11:04 AM
STEAM! where are the fixes to Fallout-3. I don't want to download and modify fixes to add! and nor should I,as I paid for that privilege by buying a game via STEAM!

It should have had them by now!


Dennis:mad:

GoldenShadow
04-29-2009, 11:56 AM
Don't hold your breathe

cocokiwi
04-29-2009, 11:10 PM
Trying to follow your advice here, does anyone know whether I should download the US English or UK English version?

I live in UK but does that mean my copy of Fallout is as well?

your version is UK!

Dennis:cool:

cocokiwi
04-29-2009, 11:21 PM
Don't hold your breathe


Thank you for contacting Steam Support.

Patches for third party games can only be distributed through Steam once the following two actions have occured:

(1) The Publisher has provided us with the necessary files
(2) The Publisher has given us permission to release the update

The latest patches will be released as soon as possible, and will be downloaded automatically when available.

If you have questions about the availability of a specific patch, please contact the support department for the game in question.

Usual response! DOA:rolleyes:

Dennis :confused::eek:

MrXGamer
04-30-2009, 12:10 AM
People with x64 OS usually face more problems. K-Lite codec pack (full/mega versions) are a MUST for anyone who uses x64. They have dedicated support for 64-bit. If you download these codecs separately, some of them don't work too well since they're only optimized for 32-bit. I ran into problems until I tried K-lite. Everything works great now.

Also get - MS .NET Framework 3.5 + SP1, OpenAL, Visual C++ Redistributable 05/08, Java with latest updates & DirectX Redistributable latest pack.

These things usually solve most problems PC gamers run into.

wssymes
04-30-2009, 08:38 AM
People with x64 OS usually face more problems. K-Lite codec pack (full/mega versions) are a MUST for anyone who uses x64. They have dedicated support for 64-bit. If you download these codecs separately, some of them don't work too well since they're only optimized for 32-bit. I ran into problems until I tried K-lite. Everything works great now.

Also get - MS .NET Framework 3.5 + SP1, OpenAL, Visual C++ Redistributable 05/08, Java with latest updates & DirectX Redistributable latest pack.

These things usually solve most problems PC gamers run into.

Cool. Thanks for the reply :)BTW, I played last night after installing these the other day, and still NO FREEZES. Thanks to OP for posting this fix.

EvaUnit02
04-30-2009, 09:43 PM
Or just try this uncomplicated fix. If you're running a codec pack that uses ffdshow (eg K-Lite, CCCP), just do the following:-
You don't need to play in window mode to fix the crash. The freeze is usually caused by your codec being used in the game. I had the same problem that randomly happened throughout the game but after doing this I haven't had one crash in the last 40 hours put into the game since my last crash.

1. Click Start
2. Click "All Programs" (or just Programs, depending on the version of Windows 3. Go to the ffdshow folder.
4. Click "Audio decoder configuration."
5. In the left hand pane, click "DirectShow control" This is the second entry in the list.
6. In the right hand pane, near the bottom, find a check box labelled "Don't use ffdshow in:"
7. Check that box, and in the text box underneath (it lights up when you check the check box), add "fallout3.exe" (don't include the quotes). If there is already something in that box, put a semi-colon ( ; ) after what's already there, and fallout3.exe after that. Do NOT use spaces, since ffdshow will think that's part of the filename. A valid entry would be "explorer.exe;fallout3.exe" (without quotes).
8. Finally, click "Ok" and start Fallout 3.

Oh and make sure you do this for "Video decoder configuration" too.

RedSwir1
05-23-2009, 10:59 PM
Or just try this uncomplicated fix. If you're running a codec pack that uses ffdshow (eg K-Lite, CCCP), just do the following:-

I suspected the problem had something to do with ffdshow.

TrappaKeepa
06-06-2009, 01:35 PM
Just thought I would note that the Klite codec pack has been updated. File Hippo has two versions. K-lite "full" and just K-lite. K-lite "full" is the one a "normal" user would need. The other K-lite pack is for video designers and developers.

http://www.filehippo.com/download_klite_codec_pack/

File Hippo is a great source for program updates and is a safe download location.

namanert
06-10-2009, 05:17 PM
GoldenShadow, thank you so much. I had actually given up on beating the game because it would crash literally after three minutes of playing, and was therefore unplayable. I followed the steps in your guide, and now I've played for over three hours without a single crash.

GoldenShadow
06-10-2009, 07:06 PM
You're Welcome!

Tinyrake
06-14-2009, 03:52 PM
I kept crashing in the same place. It was during some of the first firefights after the big robot "has the accident" [avoiding spoilers]).

The fix for me (played for hours now and I'm good finally) was to disable Anti-Aliasing when using HDR. You don't really need it with HDR on and a high resolution monitor. I don't really notice it being off.

Anyway, just wanted to add my 2 cents. I still can't close the game reliably, but I can live with that for now.

My rig:
Nvidia GX280 (drivers 185.85)
Windows XP (up-to-date)
Quad core Intel proc
4 GB RAM (32-bit OS though)

lobotomite
06-16-2009, 01:49 PM
all u had to do was just download the newest patch it works now for me:)

Skoll
06-17-2009, 10:37 AM
My game continues to freeze regularly. Maybe once every 10-60 minutes. I didn't have any custom codecs installed, but I tried the K-Lite install anyway and that didn't fix it. Disabled ffdshow after installing it, that didn't help. Also tried running in a window, running with vsync, lowest video settings, setting affinity to 1 core, setting affinity to 2 cores, turning off HDR, antialiasing, and anisotropic filtering, upgraded to latest WHQL nvidia driver, updated to latest vista x-fi driver.

Nothing ... stops ... the ... freezes.

By freeze I mean a total lock up of fallout3.exe which I have to kill from task manager.

The Steam version of the game is 1.5.0.22 and so everyone in this forum should be running that.

NizeGuy
06-17-2009, 01:14 PM
I finally got it to work, but then when Im entering the waste lands from vault 101 it crashes! WTF!

BTW, Im getting my money, cause' Im not gonna spend another second trying to figure out why it crashes. I use vista Ultimate 64bit btw.

Ekibiogami
06-29-2009, 12:36 PM
Can we get this made a Stickie?? Im Tired of looking for it when ever I need to fix a Friends game :(

ngwoo
06-29-2009, 01:59 PM
Know what fixed my performance issues? Games For Windows Live Disabler Mod. (http://www.fallout3nexus.com/downloads/file.php?id=1086) I recommend everyone use this utility immediately.

FPS increased by almost 10, startup time was halved, and I don't have the crash-on-exit problem anymore.

cocokiwi
06-30-2009, 03:37 PM
1 >vista 64bit now has SP-2.
2 >fo3 is now at 6.0 v#
3 >the latest codac file has the fo3.exe in the ignore list!
also! a quick note! I make a note! The Win Live deactivate patch works But i ran into a couple of minor things!
When you first run after running it Fo3 will hang and you will close it! rerunning it will work! I used a frag and the picture went nuts,most of the screen went white/right to left to about 2" left of the timer ring in the middle,the rest is a shaded version of what was there already!But it came back after the frag went off!go figure!This is my Laptop!(grin)

Too add! Arggggg! I cannot get rid of it! I reintalled it! came back ,when I ran it it came "INSTALL" instead of "PLAY" Install AGAIN! CRASHED just before it runs,running the live swich fixes it but adds more problems with background going color as mentioned above, any ideas?

Cheers Dennis

ToN
08-16-2009, 06:26 AM
Since my audio is messed up on the main menu, and from time to time during the course of the game (though not all the time) il give this a try. Though im currently trapped in a room where all exits lead to a Crsh To Desktop so i wont really be able to test wether this works or not.

EDIT: Mm no luck with the OP's fix and "fallout3.exe" was already in my ffdshow's "dont use" list. though i had these problems with all bethesda games ive ever bought buying fallout 3 was pretty stupid of me ^^.

Beastage
08-21-2009, 08:32 AM
I have an identical problem and I tried all solutions, reinstalled and installed any of klite codec packs, no success :(

The freezing in mothership Zeta dwarves in comparison the freezes in all the previous DLCs combined.

Lethal_Apple
08-22-2009, 08:50 PM
Serves you right for buying the DLCs, in my opinion. Serves me right, for that matter...I bought Broken Steel before learning my lesson.

The crashes are our computers' way of saying, "FOR GOD'S SAKE, STOP RUNNING THIS GARBAGE ON ME. GO OUTSIDE AND LET ME RECOVER FROM THIS BULL♥♥♥♥."

Mine actually yells that at me. I haven't reformated for a few years, and it is starting to become self aware.

Souls
08-26-2009, 08:04 PM
My game continues to freeze regularly. Maybe once every 10-60 minutes. I didn't have any custom codecs installed, but I tried the K-Lite install anyway and that didn't fix it. Disabled ffdshow after installing it, that didn't help. Also tried running in a window, running with vsync, lowest video settings, setting affinity to 1 core, setting affinity to 2 cores, turning off HDR, antialiasing, and anisotropic filtering, upgraded to latest WHQL nvidia driver, updated to latest vista x-fi driver.

Nothing ... stops ... the ... freezes.

By freeze I mean a total lock up of fallout3.exe which I have to kill from task manager.

The Steam version of the game is 1.5.0.22 and so everyone in this forum should be running that.

Did all the above with the same effect. Game freezes, kill it in task manager. I have even tried three different video cards (8800GT, 9400GT and GTS250) and it still freezes.

GoldenShadow
08-26-2009, 08:31 PM
Gotta try and eliminate suspect components. Try disabling your sound card in device manager and try a nice long play session to see if the problem happens. For example.

Souls
08-30-2009, 10:16 AM
Gotta try and eliminate suspect components. Try disabling your sound card in device manager and try a nice long play session to see if the problem happens. For example.

I should not have to do all this crap when I don't have any suspect components. No other game I have freezes like this so I think Bethesda, GFWL or Steam need to fix this BS before they release it or give me my freaking money back. It can be the highest rated game ever but if it don't work whats the use in having it?

GoldenShadow
08-30-2009, 10:43 AM
Buy it for Xbox then.

Souls
09-03-2009, 07:11 PM
Gotta try and eliminate suspect components. Try disabling your sound card in device manager and try a nice long play session to see if the problem happens. For example.

I bought the DVD version of the game because I found it cheap. Installed it and have played probably 7-8 hours of play with no freezes. I think its the Steam version.

Mulky
09-09-2009, 03:09 PM
I've got the steam version, never had any problems until I got the broken steel DLC. Now I get crashes to desktop anywhere between 5 minutes to 2 hours. It's not a question of "if" but "when".

:(

Smudo
09-20-2009, 09:20 AM
Hi,
for me it helped to disable 2 CPU Cores and Hyperthreading in the Bios. Is seems that the game has a problem with more then 2 CPU Cores.
I havent got any crash since i did this.

twidget64
04-11-2010, 01:55 PM
I tried all these various tricks and couldn't get it to run. I am running Windows 7 Pro with a Quad Core Intel Processor. After doing other searches, I finally found a fix that worked for me. It required editing the Fallout.ini File to allow the game to only run on two processors.
Here's the fix from http://www.sevenforums.com/gaming/20199-fallout-3-windows-7-w-quad-core.html:

Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2

Hopefully it'll help some others having similar issues.

cocokiwi
04-12-2010, 01:39 AM
I tried all these various tricks and couldn't get it to run. I am running Windows 7 Pro with a Quad Core Intel Processor. After doing other searches, I finally found a fix that worked for me. It required editing the Fallout.ini File to allow the game to only run on two processors.
Here's the fix from http://www.sevenforums.com/gaming/20199-fallout-3-windows-7-w-quad-core.html:

Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2

Hopefully it'll help some others having similar issues.
I tried it,it did not work,prob cause I use AMD

Cheers, Dennis:cool:

Iron_wofle
04-12-2010, 08:11 AM
So I installed the K-lite codec pack yesterday, and the game worked fine.. until I fired it up today. The freezing problem has returned, although it doesn't happen quite as frequently. I'm going to try un- and reinstalling the codecs, see if that works.

Yep, working fine now. So something either went screwy with the codecs on reboot, or there's something else.

fjk1138
04-13-2010, 05:37 PM
Doesn't help me either - still get CTD or BSOD randomly.

pureguava
04-24-2010, 07:09 PM
Same here - tried this fix, dual monitor fix, I have a dual core proc, tried single core, updated fallout, updated soundcard and video drivers... ALL OTHER GAMES WORK GREAT. Even the ones prior to Windows 7.

pureguava
04-26-2010, 05:42 PM
I know there are multiple threads on this - but I have done my research for the past week and tried everything - I am about to give up but I thought I would try and see if Bethesda or someone who knows another fix is watching.

I still freeze at random times in vault101, I can't even leave because the screen freezes, but the sound keeps playing. I have to CTRL-ALT-DEL. I do NOT crash to desktop and I do not bluescreen. All other games play fine. I just finished a 2 hour session of battlefield BC2, and a 4 hours session of Dragon Age. I also just played some Unreal tournament 3 for about 1 hour. I have no crashes in any other game on my pc, my system is running at optimal temps. RAM check came out fine.

Here is what I have tried to no avail:

- Maximizewindow.exe (i ran it with 10 1680 1050, which is my desktop res., but the window keeps its borders)
- adding fallout3.exe to ffdshow exclusions
- window mode with no AA
- fullscreen/window max settings
- fullscreen/window lowest settings
- matching refresh rates of desktop and game
- forcing vsync on and forcing it off
- Disabling windows data execution protection for fallout3.exe
- updating motherboard drivers, graphics drivers and sound drivers
- reinstalling .net framework, c++ redist, directx9 end user runtime,
- I have a dual core but I have tried the quad core thread fix in the .ini
- disabling dual monitor
- disabling all antivirus/spywar protectors
- clean boot then starting the game
- all windows updates
- checked for arcsoft in services didnt have it
- setting fallout3.exe in compatibility mode xp sp3, disabling themes and aero, run as administrator
- patching fallout3 to the latest version from here http://fallout.beths...ds/updates.html 1.7
- I dont have any DLC this is the barebones game. I don't have any mods.


I am

Windows 7 64bit
8800GT
i3 530 intel
4GB of RAM

I am using the STEAM version of the game. I am running the game away from steam and launching it via the executable. I've also tried running the game from within steam.

If you would like my dxdiag please let me know I will be happy to post it!

Thanks in advance, really desperate at this point and down about 50 dollars :(

JKflipflop
04-27-2010, 01:46 AM
Serves you right for buying the DLCs, in my opinion. Serves me right, for that matter...I bought Broken Steel before learning my lesson.

The crashes are our computers' way of saying, "FOR GOD'S SAKE, STOP RUNNING THIS GARBAGE ON ME. GO OUTSIDE AND LET ME RECOVER FROM THIS BULL♥♥♥♥."

Mine actually yells that at me. I haven't reformated for a few years, and it is starting to become self aware.

Rofl. you slag on the developer's work on the DLC, then go on to mention that you havent formatter your computer for years.

Good show!

Corion
05-19-2010, 09:03 PM
I tried all these various tricks and couldn't get it to run. I am running Windows 7 Pro with a Quad Core Intel Processor. After doing other searches, I finally found a fix that worked for me. It required editing the Fallout.ini File to allow the game to only run on two processors.
Here's the fix from http://www.sevenforums.com/gaming/20199-fallout-3-windows-7-w-quad-core.html:

Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2

Hopefully it'll help some others having similar issues.

I too have a Quad Core on Windows 7. This seems to have fixed the freezing I was getting fairly regularly (especially inside grocery stores, for some reason). THANK YOU VERY MUCH.

If you are on Win7 with a quad-core processor, try the above solution! It worked for me! It might only work for Intel processors, though, but try it even if you're on AMD - you have nothing to lose.

Staccatto
06-02-2010, 03:44 PM
I tried all these various tricks and couldn't get it to run. I am running Windows 7 Pro with a Quad Core Intel Processor. After doing other searches, I finally found a fix that worked for me. It required editing the Fallout.ini File to allow the game to only run on two processors.
Here's the fix from http://www.sevenforums.com/gaming/20199-fallout-3-windows-7-w-quad-core.html:

Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2

Hopefully it'll help some others having similar issues.

Worked perfectly! 2 hours of gameplay with NO crashes. Thanks man. :D

sytto
06-03-2010, 09:41 AM
Haven't played in a while and when i started playing again with the latest patches, I too was experiencing similar crashes and major hiccups too. Can't tell you how badly that ruins the immersion.

First thing i did was copy all the DLC to the Fallout folder where the main esp files are, but that didn't help, actually started to crash more.

Frustrated and disappointed, i started to read tons of "this is the fix', "solved" threads. I wasn't into messing with everything that much, I'll go play something else if this is the case.

So, I did none, zero, nada of these huge fix threads.
Here is what i did.

I downloaded this file, added it to where all the main game esp files are located, check marked it under data on the load screen.
http://www.fallout3nexus.com/downloads/file.php?id=5152

I set my setting to high, started the game, exited the game, went back and set to ultra (got a powerhouse box).

15 hours of game time later (knocking on everything wooden around me), no hiccups and zero crashes.

Azrael88
06-05-2010, 02:12 PM
I did the thread limiting on an amd x3 + win7 platform and uninstalled the k-lite codec pack I had. The random freeze seems to be gone from one or the other. I just have a far less frequent random crash to desktop to deal with now.

fragger59
06-21-2010, 07:13 PM
ive tried editing the .ini file and every other fix i could find but i cant play for more than one or two minutes
CPU: Intel Core i5 CPU M430 @ 2.27GHz
RAM: 4gb
Video Card: nVIDIA GeForce GT 325M, 1GB
OS: Windows 7 64-bit

cocokiwi
06-22-2010, 02:33 PM
ive tried editing the .ini file and every other fix i could find but i cant play for more than one or two minutes
CPU: Intel Core i5 CPU M430 @ 2.27GHz
RAM: 4gb
Video Card: nVIDIA GeForce GT 325M, 1GB
OS: Windows 7 64-bit

MOST problems I've found have been minor , I had a GTX 280 and found it would crash the game on start untill I lowered the settings down a notch,it then worked fine go from ultra down to HIGH, for some reasn it don't like ULTRA mode! I now have an ATI
HD 5830 1 gig Nice and it flies IN ULTRA mode!It crashed When I changed motherboard and CPU to AM3 8 gig 1333 memory and a NEW Phenom X6 core from a 4 .The so called Thread to change the core setting don't work,I know I tried it on both 4 core and 6,and my Laptop ha intel Dual core,All worked fine! I tried moving my GOOD working DATA file from the laptop to my new system,It WORKED
so no more problems.. So if you have another computer with the game on it and working copy the DATA file over as well as the "my games" file in Documents. worked for me!
Dennis:cool:
Not bad ! But FO3 don't have 2880x900 (grin)TWO 1440x900 HDTV monitors side by side! There are a lot of older games that Do support 2880x900 New Crysis set do , old try FARCRY The FEAR set,Etc

EhkoXC
06-27-2010, 11:26 AM
A question about this fix. The only time my game crashes if I have the radio on, or go to listen to a log, otherwise it's extremely stable. Does this fix that too?

Corpfox
06-29-2010, 12:11 AM
ive tried editing the .ini file and every other fix i could find but i cant play for more than one or two minutes
CPU: Intel Core i5 CPU M430 @ 2.27GHz
RAM: 4gb
Video Card: nVIDIA GeForce GT 325M, 1GB
OS: Windows 7 64-bit

Same

So annoying!

CPU: Intel Core i7 920
RAM: 6GB
Video Card: Geforce GTX 275
OS: Windows 7 64bit

mark92392
07-06-2010, 12:06 PM
I used to play this game just fine on an old P4 3.2. I built a new PC using the i3-550 and the game froze every 10 seconds. Sometimes it wouldn't even start. I applied this fix and now it works perfectly again.

Change bUseThreadedAI=0

to

bUseThreadedAI=1

Then below it add this line:

iNumHWThreads=2Bethesda says this should not make any difference, but they're full of ♥♥♥♥. It makes all the difference in the world.

elimin1
07-07-2010, 05:15 PM
Just wanted to give some more issue since I have the same problem.

Note I have not tried the 64-bit/win7 fix yet, and that is my setup.. Additionally I have two monitors.

Note: I never had a single issue until I installed windows Live/added broken steel.
Note2: I have a retail version... it's not steam.

I have a feeling this has something to do with Direct X 9 support more than anything. So asking steam to fix this is probably going to be wasted effort. Additionally here is a couple of things I have tried to limit the crashing and increase overall game performance.

Additionally this could quite simply be just a addon issue from Bethsheada.

1. Disabled AERO desktop and turned on Windows 7 Basic. While I dislike this, and have since switched back, this fix did allow me to watch movies or sports on my second screen while playing Fallout 3, With Live enabled. I also found that it still crashed, but it was not nearly as often.

2. I reinstalled, Direct X 9. I had to do this a couple of times as windows likes to update it, and when it does my crashes for DX 9 games come back. The built in run games /XP DX9 native, is just not the same as installing DX9.e, It helps on more than just this game, it has helped on a handful of Total war games as well.

3. Running the game windowed. This pretty much eliminated all my issues. But unfortunatly my Gamma support was gone, so playing the game during a sunny day made it hard for me to see around the enviroment of the game. If your computer is in some dark place underground already you will probably not notice... or you have better gamma support for your monitors.

I will try asking the game to run a single proccessor tonight, but it just seems more of a MS issue because this seems to only be happeneing to Vista/Win7 Users, and more often to 64-bit issues. People need to just get over the hurdle and start making games for DX10/11 rather than continuing to develop on old tech.

Cheers.

mark92392
07-07-2010, 05:54 PM
I should have noted that I am running Win7 64bit also. The fix:

Change bUseThreadedAI=0

to

bUseThreadedAI=1

Then below it add this line:

iNumHWThreads=2 Fixed every issue with the game.

BTW, KUDOS to whomever figured this fix out.

Darthlex
07-26-2010, 04:53 AM
ive tried editing the .ini file and every other fix i could find but i cant play for more than one or two minutes
CPU: Intel Core i5 CPU M430 @ 2.27GHz
RAM: 4gb
Video Card: nVIDIA GeForce GT 325M, 1GB
OS: Windows 7 64-bit

I got pretty much the exact same specs (Asus N71Jv?) and I also have the exact same problem ..

also this:

Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2

changed absolutely nothing =/ I crashed again after a minute or two, as always .. It's not at any certain spot either.

JK_DC
08-04-2010, 10:13 PM
None of them work. I tried every one of them. I was able to play it when it first came out on XP before it was patched but haven't been able to since then. I'm not going back to XP though for one game.

LightOfDarkness
08-09-2010, 12:16 PM
I installed the codec and the crashes have stopped. I did have one crash which involved the 1.5 patch not installing correctly. I restarted the game and it played just fine. Hmmm.

I have a question though...what is it about the codecs that causes the game to stop freezing? I am not understanding why this should work.

It's something to do with not playing video/sounds properly, because Fallout 3 doesn't play nice with the default codecs