PDA

View Full Version : Unpredictable Crashes


QualityJeverage
06-18-2009, 01:44 PM
Whenever I go to play the game, I manage to play for a minute or two because the screen freezes, the music begins to loop, and eventually I crash to desktop with a "Oblivion has stopped working" error.

During the training portion in the caves/sewers, the game would freeze every few minutes but would not crash, instead returning to normal after 10-15 seconds. Outside of that beginning area though, the freezes crash the game, always. I've tried everything I can think of, to no avail, details to follow:

System specs:

Windows 7 RC Build 7100, 64-bit
XFX GTX280 GPU on 186.18 Drivers
Intel Q6600 at 3.1GHz
WD Caviar Black 1TB HDD
8GB Corsair Dominator DDR2-1066
ASUS Xonar DX 7.1 PCI-E Audio card

Things I've tried:

Returning the CPU to it's stock speeds
Updating/Rolling back GPU Drivers
Updating/Rolling back Sound card Drivers
Running the game in a window
Running the game with all video and audio settings off or at lowest setting
Disabling the Steam in-game interface
Removing all mods
Disabling AV Software

--

This is getting frustrating. Any ideas anyone has would be greatly appreciated!

mr.darky
06-18-2009, 01:46 PM
See if deleting or renaming your "Oblivion.ini" file solves the crashes. It stores graphics and sound settings for the game, and should be located here: (C:\Users\WINDOWS-LOGIN-NAME\Documents\My Games\Oblivion)

If you happen to have XP or Vista dual-booted on the same machine, you might try and see if it works on that instead. In that case, the problem is likely a compatibility issue with Windows 7 or one of its drivers.

QualityJeverage
06-18-2009, 01:51 PM
Thanks for the quick reply! No luck with the .ini unfortunately.

I've suspected it was a Win7 issue, though I've read of other people running the game successfully on it. Of course, it is beta software, so I can't expect perfection.

mr.darky
06-18-2009, 02:05 PM
Another thing you could give a shot is running the game in Vista or XP compatibility mode. Go to Oblivion's Steam installation directory, which should be around here: (C:\Program Files\Steam\steamapps\common\oblivion)

.. and right-click "Oblivion.exe" and select Properties. In the dialog that pops up, click the Compatibility tab, and then select one of the operating systems in the Compatibility mode area. You should also do the same for "OblivionLauncher.exe".

CobraVE
06-18-2009, 02:39 PM
It's an (audio) codec issue. Oblivion just as Fallout3 is very codec nitpicky. Find out which codec makes your game crash, or find the correct codec sequence to make it run and post it here. We are all looking for it, check google.

QualityJeverage
06-18-2009, 05:13 PM
Yep, it was a codec issue. Found this after a little Google hunting and used it to disable all codecs:
http://nightmare2013.brashendeavors.net/directshowfiltersreset_v4.1.zip

Sure enough, the game ran fine. Now, the hard part is determining which specific codec was causing my problem, but that's on me to do. Thanks for the help guys!

CobraVE
06-19-2009, 02:52 AM
I know that seems to work, but I have Vista x64 so the reg-hack just won't work for me=/

UltimateTobi
06-19-2009, 04:11 AM
I've had played Oblivion with the Windows 7 Beta 64-Bit-Version some months ago, and it didn't work right, it was stuttering everytime and crashing sometimes, so I guess it has something to do with the 64-Bit version.

My systemspecs:
Windows 7 Ultimate 32-Bit (RC1)
AMD Phenom 9950
NVIDIA GeForce 9800 GTX+ 512MB GDDR3 (186.18)
4096MB DDR2-800 (3GB usable)

And it runs just well as I've never imagined it.

Kind regards, Ultimate! :D

Enmoku
06-20-2009, 12:59 PM
If ffdshow is the source of your problems, then add the game's executable to ffshow's ignore/exclude list. No need to cripple every other software using them.

People with multi-core systems may want to try limiting the game to single core (through task manager, imagecfg, start /affinity n ♥♥♥♥, etc.). This solved my crashes (Athlon X2 64 CPU, but the Athlon X2 line is horrible anyway and exhibits issues no other CPU does on top of the usual multi-core problems).

nofattiesplease
06-23-2010, 11:09 PM
Sorry to bump an old thread, but since codecs seem to be the problem, you can disable the intro movies. It worked PERFECTLY for me. I searched around for a long time trying to find a solution and didn't find anything that worked well.

Modify C:\Users\_______\Documents\My Games\Oblivion\Oblivion.ini
just remove the values for the main intro and the menu intro movie. The menu movie (map loop) can stay there but if you still have issues try removing that as well.
SMainMenuMovie=Map loop.bik
SMainMenuMovieIntro=
SIntroSequence=