PDA

View Full Version : stuttering in-game?


curlyhairedboy
09-08-2009, 06:15 PM
i've been playing the demo, and been getting 60+ FPS at all times. only problem is, around every 4 seconds, there's a "hitch" in the game. anybody else have this problem?

theyarecoming4u
09-09-2009, 04:32 AM
I get the same thing and it's definitely not my specs. The same thing happens with Kane & Lynch and it makes it unplayable (with K&L it was related to USB keyboards with volume controls) - I think it's beyond a coincidence that both games are by the same developer. Another shoddy game by a shoddy developer.

Specs:

Core i7 @4GHz / 6GB DDR3 / 4870 / Win7 x64 RC / Saitek Eclipse keyboard

curlyhairedboy
09-09-2009, 07:09 AM
bahahahaha

are you serious? that's a laugh. i mean, i can just plug in another keyboard or just unplug it while i use a controller, but jeez, that's crazy.

utilael
09-09-2009, 06:14 PM
I'm having the same problem, definitely not the specs, it runs just fine at max graphics and does the same thing with the same period of time between 'shuttering' with the graphics as low as it can go. Same thing happened for me with Oblivion once, believe it was a DirectX problem but I can't remember what I did to solve it.

Windows Vista x64
Intel Pentium Dual Core E2220 2.4GHz / 4GB DDR2 / GForce 9600 GSO 768MB DDR3

Not near as good as theyarecoming4u but runs most games without a problem ;P

If anyone has any ideas.. I'd like to play the game without the annoying jolt, in fact it might stop me from playing all together with how annoying it is >.>.

gve
09-09-2009, 09:58 PM
i had same problem on demos before, strange seems steam demos got these kind of problems. Las one was on fear 2 demo after getting the game is gone. But atm no problems.

Phenom x4 2.6ghz 4gb 1066mhz, 4870 1gb

shackl
09-09-2009, 11:30 PM
same problem! It's unplayable like this. Anyone find a fix yet?

JawJacker
09-10-2009, 03:01 PM
I have the same issue and have verified that the stuttering goes away if I unplug my USB keyboard AND mouse (either one plugged in causes the stuttering). This is a showstopper for me since I don't have an XBOX 360 receiver for Windows nor do I have any PS/2 keyboards or mice. The game is unplayable. Can I get a refund so that I can go buy the Wii version of the game?

JawJacker
09-10-2009, 03:24 PM
I was able to get rid of the stuttering by disabling all HID-compliant devices in device manager and can still use my USB keyboard and mouse.

d3vilsadvocate
09-11-2009, 02:46 AM
I have like 30 entries under HID, there is no way I am going to disable all of them manually in order to just play one damn buggy game...

And why the heck doesn't this game support my logitech controller???

viralomega
09-11-2009, 06:28 AM
how is this bug still around? Kane and Lynch and now this game. what a pathetic developer. i get the same stuttering


edit: Thanks Jawjacker. Disabling HID device entries worked for me as well.

SHREDDER
09-11-2009, 09:24 AM
how is this bug still around? Kane and Lynch and now this game. what a pathetic developer. i get the same stuttering


edit: Thanks Jawjacker. Disabling HID device entries worked for me as well.



That Strange... I hane an Athlon X2 4400+ 2,2GHZ 2 GB RAM 8800GT 512 MB and the game runs perfect on max settings 1280x1024+ 8XAA with sound and full speed. if you have a pc more powerful than mine you will not have any problemss. The game is very gun and unique, it is something different from all the gorry FPS games that we are used today. BUY IT< It is Realy Worth it!!:):):):):) SUPPORT PC GAMING

d3vilsadvocate
09-11-2009, 10:44 AM
look mate, reread the post, it is not a performance issue, it's a bug they should have fixed a long time ago.

shackl
09-11-2009, 12:34 PM
disabling the HID stuff worked for me perfectly.

JoeB
09-11-2009, 03:56 PM
Found a solution. It worked for the demo at least. Look here (http://forums.steampowered.com/forums/showpost.php?p=11242569&postcount=3).

d3vilsadvocate
09-12-2009, 01:39 AM
hey thanks for that answer. one question though: does that only fix the sound stuttering you had, or did it also fix the video stuttering occurring every 4 seconds?

thanks

d3vilsadvocate
09-12-2009, 04:56 AM
ok I've tried it. It didn't solve the problem, the video stuttering bug is still there.

MrPing1000
09-12-2009, 06:15 AM
I also have this problem. Tried the sound thing, fixed my sound, didn't fix my stuttering. In win 7 64bit.

JoeB
09-13-2009, 07:02 AM
OpenAL only handles sound so I can see why this would only correct the audio aspect (so that was part of the solution at least). Unfortunately I can not replicate the video stuttering (I'm on Windows 7 x64 as well) or else I'd try and troubleshoot that as well.

Do you have an ATI video card? If so, you can try and reset all your Catalyst settings back to their default. That can fixes the strangest of problems at time (if there are compatibility issues with your settings). If you have an nVidia card, perhaps you can do the same thing in the video control panel.

JawJacker
09-14-2009, 06:50 PM
The OpenAL fix doesn't do anything for the video stuttering...I just tried it. I never had any sound stuttering issues...

JawJacker
09-14-2009, 06:52 PM
I have like 30 entries under HID, there is no way I am going to disable all of them manually in order to just play one damn buggy game...

And why the heck doesn't this game support my logitech controller???

You're right...this shouldn't even be an issue. Up to you whether you think disabling HID devices is worth it or not. You don't actually have to disable ALL HID devices, just the ones associated with any USB mice or keyboards. It's hard to tell which those are, however. You can use trial and error until you find them...or not.

Jezuz
09-15-2009, 12:54 AM
It's a shame you all bash a developer for what is a publisher's issue. Eidos pushes developers to get games out as quick as possible. If this effects 15% of customers, then the developer has to decide... should they make a game that works for 85% of people, or use valuable time on a glitch and make a less complete, less enjoyable game for that large majority.

While it sucks that you guys can't play the game, don't bash the developer. Bash the publisher for making a truly great developer force out a game without being able to hammer out the bugs... and more than likely, not giving them the funding for a patch in any way.

d3vilsadvocate
09-15-2009, 01:39 AM
I don't care who it is I have to blame. Neither of them is going to see my money.

Games are getting buggier and buggier these days, and in the end all I will be buying are Blizzard and Valve games for exactly that reason.

Jezuz
09-15-2009, 11:58 AM
I don't care who it is I have to blame. Neither of them is going to see my money.

Games are getting buggier and buggier these days, and in the end all I will be buying are Blizzard and Valve games for exactly that reason.

Enjoy your great variety of SHOOTING TIME 4: EPISODE 45 and GENERIC RTS 43: ATTACK OF THE WEIRD ALIEN THINGS. Oh, and don't forget that with Blizzard, you now get to pay 3 times for one game! GOOOOOO BLIZZARD!

Blizzard/Activision is the most corrupt business of them all, so I'd try to find a business that actually gives you a complete product, if that's what you're after.

d3vilsadvocate
09-15-2009, 02:04 PM
lol mate you got issues man...

and I'd gladly pass on a hundred good games in order to play only one blizzard game. They are simply so much better than the rest (wow being the only exception imho...).

But yeah go back to play your buggy games, it's your money.

sub7th
09-16-2009, 03:12 AM
Was having sound issues at first.
I ran CCleaner and then ran CCleaners registry cleaner until I had no more issues found, then defragged, restarted.

No more issues.

Geforce 8800GTX, QX6850 @ 3GHz, XP Pro
Also I have USB mouse and Keyboard and on board sound.
But I'm using an XBox360 controller to play.
I run the game at 1920 x 1080 all settings at full including 4x AA.
I just finished the water level, haven't had a stutter since the first level at the dojo.

Hope that helps at least a few of you.
It's a fun game.

lafingman0
11-28-2009, 12:56 AM
I have a similar issue - only the game locks up every couple minutes for about 3 seconds.

And now the sound is kinda staticy :P

Quatrix
12-16-2009, 07:37 AM
I'm getting the same brief pauses every 2 - 3 seconds. It happens on a clean install of Windows 7 Pro x64 but NOT on XP Pro. It's a dual-boot setup on one PC, so 7 and XP have the same USB/HID devices. I tried plugging the mouse into the PS/2 port (which is a superior interface for keyboards and mice anyway) with no luck.

Herbalacious
12-29-2009, 01:17 PM
Hmm..Same problem. Altho I bought the Eidos pack on special mostly for the tomb raider/hitman series/batman. For 50 bones it's a great deal imo. This game looks fun, but the stutter just kills me. I haven't played the game longer than 5 minutes.

Intel i7 920 @ 3.33GHZ OC
Asus P6T V2
6GB Corsair Dominator
x2 NVidia 295 GTX SLI

Kaixx
03-13-2010, 02:21 AM
It's a shame you all bash a developer for what is a publisher's issue. Eidos pushes developers to get games out as quick as possible. If this effects 15% of customers, then the developer has to decide... should they make a game that works for 85% of people, or use valuable time on a glitch and make a less complete, less enjoyable game for that large majority.

While it sucks that you guys can't play the game, don't bash the developer. Bash the publisher for making a truly great developer force out a game without being able to hammer out the bugs... and more than likely, not giving them the funding for a patch in any way.Too bad your point is completely invalid. It was around for Kane & Lynch apparently, and because of this they DID know about the issue and didn't bother to solve it for this game when they were getting the funds to make the game.

toejam
03-13-2010, 04:31 AM
This game runs worse then Crysis maxed for me.
E7400 @3GHz
2*HD4850
2GB DDR667 Dual Channel RAM (need to upgrade it :()

Nexus Prime
03-13-2010, 09:37 PM
I take it this wont be getting fixed anytime soon.

Kodi Lux
03-21-2010, 01:18 AM
I take it this wont be getting fixed anytime soon.

Don't hold your breath. Since this seems to be a bug found in other Eidos games (I haven't played K&L so I can't say personally) and it hasn't been fixed yet, I'm guessing it's not at the top of their priorities. Sad.

Quatrix
07-08-2010, 12:41 PM
In case anyone is still looking for a fix, I hope this post helps. I have 14 different HID devices in Windows 7, but I only had to disable the one associated with my Microsoft USB keyboard to eliminate the stutter. You can either right-click the device and choose "Disable" in Device Manager or use the utility devcon.exe plus a batch file to automatically disable the device before running the game and then turn it back on (sorry, you'll have to research that option yourself).

deedward9
02-12-2011, 01:51 PM
For me, I had to disable the HID entry for my USB Gyration mouse and keyboard. It seems to play fine now with my Logitech mouse and keyboard.

I also had the now sound problem with an older 1st gen Audigy card. I changed over to a HT Omega Striker and now the sound works flawelessly without any mucking around.

Phredster
05-24-2011, 10:51 AM
Ok so you guys deleted the HID entries or disabled them, but did you then use another KEYBOARD as well or the same one with a different HID or what? :confused:

g0r3m4ch1n3
05-24-2011, 12:05 PM
Same problem.
So what´s it going to be, a patch or a refund?