PDA

View Full Version : Howcome listen server doesn't work?


OwnageChicken
10-24-2009, 02:59 PM
I've tried making my own Listen server, but my friends can't join? Howcome? Also, what's the difference between dedicated and listen? Everytime I try to host dedicated, my KF closes and this window opens up with a whole bunch of text. I have no idea how it works.

mystrdat
10-24-2009, 03:01 PM
Turn on uPnP on your router or make the adequate port forwards that the game suggests when you try to host.

Listen is WITH you playing, Dedicated is WITHOUT.

BigFactHunt
10-24-2009, 03:04 PM
Once you click Dedicated, that window that opens is the log, look at your tray icons, there'll be a red KF icon there. You can then join your own server through the server list in game (start KF up again) or by right clicking in the server list and choosing add IP, then typing in your own IP address.

OwnageChicken
10-25-2009, 02:48 AM
Waiittt... so can you run me through the steps, but in numbered form? I'm new to this whole 'making own server' thing.

Ramzuz
10-25-2009, 08:29 AM
Do you have a router? If you do, the problem is propably the ports.

If you're new to ports, use this website

http://portforward.com/

I opened the ports needed for KF, and BOOM, i can now host an online game, haven't tried dedicated, but listenserver works fine.

Heres the list of ports:

7707 UDP/IP (Game Port)
7708 UDP/IP (Query Port)
7717 UDP/IP (GameSpy Query Port)
28852 TCP/IP and UDP (Allows your Server to Connect to the Master Server Browser)
8075 TCP/IP (Port set via ListenPort that your WebAdmin will run on)
20560 UDP/IP (Steam Port)

Another setting you might have to deal with when hosting a listen server in your killingfloor.ini is:

ServerBehindNAT=False Set it to True

Hope i could help

Yoshiro
10-25-2009, 08:35 AM
Do what Ramzuz said to forward your own ports. Alternatively (you might end back up doing this manually if the following does not work) you can make sure UPnP is enabled on your router, and the game will try and open those ports for you when you host. However some routers do not properly do this and as we just added UPNP support the game doesn't have all the hack/work arounds that other programs might have to get UPNP working on all systems (also believe you need to make sure upnp/network discovery is on in windows).

kurcatovium
01-25-2011, 04:28 AM
I am still not able to host listen server. I tried everything described her. Windows firewall configured to allow KF, UPnP is enabled, all needed ports opened, killingfloor.ini file edited (ServerBehindNAT=True), but still the game is impossible to reach for any of my friends. Is there anything else to make it work? Well, I'm really pissed off now...

Dimeinurear
01-31-2011, 07:36 PM
Do what Ramzuz said to forward your own ports. Alternatively (you might end back up doing this manually if the following does not work) you can make sure UPnP is enabled on your router, and the game will try and open those ports for you when you host. However some routers do not properly do this and as we just added UPNP support the game doesn't have all the hack/work arounds that other programs might have to get UPNP working on all systems (also believe you need to make sure upnp/network discovery is on in windows).


What does the "192.168.1.x" have to be set to? I have mine set to "192.168.1.1" Will that work?

zYnthetic
01-31-2011, 08:14 PM
What does the "192.168.1.x" have to be set to? I have mine set to "192.168.1.1" Will that work?

Ports should be forwarded to the box acting as the server. ipconfig in a Windows cmd prompt should tell you the local ip. Alternatively, if there is a "Connected Devices" page on your router it should also list the IPs of everything currently on and connected to the router. If you know the host/device name it should make it easy to cross reference.

JanJanssen
01-31-2011, 10:41 PM
I am still not able to host listen server. I tried everything described her. Windows firewall configured to allow KF, UPnP is enabled, all needed ports opened, killingfloor.ini file edited (ServerBehindNAT=True), but still the game is impossible to reach for any of my friends. Is there anything else to make it work? Well, I'm really jarateed off now...

I've had a problem myself with hosting a server with Window's Firewall on Windows 7. I couldn't get it to stop blocking incoming connections. You can try disabling the firewall to test if it's causing any problems.

Miidgi
07-09-2013, 07:58 PM
Old thread, but I tried everything here after forwarding the ports through my Ethernet connection, and it still didn't work until I also disable my wifi. If you have multiple connections to the internet, maybe try that?