PDA

View Full Version : Game Tweak Tips (AA, VSYNC, MICS etc)


Pages : [1] 2

Cyborgmatt
10-26-2009, 02:38 PM
Lots of threads popping up asking about vsync, mics, aa etc.

Here's a quick guide on how to fix some of those things.

Reminder: Always make a backup copy of your INI files before editing them!


Disable Voice Chat

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowEngine.i ni
Find:
bHasVoiceEnabled=True
Change To:
bHasVoiceEnabled=False

Enable V-Sync (Stops screen tearing)

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowEngine.i ni

Find:
UseVsync=False

Change To:
UseVsync=True

Disable Intro Movies

Open:
\Steam\steamapps\common\borderlands\WillowGame\Mov ies
Delete:
2K_logo.bik, Gearbox_logo.bik, NVidia.bik

Disable Intro Movies (Without Deleting Any Files)

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowEngine.i ni
Find:
[FullScreenMovie]
StartupMovies=2K_logo
StartupMovies=Gearbox_logo
StartupMovies=NVidia
StartupMovies=Loading
SkippableMovies=2K_logo
SkippableMovies=Gearbox_logo
SkippableMovies=Attract
SkippableMovies=NVidia
Replace With:
[FullScreenMovie]
;StartupMovies=2K_logo
;StartupMovies=Gearbox_logo
;StartupMovies=NVidia
;StartupMovies=Loading
SkippableMovies=2K_logo
SkippableMovies=Gearbox_logo
SkippableMovies=Attract
SkippableMovies=NVidia

Enable Anti-Aliasing

ATI Cards:
Download Rivatuner and use the "D3DOverrider" option. http://www.guru3d.com/category/rivatuner/
NVidia Cards:
Download and nHancer. http://www.nhancer.com/

Adjust the FOV (Field Of View)

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i

Find Under The "[Engine.PlayerInput]" Section:
Bindings=(Name="F8",Command="shot")

Add Below:
Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)
You can experiment with different FOV figures to find a field of view that suits you.

Disable Mouse Smoothing

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i

Find:
bEnableMouseSmoothing=true

Change To:
bEnableMouseSmoothing=false

Enable Third Person (Thanks [BoX]SteroidFreud)

Screenshot: http://www.uploads.gaming-resources.com/files/35_la0hj/Borderlands3P.jpg

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i

Find Under The "[Engine.PlayerInput]" Section:
Bindings=(Name="F8",Command="shot")

Add Below:
Bindings=(Name="F3",Command="Camera ThirdPerson",Control=False,Shift=False,Alt=False)
Bindings=(Name="F4",Command="Camera FirstPerson",Control=False,Shift=False,Alt=False)

Toggle Aim (Right Mouse)

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i

Find Under The "[Engine.PlayerInput]" Section:
Bindings=(Name="RightMouseButton",Command="advancedbutton bAdvancedButtonAux5")

Replace With:
Bindings=(Name="ToggleAimOn",Command="advancedbutton bAdvancedButtonAux5 | OnRelease StartAltFire | setbind RightMouseButton ToggleAimOff")
Bindings=(Name="ToggleAimOff",Command="advancedbutton bAdvancedButtonAux5 | OnRelease StopAltFire | setbind RightMouseButton ToggleAimOn")
Bindings=(Name="RightMouseButton",Command="ToggleAimOn")

Enable Windowed Mode

To run the game in windowed mode you need to add the following onto your shortcut's command line:
-windowed
To do this in Steam, right click on Borderlands, goto "Properties", click "Set launch options..." and enter:
-windowed
To disable windowed mode, change the command line to:
-fullscreen

Enable Windowed Mode (When In Game)

Whilst the game is running press:
Alt + Enter
Press it again to revert back to fullscreen.

Ports Required To Host Multiplayer Game

To host an online game, the following ports need to be opened / pushed to the host's internal IP address:
7777 (TCP/UDP)
28900 (TCP)
27900 (UDP)
28910 (TCP)

Disable The HUD

Open:
Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i

Find Under The "[Engine.PlayerInput]" Section:
Bindings=(Name="F8",Command="shot")

Add Below:
Bindings=(Name="F7",Command="togglehud")

Show More Item Attributes

Open:
Steam\steamapps\common\borderlands\WillowGame\Loca lization\INT\gd_globals.INT

Find:
AttributePresentationTranslation="$NUMBER$ $CONSTRAINT$ $DESCRIPTION$"

Replace With:
AttributePresentationTranslation=<font size="10">$NUMBER$ $CONSTRAINT$ $DESCRIPTION$</font>
Alter the size="x" variable to a size that suits you, eg: 8, 10, 12 etc.

Psamathos
10-26-2009, 02:46 PM
Thanks, I was about to look for the config files myself but now I don't need to. +rep

Gene
10-26-2009, 02:47 PM
Do you have a way to fix the console port mouse? I tried looking at bioshocks stuff and adapting it but I can't find the equivalent line in any INIs

thaqza
10-26-2009, 02:48 PM
Lovely, cheers!

synx
10-26-2009, 02:55 PM
Download and nHancer. http://www.nhancer.com/


Seriously, don't install that crap on your computer.

Wasser
10-26-2009, 03:01 PM
Quickfix to adjusting FOV

Open willowinput.ini
Find [WillowGame.WillowPlayerInput]
Add this somewhere under the heading:
Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)
Experiment with what FOV you prefer (I like 100 on my 16:10), you can bind different FOVs to different keys.

Do you have a way to fix the console port mouse? I tried looking at bioshocks stuff and adapting it but I can't find the equivalent line in any INIs
You can try opening willowinput.ini and changing bEnableMouseSmoothing=true to false. I don't mind the mouse myself, but those who do have reported that this improves it.

Chib
10-26-2009, 03:02 PM
Especially since the default NVidia drivers let you turn on AA anyway through its control panel.

DaveKap
10-26-2009, 03:06 PM
Quickfix to adjusting FOV

Open willowinput.ini
Find [WillowGame.WillowPlayerInput]
Add this somewhere under the heading:
Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)
Experiment with what FOV you prefer (I like 100 on my 16:10), you can bind different FOVs to different keys.


You can try opening willowinput.ini and changing bEnableMouseSmoothing=true to false. I don't mind the mouse myself, but those who do have reported that this improves it.

THANK YOU!!! I was wondering how quickly someone would figure out how to fix this godawful FOV. Poor PC porters keep forgetting that PC gamers actually manage to run games at 1080p resolution unlike the console and thus needs a better FOV. Silly PC porters.

KayinAngel
10-26-2009, 03:09 PM
Quickfix to adjusting FOV

thanks for this. my biggest issue with devs who make games on console and pc, is that the pc version always has that narrow field of view the console version has.

hopefully they add the option in a patch (see: bioshock, far cry 2...)

MKing78
10-26-2009, 03:09 PM
Especially since the default NVidia drivers let you turn on AA anyway through its control panel.

What card and driver are you using? I wasn't able to get AA working with mine but I'm using an older driver though.

GTX280 - 186.18

KyRoS
10-26-2009, 03:10 PM
Nice. Thanks.

Cyborgmatt
10-26-2009, 03:39 PM
Especially since the default NVidia drivers let you turn on AA anyway through its control panel.
Yeah except when it comes to the U3 engine, AA only works when using nHancer tbh.
What card and driver are you using? I wasn't able to get AA working with mine but I'm using an older driver though.

GTX280 - 186.18
It doesn't work using the default nvidia panel.

Wasser
10-26-2009, 03:40 PM
Bumping this.

Yvese
10-26-2009, 03:42 PM
How do you force AA using Nhancer? I put it to 8x MSAA and tried SSAA but it didn't work.

MKing78
10-26-2009, 03:48 PM
How do you force AA using Nhancer? I put it to 8x MSAA and tried SSAA but it didn't work.

Try this. Found it in the Gearbox forums. Let me know if it works. Haven't tried cause I'm at work.

"For FSAA with an nVidia card download nHancer and enable Unreal Engine 3/Unreal Tournament 3 FSAA Comatability Mode under AA Tweaks."

Neferati
10-26-2009, 03:53 PM
Whats the default FOV?

noobdeagle
10-26-2009, 03:58 PM
also dont use vsync or post the alternate solution for UE3 Vsync causes alot of input lag for many people including myself hence i dont use it instead UE3 has an FPS smoothing option simply enable it and set it for under your refresh rate ie mine is 75hz so i set smoothing to 60-65

i do this in every UE3 game so borderlands is no differnt i cant play the game yet cos its not the 30th :\ but its the same for all UE3 games

this is from the UT3 ini but willowengine.ini should have something similar
bSmoothFrameRate=True

MinSmoothedFrameRate=22
MaxSmoothedFrameRate=62

DaveKap
10-26-2009, 04:15 PM
also dont use vsync or post the alternate solution for UE3 Vsync causes alot of input lag for many people including myself hence i dont use it instead UE3 has an FPS smoothing option simply enable it and set it for under your refresh rate ie mine is 75hz so i set smoothing to 60-65

i do this in every UE3 game so borderlands is no differnt i cant play the game yet cos its not the 30th :\ but its the same for all UE3 games

this is from the UT3 ini but willowengine.ini should have something similar
bSmoothFrameRate=True

MinSmoothedFrameRate=22
MaxSmoothedFrameRate=62

You are correct, those exact lines are in willowengine.ini, but say you're on a typical 1650x1080 monitor that uses 60mhz refresh rate. Are you saying that simply reducing the max down to 58 will prevent tearing? I'm unsure that's how vsync actually works... although I do agree that there is some odd mouse acceleration problems with this game (with and without aim-assist turned on.)

I'll go try this right now.

brendan55
10-26-2009, 04:24 PM
Quickfix to adjusting FOV

Open willowinput.ini
Find [WillowGame.WillowPlayerInput]
Add this somewhere under the heading:
Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)
Experiment with what FOV you prefer (I like 100 on my 16:10), you can bind different FOVs to different keys.


You can try opening willowinput.ini and changing bEnableMouseSmoothing=true to false. I don't mind the mouse myself, but those who do have reported that this improves it.

I can't get the fov tweak to work. I copy paste the line under this [WillowGame.WillowPlayerInput]

When I load up my game I cannot move, the only button that had a reaction was F11. Which did change the FOV (hooray) but I can't move. I changed the line to Bindings=(Name="F11",Command="FOV 90") But saw no difference. Help?

noobdeagle
10-26-2009, 04:25 PM
You are correct, those exact lines are in willowengine.ini, but say you're on a typical 1650x1080 monitor that uses 60mhz refresh rate. Are you saying that simply reducing the max down to 58 will prevent tearing? I'm unsure that's how vsync actually works... although I do agree that there is some odd mouse acceleration problems with this game (with and without aim-assist turned on.)

I'll go try this right now.

it should as long as the max is below your refresh you should see tearing unless it somehow spikes i know in all the other UE3 games its also default at 62 and hence lack of vsync options in some off them except it causes tearing cos its a couple frames over setting it lower should corect it IMO its a better alternative to vsync you can do similar things in source engine games using fps_max command doing these kinds of things also reduce load on video card causing it to consume less power :)

vsync works differntly it doesnt just limit frame rate it does something else

Wasser
10-26-2009, 04:27 PM
I can't get the fov tweak to work. I copy paste the line under this [WillowGame.WillowPlayerInput]

When I load up my game I cannot move, the only button that had a reaction was F11. Which did change the FOV (hooray) but I can't move. I changed the line to Bindings=(Name="F11",Command="FOV 90") But saw no difference. Help?
I have no idea what you have done wrong, but in the interest of IT Voodoo try putting the fov binding at the very bottom of the section (but still in that section) to see if it changes anything.

Lemon Jelly
10-26-2009, 04:27 PM
Thank you, awesome thread :D

Gaffadin
10-26-2009, 04:33 PM
I've been unable to get AA working on an Nvidia card using Nhancer.

I'm guessing one of the compatibility modes for UE3 needs to be set, but there are multiple versions and even though I tried them all I couldn't see any noticeable difference in image quality using any of them.

cl_hulksmash
10-26-2009, 04:38 PM
I've been unable to get AA working on an Nvidia card using Nhancer.

I'm guessing one of the compatibility modes for UE3 needs to be set, but there are multiple versions and even though I tried them all I couldn't see any noticeable difference in image quality using any of them.

This... there needs to be very specific settings to actually achieve AA it seems.

GTX 285 on 191.07 btw

moosenukes
10-26-2009, 04:48 PM
This needs a sticky!

kilaan
10-26-2009, 04:48 PM
I can't get the fov tweak to work. I copy paste the line under this [WillowGame.WillowPlayerInput]

When I load up my game I cannot move, the only button that had a reaction was F11. Which did change the FOV (hooray) but I can't move. I changed the line to Bindings=(Name="F11",Command="FOV 90") But saw no difference. Help?

Same thing happens to me, wierd.

Red Mundus
10-26-2009, 04:49 PM
Oh thank god! The mouse smoothing and FOV were driving me crazy!

brendan55
10-26-2009, 04:51 PM
I have no idea what you have done wrong, but in the interest of IT Voodoo try putting the fov binding at the very bottom of the section (but still in that section) to see if it changes anything.

I added in the line as said to. Same effect. So with the same ini I loaded up the game BUT this time I went into options-> controls and guess what? they were all blank! So I set them to default values and what happens when I run the game? The F11 fov toggle doesn't work! It worked when all controls didn't.

Very frustrating.

tiedie
10-26-2009, 04:51 PM
That FOV command is great, as is the mouse smooth=false

Gadianton
10-26-2009, 04:55 PM
I added in the line as said to. Same effect. So with the same ini I loaded up the game BUT this time I went into options-> controls and guess what? they were all blank! So I set them to default values and what happens when I run the game? The F11 fov toggle doesn't work! It worked when all controls didn't.

Very frustrating.

I am having the same problem. With the FOV binding in, no controls.

cl_hulksmash
10-26-2009, 04:59 PM
forgot to mention my thanks for this thread... :)

and for those having issues with FOV fix, read carefully and you'll understand that you need to put the binds underneath:

[WillowGame.WillowPlayerInput]

that's at the BOTTOM of the .ini file, and right above:

[IniVersion]

this is an example of how mine looks like:

[WillowGame.WillowPlayerInput]
BLAH BLAH BLAH LOTS OF BINDINGS HERE
Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)
Bindings=(Name="F12",Command="FOV 100",Control=False,Shift=False,Alt=False)

[IniVersion]
0=1256596383.000000
1=1256596393.000000

John Freeman
10-26-2009, 04:59 PM
Just reset controls to default in game menu and then add FOV binding again. Will work.

Cyborgmatt
10-26-2009, 04:59 PM
For those of you having issues with the FOV bind make sure it's being placed under the "[WillowGame.WillowPlayerInput]" header.

Edit: Hulk beat me to it, thanks hulk.

cl_hulksmash
10-26-2009, 05:00 PM
Quick note: if anyone has AA working, please post your method. :)

StingingVelvet
10-26-2009, 05:01 PM
+Rep... I made a thread on the FOV before realizing you included it here.

Way to go... someone should do this for every game.

Gadianton
10-26-2009, 05:07 PM
Ok figured out the bindings. I placed mine right after
Bindings=(Name="F8",Command="shot")

and it worked.

I noticed that my file had a ton of other stuff that cl_hulksmash's didn't.

cl_hulksmash
10-26-2009, 05:12 PM
For those of you having issues with the FOV bind make sure it's being placed under the "[WillowGame.WillowPlayerInput]" header.

Edit: Hulk beat me to it, thanks hulk.

no problem, thanks again for the thread :)

Ok figured out the bindings. I placed mine right after
Bindings=(Name="F8",Command="shot")

and it worked.

I noticed that my file had a ton of other stuff that cl_hulksmash's didn't.

that's because I only copied the bottom part and the headers... putting everything in would take up an entire page haha

kilaan
10-26-2009, 05:14 PM
Figured it out, basically before editing the ini file load up the game and set the controls to default. Then edit the ini file with the FoV string.

MonthOLDpickle
10-26-2009, 05:24 PM
The skip movie thing doesn't work for me =/

Auzner
10-26-2009, 05:33 PM
Thank you very much for this thread. When games are kind of sloppy I don't mind when console commands can be done to personalize it more.

What about scripting? Could the voice chat be be scripted to one key as a toggle?

JayFirelance
10-26-2009, 05:37 PM
Thank you very much for this thread. When games are kind of sloppy I don't mind when console commands can be done to personalize it more.

What about scripting? Could the voice chat be be scripted to one key as a toggle?


How DO you voice chat? I'm been trying to figure that out for ages.

BababooeyHTJ
10-26-2009, 05:41 PM
This needs a sticky

Mc'zee
10-26-2009, 05:42 PM
Thanks, I was looking for something like this.

Cyborgmatt
10-26-2009, 05:56 PM
The skip movie thing doesn't work for me =/
Ahh, it looks like commenting them out doesn't work, delete them from the list and that should work.

Wasser
10-26-2009, 05:58 PM
How DO you voice chat? I'm been trying to figure that out for ages.
Voice chat is always on (which is the reason some of us disable it entirely), so just speak into the mic.

The skip movie thing doesn't work for me =/
You can rename/delete the actual movies in the folder, that works as well.

twistadias
10-26-2009, 06:02 PM
Ahh, it looks like commenting them out doesn't work, delete them from the list and that should work.

Deleting lowers the number of startup videos to three

Drexion
10-26-2009, 06:09 PM
Unfortunately every time you teleport, die, enter a new zone, exit the vehicle or see a loading screen of any kind the FOV resets to it's default value. Anyone find a way around that ?

skywarp00
10-26-2009, 06:34 PM
subscibed. thanks man,.

Cyborgmatt
10-26-2009, 06:38 PM
The skip movie thing doesn't work for me =/
Check the first post for an updated method.

left4gold
10-26-2009, 06:44 PM
also dont use vsync or post the alternate solution for UE3 Vsync causes alot of input lag for many people including myself hence i dont use it instead UE3 has an FPS smoothing option simply enable it and set it for under your refresh rate ie mine is 75hz so i set smoothing to 60-65

i do this in every UE3 game so borderlands is no differnt i cant play the game yet cos its not the 30th :\ but its the same for all UE3 games

this is from the UT3 ini but willowengine.ini should have something similar
bSmoothFrameRate=True

MinSmoothedFrameRate=22
MaxSmoothedFrameRate=62
On my monitor I always get bad tearing no matter what fps I am getting in any game. I get terrible tearing in crysis and I NEVER even get up to 60 fps. Its probably the same for many other monitors as well I have a common 19 inch widescreen. vsync is necessary for me. I get a little input lag but its preferable to awful distracting tearing.

noobdeagle
10-26-2009, 06:51 PM
On my monitor I always get bad tearing no matter what fps I am getting in any game. I get terrible tearing in crysis and I NEVER even get up to 60 fps. Its probably the same for many other monitors as well I have a common 19 inch widescreen. vsync is necessary for me. I get a little input lag but its preferable to awful distracting tearing.

vsync helps at high and low fps frame smoothing helps if you can hold the actual sync rate perfectly too low or too high and you get tearing it has to be rendering a 1:1 ratio with the refresh rate hence smoothing is a viable alternative for those that can hold perfect 60fps consistently (or whatever their refresh rate is) its not anything under and you wont get tearing its get as close to a perfect fps to refresh rate ratio and it will be fine sorry i should've mentioned that earlier :)

essentially vsync waits for the refresh before allowing another frame to be displayed hence keeping the ratio no matter the FPS

Double0three
10-26-2009, 06:58 PM
Super thread, gonna go try these "fixes" out now..... why just can't they include this kind of stuff in the options

Dangerdog
10-26-2009, 07:07 PM
I am having the same problem. With the FOV binding in, no controls.

I had this problem and adding the bind to the [Engine.PlayerInput] section solved it, for some reason the
[WillowGame.WillowPlayerInput] section wasn't being completely filled out, now it is.

This is a useful bind add it to [WillowGame.WillowPlayerInput] section.

Bindings=(Name="J",Command="ThrowWeapon",Control=False,Shift=False,Alt=False)

allows you to drop the weapon in your hand with one keypress.

weez2mo
10-26-2009, 07:31 PM
please sticky this

Apbowler5
10-26-2009, 07:36 PM
Port Forwarding doesn't seem to work...

Slickviper
10-26-2009, 07:38 PM
I added the code to change the FOV, restarted steam and now all my settings and my saved games are lost from borderlands.. wtf?

tiedie
10-26-2009, 07:49 PM
Can't believe you can assign a key to a medpack...You have to hit tab and click the thing which doesn't work in battle

Lemon Jelly
10-26-2009, 08:12 PM
Unfortunately every time you teleport, die, enter a new zone, exit the vehicle or see a loading screen of any kind the FOV resets to it's default value. Anyone find a way around that ?

I just played for a couple of hours and didn't notice...but now I do....yes this is a problem.

Auzner
10-26-2009, 08:21 PM
Also does anyone know if theres a way to have it so E doesn't reload? Sometimes I'm not close enough to pick up an item and I end up reloading when I don't want to. I thought R was reload!

For the FOV switching, if anyone knows UT3 scripting, I'd say script it so that every key you press in the game is also correcting the FOV. Bind mouse1 fire and fov. Bind E use and fov. Etc.

vizionblind
10-26-2009, 08:21 PM
grrrrr

I have a DLINK dgl-4300

Here is what I have done.

The following ports are forwarded:

TCP
7777, 28910

UDP
7777, 27900

I even allowed public access under the windows 7 firewall

I put myself in DMZ mode.

People still can't connect. wtf...

nuvm
10-26-2009, 08:29 PM
Another useful binding (Show FPS):
Bindings=(Name="F9",Command="Stat FPS",Control=False,Shift=False,Alt=False)

mokn
10-26-2009, 08:37 PM
Quickfix to adjusting FOV
You can try opening willowinput.ini and changing bEnableMouseSmoothing=true to false. I don't mind the mouse myself, but those who do have reported that this improves it.
I disabled shadows and it made my mouth smooth, but lose shadows, there was a bit of a delay type lag feeling to the mouse before disabling it, was that mouse smoothing?

mokn
10-26-2009, 08:38 PM
grrrrr

I have a DLINK dgl-4300

Here is what I have done.

The following ports are forwarded:

TCP
7777, 28910

UDP
7777, 27900

I even allowed public access under the windows 7 firewall

I put myself in DMZ mode.

People still can't connect. wtf...
Check this http://www.canyouseeme.org/ with port 7777
mine says refused but when using this
http://www.portforward.com/help/portcheck.htm
it says open
One is my using my real ip the other my lan ip?

noobdeagle
10-26-2009, 08:39 PM
I disabled shadows and it made my mouth smooth, but lose shadows, there was a bit of a delay type lag feeling to the mouse before disabling it, was that mouse smoothing?

do you have vsync on ? if so make sure pre-rendered frames is set to 3 in your control panel

CannibalBob
10-26-2009, 08:52 PM
edit
Thanks for the sticky, admins :D

Hard to shuffle through all the threads to find the settings you need in the ini files

vizionblind
10-26-2009, 08:52 PM
do you have vsync on ? if so make sure pre-rendered frames is set to 3 in your control panel

where do we set that in the ati control panel?

Squallboogie
10-26-2009, 08:53 PM
any one get the aa working? i have no idea how to work nhancer, any one have a step by step tutorial on how to use it?

Void(null)
10-26-2009, 08:55 PM
Nope, havent managed to get AA working. Tried with nHancer and the nVidia CP.

noobdeagle
10-26-2009, 08:59 PM
where do we set that in the ati control panel?

not sure i have nvidia card atm and last ati card i owned was a 9600pro many years ago if i recall you can access this kind of setting through programs like rivatuner alternatively if you card is powerful enough just use the frame smoothing feature of UE3 to work around both issues of tearing and laggy input

mokn
10-26-2009, 09:01 PM
do you have vsync on ? if so make sure pre-rendered frames is set to 3 in your control panel
Nope i have vsync force off in control panel
and off ingame too
UseVsync=False

Cyborgmatt
10-26-2009, 10:47 PM
Added how to enable Windowed mode for those of you that don't want to play in fullscreen.

noobdeagle
10-26-2009, 11:00 PM
Nope i have vsync force off in control panel
and off ingame too
UseVsync=False

try disabling mouse smoothing it can cause similar problems like this on certain systems interestingly my pc used to do this in UT2k4 back on UE2 when mouse smoothing was enabled.

also for people expirencing lag there is another thing in the .ini called oneframethreadlag change that to the opposite value and see if it helps

EDIT: it looks like this in UT3 OneFrameThreadLag=False so change to oppisite of the default if you experience input lag in UE3

noobdeagle
10-26-2009, 11:04 PM
Nope, havent managed to get AA working. Tried with nHancer and the nVidia CP.

can someone try this for me run in DX10 or DX9 and change

MaxMultisamples=1

to your desired AA level

according to epic games this setting should work under DX10 as DX10 allows AA in deffered lighting engines

also if not already set you might want to do this
MaxAnisotropy=16

darkheartsmd
10-26-2009, 11:20 PM
Doing that toggle aim "fix" makes it so none of my buttons work ingame. Anyway to fix it? I've been able to make everything else work BUT that one.

Cyborgmatt
10-26-2009, 11:21 PM
Doing that toggle aim "fix" makes it so none of my buttons work ingame. Anyway to fix it? I've been able to make everything else work BUT that one.
I mentioned in the other thread that I haven't tested it yet so it might be not working yet, did you make sure you put the first set of binds under the [WillowGame.WillowPlayerInput] section?

I'll get around to testing it in a minute and I'll let you know if I make any changes to it.

Edit: It's not working, let me look into it.

darkheartsmd
10-26-2009, 11:34 PM
Ok thanks, I just didn't see any input on it so I thought i should respond with "it's not working" lol.

Just happy it's not just me. Btw thx for all the fixes and quick response.

At The Gates
10-26-2009, 11:42 PM
What is the default FOV, and can someone post some screenshots showing the differences?

Cyborgmatt
10-26-2009, 11:50 PM
What is the default FOV, and can someone post some screenshots showing the differences?
If I remember correctly 85 is the default.

I got the toggle aim right mouse working, I'll update my post in a minute, the new method is much easier.

Edit: Post Updated, if someone could test the new toggle aim code for me that would be great, ty.

DarkSyde
10-26-2009, 11:56 PM
If I remember correctly 85 is the default.

I got the toggle aim right mouse working, I'll update my post in a minute, the new method is much easier.

Seriously doubt 85 is default. There is way too much difference changing it to just 90. Judging but TF2s default of 75 I'd say it's more narrow than even that.

That said, it doesn't work right. As already stated it resets doing various different things throughout the game INCLUDING SPRINTING which basically makes that setting useless. Here's hoping someone can come up with a fix.

Cyborgmatt
10-27-2009, 12:00 AM
Seriously doubt 85 is default. There is way too much difference changing it to just 90. Judging but TF2s default of 75 I'd say it's more narrow than even that.

That said, it doesn't work right. As already stated it resets doing various different things throughout the game INCLUDING SPRINTING which basically makes that setting useless. Here's hoping someone can come up with a fix.
At the moment it's the best we can come up with, it's resetting because it's hard coded in the game, hopefully Gearbox will do something about that in a patch.

At The Gates
10-27-2009, 12:00 AM
Seriously doubt 85 is default. There is way too much difference changing it to just 90. Judging but TF2s default of 75 I'd say it's more narrow than even that.

That said, it doesn't work right. As already stated it resets doing various different things throughout the game INCLUDING SPRINTING which basically makes that setting useless. Here's hoping someone can come up with a fix.

I would really like to see a fix for that FOV. So far the game looks great, but im sure it looks much better with a higher FOV. Can you post a screenshot?

dat1337vet
10-27-2009, 01:01 AM
How doed D3Doverrider let me use AA? There is no option to force AA with it.

Does anyone with an ATi card have AA working?

loinbread
10-27-2009, 01:07 AM
At the moment it's the best we can come up with, it's resetting because it's hard coded in the game, hopefully Gearbox will do something about that in a patch.

A good place to organise efforts to convince Gearbox would be over at the Widescreen Gaming Forum (http://www.widescreengamingforum.com/wiki/index.php/Main_Page). Really, stuff like this is so basic that a moderately-sized studio like Gearbox should have been able to do from the very start. 16:10 resolutions and widescreen displays aren't anything new, yet so many developers seem to not be cluey enough to figure it out. Every developer should read the WSGF's certification requirements. It's not hard to score gold, but developer still fail regardless.

noobdeagle
10-27-2009, 01:15 AM
for everyone posting about AA UE3 allows AA in DX10 mode if you running in DX10 just increase the multisamples line in the .ini
to force it in DX9 you have to rename the EXE to a name of a game that has been tweaked to force via nvidia panel

naming it to bioshock or UT3 or any other game that nvidia has forced will allow AA theoretically it should work if steam will still launch the game after altering the exe name which is unlikely

i can confirm this for other UE3 games

what i dont know is how mirrors edge allows AA in all DX modes out of the box in the options this suggests maybe changing the multisampling line could work for everyone

dat1337vet
10-27-2009, 01:19 AM
The AllowD3D10 doesn't do anything from what I have read there is no DX10. Also steam will not let you launch the game if you rename the exe

noobdeagle
10-27-2009, 01:22 AM
The AllowD3D10 doesn't do anything from what I have read there is no DX10. Also steam will not let you launch the game if you rename the exe

ok then people were saying it was running in D3D10 unless you use the command line switch so are they wrong there just is no DX10 render path ? confirmed ? gearbox said it would have dx10 (it hasnt unlocked for me so im basing these things of other UE3 games as their settings and behavior appear to be universal)

Chib
10-27-2009, 01:30 AM
Has anyone tried combining these two?

bHasVoiceEnabled=False
Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)

?? (:

Carbon016
10-27-2009, 01:52 AM
Put a pipe ('|') instead of a comma between them and it should work.

edit: thought you meant the fov and sprint commands, there's no reason to combine those two binds?

MasterEvilAce
10-27-2009, 01:57 AM
Put a pipe ('|') instead of a comma between them and it should work.

edit: thought you meant the fov and sprint commands, there's no reason to combine those two binds?

I think he wants push-to-talk functionality

nebenschwein1
10-27-2009, 02:10 AM
thanks for this!!

+rep

TheCheshire
10-27-2009, 02:17 AM
Still need a solid AA fix, but this is all good stuff. Nice work.

noobdeagle
10-27-2009, 02:20 AM
Still need a solid AA fix, but this is all good stuff. Nice work.

ill work on an AA fix when it unlocks if no one works it out cos damn i need AA!!

noobdeagle
10-27-2009, 02:23 AM
here we go anyone care to test ?

Originally Posted by Jet Black View Post
Yes it does, you just have to do it right (I have Borderlands running with AA and it looks great):

How to get AA in Borderlands with nHancer:

1) Open nHancer and go to the Borderlands profile.
2) Select your preferred method of Antialiasing (I chose 4x Multisampling, 8x was good but slowed the game down just enough for me to take notice).
3) Make sure "Enhance In Game AA" is NOT checked! There is no AA setting in Borderlands, so if Enhance is checked it will not enhance since 0 x 4 = 0.
4) Click the Compatibility tab.
5) Check the box next to Ant-Aliasing Compatibility.
6) Choose 00000041: Unreal Engine 3
7) Quite nHancer and start up Borderlands.
8) Enjoy

further down in the thread it said that not everything is AA'd namely the black lines does this then suggest that it is a post process effect or a shader ? or alternatively is it alpha-textures so you need to enable Transparency AA

Edit: Renaming the .exe to Bioshock (forced aa/v-sync via CP) worked for me with nvidia hardware. (found on another forum)

so people with steam people who cant do this may be screwed untill nvidia place the work around in their driver like they did with bioshock, UT3 and some other UE3 games so just wait they will come through for us

Chib
10-27-2009, 02:33 AM
Something I found on the gearbox forums which probably will be helpful:
To enable console:
------------------
Within WillowInput.ini:
Search for "ConsoleKey" and you should come across the following line:

ConsoleKey=

Add 'Tilde' after the equal sign to enable the console (should look like ConsoleKey=Tilde)

To enable scroll wheel in text boxes:
-----------------------------------

Within WillowInput.ini

Search for all instances of the following (there should only be two instances):

InputKeyName="MouseScrollUp",ModifierKeyFlags=42
InputKeyName="MouseScrollDown",ModifierKeyFlags=42

remove the ",ModifierKeyFlags=42" so they look like:

InputKeyName="MouseScrollUp"
InputKeyName="MouseScrollDown"

Irritated by the toggle crouch? Add a momentary, like-any-other-FPS style crouch key with the two lines below, added to the bottom of the [WillowGame.WillowPlayerInput] section of WillowInput.ini:

Bindings=(Name="Duck",Command="Button bDuck | Axis aUp Speed=-1.0 AbsoluteAxis=100")
Bindings=(Name="LeftControl",Command="Duck",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Savage Alien
10-27-2009, 03:22 AM
And how would you go about turning windowed mode OFF?

Removing -windowed from the launch options does not work.

EDIT:
WillowEngine.ini

[SystemSettings]
find:
Fullscreen=False

set to True

noobdeagle
10-27-2009, 03:26 AM
And how would you go about turning windowed mode OFF?

Removing -windowed from the launch options does not work.

does alt-enter work to switch between window and fullscreen on the fly? used to be a standard thing in UE2 (ill test with UE3 and report back)

EDIT: works in UT3, GOW ok works in bioshock to

someone try it

Chib
10-27-2009, 03:37 AM
Alt-tab just alt-tabs for me.

noobdeagle
10-27-2009, 03:43 AM
Alt-tab just alt-tabs for me.

im sorry
i mean alt-enter

big mistake :S alt-enter is the standard for fullscreen in many apps and most UE3 games so give that a go :)

Savage Alien
10-27-2009, 03:54 AM
Yes, Alt-Enter works. I never knew this about the Unreal Engine. Nice that this common fullscreen video player key bind works in some games, thanks! :D

Qwiggalo1
10-27-2009, 03:58 AM
Hi Cyborgmatt :D

Farlong
10-27-2009, 04:40 AM
Yes, Alt-Enter works. I never knew this about the Unreal Engine. Nice that this common fullscreen video player key bind works in some games, thanks! :D

Alt+Enter has always been fullscreen... God, I feel old now. :(

carn1x
10-27-2009, 04:41 AM
Yay the game is one day old and the community is already fixing the game :D

Cleric
10-27-2009, 04:44 AM
Yeah except when it comes to the U3 engine, AA only works when using nHancer tbh.

It doesn't work using the default nvidia panel.

actually it does, but you'll have to change borderlands.exe to UT3.exe then force the anti aliasing through the control panel (prepare yourself for a pretty big performance loss though)

loinbread
10-27-2009, 05:29 AM
I don't have the game yet, but came up with this method for enabling/disabling mic ingame. Can someone please tell me if it works?

Change bHasVoiceEnabled=True to False in WillowEngine.ini. Then add the following to WillowInput.ini

Bindings=(Name="V",Command="HasVoiceEnabled",Control=False,Shift=False,Alt=False)
Bindings=(Name="HasVoiceEnabled",Command="bHasVoiceEnabled=True | setbind V HasVoiceDisabled")
Bindings=(Name="HasVoiceDisabled",Command="bHasVoiceEnabled=False | setbind V HasVoiceEnabled")

Make sure you delete the spaces in those words there, I don't know why the forums are adding spaces in "bHasVoiceEnabled" and "control"

Press the 'v' key to toggle it.

erwem576
10-27-2009, 07:09 AM
I hail everyone that has contributed to this thread. THANK YOU!


Question: When you change any of these files, do you have to set the file to "read only" in properties to insure that the computer doesn't change those settings back?

nuschu
10-27-2009, 07:47 AM
You can disable the intro movies without deleting them. Found this on the GearBox forums:

http://gbxforums.gearboxsoftware.com/showthread.php?t=79043
To disable the startup movies:
-----------------------------
Within WillowEngine.ini:

Find:
[FullScreenMovie]
StartupMovies=2K_logo
StartupMovies=Gearbox_logo
StartupMovies=NVidia
StartupMovies=Loading
SkippableMovies=2K_logo
SkippableMovies=Gearbox_logo
SkippableMovies=Attract
SkippableMovies=NVidia

and comment out lines like so:

[FullScreenMovie]
;StartupMovies=2K_logo
;StartupMovies=Gearbox_logo
;StartupMovies=NVidia
;StartupMovies=Loading
;SkippableMovies=2K_logo
;SkippableMovies=Gearbox_logo
;SkippableMovies=Attract
;SkippableMovies=NVidia

-----
Here are the rest from that thread:


To adjust FOV (Field of View):
-----------------------------
Within WillowInput.ini:
Search for "WillowGame.WillowPlayerInput". Below the chunk of bindings, add the following:

Bindings=(Name="F10",Command="FOV 90",Control=False,Shift=False,Alt=False)
Bindings=(Name="F11",Command="FOV 110",Control=False,Shift=False,Alt=False)

You can change the keys (F10 and F11) to whatever you'd like, as well as the FOV values.


To disable/adjust weapon view bob:
----------------------------------
Within WillowGame.ini:
Search for "bWeaponBob" and you should come across the following lines:

bWeaponBob=TRUE
Bob=0.005

They should be pretty self explanatory. I can confirm the Bob numerical adjustment does work.


To enable VSync:
-----------------
Within WillowEngine.ini:
Search for "UseVsync" and you should come across the following line:

UseVsync=False

Change to TRUE.


To disable voice chat:
---------------------
Within WillowEngine.ini:
Search for "bHasVoiceEnabled" and you should come across the following line:

bHasVoiceEnabled=True

Change to FALSE.


To enable console:
------------------
Within WillowInput.ini:
Search for "ConsoleKey" and you should come across the following line:

ConsoleKey=

Add 'Tilde' after the equal sign to enable the console (should look like ConsoleKey=Tilde)


To disable mouse smoothing:
----------------------------
Within WillowInput.ini:
Search for "bEnableMouseSmoothing" and you should come across the following line:

bEnableMouseSmoothing=True

Change to FALSE. Should improve the feel of the mouse when looking around and navigating the UI.


Enable Drop Weapon Key:
-------------------------
Within WillowInput.ini:
Search for "WillowGame.WillowPlayerInput". Within that section, search for "ThrowWeapon". By default, it's bound to "Underscore" - I changed mine to V, so it looks like:

Bindings=(Name="V",Command="ThrowWeapon",Control=F alse,Shift=False,Alt=False)

narudis
10-27-2009, 08:17 AM
I got the toggle for the aim to work.You gotta fine the following in the willowinput.ini :

Bindings=(Name="RightMouseButton",Command="ToggleAimOn",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleAimOn",Command="StartAltFire | setbind RightMouseButton ToggleAimOff",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleAimOff",Command="StopAltFire | setbind RightMouseButton ToggleAimOn",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Then replace both Bindings=(Name="ToggleAimOn and Bindings=(Name="ToggleAimOff with the following:

Bindings=(Name="ToggleAimOn",Command="StartAltFire | setbind RightMouseButton ToggleAimOff")
Bindings=(Name="ToggleAimOff",Command="StopAltFire | setbind RightMouseButton ToggleAimOn")

AeonGrey
10-27-2009, 08:19 AM
Would it be possible to find out how to kick players from a game you're hosting? As I see it now there is absolutely no way to do it.

NiteX
10-27-2009, 08:32 AM
I'm wondering if it's possible to do these 3 things with the ini files. Remove the black outline, increase the number of blood decals, and increase the lifetime of blood decals. I'm guessing removing the outline would be considered modding the game huh?

xerawx
10-27-2009, 08:49 AM
I think the cell shading (black outline) is a pretty core part of the game, and probably pretty tough to remove, although I could be wrong. I've successfully managed to force AA on using the nHancer app, and specifying Unreal Engine 3 in the compatibility settings on my GTX260, at least on my system, it's really just not worth it. On my e8400 running at 4.0ghz, GTX260 at stock speed, even 2x multisampling was a huge performance hit. The difference is everything else maxed, silky smooth at 1920x1080 with no AA, and horribly choppiness with even 2x AA.

Also with multisampling forced there is an annoying colored outline around the cell shading effect, most noticeable on your gun, didn't seem to matter how much AA I applied it was still there, when I tried to force supersampling on it just hard-locked on startup with a garbled screen.

It's kind of dissapointing to see a new game come out towards the end of 2009 that doesn't support AA -at all- on the PC, and in some spots the cell shading makes it even more painfully obvious, but I guess it is what it is. The game is generally fast paced enough that if you're getting a good FPS with everything else maxed, you don't really notice the lack of AA after a while.

Pillz_Here
10-27-2009, 08:51 AM
Some better directions on enabling AA with rivatuner and an ATi card would be nice. I can't seem to find the "D3DOverrider" option.

Cyborgmatt
10-27-2009, 09:15 AM
And how would you go about turning windowed mode OFF?

Removing -windowed from the launch options does not work.

EDIT:
WillowEngine.ini

[SystemSettings]
find:
Fullscreen=False

set to True
You can also use the command line -fullscreen

xerawx
10-27-2009, 09:33 AM
alt-enter seems to work for toggling full screen for me

SLowrAM
10-27-2009, 09:54 AM
If after adding some bindings you aren't able to use the mouse/any key but bindings entered, be sure to:

Just reset controls to default in game menu and then add FOV binding again. Will work.

The problem is if you haven't chosen reset controls to default you won't have any bindings in ini file and once you add some it looks for them all in the ini file. Resetting to defaults places them all in ini so you can add ones you want.

RStriker69
10-27-2009, 10:04 AM
here we go anyone care to test ?
How to get AA in Borderlands with nHancer:

1) Open nHancer and go to the Borderlands profile.
2) Select your preferred method of Antialiasing
3) Make sure "Enhance In Game AA" is NOT checked! There is no AA setting in Borderlands, so if Enhance is checked it will not enhance since 0 x 4 = 0.
4) Click the Compatibility tab.
5) Check the box next to Ant-Aliasing Compatibility.
6) Choose 00000041: Unreal Engine 3
7) Quite nHancer and start up Borderlands.
8) Enjoy


I can verify that this works. 16x looks a lot better than nothing, but gave a big performance hit on my midrange system with a 9800GTX+, crashing within 20 minutes.

8x and 4x both crashed eventually as well, though it took longer with 4x. I've been playing for a few hours with 2x on, it looks noticably better than no AA and hasn't crashed. Only a slight performance hit for me on 2x, almost nothing.

dat1337vet
10-27-2009, 10:09 AM
no one has AA working on Ati yet?

Dyrnwyn
10-27-2009, 10:17 AM
I have an SLI GTX 285 setup with latest nvidia driver on a 1650 x 1080 60hz monitor...just added this game to program settings and forced vsync setting to "on": no screen tearing after that and it looks great.

Question though: what does the mouse smoothing do?

vizionblind
10-27-2009, 10:25 AM
no one has AA working on Ati yet?

I do by enabling it in the CCC

dat1337vet
10-27-2009, 10:32 AM
I do by enabling it in the CCC

are you using MSAA or SSAA?
what are your AI settings?
did you make a game specific profile?

Dionis
10-27-2009, 11:33 AM
I do by enabling it in the CCC

how? can you give the specific method? sorry, im ♥♥♥♥♥♥♥♥ and it doesnt seem like enabling it in ccc is doing anything in game, still aliased.

erwem576
10-27-2009, 11:45 AM
When you change any of these files, do you have to set the file to "read only" in properties to insure that the computer doesn't change those settings back?

narudis
10-27-2009, 12:22 PM
When you change any of these files, do you have to set the file to "read only" in properties to insure that the computer doesn't change those settings back?

When a file is read only you are unable to alter its contents and save the file. So yes you need to un-check the read only option in the properties for said file.

Mr.Bigtime
10-27-2009, 12:23 PM
i solved my problem with mousesmooth trick. thanx for the post.

Yvese
10-27-2009, 12:35 PM
I can verify that this works. 16x looks a lot better than nothing, but gave a big performance hit on my midrange system with a 9800GTX+, crashing within 20 minutes.

8x and 4x both crashed eventually as well, though it took longer with 4x. I've been playing for a few hours with 2x on, it looks noticably better than no AA and hasn't crashed. Only a slight performance hit for me on 2x, almost nothing.How did you uncheck the 'Enhance in-game AA setting'? Everytime I try and uncheck it a window pops up saying 'nVidia explicitly disabled modifications of this option yadayada'. No clue how to override it.

EDIT: NM got it.

mad1723
10-27-2009, 12:35 PM
Thanks for the tips, used most of them! :D

CannibalBob
10-27-2009, 12:39 PM
I don't have the game yet, but came up with this method for enabling/disabling mic ingame. Can someone please tell me if it works?

Change bHasVoiceEnabled=True to False in WillowEngine.ini. Then add the following to WillowInput.ini

Bindings=(Name="V",Command="HasVoiceEnabled",Control=False,Shift=False,Alt=False)
Bindings=(Name="HasVoiceEnabled",Command="bHasVoiceEnabled=True | setbind V HasVoiceDisabled")
Bindings=(Name="HasVoiceDisabled",Command="bHasVoiceEnabled=False | setbind V HasVoiceEnabled")

Make sure you delete the spaces in those words there, I don't know why the forums are adding spaces in "bHasVoiceEnabled" and "control"

Press the 'v' key to toggle it.

Has anyone tried this? Does it work? Does it disable ALL voice chat or only toggle transmission?

Cent
10-27-2009, 12:58 PM
I haven't tried this, but from the looks of it, all you're doing is enabling voice chat. You'd still need to make sure to raise your voice pickup sensitivity so that it transmits everything from the second you press your Push To Talk. Also, unless you use an OnRelease command, like Loinbread said, this is a TOGGLE PPT, not a HOLD PTT.

mesaone
10-27-2009, 01:24 PM
here's an FOV calculator....

http://emsai.net/projects/widescreen/fovcalc/

and in WillowEngine.ini there is a FOVAngle variable with a default value of 90.0000

if I change that value to, maybe 106, will the change be permanent without the need to toggle?

Caylin
10-27-2009, 01:31 PM
I can't make the toggle aim tweak work.

RED_
10-27-2009, 01:43 PM
Thanks for this thread, especially the mouse smoothing disable.

Is there anyway I can make the mouse sensitivity any lower? I put it on lowest but it's still way too fast for me.

Caylin
10-27-2009, 01:47 PM
Try tweaking your overall windows mouse settings.

Jet Black
10-27-2009, 01:50 PM
I can't make the toggle aim tweak work.

That's because the Toggle tweak posted here is wrong.

Try this:

Within WillowInput.ini:

Add the text below under [WillowGame.WillowPlayerInput]

Bindings=(Name="ZoomIn",Command="StartAltFire | setbind RightMouseButton ZoomOut",Control=False,Shift=False,Alt=False,LeftT rigger=False,RightTrigger=False,bIgnoreCtrl=False, bIgnoreShift=False,bIgnoreAlt=False)
Bindings=(Name="ZoomOut",Command="StopAltFire | setbind RightMouseButton ZoomIn",Control=False,Shift=False,Alt=False,LeftTr igger=False,RightTrigger=False,bIgnoreCtrl=False,b IgnoreShift=False,bIgnoreAlt=False)

Then, edit the preexisting RightMouseButton binding to reflect the change:

Bindings=(Name="RightMouseButton",Command="advance dbutton bAdvancedButtonAux5",Control=False,Shift=False,Alt =False,LeftTrigger= False,RightTrigger=False,bIgnoreCtrl=False,bIgnore Shift=False,bIgnoreAlt=False)

to

Bindings=(Name="RightMouseButton",Command="ZoomIn" ,Control=False,Shift=False,Alt=False,LeftTrigger= False,RightTrigger=False,bIgnoreCtrl=False,bIgnore Shift=False,bIgnoreAlt=False)

Cyborgmatt
10-27-2009, 01:55 PM
That's because the Toggle tweak posted here is wrong.
Works fine for me, I just tested it again.

Make sure you do my tweak in the "[Engine.PlayerInput]" section.

Not the "[WillowGame.WillowPlayerInput]" section.

Jet Black
10-27-2009, 02:02 PM
Works fine for me, I just tested it again.

Make sure you do my tweak in the [Engine.PlayerInput] section.

Not [WillowGame.WillowPlayerInput]

The one I posted does work in the WillowPlayerInput section which is where my other keybinds were. But if there's two ways to skin a cat, no problem :)

Cyborgmatt
10-27-2009, 02:04 PM
The one I posted does work in the WillowPlayerInput section which is where my other keybinds were. But if there's two ways to skin a cat, no problem :)
Yeah I should of mentioned in the tweak that it needed to be under the engine header, I've updated the first post with that now.

Caylin
10-27-2009, 02:11 PM
Ok I was able to get jet black's tweak to work, but not cyborgmatt's. However, I can no longer fire the turret gun from the driver's seat of a runner.

MultiVaC
10-27-2009, 02:20 PM
Does anyone know how to disable the toggle on ducking? I really want to have it to just hold the button.

Grunt7684
10-27-2009, 02:23 PM
Does anyone know how to disable the toggle on ducking? I really want to have it to just hold the button.

Toggled ducking makes it SO feel like a console game.

It looks like an astounding game overall. Push-to-talk really is needed... One guy destroyed my eardrums with his coughing and sneezing and blowing his nose on mic "sorry I have the flu"... ARgh!!! :(

...and _KUDOS_ to everyone who posted fixes and tweaks here, thank you!!! :)

Caylin
10-27-2009, 02:23 PM
I saw another thread about it a lil farther down about an hour ago.

Cent
10-27-2009, 02:30 PM
Sorry if there may be a few mistakes, my own ini files are so messed up in trial and error coding that I hope these are the right changes I copied over. Make sure you back up your existing inis before you modify them. Also, sometimes u will need to wipe out the existing bind before you use the ones below... Just tell me if something goes wrong, and I'll try to find out what I left out >_>


For HOLD crouch rather than TOGGLE crouch

Keep in mind this is the simplest way to implement hold crouch, by bypassing the aux command that Borderlands uses, and instead relying on UT3's method of crouch. This means that there is NO crouch indicator that appears on the screen. A friend of mine created a slightly more complex method, but does show an indicator.

Use C to activate the standard toggle crouch and the context sensitive CHANGE SEATS command. Use Left Control to use the new hold crouch.


in WillowInput.ini
[WillowGame.WillowPlayerInput]

Bindings=(Name="C",Command="advancedbutton bAdvancedButtonAux1 | SwitchSeats",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Bindings=(Name="LeftControl",Command="Button bDuck | Axis aUp Speed=-1.0 AbsoluteAxis=100 | OnRelease StopDuck",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)



To use TOGGLE Right Click AIM, first remap your AIM command to MIDDLE MOUSE (or something else). We will create a new AIM command.


in WillowInput.ini
[WillowGame.WillowPlayerInput]

Bindings=(Name="MiddleMouseButton",Command="advancedbutton bAdvancedButtonAux5",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Bindings=(Name="ZoomIn",Command="StartAltFire | setbind RightMouseButton zoomout",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ZoomOut",Command="StopAltFire | setbind RightMouseButton zoomin",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="RightMouseButton",Command="zoomin",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)



For weapon QUICK SWITCH between slots 1 and 2. (You can change which slots are affected.)



in WillowInput.ini
[WillowGame.WillowPlayerInput]
Find this line.

Bindings=(Name="Q",Command="advancedbutton bAdvancedButtonAux4",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Change to:

;Bindings=(Name="Q",Command="advancedbutton bAdvancedButtonAux4",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="SwitchSecondary",Command="switchweapon 2 | setbind Q SwitchPrimary")
Bindings=(Name="SwitchPrimary",Command="switchweapon 1 | setbind Q SwitchSecondary")
Bindings=(Name="Q",Command="SwitchSecondary")



To Increase the Distance At Which Popup icons appear for items on the ground (Like Ammo and stuff). You still have to mouse over the item to get the popup to appear, only the distance this is possible from increases. Find and change PlayerInfoMaxDist. By default it is 15000.


in WillowGame.ini
[WillowGame.WillowHUD]
PlayerInfoMaxDist=60000

TheGreatStone
10-27-2009, 03:20 PM
70 is the default FOV value for Borderlands. 90 is nice for a 4:3 monitor.

For those of you who like Mouse4 and Mouse5 to have some functionality:
'ThumbMouseButton' is Mouse button 4
'ThumbMouseButton2' is Mouse button 5

Bindings=(Name="ThumbMouseButton2",Command="FOV 90",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ThumbMouseButton",Command="FOV 70",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

I've tested this in Single Player, LAN, and Online* games. Sprinting does not revert the FOV back to 70. Entering vehicles does revert the FOV back to 70.

*have only tested in hosting game, not joining a game

Screenshot comparison:
http://i212.photobucket.com/albums/cc73/TheGr8Stone/FOV-70.jpg
http://i212.photobucket.com/albums/cc73/TheGr8Stone/FOV-90.jpg


I hope someone will find a way to permanently modify the FOV angle, without having to press a special button upon exiting a vehicle, or executing an extra and unnecessary line of code with every press of some commonly-used key.


Update:
I made a few tweaks to the willowinput.ini file (separating toggleaim from the code that does everything that right mouse button should do) -- this required an in-game reset-to-default -- and now when I sprint it does revert the FOV back to 70!

I'm at a loss... :/

Corion
10-27-2009, 04:34 PM
Is there a bind to quick-use a single health kit (preferably the most powerful one first)? That would be greatly appreciated.

Mama Sutra
10-27-2009, 05:02 PM
Instead of deleting the preroll video files, seems safer to just comment out the lines that enable display of the videos (in WillowEngine.ini)

See this thread on the Gearbox forums: http://gbxforums.gearboxsoftware.com/showthread.php?t=79043

Mama Sutra
10-27-2009, 05:05 PM
Push-to-talk really is needed... One guy destroyed my eardrums with his coughing and sneezing and blowing his nose on mic "sorry I have the flu"... ARgh!!! :(

I forget if it's possible to get the flu over TCP/IP, but I sure hope not.

DaveKap
10-27-2009, 06:06 PM
Sprinting does not revert the FOV back to 70.


My quick testing shows that it actually does revert the FOV back. :(

Also I'm curious if anyone got Toggle Aim (Right Mouse) to actually work. It's not working for me. :(

creepjacker
10-27-2009, 06:17 PM
I got the nhancer 2.5.7 to implement AA with forceware 190.62. But when i installed 191.07 it stopped working. I think the 191.07 is needed for SLI. Any advice?

Caylin
10-27-2009, 07:09 PM
My quick testing shows that it actually does revert the FOV back. :(

Also I'm curious if anyone got Toggle Aim (Right Mouse) to actually work. It's not working for me. :(

I used Jet Black's method and it worked for me, at the cost of not being able to fire the rockets/machine gun in the back of the runner while I was driving. That doesn't bother me too much, because I prefer to kill whatever I'm killing with my weapons anyways to get my skill level up.

Cent
10-27-2009, 07:27 PM
I used Jet Black's method and it worked for me, at the cost of not being able to fire the rockets/machine gun in the back of the runner while I was driving. That doesn't bother me too much, because I prefer to kill whatever I'm killing with my weapons anyways to get my skill level up.

Use my method above. You can still use middle mouse to control your rockets and stuff as if it was the normal right click.

TheGreatStone
10-27-2009, 08:09 PM
Update:
I made a few tweaks to the willowinput.ini file (separating toggleaim from the code that does everything that right mouse button should do) -- this required an in-game reset-to-default -- and now when I sprint it does revert the FOV back to 70!

I'm at a loss... :/

casin.
10-27-2009, 09:04 PM
How do steam users do the mouse smoothing trick, i cant find it anywhere.

In the config folder in steam version i get the following ini files:

DefaultCompat
DefaultEditor
DefaultEditorKeyBindings
DefaultEditorUserSettings
DefaultEngine
DefaultGame
DefaultInput
DefaultUI

Cant find benalbemousesmoothing in any.

noobdeagle
10-27-2009, 09:48 PM
How do steam users do the mouse smoothing trick, i cant find it anywhere.

In the config folder in steam version i get the following ini files:

DefaultCompat
DefaultEditor
DefaultEditorKeyBindings
DefaultEditorUserSettings
DefaultEngine
DefaultGame
DefaultInput
DefaultUI

Cant find benalbemousesmoothing in any.

its stored in users > mygames >borderlands (or somthing similar on your C: drive)

fLaMePrO
10-27-2009, 09:49 PM
You are looking in the wrong directory. It's My Documents > My Games > Borderlands > Willowgame > Config

[Edit] Beaten

iandh
10-28-2009, 12:19 AM
I can confirm AA working on ATI by forcing in CCC, this is with a 5850.

To see a notable difference I have to runn 8xSSAA with edge sampling enabled.

Once I pass 4xAA, my FPS dips below vsync at 1920x1080, so I know that it is enabling. I also see major improvements in transparent items such as fences.

There are still jaggies on the outlines, but there is definitely AA going on in many items in the scene.

RED_
10-28-2009, 01:54 AM
Update:
I made a few tweaks to the willowinput.ini file (separating toggleaim from the code that does everything that right mouse button should do) -- this required an in-game reset-to-default -- and now when I sprint it does revert the FOV back to 70!

I'm at a loss... :/

It seems that in single player sprinting doesn't revert the FOV back, but in multiplayer it does. This is from my observation.

Zpace
10-28-2009, 02:00 AM
Nice post! Thank you :D

RyanH
10-28-2009, 02:09 AM
How does D3D overrider let you enable AA? Please explain how to do this in detail?

Somnambulator
10-28-2009, 05:28 AM
THANK YOU

will try these out when i get home.

i knew from the main game menu, where it tells you to hit [ENTER] that this game was not developed primarily for the PC.

as almost everyone ive talked with agrees...the gameplay, graphics, etc are superb, but almost everything else SUCKS. the menu lag is terrible, the FOV is console FOV, the menus themselves are annoying (who uses page up/down??), and the mouse smoothing was evident to me within 15 seconds of being able to move.

completely unnacceptable. also, i HATE the UE engine solely because of its hard-coded inability to write to My Documents located as a root hard drive. it's the sole reason i refuse to buy UE3 games im on the fence with. why cant valve force them to change saved game located to inside their steam folder?

asforme
10-28-2009, 05:36 AM
It seems that in single player sprinting doesn't revert the FOV back, but in multiplayer it does. This is from my observation.

This has been my experience too. It was manageable in single player, but when I played multiplayer last night for the first time it was unbearably annoying.

noobdeagle
10-28-2009, 05:54 AM
umm whats this about pageup page down scrolling what menu is this for my mouse wheel works in every one that ive encountered so far

Somnambulator
10-28-2009, 06:13 AM
quest menu description

noobdeagle
10-28-2009, 06:17 AM
quest menu description

oh ok i never read them in detail :P so never tried scrolling on that one

Tuqui-tuqui
10-28-2009, 06:49 AM
Sorry if there may be a few mistakes, my own ini files are so messed up in trial and error coding that I hope these are the right changes I copied over. Make sure you back up your existing inis before you modify them. Also, sometimes u will need to wipe out the existing bind before you use the ones below... Just tell me if something goes wrong, and I'll try to find out what I left out >_>


For HOLD crouch rather than TOGGLE crouch

Keep in mind this is the simplest way to implement hold crouch, by bypassing the aux command that Borderlands uses, and instead relying on UT3's method of crouch. This means that there is NO crouch indicator that appears on the screen. A friend of mine created a slightly more complex method, but does show an indicator.

Use C to activate the standard toggle crouch and the context sensitive CHANGE SEATS command. Use Left Control to use the new hold crouch.



Hey! Thank you for the script, but it does not work for me. Did anyone get it to work?

Somnambulator
10-28-2009, 07:03 AM
You say 70 but I've also heard 85 and 90. So what's the definitive number and how do you know?

i dont know how he knows but the screenshots comparing 70 and 90 are drastically different. the default, if not 70, is certainly closer to 70 than 90

Grunt7684
10-28-2009, 07:26 AM
FOV 70 has given my friend a headache on her PC.

Countach
10-28-2009, 09:00 AM
This solution is better for disabling the intro movies (you don't need to delete the original videos).


ĘTo disable the startup movies:
-----------------------------
Within WillowEngine.ini:

Find:
[FullScreenMovie]
StartupMovies=2K_logo
StartupMovies=Gearbox_logo
StartupMovies=NVidia
StartupMovies=Loading
SkippableMovies=2K_logo
SkippableMovies=Gearbox_logo
SkippableMovies=Attract
SkippableMovies=NVidia

and comment out lines like so:

[FullScreenMovie]
;StartupMovies=2K_logo
;StartupMovies=Gearbox_logo
;StartupMovies=NVidia
;StartupMovies=Loading
;SkippableMovies=2K_logo
;SkippableMovies=Gearbox_logo
;SkippableMovies=Attract
;SkippableMovies=NVidia

Taken from gb forum.

kasbal
10-28-2009, 09:35 AM
I just found a bunch of neat tweak info. It even has mouse scrolling fix for quests and such. This guy just pasted from the BL forums and put it into one page. It also has the FOV sprinting fix; it's a long page, so... I don't thikn I want to quote the entire page on here, but you guys can go to the url at the bottom of my post.

Well, I'll quote a few things from the page:


FOV Stuff

Quote
Some things you should know about the FOV

Apparently when playing single player, once you change the FOV it'll stay at that setting no matter what you do (like sprinting). However, when you are in a multiplayer game, sprinting will reset your FOV to their default (which is apparently very, very low). Someone earlier in the thread suggested adding the FOV command to your sprint bind, which mostly works... but since sprinting is not really a toggle or press/release thing... it's a turn on while moving forward by tapping it thing... you end up sprinting, then stopping, then looking at an awful FOV. The solution?

Put the FOV command you want on not only your sprint key, but also all your movement keys. It'll look something like this in your ...\My Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i file under the heading [WillowGame.WillowPlayerInput]



Bindings=(Name="E",Command="MoveForward | Axis aGas Speed=+1.0 | FOV 106",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Bindings=(Name="D",Command="MoveBackward | Axis aBrake Speed=+1.0 | FOV 106",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Bindings=(Name="S",Command="StrafeLeft | FOV 106",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Bindings=(Name="F",Command="StrafeRight | FOV 106",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Bindings=(Name="SpaceBar",Command="advancedbutton bAdvancedButtonAux6 | FOV 106",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)


Note that I play with ESDF for movement keys, and Spacebar as Sprint. Also note that I like an FOV of 106 for my 1920x1200 resolution. Alter to taste.

Hmm... steam forums doing something weird withe the quote paste. It should be LeftTrigger, not LeftTrig ger. So, delete teh spaces, when entering into your ini.

Quest Box Scrolling (Full of Win)
Quote
Within WillowInput.ini

Search for all instances of the following (there should only be two instances):

InputKeyName="MouseScrollUp",ModifierKeyFlags=42
InputKeyName="MouseScrollDown",ModifierKeyFlags=42

remove the ",ModifierKeyFlags=42" so they look like:

InputKeyName="MouseScrollUp"
InputKeyName="MouseScrollDown"

Title: Re: Borderlands .INI Stuff
Post by: fuser on October 27, 2009, 12:17:07 pm
Solution someone found from gbxforums
Quote
To enable scroll wheel in text boxes:
-----------------------------------
Within WillowInput.ini

Search for all instances of the following (there should only be two instances):

InputKeyName="MouseScrollUp",ModifierKeyFlags=42
InputKeyName="MouseScrollDown",ModifierKeyFlags=42

remove the ",ModifierKeyFlags=42" so they look like:

InputKeyName="MouseScrollUp"
InputKeyName="MouseScrollDown"



Found at this site for the rest of tweaks: http://forums.f13.net/index.php?action=printpage;topic=18172.0

JackieChan
10-28-2009, 11:43 AM
Instead of disabling "bHasVoiceEnabled", it's probably better to set the "VolumeThreshold" to a really high number, like 99 or something. That way you can hear other people and not talk. With the "bHasVoiceEnabled" set to "false", it disables voice chat entirely meaning you can't hear other people talk in game.

Maybe it could used for a push-to-talk thing with "VolumeThreshold".

asforme
10-28-2009, 11:51 AM
Instead of disabling "bHasVoiceEnabled", it's probably better to set the "VolumeThreshold" to a really high number, like 99 or something. That way you can hear other people and not talk. With the "bHasVoiceEnabled" set to "false", it disables voice chat entirely meaning you can't hear other people talk in game.

I wonder if you could bind setting the VolumeThreshold to a key. On click it drops it down to 1 and on release sets it up to 99. I'm gonna test this out and see if I can make it work.

Edit: Doh, I posted before you edited.

Cyborgmatt
10-28-2009, 11:52 AM
This solution is better for disabling the intro movies (you don't need to delete the original videos).

I had this listed as my method first, I didn't get chance to test it but I was told that it apparently didn't work so I suggested deleting the files instead.

DaveKap
10-28-2009, 12:04 PM
I wonder if you could bind setting the VolumeThreshold to a key. On click it drops it down to 1 and on release sets it up to 99. I'm gonna test this out and see if I can make it work.

Edit: Doh, I posted before you edited.

I get the feeling that since the default threshold is 0.2, it's working on a 0.0 to 1.0 scale, not a 0.0 to 100.0 scale, so keep that in mind while testing. I eagerly await your results! *currently at work*

Can anyone verify if the FOV and Mouse scrolling thing above works and if so, can the original poster of this thread update his post? Or is there a wiki with these hacks constantly being updated somewhere? We really should use a central, editable source to keep track of all these cool tricks.

asforme
10-28-2009, 12:32 PM
I get the feeling that since the default threshold is 0.2, it's working on a 0.0 to 1.0 scale, not a 0.0 to 100.0 scale, so keep that in mind while testing. I eagerly await your results! *currently at work*

Can anyone verify if the FOV and Mouse scrolling thing above works and if so, can the original poster of this thread update his post? Or is there a wiki with these hacks constantly being updated somewhere? We really should use a central, editable source to keep track of all these cool tricks.

The FOV trick works great, haven't accepted a quest to check the mouse scrolling yet. The volumethreshold doesn't seem to work, but testing is a PITA since there's no real developer console. The console that you can enable is worthless and passes every command as a "say" command.

lePewdeOdeur
10-28-2009, 01:49 PM
I feel like an absolute idiot for having to ask, but where are the .ini files you guys are talking about?

http://i17.photobucket.com/albums/b58/ThortheClod/willowgame.jpg

they're not in willowgame/config for me (and yes, I've played the game a couple times already and I've messed with the screen resolution so the file should be there, right?)

asforme
10-28-2009, 02:13 PM
I feel like an absolute idiot for having to ask, but where are the .ini files you guys are talking about?

http://i17.photobucket.com/albums/b58/ThortheClod/willowgame.jpg

they're not in willowgame/config for me (and yes, I've played the game a couple times already and I've messed with the screen resolution so the file should be there, right?)

Inside your My Documents folder: My Games\Borderlands\WillowGame\Config

Cyborgmatt
10-28-2009, 02:21 PM
It DOES work.
Yeap that's usually the case, people need to make sure they read the instructions fully before posting a reply saying that it isn't working.

KyrenCross
10-28-2009, 05:48 PM
Can someone help me with the interface in chatting. If I press T the chat menu appears, but if I type let say "RATS" , as soon as I press the "T" in RATS my chat window closes. IN short I can never press T again while typing my message. I don't know what to do, I changed the bind in willowinput but it still goes to default when I enter the game, help please. I hate subtituting the number 7 for the letter T >_<

HorrorScope
10-28-2009, 06:13 PM
Here's a link to 3rd Person mode if it hasn't been linked already: http://gbxforums.gearboxsoftware.com/showthread.php?t=80533

phonebook
10-28-2009, 07:19 PM
I need help. I decided I no longer wanted to have the game windowed, but even when I removed "-windowed" from the command bar and restarted my computer it's windowed. Can anyone help?

Cyborgmatt
10-28-2009, 07:20 PM
I need help. I decided I no longer wanted to have the game windowed, but even when I removed "-windowed" from the command bar and restarted my computer it's windowed. Can anyone help?
Change "-windowed" to "-fullscreen", or ingame press: alt + enter.

Cyborgmatt
10-28-2009, 07:28 PM
Here's a link to 3rd Person mode if it hasn't been linked already: http://gbxforums.gearboxsoftware.com/showthread.php?t=80533
I'll update my post in a minute with an easier way to add that bind, it only involves changing it in one ini tbh.

Edit: Updated, if someone could test out it for us that would be great.

dwnewby
10-28-2009, 08:00 PM
It works like a charm. I has its share of "oddities" but its good to go. Only thing is with some scopes, you can see your head in the lower left hand corner when your zoomed in, and "aim mode" has no animation, only zooms in a tad. But yes, it does work and you are in 3rd person. I like it, just can't stand seeing my own head in my scope. :)

Cyborgmatt
10-28-2009, 08:03 PM
I'll put together something better tomorrow, I'll probably make the right mouse button switch you into first person and then back into third person on release it should work pretty well.

Thanks for testing it.

Mr Xombie
10-28-2009, 08:38 PM
I'll put together something better tomorrow, I'll probably make the right mouse button switch you into first person and then back into third person on release it should work pretty well.

Thanks for testing it.

I did a quick edit, and it works perfectly. Its based on the Toggle Right Click edit, but it works is whats important!
Bindings=(Name="RightMouseButton",Command="ToggleAimOff",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleAimOn",Command="StartAltFire | Camera FirstPerson | setbind RightMouseButton ToggleAimOff",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleAimOff",Command="StopAltFire | Camera ThirdPerson | setbind RightMouseButton ToggleAimOn",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

also, 2 seconds to mention my own little find. I made a some changes to the aim toggle to make an FOV toggle. nothing fancy, but again, it works.
Bindings=(Name="F11",Command="ToggleFOVOff",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleFOVOn",Command="FOV 90 | setbind F11 ToggleFOVOff",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleFOVOff",Command="FOV 70 | setbind F11 ToggleFOVOn",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

finally, i am having issues with v-sync and mouse smoothing. basically, if v-sync is on, i can't get the mouse to be smooth, no matter what. have tried through the ini, setting pre-rendered frames to 3. nada. it only gets smooth when v-sync is off. I AM using a logitech wireless mouse, but the fact that the mouse is smooth when v-sync is off counters that idea. or so i think. any thoughts?

TheGreatStone
10-28-2009, 09:44 PM
You say 70 but I've also heard 85 and 90. So what's the definitive number and how do you know?
I made a key that set FOV to 70. I pressed it, and the FOV didn't change. As opposed to the key that set FOV to 90, which definitely changed things. Trial and error is how I found 70.

KyrenCross
10-28-2009, 11:22 PM
Can someone help me with the interface in chatting. If I press T the chat menu appears, but if I type let say "RATS" , as soon as I press the "T" in RATS my chat window closes. IN short I can never press T again while typing my message. I don't know what to do, I changed the bind in willowinput but it still goes to default when I enter the game, help please. I hate subtituting the number 7 for the letter T >_<

Does this only happen to me? Someone help me with this problem please >_< .

Rainmaker666
10-28-2009, 11:54 PM
I can't get the toggle aim fix to work either...

I am sure that I am applying the fix to the "[Engine.PlayerInput]" section. But nothing changes.

blazur
10-29-2009, 07:43 AM
Many thanks! Rep ye shall have...

NeryK
10-29-2009, 09:28 AM
Batch script to backup your savegame on launch, original script courtesy of adrian783 on the gbx forums (http://gbxforums.gearboxsoftware.com/showpost.php?p=1605730&postcount=1) :


C:
cd "\Documents and Settings\[USER]\My documents\My Games\Borderlands\backup"
md SaveData
cd SaveData
xcopy "C:\Documents and Settings\[USER]\My documents\My Games\Borderlands\SaveData" /e
cd ..

set timestr=%date:~-4,4%%date:~-7,2%%date:~-10,2%_%time:~-11,2%%time:~-8,2%
set timestr=%timestr: =0%

rename SaveData SaveData_%timestr%

cd "C:\Program Files\Steam\"
"C:\Program Files\Steam\Steam.exe" -applaunch 8980



Better safe than sorry guys.
Create the backup directory and replace the [USER] part to run your game with this .bat file.

twistadias
10-29-2009, 02:06 PM
A nifty ini editor

http://www.coflash.com/stuff/borderlands_ini_editor_gui.zip
http://img9.imageshack.us/img9/4117/bicw.jpg

Bulletzen
10-29-2009, 02:38 PM
Could someone please give me step by step instructions on how to enable AA on my ATI card with this game using RivaTuners D3DOverdirver? I would be very grateful.

Roadhog
10-29-2009, 03:18 PM
Could someone please give me step by step instructions on how to enable AA on my ATI card with this game using RivaTuners D3DOverdirver? I would be very grateful.


^ this. I have a 2x5870, and I can't for the life of me figure out anything to get AA to work. I'm pretty sure its impossible for 5 series ati cards.

TranceField
10-29-2009, 04:51 PM
I tried to run my games in window mode... it worked... but then I wanted to go back to full screen so I used this

To disable windowed mode, change the command line to:
Code:

-fullscreen

Now when I try to play my game my screen goes black... it reads output not supported :( wtf....

TranceField
10-29-2009, 04:54 PM
I tried to run my games in window mode... it worked... but then I wanted to go back to full screen so I used this

To disable windowed mode, change the command line to:
Code:

-fullscreen

Now when I try to play my game my screen goes black... it reads output not supported :( wtf....

Oki nm... I figured it out...

When the screen went black I just hit ALT+ENTER to go into window mode and I changed the resolution in the menu...

works fine now :P :D

Weasle
10-29-2009, 04:54 PM
I'm sorry if this has already been posted:

Quick warning about using the toggle aim bind, it disables the use of the main weapon when driving a vehicle (can't right click to fire machine gun/rocket launcher)

LurnToSpel
10-29-2009, 05:14 PM
I'm sorry if this has already been posted:

Quick warning about using the toggle aim bind, it disables the use of the main weapon when driving a vehicle (can't right click to fire machine gun/rocket launcher)

To fix this, just go into the options menu and reassign aiming to a different key. You can use that key instead for firing from vehicles, which is what I do, and then use the toggle aim bind to aim down the sights.

LiquorQuickly
10-29-2009, 06:35 PM
I tried locking iron sights to the right mouse button. But when using brick with this enabled you are NOT able to uppercut. Is there a fix for this? I would really like toggleable iron sights on Brick :s

Wasser
10-29-2009, 06:37 PM
The only solution is to bind the regular hotkey iron sights to a different button, which you can use to uppercut.

DarkSyde
10-29-2009, 07:09 PM
Batch script to backup your savegame on launch, original script courtesy of adrian783 on the gbx forums (http://gbxforums.gearboxsoftware.com/showpost.php?p=1605730&postcount=1) :



Better safe than sorry guys.
Create the backup directory and replace the [USER] part to run your game with this .bat file.

For Vista/Win7 change 'Documents and Settings' to 'Users'.

DarkSyde
10-29-2009, 07:32 PM
Ok, I'm trying to use the .bat file to make backups but it just makes a new emtpy folder on my desktop with the proper timestamp in the name. Heres what I have: (user name removed)

D:
cd "\Users\Username\My Documents\My Games\Borderlands\Backup"
md SaveData
cd SaveData
xcopy "D:\Users\Username\My Documents\My Games\Borderlands\SaveData" /e
cd ..

set timestr=%date:~-4,4%%date:~-7,2%%date:~-10,2%_%time:~-11,2%%time:~-8,2%
set timestr=%timestr: =0%

rename SaveData SaveData_%timestr%

cd "D:\Program Files (x86)\Steam\"
"D:\Program Files (x86)\Steam\Steam.exe" -gameidlaunch 12110788420100423680

-------------------------------------
I have my programs and user folders on Drive D. The game launches fine (retail disc with shortcut added to steam) but doesn't do the backup properly and I can't seem to figure out why. Ideas?

Edit: Figured it out. I forgot that in Win7/Vista(?) the 'My Documents' folder, even though it says My Documents, is actually just 'Documents' :|. Works now.

ArmoredCavalry
10-29-2009, 08:52 PM
I've tried just about everything I can think of, and still can't seem to get third person or fov tweaks working.

I deleted the entire input file, let the game generate a brand new one, tried putting the lines of code under [Engine.PlayerInput] section and under the [WillowGame.WillowPlayerInput] section, all with no luck....

Anyone else have this issue.... Can somone send me their .ini for testing?

RyanH
10-29-2009, 09:07 PM
^ this. I have a 2x5870, and I can't for the life of me figure out anything to get AA to work. I'm pretty sure its impossible for 5 series ati cards.

If you have a 5K series ATI you should be able to use the new Super Sampling AA modes, those should work with any game, but the performance is much steeper then using MSAA and 4K series and earlier ATI cards don't have those modes either.

twistadias
10-29-2009, 09:35 PM
For toggling the mic, im trying out nircmd -> http://www.nirsoft.net/utils/nircmd2.html


nircmdc.exe mutesysvolume 2 microphone
toggles mic on and off :)

Create a shortcut-> Right click-> Put in a shortcut key :)

EDIT: Doesnt work ingame though :(

BirdsOnMyBack
10-29-2009, 11:34 PM
I didn't backup my config file, can someone put theirs up?

moonfudgeman
10-30-2009, 12:27 AM
Mouse smooth disabling = breath of fresh air, thanks. How Gearbox screwed up a PC port when they have such a long running tradition of PC games we'll never know, but I'm sure we'll have some decent patches soon. Also, a Zombie Island DLC is coming out soon

Zombie Vampire
10-30-2009, 04:18 AM
I just have a comment about enabling AA for nVidia users: There is no need to download any 3rd party apps. The nVidia control panel has the ability to force AA in programs via profiles, just like ATI Tray Tools. Been using this feature since Oblivion, and works like a charm.

caddux
10-30-2009, 07:02 AM
Ok, I would love to try some of these tweaks, but I never done this before and I wonder: will there be any trouble at all when a patch comes out and I install it over a tweaked game?

I really would love to try the FOV and mouse smothing tweaks...:(

kerrang
10-30-2009, 07:06 AM
Looks like third person mode has a bug related with sound.

There is no footstep sound in third person when using all the guns except limmitter and revolver.

caddux
10-30-2009, 07:46 AM
Another question: to edit an .ini file do I doubleclick to open it or do I have to open it in a notepad?

darkest_ev1l
10-30-2009, 08:46 AM
You have to right click the .ini and 'Open With' notepad.

caddux
10-30-2009, 09:55 AM
You have to right click the .ini and 'Open With' notepad.

Thanx! But when I save it, it will be saved with a .txt in the end, right? Then after saving I just rename it to .ini?

Another question that I really would like an answer:

Will there be any problem to patch a game that has been tweaked?

Thanx a lot! I'm just new to tweaking games and I didn't want to mess up my Borderlands, because despite these minor troubles, I didn't had any major problem installing and playing it until now... and I REALLY wanted to try the "disable mouse smothing" tweak

ms255
10-30-2009, 10:36 AM
Thanx! But when I save it, it will be saved with a .txt in the end, right? Then after saving I just rename it to .ini?

No. Just save it over the original and it will still be a .ini file. If you're scared of ruining your install, then backup all of the .inis before editing them.

darkest_ev1l
10-30-2009, 11:35 AM
I still can't get the increased FOV tweak to work >< I stopped playing a while ago and i've still got this dull headache..... really need to fix this. I followed the instructions in this thread, but to no avail, pressing F11 does nothing. Any help?

PfefferScope
10-30-2009, 11:37 AM
No matter what I try, no changes to the
C:\Documents and Settings\XXXXXX\My Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i
take effect, period. I have edited other .INI files before, but this one refuses to cooperate.

Every time I make a change, I save it and change the file to read-only, but to no avail. I should mention that changing WillowEngine.ini to disable intro movies worked fine. Any tips?

(PS: If it matters, what I was trying to accomplish was turning that god-awful mouse-smoothing off!)

darkest_ev1l
10-30-2009, 11:45 AM
I just tried changing the .ini files in my steamapps/common/borderlands directory (not C:\Documents and Settings\XXXXXX\My Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i) and I could remove the intro videos. Inside your Borderlands directory there's a folder called WillowGame, just like in your user folders, which has the same .ini files but with 'Default' replaced infront of them. Such as 'DefaultInput', 'DefaultEngine'. You bascially just do the same as you tried to do in the 'WillowInput' file, and it worked. But i tried to do the increased FOV tweak and it half-worked. I can press F11 and it'll go to a perfect FOV, but then after i sprint, it goes back to the default FOV. Crap. Help!

PfefferScope
10-30-2009, 12:44 PM
As far as I can tell, the FOV during sprinting is forced, so you'll need to hotkey something to re-apply the FOV you prefer every time you go for a run.

Also, I'd be very wary editing the DefaultX.ini files, as they are the backups that get reinstated should the originals be deleted or modified.

darkest_ev1l
10-30-2009, 01:09 PM
Well I get no affect from editing the Willow.ini files, I don't have much choice as I really can't go on much longer with headaches everytime I play Borderlands. I'm not and have never been sea/car sick before in my life, so this is really wierd. Anyway, I need some help making a hotkey which re-applys my prefered FOV of 90 after I finish sprinting. Can anyone help me? And why isn't anyone else having this issue? :s

neuromancer
10-30-2009, 01:19 PM
I still can't get the increased FOV tweak to work >< I stopped playing a while ago and i've still got this dull headache..... really need to fix this. I followed the instructions in this thread, but to no avail, pressing F11 does nothing. Any help?

In the WillowInput.ini file you need to search for:

[WillowGame.WillowPlayerInput]

In that section is a massive block of key bindings, at the end of the block insert the code:

Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)

Also, you can change F11 to any key you like and you can try different values for the FOV (I have mine set at 100 on 1680x1050 resolution).

neuromancer
10-30-2009, 01:24 PM
As a work-around for the MP issue where the FOV resets after Sprinting you can add the FOV command to a movement key so the FOV command is executed every time you press it. I use E for move forward so the binding for it in the WillowInput.ini file is:

Bindings=(Name="E",Command="MoveForward | Axis aGas Speed=+1.0 | FOV 100",Control=False,Shift=False,Alt=False,LeftTrigge r=False,RightTrigger=False,bIgnoreCtrl=False,bIgno reShift=False,bIgnoreAlt=False)

darkest_ev1l
10-30-2009, 01:28 PM
As a work-around for the MP issue where the FOV resets after Sprinting you can add the FOV command to a movement key so the FOV command is executed every time you press it. I use E for move forward so the binding for it in the WillowInput.ini file is:

Bindings=(Name="E",Command="MoveForward | Axis aGas Speed=+1.0 | FOV 100",Control=False,Shift=False,Alt=False,LeftTrigge r=False,RightTrigger=False,bIgnoreCtrl=False,bIgno reShift=False,bIgnoreAlt=False)

I might try that but wouldn't it mean that if i stop moving and let go of my movement keys, the FOV would revert back to the default? Also, my sprint key is my right shift key and I noticed in the code (your one and the one at the start of the thread) that it sais 'Shift=False'. Is that why when I press my shift key (my sprint key), my FOV goes back to the default?

neuromancer
10-30-2009, 01:30 PM
I might try that but wouldn't it mean that if i stop moving and let go of my movement keys, the FOV would revert back to the default?

Nope, the only time that actually does anything is when you first start the game and after you Sprint in MP. All other times it just stays at 100.

darkest_ev1l
10-30-2009, 02:17 PM
Alright, I tried the code and the FOV aspect of it works, but now I can't move forward... I changed the 'E' in your code to 'MoveForward' as I use the arrow keys to move around. So I went in-game and pressed my forward key and the FOV switched to 100, but I could only move left, right and back. So it's obviously because move forward button is the MoveForward command in the code, so how do i fix that? ;)

Edit: No matter, I just replaced the 'E' with some other button out of the way which i'll use to toggle the FOV when I join a game. I don't mind because i'll eventually get into the habit of doing it. Thanks for the help! +RRREEEPPP

DarkSyde
10-30-2009, 02:41 PM
Ok, I would love to try some of these tweaks, but I never done this before and I wonder: will there be any trouble at all when a patch comes out and I install it over a tweaked game?

I really would love to try the FOV and mouse smothing tweaks...:(

No, all your are changing is text in a notepad file. All of these tweaks are options which the game supports but for whatever (dumb) reason were not supplied in the GUI.

DarkSyde
10-30-2009, 02:51 PM
Alright, I tried the code and the FOV aspect of it works, but now I can't move forward... I changed the 'E' in your code to 'MoveForward' as I use the arrow keys to move around. So I went in-game and pressed my forward key and the FOV switched to 100, but I could only move left, right and back. So it's obviously because move forward button is the MoveForward command in the code, so how do i fix that? ;)

Edit: No matter, I just replaced the 'E' with some other button out of the way which i'll use to toggle the FOV when I join a game. I don't mind because i'll eventually get into the habit of doing it. Thanks for the help! +RRREEEPPP

To add multiple commands to a key, do like this:

Bindings=(Name="S",Command="MoveBackward | Axis aBrake Speed=+1.0 | FOV 100",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

Simply separate commands with | (and a space on both sides). Be sure that any keybinds you change are done under the [WillowGame.WillowPlayerInput] section of WillowInput.ini!

It's also recommended to use the 'set defaults' option in game before you start editing keybinds (only need to do this before the first time) or the game might decide that none of your keys are bound to anything :eek:.

Dragonshadow
10-30-2009, 04:28 PM
Anyone figured out how to get more than 4 people ina game yet? I've toyed around with changing the maxplayers in my config but when I invite friends They get told the game is full.

dred79
10-30-2009, 04:55 PM
Hey guys i plan on trying quite a few of these tweaks but the number of configs in different locations is confusing. I know everyone says to edit the files in my documents and my games folder. The problem is that i have configured my keys in the game a certain way and everytime i edit the willowinput file i see my buttons assigned to what looks like the default configurtion. It feels like i am editing a file that does reflect how i actually have it configured in game.

Why is that? I feel like i am trying to apply changes to a file that has no effect on my actual config.

dred79
10-30-2009, 06:53 PM
guys i just added the bindings for 3rd person camera and toggle aim in the game and neither one works. I also tried turning off the smooth mouse and changed vsync to true. it seems like none of this is taking effect.

I am editing the files in the C:\Users\Admin\Documents\My Games\Borderlands\WillowGame\Config folder.

Can someone tell me why this is not working?

Doriol
10-30-2009, 08:01 PM
I can't seem to get thirdperson to work, either.

dred79
10-30-2009, 08:53 PM
I got the toggle aim to work. but for some reason i had to paste it in the baseinput.ini which is located D:\GAMES\Steam\steamapps\common\borderlands\Engine \Config

Just so long as it works i am happy. going to try and add a few more in there now.

btw i have an ATI card it appears we cannot enable AA at this time i have tried ATI tray tools and d3doverrider. neither work. d3doverider only has vsync triple buffering options and ati tray tools AA just doesn't force it at all.

caddux
10-30-2009, 11:17 PM
No, all your are changing is text in a notepad file. All of these tweaks are options which the game supports but for whatever (dumb) reason were not supplied in the GUI.

Thanx! I just played it for the past 5 hours! This game is amazing, even without any tweak!

But I'll try the FOV tweak next time I play, because this is really the one thing I would like to change.

Thanx again ;)

Dingo
10-30-2009, 11:56 PM
To get Thirdperson to work
add the command from the main page, then at the very end of [WillowGame.WillowPlayerInput] add

Bindings=(Name="F3",Command="Camera ThirdPerson",Control=False,Shift=False,Alt=False)
Bindings=(Name="F4",Command="Camera FirstPerson",Control=False,Shift=False,Alt=False)

Fenchurch
10-31-2009, 04:06 AM
For all (like me) who rather play in 3rd person but have the problem, that sometimes after switching to zoom mode the bullets go far off the crosshair, the following lines to the trick:

Bindings=(Name="RightMouseButton",Command="ToggleAimOn",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleAimOn",Command="Camera FirstPerson | StartAltFire | setbind RightMouseButton ToggleAimOff",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="ToggleAimOff",Command="StopAltFire | Camera ThirdPerson | setbind RightMouseButton ToggleAimOn",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

-----
hmmm....
it's "ToggleAimOn" without the Space, of course, but this forum fills in a space which I can't delete. Interesting.

Dragonshadow
10-31-2009, 06:30 AM
My problem with thirdperson is that brick takes of 3/4 of the screen :)

caddux
10-31-2009, 07:28 AM
Hi :)
I just tryied the fov tweak. Set it to 100. Got in the game but I really couldn't tell if I saw any diference... But now I have the impression that my guns look bigger... but I'm not sure...
Guess I'll make a screenshot of how it looks now and without the tweak to compare them... :(

caddux
10-31-2009, 08:58 AM
In the WillowInput.ini file you need to search for:

[WillowGame.WillowPlayerInput]

In that section is a massive block of key bindings, at the end of the block insert the code:

Bindings=(Name="F11",Command="FOV 90",Control=False,Shift=False,Alt=False)

Also, you can change F11 to any key you like and you can try different values for the FOV (I have mine set at 100 on 1680x1050 resolution).

Ok, now something just came up in my head: After you edit the ini file, do you have to press F11 ingame to apply the new FOV???

Nor
10-31-2009, 09:03 AM
is there a disable voicechat when hosting a server to anyone whoever joins in?

Jinnai
10-31-2009, 09:23 AM
Anyone feel like testing this tweak? Sorry if it's been said already, didn't see it in skimming here, and no search makes it tought...

Turn on friendly fire in coop games:
in the WillowGame.ini file there is this setting:

[WillowGame.WillowCoopGameInfo]
bIgnoreFriendlyFire=true

I imagine setting it to false turns on friendly fire.

caddux
10-31-2009, 10:09 AM
ALLRIGHT!!! I finally made the FOV work!!! It's that I never used tweaks before and I didn't realise that I had to press F11 ingame to make it work! It's SO much better now!!! Thank you all!!! :D:D:D

One thing is a little annoying though: after I use a vehicle the FOV goes back to default, but other than that it just stays the same, even after sprinting. But I'm only playing single player until now. I heard that in multiplayer the FOV resets after sprinting.

Anyways, it's much better now!

HorrorScope
10-31-2009, 11:32 AM
ALLRIGHT!!! I finally made the FOV work!!! It's that I never used tweaks before and I didn't realise that I had to press F11 ingame to make it work! It's SO much better now!!! Thank you all!!! :D:D:D

One thing is a little annoying though: after I use a vehicle the FOV goes back to default, but other than that it just stays the same, even after sprinting. But I'm only playing single player until now. I heard that in multiplayer the FOV resets after sprinting.

Anyways, it's much better now!

I know a lot of people don't understand this, but actually knowing how to do things like that are good to know and cool and can lead to other things. I'm a guy that has made a living since '85 in the computer world, all based on two things, gaming/toying/learning pc's and fear.

Try out this fix for MP sprinting.

Even so, that said Gearbox should correct these.

Acer Knight
10-31-2009, 01:56 PM
In the first post of the thread, Cyborgmatt lists to put the commands for setting the 3rd person camera and FOV changes under [Engine.PlayerInput].

Based on my own experience, and a couple of other posts where I saw people had trouble getting it working, it seems that the correct section for these commands is actually under
[WillowGame.WillowPlayerInput].

If someone else can confirm let's get the post updated.

Also, for the people who were asking earlier, the default FOV seems to be 70. I say this because if you set a keybind to set it to 70 and press it nothing seems to happen. You can set another key for 90 and toggle back between them. 70 appears to be the default.

S0N0S
10-31-2009, 02:13 PM
In the first post of the thread, Cyborgmatt lists to put the commands for setting the 3rd person camera and FOV changes under [Engine.PlayerInput].

Based on my own experience, and a couple of other posts where I saw people had trouble getting it working, it seems that the correct section for these commands is actually under
[WillowGame.WillowPlayerInput].

If someone else can confirm let's get the post updated.

Also, for the people who were asking earlier, the default FOV seems to be 70. I say this because if you set a keybind to set it to 70 and press it nothing seems to happen. You can set another key for 90 and toggle back between them. 70 appears to be the default.

THANK YOU for that. I've been trying to figure out why these fixes weren't working.

Seriously, thanks a lot. :D

caddux
10-31-2009, 02:22 PM
Ok, I got the FOV to work. I set it to 100.

It feels MUCH better, but now I want more!!! :o

Does anybody know what's the FOV limit for this game? :cool:

jseweb
10-31-2009, 04:22 PM
Has anybody figured out how to make an auto run command yet? I tried searching google, but that just finds autorun scripts for removable devices.

Cyborgmatt
10-31-2009, 04:38 PM
In the first post of the thread, Cyborgmatt lists to put the commands for setting the 3rd person camera and FOV changes under [Engine.PlayerInput].

Based on my own experience, and a couple of other posts where I saw people had trouble getting it working, it seems that the correct section for these commands is actually under
[WillowGame.WillowPlayerInput].

If someone else can confirm let's get the post updated.

Also, for the people who were asking earlier, the default FOV seems to be 70. I say this because if you set a keybind to set it to 70 and press it nothing seems to happen. You can set another key for 90 and toggle back between them. 70 appears to be the default.
It's hit and miss really tbh, for some people the binds only work under the Engine section for others they only work under the PlayerInput section.

If you place the binds exactly where it says to (under certain lines etc) it should work fine.

Acer Knight
10-31-2009, 04:57 PM
It's hit and miss really tbh, for some people the binds only work under the Engine section for others they only work under the PlayerInput section.

If you place the binds exactly where it says to (under certain lines etc) it should work fine.

Yeah, I went back through the entire thread and noticed some people were reporting different results. Maybe just put both on the main post?

I tried adding the lines exactly as suggested (right after Bindings=(Name="F8",Command="shot")), but it didn't do anything for me. Most of the separate threads I've read say to put it under [WillowGame.WillowPlayerInput]. I also noticed that the syntax for all of the other [Engine.PlayerInput] statements does not include the extra parameters.

dred79
10-31-2009, 06:35 PM
is there a momentary crouch bind for steam? i seen it for the retail game but i can't get it to work in my steam copy. was hoping someone knows how to make it work for steam.

xlynx99
10-31-2009, 06:46 PM
4:3 = 70
16:10 = 80
16:9 = 86

http://gbxforums.gearboxsoftware.com/showpost.php?p=1604557&postcount=164

xlynx99
10-31-2009, 08:59 PM
anyone figured how to change the FOV difference while sprinting?

Mr Xombie
10-31-2009, 10:19 PM
is there a momentary crouch bind for steam? i seen it for the retail game but i can't get it to work in my steam copy. was hoping someone knows how to make it work for steam.

yes. if you put this bit of code in WillowInput.ini, at the bottom of the section named WillowGame.WillowPlayerInput, it will give you the desired effect:
Bindings=(Name="Duck",Command="Button bDuck | Axis aUp Speed=-1.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)
Bindings=(Name="LeftControl",Command="Duck",Control=False,Shift=False,Alt=False,LeftTrigger=F alse,RightTrigger=False,bIgnoreCtrl=False,bIgnoreS hift=False,bIgnoreAlt=False)

credit to whoever first mentioned it. sorry, dont remember the name.

skywarp00
10-31-2009, 10:20 PM
sprint FOV is forced graphic effect and can not be changed. changing to 90 for FOV is good but i just keep forgeting to press f11....seems i have to press it if i get a 2nd wind or respawn....becomes slighty annoying. fix?

xlynx99
10-31-2009, 10:59 PM
screenshot key:


My Documents\My Games\Borderlands\WillowGame\Config\WillowInput.in i

[WillowGame.WillowPlayerInput]
Bindings=(Name="F12",Command="shot")

bitmaps appear in My Documents\My Games\Borderlands\WillowGame\ScreenShots

godofnoob
10-31-2009, 11:57 PM
Am i the only one not finding the willowinput or willowengine in my borderlands folder anywhere?