View Single Post
Old 09-09-2011, 03:50 PM   #394
AcidBee
 
Join Date: Sep 2011
Reputation: 0
Posts: 3
Symptom:
Crash when launching due to module filesystem_x86_rwdi.dll (Details from Windows Event Viewer).

Reasons:
The game fails to launch because it cannot access your Documents folder. You have most likely redirected your Documents folder to a remote location (i.e. a file server on your network). Dead Island cannot traverse the network path.

Solution:
All Windows Versions
Create a new user and do not redirect the Documents directory (keep it local). Play Dead Island logged in as the user you just created.

Windows Vista/7
Make your documents folder appear as part of the local file system. NOTE: THIS REQUIRES FINDING AND CHANGING VALUES IN THE REGISTRY, DO NOT ATTEMPT IF YOU DO NOT KNOW WHAT YOUR ARE DOING.
  1. Using the command prompt as admin, add a symbolic link to your user directory (C:\Users\<USER NAME>). The command looks like this: mklink /D Documents \\path\to\remote\documents
  2. Using regedit, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
  3. Check the ProfileImagePath value to identify which SSID belongs to your login. (Value should be C:\Users\<YOUR USER NAME>)
  4. Using this SSID navigate to HKEY_USERS\<USER SSID>\Software\Microsoft\Windows\CurrentVersion\Ex plorer\User Shell Folders in regedit and chang the value for Personal from your remote network location to %USERPROFILE%\Documents

Last edited by AcidBee: 09-09-2011 at 03:54 PM. Reason: Put the easier solution first
AcidBee is offline   Reply With Quote