Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Mount & Blade series

Reply
 
Thread Tools Display Modes
Old 08-13-2011, 02:18 PM   #1
BlueFlam3Z
 
Guest
Posts: n/a
Exclamation Strange kind of lag in Fire and Sword

I can Run the game just fine with 45 fps or higher but for some reason the game frequently does short freezes when i am in battle or even in the map. I think the problem is that im using Direct x 11. I had some issues with the Direct x 11 before in Killing Floor, I fixed it changing a in-game option from Direct x 9 to Direct x.
When i change Dx from 9 to 7 in M&B it runs perfectly.

My pc specs are:
Geforce 9500 gt
2x 2,8 Ghz
Windows 7 64 bit
4gb Ram
 
Reply With Quote
Old 08-13-2011, 10:42 PM   #2
Asphe
 
Join Date: Apr 2010
Reputation: 232
Posts: 1,792
No, DX9 is installed as part of the install process (if you didn't have it installed already). The game just uses a lot of ram although 4GB should be enough. In the game launcher try to see if disabling or enabling 'Load Texture on Demand' since your 9500 GT probably only has 256 or 512MB. Some models have 1024MB and the game will easily load up to 1024MB. If you have that model, you should get better performance disabling it. You can try reducing texture detail to improve memory performance but if you're averaging 45fps, you should expect 5-10 in some spots.
Asphe is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Mount & Blade series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.