Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > RailWorks

Reply
 
Thread Tools Display Modes
Old 10-12-2011, 04:50 AM   #1
wbgron
 
Join Date: Dec 2010
Reputation: 21
Posts: 198
List your RW3/Train Sim 2012 issues here, to be forwarded to RS Dev Team

This topic I thought could be put together for the whole community to list, all and any issues they have found with RW3 or as know known as Train Simulator 2012.

I have seen many posts and threads were members have slagged off Railsim team for what they believe is a badly scripted patch.

SO LETS STOP SLAGGING THE GAME OFF, SLAGGING RAILSIM OFF & SLAGGING EACH OTHER OFF AND GET IT SORTED AS A COMMUNITY!


Please can you all respond to this thread with a list of what you believe is an issue, a problem, a bug or something you feel isn't quite right since the RW3 patch release.
After a week or so I'll painstakingly go through all the posts, copying and pasting all your posts into one large post, that I'll email to the developers so that the team have one larger solid list they can look at.


Please can an Admin or Moderator sticky this post so it doesn't get lost?

Last edited by wbgron: 10-12-2011 at 05:01 AM. Reason: Found a spelling mistake :)
wbgron is offline  
Reply With Quote
Old 10-12-2011, 04:55 AM   #2
Bob360
 
 
 
Join Date: Oct 2010
Reputation: 159
Posts: 1,776
I have reported your thread. Not in a bad way though. I reported it as this:

Can we have this thread as a STICKY? It makes so much sense.
Bob360 is offline   Reply With Quote
Old 10-12-2011, 05:00 AM   #3
wbgron
 
Join Date: Dec 2010
Reputation: 21
Posts: 198
Cheers Bob!
wbgron is offline   Reply With Quote
Old 10-12-2011, 05:02 AM   #4
Bob360
 
 
 
Join Date: Oct 2010
Reputation: 159
Posts: 1,776
Maybe if we can get more people reporting this thread in that fashion, we can make it happen.

Good day to you. It’s time to go to work, and send some people to jail.

Last edited by Bob360: 10-12-2011 at 05:04 AM.
Bob360 is offline   Reply With Quote
Old 10-12-2011, 08:15 AM   #5
wbgron
 
Join Date: Dec 2010
Reputation: 21
Posts: 198
Well I've had 61 views and no replies so Obviously RW3 isn't as broken as you all report!!!
wbgron is offline   Reply With Quote
Old 10-12-2011, 08:38 AM   #6
lonewolfdon
 
Join Date: Mar 2009
Reputation: 328
Posts: 3,101
Quote:
Originally Posted by wbgron View Post
Well I've had 61 views and no replies so Obviously RW3 isn't as broken as you all report!!!
Patience young gwass-hopper
Plus, on forums in general you tend to get more lurkers and viewers than posters.

Cheers!
lonewolfdon is offline   Reply With Quote
Old 10-12-2011, 08:53 AM   #7
Suicide Perkies
 
Join Date: Apr 2011
Reputation: 87
Posts: 815
Career mode high scores not being recorded/uploaded correctly and associated achievements not unlocking.

When resuming a scenario and the game is running, the train suffers a violent jolt as it spawns in the game world, causing the G-force meter to go nuts, sometimes causing excessive forces and affecting your evaluation.
Suicide Perkies is offline   Reply With Quote
Old 10-12-2011, 09:12 AM   #8
wbgron
 
Join Date: Dec 2010
Reputation: 21
Posts: 198
Quote:
Originally Posted by lonewolfdon View Post
Patience young gwass-hopper
Plus, on forums in general you tend to get more lurkers and viewers than posters.

Cheers!
Yeah ya right matey!
wbgron is offline   Reply With Quote
Old 11-03-2011, 01:44 AM   #9
37357
 
Join Date: Jun 2010
Reputation: 14
Posts: 117
Quote:
Originally Posted by wbgron View Post
Well I've had 61 views and no replies so Obviously RW3 isn't as broken as you all report!!!

hst class 43 power car needs the digital speedo to work!!
37357 is offline   Reply With Quote
Old 10-12-2011, 08:36 AM   #10
lonewolfdon
 
Join Date: Mar 2009
Reputation: 328
Posts: 3,101
Let's see, just going to quickly mention a couple of things with RW3 that I think could be fixed or improved upon:

* RW3 still seems a bit poorly optimized and can often struggle to run consistently with decent / smooth / good performance and FPS (and in many cases Users see the dreaded 14 FPS as a constant number when using RailWorks built-in FPS monitor. Of course some routes & scenarios are worse than others at negatively affecting the FPS), even on some newer computers with top hardware. Tweaking around with the various settings can help some, but I feel that overall RW3 could be more optimized to run much better, especially on computers with multiple-cores and good graphics-cards.

* I think the Anti-Aliasing could be improved on.

* Traffic with Cars, Trucks, Buses, etc... on some roads tend to have an odd way of bunching-up, to the point that often times they clip-through and piggy-back each other. This can look rather strange. This was often noticeable in RW2 as well.

* Some of the Turn-Tables could be improved upon. I find that maybe around 25% of the time I try to use a turn-table, that it tends to jerk so badly while rotating that the locomotive gets toppled, thus ending the scenario due to derailment. This was still the case with RW2 as well.

* Legacy-mode (having TSX off), though it tends to improve the FPS, it looks as if the colors are washed-out (especially on distant terrain), and a bit too-bright in general. Shadows from some objects and structures can now look and act rather strange.

* Sometimes while playing a scenario, the whole screen suddenly fills up with what looks to be some random garbage frame (almost like being inside of a mountain or falling off the map for a second). It happens often enough that it can be distracting and take away from the immersion. It seemed to happen more often for me when I was in legacy-mode, but I haven`t noticed this as often when using TSX mode. Many other Users have also reported similar such graphic-oddity occurrences.

Last edited by lonewolfdon: 10-12-2011 at 08:43 AM.
lonewolfdon is offline   Reply With Quote
Old 10-12-2011, 09:14 AM   #11
wbgron
 
Join Date: Dec 2010
Reputation: 21
Posts: 198
*One of my dislikes is traffic, cars and buses etc still go through level crossings. There is a level crossing just outside of Motherwell on the WCML section, every time I approach it a bus suddenly appears (always a bus) and my train hits it but goes through it!
wbgron is offline   Reply With Quote
Old 07-15-2012, 05:26 PM   #12
BLingley
 
Join Date: Sep 2011
Reputation: 0
Posts: 1
Quote:
Originally Posted by wbgron View Post
*One of my dislikes is traffic, cars and buses etc still go through level crossings. There is a level crossing just outside of Motherwell on the WCML section, every time I approach it a bus suddenly appears (always a bus) and my train hits it but goes through it!
Also the crossing flashers at crossing are ALWAYS flashing. Not very realistic. Gates & lights should be the approach and passing of a train.

Another matter that is most annoying is when you save a scenario so you can resume it later, you get unpleasant results at times. With diesel engines you are usually at a full stop, with the emergency brake on, and with steam (Pennsy K4's on the Horseshoe Curve Route), the train immediately derails and your scenario is toast. This really sucks!
BLingley is offline   Reply With Quote
Old 10-12-2011, 10:10 AM   #13
Rhialto
 
Join Date: Jan 2010
Reputation: 10
Posts: 149
Hope you will have more success, I sent a similar call a few days ago here.

- Speedo accuracy
- Level crossing bells always on
- Physics broken (I got an email saying they should look into this one)
Rhialto is offline   Reply With Quote
Old 10-12-2011, 10:49 AM   #14
lonewolfdon
 
Join Date: Mar 2009
Reputation: 328
Posts: 3,101
* I noticed that on some trains that when in the Passenger view, (I'll use the wonderful ICE1 trainset as an example), that when the weather of a scenario was set to rain or snow, that it would often "clip-through" so it looked as if it was partially raining or snowing inside of the passenger-car.

* It would also be nice to see the TSX rain-effects-on-the-windows in passenger view as well. But I realize that would probably be a low-priority item to deal with.

Last edited by lonewolfdon: 10-12-2011 at 10:52 AM.
lonewolfdon is offline   Reply With Quote
Old 10-12-2011, 11:14 AM   #15
Class76
 
Join Date: Mar 2011
Reputation: 313
Posts: 3,829
WELL DONE TO WHOEVER GOT THIS THREAD AS A STICKY
Class76 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > RailWorks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.