Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Q.U.B.E.

Reply
 
Thread Tools Display Modes
Old 01-06-2012, 06:05 PM   #1
Sp3tZn4z
 
 
 
Join Date: May 2011
Reputation: 25
Posts: 105
Controls and other problems.

So far my major complaint is not beeing able to customize the controls. I use an AZERTY keyboard so using WASD is not an option, people with an AZERTY keyboard use ZQSD instead.

Screen tearing, Vsync is on but doesn't seem to work.

Mouse speeds aren't adjustable thru the option menu.
Sp3tZn4z is offline  
Reply With Quote
Old 01-06-2012, 06:15 PM   #2
Belgium
 
 
 
Join Date: Dec 2011
Reputation: 5
Posts: 42
One workaround for vsync is to change the resolution, then change back to your preferred resolution - vsync should be working after that. I've seen this bug in other games.
Belgium is offline   Reply With Quote
Old 01-06-2012, 06:47 PM   #3
Oshroth
 
Join Date: Oct 2008
Reputation: 3
Posts: 51
Quote:
Originally Posted by Sp3tZn4z View Post
So far my major complaint is not beeing able to customize the controls. I use an AZERTY keyboard so using WASD is not an option, people with an AZERTY keyboard use ZQSD instead.

Screen tearing, Vsync is on but doesn't seem to work.

Mouse speeds aren't adjustable thru the option menu.
Since this is a UDK mod, you should be able to change controls and mouse speed through the config files in steamapps\common\qube\UDKGame\Config\. The file containing key bindings is UDKInput.ini. There are some graphic settings in either UDKGame.ini or UDKEngine.ini
Oshroth is offline   Reply With Quote
Old 01-06-2012, 07:31 PM   #4
Sp3tZn4z
 
 
 
Join Date: May 2011
Reputation: 25
Posts: 105
Quote:
Originally Posted by Oshroth View Post
Since this is a UDK mod, you should be able to change controls and mouse speed through the config files in steamapps\common\qube\UDKGame\Config\. The file containing key bindings is UDKInput.ini. There are some graphic settings in either UDKGame.ini or UDKEngine.ini
Just changing the following lines in "UDKInput.ini" doesn't work (adjusting other lines also doesn't work):

Code:
Bindings=(Name="Z",Command="GBA_MoveForward")
Bindings=(Name="S",Command="GBA_Backward")
Bindings=(Name="Q",Command="GBA_StrafeLeft")
Bindings=(Name="D",Command="GBA_StrafeRight")
Changing everything to AZERTY in "DefaultInput.ini" also doesn't work. I'll look into this some more later or tomorrow but so far I can't change them, and I shouldn't have to do all that just to change controls.

Anyway personally I can play since this has been an issue in multiple games and when the game has started up I just have to press ALT+SHIFT, changes my keyboard to QWERTY, but not everyone has multiple languages installed and the ability for changing controls should be standard in every game.

Last edited by Sp3tZn4z: 01-06-2012 at 07:34 PM.
Sp3tZn4z is offline   Reply With Quote
Old 01-06-2012, 07:28 PM   #5
Sonkilary
 
 
 
Join Date: Dec 2011
Reputation: 19
Posts: 91
Same Problem as SP3 thanks for your help Oshroth.
Sonkilary is offline   Reply With Quote
Old 01-06-2012, 09:11 PM   #6
Akuen
 
 
 
Join Date: Dec 2004
Reputation: 64
Posts: 824
Have you tried pressing Alt+Shift to switch your keyboard layout from your local one to an american layout? That might work for you.
Akuen is offline   Reply With Quote
Old 01-06-2012, 09:25 PM   #7
Sp3tZn4z
 
 
 
Join Date: May 2011
Reputation: 25
Posts: 105
Quote:
Originally Posted by Akuen View Post
Have you tried pressing Alt+Shift to switch your keyboard layout from your local one to an american layout? That might work for you.
Read my last post in this topic. That's what I currently do, not everyone with an AZERTY keyboard has installed multiple languages.
Sp3tZn4z is offline   Reply With Quote
Old 01-07-2012, 01:46 AM   #8
Akuen
 
 
 
Join Date: Dec 2004
Reputation: 64
Posts: 824
Quote:
Originally Posted by Sp3tZn4z View Post
Read my last post in this topic. That's what I currently do, not everyone with an AZERTY keyboard has installed multiple languages.
Right, I must have missed that.

You should probably file it as a bug to the developers, if you want to see a proper fix: http://qube-game.com/contact
Akuen is offline   Reply With Quote
Old 01-07-2012, 12:42 AM   #9
facebrick
 
Join Date: Jul 2011
Reputation: 0
Posts: 5
This game is definitely missing a controls configuration option. I'd really like to be able to use ijkl instead of wasd for movement...
facebrick is offline   Reply With Quote
Old 01-07-2012, 12:53 AM   #10
sarcacid
 
 
 
Join Date: Sep 2009
Reputation: 50
Posts: 663
Editing these lines in Steam\steamapps\common\qube\UDKGame\Config\UDKInpu t.ini worked for me:

Bindings=(Name="W",Command="GBA_MoveForward")
Bindings=(Name="S",Command="GBA_Backward")
Bindings=(Name="A",Command="GBA_StrafeLeft")
Bindings=(Name="D",Command="GBA_StrafeRight")
sarcacid is offline   Reply With Quote
Old 01-07-2012, 03:25 AM   #11
Sp3tZn4z
 
 
 
Join Date: May 2011
Reputation: 25
Posts: 105
Quote:
Originally Posted by sarcacid View Post
Editing these lines in Steam\steamapps\common\qube\UDKGame\Config\UDKInpu t.ini worked for me:

Bindings=(Name="W",Command="GBA_MoveForward")
Bindings=(Name="S",Command="GBA_Backward")
Bindings=(Name="A",Command="GBA_StrafeLeft")
Bindings=(Name="D",Command="GBA_StrafeRight")
Still doesn't work for me, still goeing thru all .ini files and looking up documentation for the UDK.

EDIT:I got it working now. I actually don't know what went wrong the first couple of times I did it. I did unplug everything that could influence the controls for a game, like my 360 Controller, PS3 Controller and some other stuff that is used for "multiboxing". Also shutdown any programs used by any of that hardware.

Last edited by Sp3tZn4z: 01-07-2012 at 04:14 AM.
Sp3tZn4z is offline   Reply With Quote
Old 01-07-2012, 11:19 AM   #12
facebrick
 
Join Date: Jul 2011
Reputation: 0
Posts: 5
Quote:
Originally Posted by sarcacid View Post
Editing these lines in Steam\steamapps\common\qube\UDKGame\Config\UDKInpu t.ini worked for me:

Bindings=(Name="W",Command="GBA_MoveForward")
Bindings=(Name="S",Command="GBA_Backward")
Bindings=(Name="A",Command="GBA_StrafeLeft")
Bindings=(Name="D",Command="GBA_StrafeRight")
I tried that, but it didn't work for me. Qube still insisted on using WASD even after I changed the values in the INI file.
facebrick is offline   Reply With Quote
Old 01-08-2012, 12:12 PM   #13
Bonq
 
Join Date: Dec 2009
Reputation: 385
Posts: 540
Quote:
Originally Posted by facebrick View Post
I tried that, but it didn't work for me. Qube still insisted on using WASD even after I changed the values in the INI file.
Are you sure you didn't edit these instead:

Bindings=(Name="W",Command="MoveForward")
Bindings=(Name="S",Command="MoveBackward")
Bindings=(Name="A",Command="StrafeLeft")
Bindings=(Name="D",Command="StrafeRight")

(those are under [Engine.DebugCameraInput], same file).

Anyway, I'd also would like to have in-game options for these. Pretty Please.
Bonq is offline   Reply With Quote
Old 01-07-2012, 07:35 AM   #14
TomsFZ1
 
Join Date: Mar 2009
Reputation: 3
Posts: 60
Sorry, but pure laziness on the part of the developer for not including a way to change the keyboard controls from within the game. Tried modifying the .ini files, but no luck there so I will pass.
TomsFZ1 is offline   Reply With Quote
Old 01-08-2012, 02:51 PM   #15
mystrdat
 
 
 
Join Date: Nov 2008
Reputation: 478
Posts: 3,719
Quote:
Originally Posted by TomsFZ1 View Post
Sorry, but pure laziness on the part of the developer for not including a way to change the keyboard controls from within the game. Tried modifying the .ini files, but no luck there so I will pass.
It's called time and money usually, not laziness.
mystrdat is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Q.U.B.E.


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 02:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.