Go Back   Steam Users' Forums > Steam Tool Discussions > Source SDK General Discussion

Reply
 
Thread Tools Display Modes
Old 04-25-2012, 07:09 AM   #1
soopytwist
 
Join Date: Nov 2008
Reputation: 14
Posts: 350
Source SDK no longer loads (64 bit OS)

I used Hammer last night. Today Source SDK won't load. I have 64 bit Windows 7 and I've read there are problems running SDK and Gary's Mod in a 64 bit OS since the Orange Box update a couple of years ago. I have original Half Life 2 and Episodes. I have the same none load problem with Gary's Mod.

I was playing around with the editor yesterday but now I can't continue. The process opens, SDKLauncher.exe *32 but nothing opens.

I've tried the "-32bit" launch option and also "-engine ep1" (minus quotes) but neither of those work.

Meanwhile Half Life 2, Episodes 1 and 2 and Cinematic Mod 11 which I've been playing all load fine. So does Source SDK Base 2007.

EDIT

Hammer still works if I run the .exe from the SDK 2009 directory, but the SDK utility window still won't load up.

Last edited by soopytwist: 04-25-2012 at 07:40 AM.
soopytwist is offline  
Reply With Quote
Old 04-26-2012, 04:09 AM   #2
zombie@computer
 
Join Date: Aug 2008
Reputation: 416
Posts: 908
Try deleteing the related sourcesdk/bin directory, then restart steam and sourcesdk. Should regenerate everything.

(might want to back up if you notice hammer wont work either after this)
zombie@computer is offline   Reply With Quote
Old 04-26-2012, 05:58 AM   #3
soopytwist
 
Join Date: Nov 2008
Reputation: 14
Posts: 350
Nope, still doesn't work. I deleted the bin directory and launched Source SDK again but nothing appears, just the running process and the bin directory has automatically been reinstated.

I've also tried uninstalling Source SDK and SDK Base 2007 and 2009 and reinstalling them. Still can't open the SDK.
soopytwist is offline   Reply With Quote
Old 04-29-2012, 08:48 PM   #4
DeathNimrod
 
 
 
Join Date: Oct 2009
Reputation: 6
Posts: 188
Have you verified data integrity of all the games/tools?

That might be the case.

Also defragment them.

I run my source sdk and garry's mod on 64 bit home premium windows 7, and they work perfectly fine (all data verified and defragmentated) and Garry's mod all extensions are enabled and work 100%.
DeathNimrod is offline   Reply With Quote
Old 04-30-2012, 04:59 AM   #5
soopytwist
 
Join Date: Nov 2008
Reputation: 14
Posts: 350
I tried the verify integrity and defrag when Garry's Mod stopped working sometime ago - it didn't help. I haven't yet tried doing that for the SDK though so it's worth a try I guess.

EDIT

Nope. Still doesn't load after verifying data integrity and defragging.

Last edited by soopytwist: 04-30-2012 at 09:38 AM.
soopytwist is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Tool Discussions > Source SDK General Discussion


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.