Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Lucidity

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 10-08-2009, 12:53 PM   This is the last staff post in this thread.   #1
BurtonJ
 
BurtonJ's Avatar
 
Valve
Join Date: Nov 2007
Reputation: 10677
Posts: 9,043
Common Issues and Fixes

Crash after choosing language –
If for some reason Lucidity crashes after choosing a language this may be a problem with your video playback codecs when it is trying to show the LucasArts intro movie.
On your STEAM games list, right click “Lucidity” and select “properties”.
In the General Tab click “Set launch options” and type “-novideo” (without quotes of course!)
This will skip the intro movie and get right to the main menu.

.NET –
Lucidity requires Microsoft .NET framework 3.5 to run. The XNA framework (also required and part of Lucidity’s installation) requires .NET to install as well.
Head to http://www.microsoft.com/net and click “install it now” on the top right.

The Steam overlay (Shift+Tab) –
When you boot up the title you may notice the Steam Overlay pop-up does not work. Although you will not be able to use the shift+tab keys to bring up the in-game overlay, you will still see messages and achievements pop-up.

Game does not start, “XP SP3 or higher required” error message.
This is most likely caused by the Steam client trying to run Lucidity in Compatibility mode. The way to fix this is by deleting a registry key in your windows registry.

For a 32bit Windows system:
Hit START and then “Run” – type “Regedit”
If there is a steam.exe located in the layers folder here, rename or delete the entry.
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Also check:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

For a 64bit Windows system:
Same thing but in a different location:
If there is a steam.exe located in the layers folder here, rename or delete the entry.
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Also check:
HKEY_CURRENT_USER\Software\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

Other command parameters -
If you feel like trouble shooting any other issues here is a list of other command parameters. These are unsupported, but can help you narrow down issues

-noaudio > Disables Audio
-nomouse > disables the mouse (will work with 360 gamepad only..not officially supported)
-fullscreen > switches game to fullscreen
-windowed > switches game to windowed
-resolution=WxH > replace W with width and H with Height

Your config file-
Some of these folders may be “hidden” on your windows
On windows XP this is located in:
C:\Documents and Settings\All Users\Application Data\LucasArts\Lucidity\PROFILENUMBER
On windows Vista and 7 this is located in:
C:\Users\All Users\LucasArts\Lucidity\PROFILENUMBER

Deleting the config.xml file in here and running the game again will reset your settings back to default.

The .bin files in here are the save games if you want to backup your progress!



For more information, please see the Lucidity Steam Support FAQ.
BurtonJ is offline  
Reply With Quote
Old 10-08-2009, 01:50 PM   #2
FatBaby
 
 
 
Join Date: Nov 2008
Reputation: 3
Posts: 71
I am definitely going to try that fix for 64bit version of Windows. Tried the 32bit last night, but could only get to AppCompatFlags part of the registry.

Now all I need to do is get home from work! Hopefully it works.
FatBaby is offline   Reply With Quote
Old 10-08-2009, 06:09 PM   #3
The_Mega_ZZTer
 
Join Date: Sep 2004
Reputation: 10
Posts: 827
Hi, you might want to revise the bit about "registry key". A "registry key" is represented by a FOLDER icon... I believe you mean "value" which is represented in the right pane of Registry Editor by a file icon. It could confuse some people and they may break Windows functionality by accident by deleting the entire key!

FatBaby: You can also check without using the registry editor. Simply open your Steam folder, right click on steam.exe, properties, compatibility, and make sure all options are unchecked.

Actually BurtonJ you might want to ask users to do that instead of the registry, less chance they'll get confused and delete the wrong thing.
The_Mega_ZZTer is offline   Reply With Quote
Old 10-08-2009, 06:38 PM   #4
FatBaby
 
 
 
Join Date: Nov 2008
Reputation: 3
Posts: 71
Hey, thanks for the info The_Mega_ZZTer.

I come home from work and the first thing I do is open up Steam and just try it again just for the hell of it. To my surprise, the thing starts up and I am able to play. Not sure what the heck changed, but at least it is working now. I guess the computer just needed a break or something.
FatBaby is offline   Reply With Quote
Old 10-09-2009, 11:16 PM   #5
richardjones
 
Join Date: Jun 2008
Reputation: 4
Posts: 35
I have Windows 7 (32 bit) and hve installed .NET 3.5.1 and the game still says I need to install .NET
richardjones is offline   Reply With Quote
Old 10-10-2009, 03:03 AM   #6
StingingVelvet
 
Join Date: Apr 2008
Reputation: 264
Posts: 4,797
Quote:
Originally Posted by richardjones View Post
I have Windows 7 (32 bit) and hve installed .NET 3.5.1 and the game still says I need to install .NET
Make sure your windows update is on and everything is updated... I had this issue with a previous game and when I updated through windows update the game worked.
StingingVelvet is offline   Reply With Quote
Old 10-10-2009, 04:58 PM   #7
richardjones
 
Join Date: Jun 2008
Reputation: 4
Posts: 35
Quote:
Originally Posted by StingingVelvet View Post
Make sure your windows update is on and everything is updated... I had this issue with a previous game and when I updated through windows update the game worked.
I am completely up to date.
richardjones is offline   Reply With Quote
Old 10-11-2009, 06:30 PM   #8
WaffleWolf
 
Join Date: May 2009
Reputation: 0
Posts: 4
Is it just me or is the install link on the .NET framework webpage not working anymore?
WaffleWolf is offline   Reply With Quote
Old 10-13-2009, 01:25 AM   #9
montanaCZ
 
Guest
Posts: n/a
In the General Tab click “Set launch options” and type “-novideo”

I tried, but still nothing... any other help, please?
It's been a week and LucasArts does not solve the problem at all. Annoying :/
  Reply With Quote
Old 10-13-2009, 04:36 AM   #10
tiscaligames
 
Guest
Posts: n/a
So I have installed Windows 7 RTM 64-bit and I have still the same problem like on XP 32-bit SP3. It crashes after choosing of language. Tried every tip from here.

Windows 7 says this:

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: lucidity.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 4abc03ed
Problem Signature 04: Labs.Core
Problem Signature 05: 1.0.0.0
Problem Signature 06: 4abc03d6
Problem Signature 07: 23f
Problem Signature 08: 82
Problem Signature 09: System.InvalidOperationException
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1029
  Reply With Quote
Old 10-13-2009, 08:49 AM   #11
raz84
 
Guest
Posts: n/a
Quote:
Originally Posted by tiscaligames View Post
So I have installed Windows 7 RTM 64-bit and I have still the same problem like on XP 32-bit SP3. It crashes after choosing of language. Tried every tip from here.

Windows 7 says this:

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: lucidity.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 4abc03ed
Problem Signature 04: Labs.Core
Problem Signature 05: 1.0.0.0
Problem Signature 06: 4abc03d6
Problem Signature 07: 23f
Problem Signature 08: 82
Problem Signature 09: System.InvalidOperationException
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1029
exactly. any update on this?
  Reply With Quote
Old 10-13-2009, 12:21 PM   #12
tiscaligames
 
Guest
Posts: n/a
Quote:
Originally Posted by raz84 View Post
exactly. any update on this?
guys from Valve said me, that best solution is to contact LucasArts support for Lucidity (because it is third party game)...so I will try to contact them...
  Reply With Quote
Old 10-13-2009, 01:21 PM   #13
raz84
 
Guest
Posts: n/a
Quote:
Originally Posted by tiscaligames View Post
guys from Valve said me, that best solution is to contact LucasArts support for Lucidity (because it is third party game)...so I will try to contact them...
ok, understood. i'll let them know. hope they'll fix it soon..
  Reply With Quote
Old 10-13-2009, 03:06 PM   #14
raz84
 
Guest
Posts: n/a
non-us; non-uk: guys, it seems i've found solution to our problem. just change system format to english (united states) under "region and language" settings in control panel. i was wondering why so many czech ppl have the same problem..

Last edited by raz84: 10-13-2009 at 03:18 PM.
  Reply With Quote
Old 10-13-2009, 03:54 PM   #15
tiscaligames
 
Guest
Posts: n/a
Quote:
Originally Posted by raz84 View Post
non-us; non-uk: guys, it seems i've found solution to our problem. just change system format to english (united states) under "region and language" settings in control panel. i was wondering why so many czech ppl have the same problem..
oh man, thank you very much! finally I can write that review, thanks to you...
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Lucidity


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.