Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Counter-Strike: Source

Reply
 
Thread Tools Display Modes
Old 06-25-2010, 09:49 AM   #1
dawNNN
 
Join Date: May 2010
Reputation: 0
Posts: 46
FPS CONFIG

I need a fps config for this css.
can someone give me one? big thx
dawNNN is offline  
Reply With Quote
Old 06-25-2010, 09:57 AM   #2
epics
 
Guest
Posts: n/a
I use this

Code:
//Epics AUTOEXEC

//net
cl_cmdrate "101"
cl_updaterate "101"
cl_interp "0.01"

//binds
bind mwheeldown "+jump"
bind t "+voicerecord"
bind p "impulse 201"
bind v "messagemode"
bind f4 "exec autoexec.cfg"
bind q +right
bind o sm_admin
bind i kill
bind space +jump

//ingame
cl_crosshairscale "1200"
cl_dynamiccrosshair "0"
cl_crosshairalpha "255"
cl_crosshairusealpha "1"
cl_minmodels 1
sensitivity "2.1"
cl_autohelp "0" 
cl_autowepswitch "0"
con_enable "1"
hud_fastswitch "1"
cl_yawspeed 375
net_graph 1
net_graphpos 2

//buy scripts
bind [ "buy scout;buy defuser"
bind ] "buy awp;buy defuser;buy deagle"
bind = "buy flashbang;buy hegrenade;buy flashbang;buy defuser"
bind ' "buy deagle;buy defuser; buy vesthelm"
bind \ "buy m4a1;buy ak47"

//graphics
fps_max "101"
cl_ragdoll_physics_enable "0"
mat_picmip 0
mat_reducefillrate 0
r_shadowrendertotexture 1
mat_antialias 0
mat_forceaniso 0
mat_trilinear 1
mat_vsync 0
mat_hdr_enabled 0
mat_hdr_level 0
cl_scoreboard_t_color_blue
cl_scoreboard_dead_t_color_blue
//_Set Render vars_
r_decals "0" // Disables decals.
r_drawbatchdecals "1" // Enables the rendering of decals in batch.
r_decal_cullsize "9999" // Any decals under this size are not rendered.
r_rootlod "2" // Base lod of the model in the memory.
r_lod "-1" // Different level of details on models. -1 = Variable at distance. 0 = None. 1 = Minor. 2 = Less minor.
r_modellodscale "1.0" // The transitioning power of LOD.
r_drawmodeldecals "0" // Models decals, I.E. Blood.
r_shadowmaxrendered "32" // Max shadows the game will render.
r_shadows "0" // Disables shadows (Change to 1 if you like them.)
r_shadowrendertotexture "1" // Rendered the shadow texture causing it to match the player model.
r_dynamic "0" // Disables dynamic lights.
r_propsmaxdist "1200" // Max distance at which props are rendered.
r_drawdetailprops "1" // Enables the rendering of detail props.
r_occlusion "1" // Enables the Model Occlusion system.
r_renderoverlayfragment "0"
r_3dsky "0" // Disables the rendering of 3d sky boxes.
r_waterdrawreflection "0" // Disables the rendering of water reflections.
r_waterforceexpensive "0" // Forces cheap water.
r_drawflecks "0" // Disables the sparks and dirt from bullet impacts.
r_eyes "0" // Disables eyes in models.
r_teeth "0" // Disables teeth in models.
gl_clear "0" // Disables the gl_clear convariable!
mat_monitorgamma "1.6" // Lower the number the brighter the screen. Only works in fullscreen.
mat_disable_bloom "1" // Disables bloom effects.
mat_hdr_enabled "0" // Disables HDR.
mat_hdr_level "0" // Double Disables HDR.
mat_specular "0" // Disables Specularity on objects.
mat_picmip "2" // Changes the resolutions of textures when they're loaded into memory. May improve FPS on graphics cards with low memory sizes.
mat_antialias "0" // Disables the use of multisampling to smooth out edges.
mat_bumpmap "0" // Disables bump mapping.
mat_clipz "0" // Disables optimized Z-Buffer rendering.
mat_compressedtextures "0" // Disables texture compression. Users with low amounts of system memory should turn this on.
mat_mipmaptextures "1" // Enables the use of mipmapping to make textures look smooth.
mat_reducefillrate "1" // Reduces the fillrate when the game is run in DXLevel 8.
mat_trilinear "0" // Disables the use of Trilinear mipmapping.
mat_wateroverlaysize "8" // Sets the resolution of water distortion. Must be multiple of 8.



//volume
volume "1"
  Reply With Quote
Old 06-25-2010, 09:59 AM   #3
rym9k
 
Join Date: May 2007
Reputation: 28
Posts: 818
Search for Casey's Config that seems to be popular. Here's my advice:

Beside lowering all graphical detail to the lowest possible settings in Video, also switch to DirectX 8.1. Do this by right-clicking CS in Steam, then you should see launch options (or something like that). Put in "-dxlevel 81". Run the game once, close it, and take out that command. Careful as it might have reset all your Video settings.

In your exec put "r_3dsky 0", for a single cvar it does wonders. Doing just these 2-3 things (for now), got me from 20 to 50.
rym9k is offline   Reply With Quote
Old 06-25-2010, 10:01 AM   #4
ds-
 
 
 
Join Date: Jan 2009
Reputation: 214
Posts: 1,994
This one was just created specifically for this update by Netcode Illuminati and I got a huge boost, try it yourself and see if it works for you
Code:
-- Graphics --

blink_duration 					"0"
budget_averages_window 				"0"
budget_background_alpha 			"0"
budget_history_numsamplesvisible 		"0"
budget_history_range_ms 			"5"
budget_peaks_window				"0"
budget_show_averages 				"0"
budget_show_history 				"0"
budget_show_peaks 				"0"
cl_c4dynamiclight 				"1"
cl_detail_avoid_force				"0"
cl_detail_avoid_radius				"0"
cl_detail_avoid_recover_speed			"0"
cl_detail_max_sway				"0"
cl_drawmonitors 				"0"
cl_ejectbrass 					"0"
cl_forcepreload 				"1"
cl_logofile 					"0"
cl_phys_props_max 				"50"
cl_ragdoll_collide				"0"
cl_ragdoll_physics_enable			"0"
cl_rumblescale					"0"
cl_show_splashes 				"0"
closecaption					"0"
datacachesize 					"128"
flex_smooth					"0"
func_break_max_pieces 				"0"
g_ragdoll_fadespeed 				"0"
g_ragdoll_important_maxcount 			"0"
g_ragdoll_lvfadespeed				"0"
g_ragdoll_maxcount 				"0"
gl_clear 					"1"
lod_TransitionDist			        "0"
mat_aaquality 					"0"
mat_antialias 					"0"
mat_autoexposure_max				"0"
mat_autoexposure_min 				"0"
mat_bloomscale 					"0"
mat_bufferprimitives				"1"
mat_bumpmap 					"0"
mat_clipz 					"1"
mat_colorcorrection				"0"
mat_compressedtextures 				"1"
mat_debug_postprocessing_effects 		"0"
mat_debugdepthmode 				"0"
mat_debugdepthval 				"128"
mat_debugdepthvalmax 				"256"
mat_disable_bloom 				"1"
mat_disable_fancy_blending			"1"
mat_disable_lightwarp				"1"
mat_disable_ps_patch				"1"
mat_envmapsize 					"0"
mat_envmaptgasize 				"0"
mat_fastspecular 				"1"
mat_filterlightmaps 				"1"
mat_forceaniso 					"2"
mat_forcehardwaresync 				"0"
mat_forcemanagedtextureintohardware 		"0"
mat_framebuffercopyoverlaysize 			"0"
mat_hdr_enabled 				"0"
mat_hdr_level					"0"
mat_monitorgamma 				"1.6"
mat_parallaxmap 				"0"
mat_picmip 					"-1"
mat_reducefillrate 				"1"
mat_specular 					"0"
mat_trilinear 					"0"
mat_shadowstate					"0"
mat_vsync 					"0"
mat_wateroverlaysize 				"8"
mp_decals 					"0"
muzzleflash_light 				"0"
props_break_max_pieces 				"0"
props_break_max_pieces_perframe 		"0"
r_3dsky						"0"
r_ambientboost					"0"
r_ambientfactor					"1"
r_cheapwaterend 				"1"
r_cheapwaterstart				"1"
r_decal_cullsize 				"9999"
r_decals 					"0"
r_dopixelvisibility 				"0"
r_drawbatchdecals 				"0"
r_drawflecks 					"0"
r_drawmodeldecals 				"0"
r_dynamic 					"0"
r_eyegloss 					"0"
r_eyemove 					"0"
r_eyes 						"0"
r_eyeshift_x 					"0"
r_eyeshift_y 					"0"
r_eyeshift_z 					"0"
r_eyesize 					"0"
r_flex 						"0"
r_forcewaterleaf				"0"
r_lightaverage 					"1"
r_lod                                           "2"
r_maxdlights					"32"
r_maxmodeldecal 				"0"
r_maxnewsamples					"0"
r_maxsampledist					"0"
r_minnewsamples 				"0"
r_norefresh 					"0"
r_occlusion 					"1"
r_PhysPropStaticLighting 			"0"
r_renderoverlayfragment 			"0"
r_rootlod 					"2"
r_ropetranslucent 				"0"
r_shadowmaxrendered 				"9"
r_shadowrendertotexture 			"1"
r_shadows 					"1"
r_spray_lifetime				"0"
r_teeth 					"0"
r_WaterDrawReflection 				"0"
r_WaterDrawRefraction				"0"
r_waterforceexpensive 				"0"
r_waterforcereflectentities			"0"
r_worldlightmin 				"0.0002"
r_worldlights 					"1"
rope_averagelight 				"0"
rope_collide 					"0"
rope_rendersolid 				"0"
rope_shake 					"0"
rope_smooth 					"0"
rope_smooth_enlarge 				"0"
rope_smooth_maxalpha 				"0"
rope_smooth_maxalphawidth 			"0"
rope_smooth_minalpha 				"0"
rope_smooth_minwidth 				"0"
rope_subdiv 					"0"
rope_wind_dist 					"0.01"
showhitlocation 				"1"
sv_forcepreload 				"1"
texture_budget_background_alpha 		"9999999"
texture_budget_panel_height 			"0"
texture_budget_panel_width 			"0"
violence_ablood 				"1"
violence_agibs 					"1"
violence_hblood 				"1"
violence_hgibs 					"1"
weapon_showproficiency 				"1"

	-- CPU settings --

r_3dnow 					"0"
r_sse2 						"1"

	
	-- Netcode settings --

cl_allowdownload 				"0"
cl_allowupload					"0"
cl_cmdrate					"101"
cl_downloadfilter 				"none"
cl_interp					"0.020"
cl_interp_all 					"0"
cl_interp_npcs 					"0"
cl_interp_ratio 				"1"
cl_interp_threadmodeticks 			"0"
cl_lagcomp_errorcheck				"1"
cl_lagcompensation 				"1"
cl_pred_optimize 				"2"
cl_predictweapons 				"1"
cl_resend					"6"
cl_smooth 					"0"
cl_smoothtime 					"0.01"
cl_timeout 					"9999999"
cl_updaterate					"101"
rate						"35000"


	-- Sound & volume --

cl_customsounds 				"0"
cl_soundfile 					"0"
dsp_enhance_stereo 				"0"
dsp_mix_max 					"0.9"
dsp_room 					"0"
dsp_slow_cpu 					"0"
dsp_spatial 					"40"
dsp_speaker 					"50"
dsp_volume 					"2.0"
dsp_water 					"14"
room_type 					"0"
snd_async_fullyasync 				"0"
snd_duckerattacktime 				"0.5"
snd_duckerreleasetime 				"2.5"
snd_duckerthreshold 				"0.15"
snd_ducktovolume 				"0.55"
snd_mixahead 					"0.1"
snd_musicvolume 				"0"
snd_noextraupdate 				"1"
snd_pitchquality 				"1"
snd_profile 					"0"
snd_surround_speakers 				"0"
soundscape_flush 				"9999"
suitvolume					"0"
voice_enable 					"1"
voice_forcemicrecord 				"1"
voice_modenable 				"1"
voice_scale 					"0.4"




	-- HUD --

cl_c4progressbar 				"1"
cl_autohelp 					"0"
cl_autowepswitch				"0"
cl_min_ct 					"1"
cl_min_t 					"1"
cl_minmodels 					"1"
cl_radar_locked 				"0"
cl_radaralpha 					"250"
cl_radartype 					"1"
cl_righthand 					"1"
cl_wpn_sway_interp 				"0"
con_enable 					"1"
fps_max 					"1000"
hud_centerid 					"1"
hud_fastswitch 					"1"
jpeg_quality 					"100"
overview_health 				"1"
overview_names 					"0"
overview_preferred_mode 			"1"
overview_tracks 				"0"




	-- CS:S Update Tweaks --

r_bloomtintg 					"0"
r_bloomtintb 					"0"
r_bloomtintexponent 				"0"
r_bloomtintr 					"0"
r_drawdetailprops 				"0"
r_flashlightrendermodels 			"0"
r_hunkalloclightmaps 				"0"
r_lightcache_zbuffercache 			"0"
r_propsmaxdist 					"0"
r_staticprop_lod 				"7"
r_sse_s 					"1"

cl_clearhinthistory 				"1"
cl_detaildist 					"0"
cl_detailfade 					"0"
cl_debugrumble 					"0"
cl_playerspraydisable 				"1"
cl_showhelp 					"0"

mat_alphacoverage 				"0"
mat_bloom_scalefactor_scalar 			"0"
mat_maxframelatency 				"0"
mat_max_worldmesh_vertices 			"0"
mat_software_aa_blur_one_pixel_lines 		"0"
mat_software_aa_strength 			"0"
mat_software_aa_strength_vgui 			"0"
mat_software_aa_tap_offset 			"0"

prop_active_gib_limit 				"0"
adsp_debug 					"0"


	-- Multicore rendering tweaks --

mat_queue_mode 					"-1"
cl_threaded_bone_setup 				"0" 
cl_interp_threadmodeticks 			"0" 
cl_threaded_client_leaf_system 			"0" 
r_threaded_client_shadow_manager 		"1" 
r_threaded_particles 				"1" 
r_threaded_renderables 				"1" 
r_queued_decals 				"0" 
r_queued_post_processing 			"1" 
r_queued_ropes 					"1"
mp_usehwmmodels 				"-1" 
mp_usehwmvcds 					"-1" 



soundscape_flush
mat_savechanges
clear
ds- is offline   Reply With Quote
Old 06-25-2010, 12:40 PM   #5
qfxzid23
 
Guest
Posts: n/a
Quote:
Originally Posted by rym9k View Post
Search for Casey's Config that seems to be popular. Here's my advice:

Beside lowering all graphical detail to the lowest possible settings in Video, also switch to DirectX 8.1. Do this by right-clicking CS in Steam, then you should see launch options (or something like that). Put in "-dxlevel 81". Run the game once, close it, and take out that command. Careful as it might have reset all your Video settings.

In your exec put "r_3dsky 0", for a single cvar it does wonders. Doing just these 2-3 things (for now), got me from 20 to 50.
This helped me SO MUCH, ty SO MUCH xD It raised my fps from roughly 20 to almost 60. But only problem is, my mouse feels weird now. It feels heavy , any way to fix this?
  Reply With Quote
Old 06-25-2010, 12:49 PM   #6
rym9k
 
Join Date: May 2007
Reputation: 28
Posts: 818
Quote:
Originally Posted by qfxzid23 View Post
This helped me SO MUCH, ty SO MUCH xD It raised my fps from roughly 20 to almost 60. But only problem is, my mouse feels weird now. It feels heavy , any way to fix this?
Don't know exactly what you mean by weird. Perhaps your mouse sensitivity got reset? trying raising it. Either in Options or use the console variable "sensitivity." Mine is 7.5, for example.
rym9k is offline   Reply With Quote
Old 06-25-2010, 01:07 PM   #7
qfxzid23
 
Guest
Posts: n/a
Quote:
Originally Posted by rym9k View Post
Don't know exactly what you mean by weird. Perhaps your mouse sensitivity got reset? trying raising it. Either in Options or use the console variable "sensitivity." Mine is 7.5, for example.
Basically, my mouse lags when i turn or anything. Its harder for me to flick my scout shots and just to aim in general. Any help? D:
  Reply With Quote
Old 06-25-2010, 01:12 PM   #8
rym9k
 
Join Date: May 2007
Reputation: 28
Posts: 818
Quote:
Originally Posted by qfxzid23 View Post
Basically, my mouse lags when i turn or anything. Its harder for me to flick my scout shots and just to aim in general. Any help? D:
That's strange. If anything, your mouse should not lag now. My mouse slightly lagged when I had 20 FPS, but became normal once I had 50-60 FPS. Are you using Casey's config or something else?
rym9k is offline   Reply With Quote
Old 06-25-2010, 01:12 PM   #9
Angelslayer
 
Join Date: Apr 2005
Reputation: 73
Posts: 2,279
Are you using a mousrfix? Did you disable mouse acceleration in windows and CSS?
Angelslayer is offline   Reply With Quote
Old 06-25-2010, 01:16 PM   #10
n0iz
 
 
 
Join Date: Jun 2010
Reputation: 0
Posts: 34
Quote:
Originally Posted by qfxzid23 View Post
Basically, my mouse lags when i turn or anything. Its harder for me to flick my scout shots and just to aim in general. Any help? D:
turn off vertical sync
n0iz is offline   Reply With Quote
Old 06-25-2010, 01:17 PM   #11
qfxzid23
 
Guest
Posts: n/a
Quote:
Originally Posted by Angelslayer View Post
Are you using a mousrfix? Did you disable mouse acceleration in windows and CSS?
Where do I check this?

@Above, Let me try that.
EDIT: I disabled vertical syncing. I think its still the same..or it got better. But what do i do with multiplayer rendering? Its under the vertical sync.

Last edited by qfxzid23: 06-25-2010 at 01:20 PM.
  Reply With Quote
Old 06-25-2010, 01:21 PM   #12
Angelslayer
 
Join Date: Apr 2005
Reputation: 73
Posts: 2,279
Windows > configuration > mouse > 3rd tab > enhance pointer precision; should be off.

CSS > options > mouse; mouse smooth should be off.

STEAM > games > CSS > properties > set launch options > -noforcemparms -noforcemaccel -noforcemspd; those remove any mouse acceleration.
Angelslayer is offline   Reply With Quote
Old 06-25-2010, 01:25 PM   #13
nabokovfan87
 
 
 
Join Date: Jun 2008
Reputation: 308
Posts: 1,430
Quote:
Originally Posted by qfxzid23 View Post
Basically, my mouse lags when i turn or anything. Its harder for me to flick my scout shots and just to aim in general. Any help? D:
Try turning off the windows and cs:s side mouse "smoothing". It adds a filter, which introduces a delay on the mouse movement. If it feels slow and sluggish, or not responding properly it may be the laser inside the mouse has become misalinged or if the mouse is not moving fast enough/far enough bump up the sensitivity.

As always, with any mouse, turn down windows sensitivity as far ar possible, and turn up the dpi in the mouse driver to a comfortable level.
nabokovfan87 is offline   Reply With Quote
Old 06-25-2010, 01:26 PM   #14
qfxzid23
 
Guest
Posts: n/a
Quote:
Originally Posted by Angelslayer View Post
Windows > configuration > mouse > 3rd tab > enhance pointer precision; should be off.

CSS > options > mouse; mouse smooth should be off.

STEAM > games > CSS > properties > set launch options > -noforcemparms -noforcemaccel -noforcemspd; those remove any mouse acceleration.
Are you sure? I heard enhancer presicion should be ticked and so should mouse filter. Eh?
  Reply With Quote
Old 06-25-2010, 01:28 PM   #15
Angelslayer
 
Join Date: Apr 2005
Reputation: 73
Posts: 2,279
Quote:
Originally Posted by qfxzid23 View Post
Are you sure? I heard enhancer presicion should be ticked and so should mouse filter. Eh?
Whoever told you is that wrong. Of course you wouldn't believe me, so I kindly ask the rest of the forum to confirm what I just said.
Angelslayer is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Counter-Strike: Source


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 02:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.