Go Back   Steam Users' Forums > Steam Tool Discussions > Source Level Design

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 07-17-2010, 07:17 AM   #1
shawnolson
 
 
 
Join Date: Nov 2009
Reputation: 41
Posts: 190
Custom Map crashes after CS:S OB Update

I am in the last leg of my second CS:S map when I learned that my first CS:S map no longer works after the update to the Orange Box engine. The map is de_tension and its variant ww_de_tension . And it's a pretty hard crash that freezes CS to the point that you have to use task manager to close it--which won't always pop up because of the screen resolution setting when CS is running.

I thought that it would be that I just needed to recompile the map. But that is not the case. Even after recompiling it with SDK 2009, the map will not work. It always now crashes if you enter the section of the map where you can see the waterfall.

I have recompiled it with many different items deleted along that whole area. The error continues.

I thought that it might be one of the entities (like logic_auto) but turning them off does not help.

I've deleted the displacements along that stretch. No good. Deleted the waterfall. Crash. I stripped it to the bare brushwork along that strip, and it still crashes.

Even more bizarre is that if you join the map in spectator mode and fly through the same area, the map doesn't crash.

I am curious if anyone has any input on this. Thanks in advance.
shawnolson is offline  
Reply With Quote
Old 07-17-2010, 07:30 AM   #2
Punishment
 
Join Date: Feb 2008
Reputation: 355
Posts: 4,549
Are there any compile errors? Are you getting any error messages in the console right before it crashes?
Punishment is offline   Reply With Quote
Old 07-17-2010, 07:34 AM   #3
shawnolson
 
 
 
Join Date: Nov 2009
Reputation: 41
Posts: 190
Quote:
Originally Posted by Punishment View Post
Are there any compile errors? Are you getting any error messages in the console right before it crashes?
There are no compile errors. And nothing shows up in my console. When the crash happens, CS is absolutely frozen and you cannot access the console. I am totally baffled.

Last edited by shawnolson: 07-17-2010 at 08:18 AM. Reason: Added more detail to response to answer second question.
shawnolson is offline   Reply With Quote
Old 08-25-2010, 07:36 AM   #4
shawnolson
 
 
 
Join Date: Nov 2009
Reputation: 41
Posts: 190
I am not completely sure what the problem was, but it almost certainly involved displacements. I deleted a large section of the map's displacements and remade them from scratch. I have more details on fixing the map here. Anyone wanting to run the map has to download the newest version.
shawnolson is offline   Reply With Quote
Old 09-01-2010, 10:41 AM   This is the last staff post in this thread.   #5
Jay Stelly
 
Jay Stelly's Avatar
 
Valve
Join Date: Feb 2005
Reputation: 211
Posts: 172
These links all point to a map that doesn't crash. Where can I download the crashing map?
Jay Stelly is offline   Reply With Quote
Old 09-01-2010, 12:12 PM   #6
ICantShoot
 
 
 
Join Date: Jan 2005
Reputation: 415
Posts: 5,896
Quote:
Originally Posted by Jay Stelly View Post
These links all point to a map that doesn't crash. Where can I download the crashing map?
I had that old version on my pc, i packed it for you. Download here: http://server2.pelipurkki.fi/~dustin/de_tension.rar
Had a crash on that myself while running over the bridge in the map.

Also if you did not already notice, i created a thread for other maps that crash or have started having network lag after the engine update. I have included screenshots and map downloads in the thread too. Please have a look here http://forums.steampowered.com/forum...php?p=16819612

Thanks
ICantShoot is offline   Reply With Quote
Old 12-02-2010, 01:10 PM   #7
shawnolson
 
 
 
Join Date: Nov 2009
Reputation: 41
Posts: 190
Quote:
Originally Posted by ICantShoot View Post
I had that old version on my pc, i packed it for you. Download here: http://server2.pelipurkki.fi/~dustin/de_tension.rar
Had a crash on that myself while running over the bridge in the map.
Thanks for providing the older map... I never got any emails that anyone was responding after a certain point!

As stated in another post, I think it was displacements cutting into each other. I talked more about my suspiscions and fix at http://www.shawnolson.net/a/1460/ora...stom-maps.html
shawnolson is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Tool Discussions > Source Level Design


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 07:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.