Go Back   Steam Users' Forums > Steam Game Discussions > H - L > King's Quest Collection

Reply
 
Thread Tools Display Modes
Old 07-24-2009, 02:32 PM   #1
surfacewound
 
 
 
Join Date: Nov 2008
Reputation: 31
Posts: 183
Not A Single KQ Game Will Run

Well that was a complete waste of money. Not a single KQ game will run on my machine. I have Vista x64 so I was prepared for KQ VII to not work, but when I launch KQ1-6, a DOS box window opens briefly (~1 second) and just disappears, and that's it.

There's absolutely no excuse for this lazy BS, and Steam needs to allow a 7 day return period or something for games to ensure compatibility. If it's not, they could simply revoke access to the game and issue a refund, because this is absolutely pathetic.
surfacewound is offline  
Reply With Quote
Old 07-24-2009, 03:20 PM   #2
aerundel
 
 
 
Join Date: Apr 2007
Reputation: 124
Posts: 2,248
...Have you even tried asking Steam for a refund? They do it sometimes, and in the meantime you could try figuring out how to make the games work. Try downloading DOSBox directly from the dev's site and using that instead.
aerundel is offline   Reply With Quote
Old 07-25-2009, 12:32 AM   #3
in.meinem.turm.
 
 
 
Join Date: Feb 2008
Reputation: 387
Posts: 4,273
Quote:
Originally Posted by surfacewound View Post
I have Vista x64
And you have been warned on the store-page...

on the top in orange:
Quote:
Microsoft Windows XP 64 and Vista users: See system requirements below.
And in the requirements:
Quote:
Some games in this collection may run under Windows XP 64 and Vista 32/64, but are not officially supported
And you might wanna try to run these games with ScummVM.
www.scummVM.org

It can run Kings Quest I-IV and Space Quest I+II if you bought that pack too.

Last edited by in.meinem.turm.: 07-25-2009 at 12:46 AM.
in.meinem.turm. is offline   Reply With Quote
Old 07-25-2009, 05:27 AM   #4
Knives98
 
Join Date: May 2009
Reputation: 1
Posts: 38
I have the same problem. I use Windows 7 RC 64-bit and i read on the forums that the KQ Collection was working for other Windows 7 users (except for KQ 7), so I got it. But not a single one works.

I tried both the recommendations here and dling DOSBox from the dev does not help. I tried using scummvm and only KQ 2 and 3 seem to play on it, none of the others will.
Knives98 is offline   Reply With Quote
Old 07-25-2009, 06:11 AM   #5
aerundel
 
 
 
Join Date: Apr 2007
Reputation: 124
Posts: 2,248
Dual-boot XP. I'm totally serious.
aerundel is offline   Reply With Quote
Old 07-25-2009, 10:26 AM   #6
QDman
 
Guest
Posts: n/a
The version of DOSbox used by this compilation (the decidedly old 0.6.3) has problems running the collections with DEP (Data Execution Prevention) enabled in Windows. This is a major compatabillity issue with many different kinds of software, so consider disabling it (google it for instructions for your OS).

I suspect it's a DEP issue because this is the exact symptom when DEP is enabled - the DOSbox window briefly opens and immediately closes - I had this problem, disabling DEP fixed it.
  Reply With Quote
Old 07-25-2009, 12:10 PM   #7
inSPIREd
 
Guest
Posts: n/a
You might want to try downloading the latest version of DOSbox and manually mount the games yourself. Or, if you can't be bothered to try and learn the text commands for DOSbox (like me :P), download a GUI add-on like D.O.G. and do it there. It worked great for me on the retail version of the PQ collection, not sure about this one, though.
  Reply With Quote
Old 07-27-2009, 08:34 AM   #8
djwtech
 
Guest
Posts: n/a
Try installing the latest DirectX and .NET

DirectX
http://www.microsoft.com/downloads/d...displaylang=en
http://filehippo.com/download_directx/

.NET
http://www.microsoft.com/downloads/d...displaylang=en
http://filehippo.com/download_dotnet_framework_3/


ScummVM 0.13.1 only supports the AGI engine. However, the latest SVN includes support for the SCI engine (although very beta).

There are several options to get these 2006 Collections to work. SierraHelp.com DosBox Updates: fixes games with script patches, missing installers, etc...
ScummVM (AGI now, but SCI soon)

Last edited by djwtech: 07-27-2009 at 08:42 AM.
  Reply With Quote
Old 07-27-2009, 05:57 PM   #9
thrash242
 
Join Date: Feb 2008
Reputation: 14
Posts: 1,204
Works fine for me in Vista Home Premium 64.
thrash242 is offline   Reply With Quote
Old 12-25-2009, 09:34 AM   #10
GandalfTheWhite
 
Guest
Posts: n/a
Hi,

I could also not run a Single KQ on Win7 X64. But all you have to do for KQ1-6 (for me!!) was to change a line in the DosBox.conf File have a look http://forums.steampowered.com/forum....php?t=1084988

Greetings

Gandalf
  Reply With Quote
Old 02-02-2010, 10:48 PM   #11
Redboy
 
Join Date: Jul 2009
Reputation: 30
Posts: 1,574
Quote:
Originally Posted by aerundel View Post
Dual-boot XP. I'm totally serious.
Absoutly. Now way for me to rid XP.

Keep XP and install 7
Redboy is offline   Reply With Quote
Old 02-24-2010, 10:36 PM   #12
stoneysilence
 
 
 
Join Date: Mar 2008
Reputation: 4
Posts: 822
Same issue here. Tried Gandalfs suggestion and it didn't work. Maybe I can get it running on my Vista 32bit laptop with these suggestions.
stoneysilence is offline   Reply With Quote
Old 03-11-2010, 10:45 PM   #13
stoneysilence
 
 
 
Join Date: Mar 2008
Reputation: 4
Posts: 822
I found another fix for at least 1-6 that doesn't require any downloads or patches.

Disable the in game inlay from Steam. Steam->Settings->In-Game->Uncheck Enable Steam Community in game.
stoneysilence is offline   Reply With Quote
Old 07-17-2010, 06:21 PM   #14
MattNY
 
Join Date: Jul 2010
Reputation: 1
Posts: 41
I picked up this collection and just tested the first game, running Windows 7 64 bit. KQ1 opened and ran fine, but it had some color distortion, so I disabled explorer.exe like I do on other older games and it fixed the color problem. I only fooled around with the game for a few minutes, but I experienced so issues. I hope I have the same look with the rest of them.
MattNY is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > King's Quest Collection


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.