Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Turba

Reply
 
Thread Tools Display Modes
Old 08-05-2010, 03:18 PM   #1
stukatie
 
 
 
Join Date: Jun 2010
Reputation: 121
Posts: 525
Game crashing after song is finished

As the title says Turba has been crashing on me after completing a song. It's only happening on one song though it seems. "through the fire and flames" by Dragonforce. Every other song appears to be ok. It will be on the screen where it shows you the scoreboard for the song, no scores will appear, and after about 5 seconds or so the game will freeze and a windows box pops up with a "Turba has stopped responding" message.

Edit: I'm starting to think I broke your game. I now have a bug that at the start and finish of every song it shows me the high score for cowboys from hell by pantera (on descend casual) and at the end of the song it shows me the high score table for the same song.

Last edited by stukatie: 08-05-2010 at 05:41 PM.
stukatie is offline  
Reply With Quote
Old 08-05-2010, 10:21 PM   #2
delong
 
Binary Takeover
Join Date: Apr 2009
Reputation: 14
Posts: 132
Does restarting the game (or maybe even your computer) do anything? Is it doing this every time?
delong is offline   Reply With Quote
Old 08-06-2010, 07:56 AM   #3
alfie211
 
Join Date: Oct 2009
Reputation: 4
Posts: 81
Quote:
I now have a bug that at the start and finish of every song it shows me the high score for cowboys from hell by pantera (on descend casual) and at the end of the song it shows me the high score table for the same song.
I have the same problem. I played the song "Ignorance" by Paramore on Descend/Casual and scored 543,874.

I then played "Careful" also by Paramore (and from the same album) and even before the song started it said the current hi-score was by me at 543,874, which is what I just scored on the previous song.

I went ahead and played this song anyway (also on Descend/Casual) and scored 775,489.

The hi-score table afterwards showed the track as being the song "Careful", but the hi score table was still for the song "Ignorance", so in effect my score off 775K didn't even register.

I checked scores on last 10 songs page and both scores list properly on there (songs and scores correspond correctly), yet they dont show on the hi-score tables that way.

EDIT: ALL songs are saying that I have the hi-score with 543,874, also the hi-score table being shown after each song,is exactly the same each time ( the hi-score table for Ignorance shows for EVERY song I try and play , ANY song by ANY artist).

EDIT: Tried switching to Descend/Moderate speed and scores seem to be working O.K on that. Tried going back to casual again after playing moderate and I am getting the hi-score for EVERY song appear as 882,208 by a player called Katamichi, so still the same problem, now just showing a different username to before with a different score.

I have tried closing/restarting steam/turba, doesn't make any difference, problem still happens.

Something is definitely wrong with Casual speed in Descend mode.

Last edited by alfie211: 08-06-2010 at 10:08 AM.
alfie211 is offline   Reply With Quote
Old 08-06-2010, 10:24 AM   #4
delong
 
Binary Takeover
Join Date: Apr 2009
Reputation: 14
Posts: 132
So it only seems to be descend on casual? Hmmm. It does show up correctly in the last 10 played list every time though right? That has been the one thing related to scores that has actually always worked lol
delong is offline   Reply With Quote
Old 08-06-2010, 10:54 AM   #5
alfie211
 
Join Date: Oct 2009
Reputation: 4
Posts: 81
Yes the scores show properly in the last 10 played songs list, but thats where the good news stops.

Seems to be whoever most recently set a new score on ANY song on descend/casual mode, then becomes hi-score for EVERY song on descend/casual mode, with the score they achieved on that "ANY" song. If u see what I mean.

I.e when I checked last 10 songs played, Katamichi was most recent to play Descend/Casual mode, and his score WAS that 882.208 like I mentioned above.. I forget the artist of the song now, I remember it was a rock song.
alfie211 is offline   Reply With Quote
Old 08-06-2010, 11:12 AM   #6
Katamichi
 
Join Date: Aug 2010
Reputation: 0
Posts: 3
It happened for me too.
I played the song "No one knows" by Queens of the Stone Age,casual difficulty,descend mode and scored 882208pts.
After that all the high score was 882208pts except Turba original songs.
So I changed game mode to ascend,casual difficulty. then all the high score was 235620pts by a player called nanou.
I think it happens on every game mode and difficulties except Turba original songs.
Katamichi is offline   Reply With Quote
Old 08-06-2010, 12:16 PM   #7
delong
 
Binary Takeover
Join Date: Apr 2009
Reputation: 14
Posts: 132
Do songs you guys have already played previous to this behavior work properly? They appear to on my end.

When you play a new song now though, it appears it fails to make a new score table, because it thinks it already exists every time . Not sure what the cause of this is, but I'm looking into it.
delong is offline   Reply With Quote
Old 08-06-2010, 12:28 PM   #8
alfie211
 
Join Date: Oct 2009
Reputation: 4
Posts: 81
Quote:
Do songs you guys have already played previous to this behavior work properly?
I just tested this and yes songs I have previously played on Descend/Casual appear to work just fine with regards to the scoreboard.

Still seeing Katamichi 882,208.. on any song I haven't previously played tho.
alfie211 is offline   Reply With Quote
Old 08-06-2010, 02:40 PM   #9
delong
 
Binary Takeover
Join Date: Apr 2009
Reputation: 14
Posts: 132
Looking at things, this was probably most likely the result of multiple people playing new songs and pinging the server at the exact same time and our score table count somehow getting messed up.

We'll get some code in there to do some checks right when the game is about to make a new score table, and it should prevent this from happening. (the scores appear to be working again for the time being)

For now though, can you guys try out new songs that you haven't played before and tell me if they appear to be working again? Thanks!

Last edited by delong: 08-06-2010 at 02:42 PM.
delong is offline   Reply With Quote
Old 08-06-2010, 04:51 PM   #10
stukatie
 
 
 
Join Date: Jun 2010
Reputation: 121
Posts: 525
I just tried a song I hadn't played before and everything is fine again. I need to try through the fire and flames again though to see if my original problem still exists.
stukatie is offline   Reply With Quote
Old 08-06-2010, 05:02 PM   #11
alfie211
 
Join Date: Oct 2009
Reputation: 4
Posts: 81
I have tried a couple of songs I haven't played before and it does seem fine now..
alfie211 is offline   Reply With Quote
Old 08-06-2010, 05:30 PM   #12
stukatie
 
 
 
Join Date: Jun 2010
Reputation: 121
Posts: 525
TTFAF is working too now. Thanks Delong all seems well again in the world of turba.
stukatie is offline   Reply With Quote
Old 08-07-2010, 01:53 AM   #13
Katamichi
 
Join Date: Aug 2010
Reputation: 0
Posts: 3
I tried several songs I hadn't played before and everything works fine! Thanks delong
Katamichi is offline   Reply With Quote
Old 12-11-2010, 02:15 AM   #14
mykkis
 
Guest
Posts: n/a
I have also problem with this crashing. But I have realized one thing. Crashing is so random in this game. Sometimes game crashes when I downloading song, sometimes it quit my game middle of song and some other time, when I just finnished song. Also it so random how many song I can play and then game crashes. Sometimes I can play only one song and that's it, but some other time I can play max. 10 songs and then game says bye, bye...

I know that in my case, is not problem hi-score table overloading, because I play lots of artist(s) songs what is not so popular. Every song is mp3, so that can't be a problem. Casual is form what I have always played. And yeah, I have tried properties options too, but it didn't helped.

I like this game a lot, because it's so good killing time kind of game and at the same time listen my favourite songs, but it's too bad that I can't play it very long, because this crashing problem.

Last edited by mykkis: 12-11-2010 at 02:18 AM.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Turba


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.