Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dead Space series

Reply
 
Thread Tools Display Modes
Old 02-03-2011, 09:13 PM   #1
hero_kenshin
 
Join Date: May 2009
Reputation: 5
Posts: 79
Dead space 2 Mouse problem

Okay, just bought dead space 2... and on first starting it up as soon as i get past the first menu (requiring you to push any key)
the main menu pops up and just as it does the screen shoots off to the top right.
When i move my mouse down to put the menu it view it will scroll down to the menu then shoot of view again...
I thought this bug was only in the menu but when i started a new game, it only lets me look up...

I have NEVER had any problems with my mouse in any game or with anything really.

I read somewhere that you can try disconnecting usb's so i took out everything but my KB+M and still nothing.

I have a G15 keyboard and a logitech MX518 mouse.

Any ideas?
hero_kenshin is offline  
Reply With Quote
Old 02-04-2011, 01:38 AM   #2
RA_Fox
 
Join Date: Feb 2010
Reputation: 29
Posts: 497
I have Logitech keyboard and MX518 and I don't have any problems like that.
Look deeper into it. Maybe, gamepad or any virtual gamepad devices?
RA_Fox is offline   Reply With Quote
Old 02-10-2011, 02:46 PM   #3
Finnerup
 
Guest
Posts: n/a
I have same issue.

Keeps turning the viewpoint away from the menu, unless I pull the mouse around all the time. Kinda hard to explain.

I haven't found a solution yet either, but at this point it's unplayable.

I have Logitech G15 keyboard and Logitech G9 mouse.
  Reply With Quote
Old 02-10-2011, 11:59 PM   #4
arizonachris
 
Join Date: Aug 2009
Reputation: 856
Posts: 7,506
Are you using any Logitech drivers? I have a G500 mouse and a non-Logitech (Wolf King) keyboard and I don't have any issues.

There was another game (FEAR, maybe?) that had a Logitech issue, and the fix was to disable all HID devices in Device Manager before you play, then re-enable them after you're done playing.
arizonachris is offline   Reply With Quote
Old 02-11-2011, 02:22 AM   #5
Ravenger
 
Join Date: Jan 2009
Reputation: 12
Posts: 255
Any controllers connected? If so disconnect them.

Also the Logitech keyboard may be seen by the game as a game controller because of its multimedia controls - my Saitek Eclipse II keyboard suffers from the same problem on other games, so you may have to go into the control panel device manager and disable some of the HID entries for your keyboard.
Ravenger is offline   Reply With Quote
Old 02-12-2011, 12:27 AM   #6
nabokov forum
 
Guest
Posts: n/a
my resolution

I had same problem.
I also use logitech mouse G500 and gaming board G13.
When I exit logitech software setpoint, setpoint2 and key profiler, main menu came to center of the monitor!
try this.
  Reply With Quote
Old 03-22-2011, 04:15 PM   #7
fadingfast
 
Guest
Posts: n/a
I had this problem with the original Dead Space as well. The fix described here still works:

http://forums.electronicarts.co.uk/d...r-problem.html

Except that the file in question now lives in (at least in win7):

C:\Program Files (x86)\Steam\steamapps\common\dead space 2

When you start the game it will complain that the file isn't valid, but the result is the same, the view will stop pulling up, and you can continue to use your G13!
  Reply With Quote
Old 05-09-2011, 05:17 AM   #8
runemagic7
 
Join Date: May 2011
Reputation: 0
Posts: 2
I was also experiencing this issue. While researching, I had found some people pointing to a "joypad" issue. But, I wasn't using a controller. However, I did have a Thrustmaster wireless USB connector plugged in.

I quit the game, unplugged the USB connection for the controller, restarted the game and it worked fine.

I haven't gone much further, but I do believe it's because of the settings I have on the Thrustmaster (mapped keys).

Hope this helps.
runemagic7 is offline   Reply With Quote
Old 01-11-2012, 06:28 PM   #9
wookiee21206
 
Join Date: Jan 2012
Reputation: 0
Posts: 1
Smile Many thanks

Thanks to whoever came up with simplistically brilliant idea to unplug game controllers. My flight stick was causing the "camera looks up problem".
wookiee21206 is offline   Reply With Quote
Old 01-12-2012, 12:22 PM   #10
Dorkfire83
 
Banned
Join Date: Oct 2010
Reputation: 48
Posts: 182
I disabled the virtual mouse on the G13 and that fixed the spinning for me. now if only I could actually aim...
Dorkfire83 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dead Space series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.