Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Avadon: The Black Fortress

Reply
 
Thread Tools Display Modes
Old 08-23-2011, 05:24 AM   #1
FalseProphet
 
Guest
Posts: n/a
Troubles at the main screen

I'm having a problem where the game will freeze from 1 to 3 seconds then allow me to move my cursor then freeze again repeatdly. i can start a new game but this seems to be happening even at the character screen, the game is unplayable as it is please help if u had this problem thank you.
 
Reply With Quote
Old 08-23-2011, 07:56 AM   #2
kawacatoose
 
Join Date: Feb 2010
Reputation: 0
Posts: 19
Maybe this wil help:
http://www.spiderwebsoftware.com/ava...html#WinIssues

or make contact with Spiderweb at support@spiderwebsoftware.com

Last edited by kawacatoose: 08-23-2011 at 07:58 AM.
kawacatoose is offline   Reply With Quote
Old 08-23-2011, 01:13 PM   #3
FalseProphet
 
Guest
Posts: n/a
Thx it didnt help most of the problems seem to be wth older comps mine is brand new. it should be able to run 10 of this at once no prob
  Reply With Quote
Old 08-23-2011, 01:45 PM   #4
Madd the Sane
 
Join Date: Apr 2010
Reputation: 12
Posts: 502
Make sure you have up-to-date drivers for your graphics card.
Madd the Sane is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Avadon: The Black Fortress


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.