Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Altitude

Reply
 
Thread Tools Display Modes
Old 06-20-2010, 11:27 AM   #1
isolated1
 
 
 
Join Date: Feb 2007
Reputation: 31
Posts: 334
Version of Java in Altitude is old and insecure

I just ran a scan with Secunia PSI, and it says the version of Java in Steam/steamapps/common/altitude is old and is a security threat. Is there a way to make it use the latest version that is installed in C:\Java?
isolated1 is offline  
Reply With Quote
Old 06-20-2010, 04:59 PM   #2
lamster
 
Nimbly Games
Join Date: Nov 2009
Reputation: 107
Posts: 335
The security threat they are detecting is related to browser/plugin functionality that can never be accessed. The included Java is used strictly to launch Altitude (which will never invoke any browser functionality) and is never registered with the system in a way that would allow it to be used elsewhere (like browsers). We will update the bundled Java in the future to get rid of annoying anti-virus warnings, but we've held off to minimize unnecessary downloads for purchasers.
lamster is offline   Reply With Quote
Old 12-15-2011, 04:02 AM   #3
Negh_var
 
Join Date: Dec 2011
Reputation: 0
Posts: 1
Is there any update on this? The last comment was made in June of 2010 and it's still showing as insecure several versions later. Can this please be updated?
Negh_var is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Altitude


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.