Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > RISK: Factions

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-27-2011, 03:05 PM   #1
mikej8
 
Join Date: Apr 2011
Reputation: 0
Posts: 13
Angry Wierd issue, please help!

Here is a link to the youtube video of my issue:
http://www.youtube.com/watch?v=LBvUg...ature=youtu.be
Here are my specs:
OS:Vista home basic
BRAND:Toshiba: satelite L305
CPU:Intel(R) Celeron(R) CPU 900 @ 2.20GHz,~2.2GHz
MEMORY: 1916MB RAM
DIRECTX VERSION: DirectX 11
BIOS: InsydeH2O Version 1.80
VIDEO CARD: Mobile Intel (R) 4 series Express Chipset Family
VIDEO MEM: 830 MB
VIDEO DRIVER VERSON: 7.15.0010.1502
DISPAY MODE: 1280x800 (32 bit) (60Hz)
I checked the game cache, and ran steam in admin mode.
To show that I CAN run games, here are my games:
Terraria
Minecraft
Hacker Evolution: Untold
Portal
Defcon
Voxatron
Blocks That Matter
These games run on my computer, this proves that i can run steam games. I have scaned my computer for viruses recently and will do so again after i post this.
mikej8 is offline  
Reply With Quote
 

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > RISK: Factions


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.