Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Theatre of War series

Reply
 
Thread Tools Display Modes
Old 01-18-2011, 10:32 AM   #1
Kasumi_Ninja
 
Guest
Posts: n/a
Low fps rate of 10 FPS

I've bought this game during the sale but I haven been able to play it because of the low fps problem. I've contacted both help desks (battlefront and 1c company) and they didn't have a solution

I have a decent pc capable of playing recent games with all settings maxed out on 1920x1080. But for some reason tow (1 and 2) doesn't get above 10-20 fps. I've tried all possible solutions (lasso, set affinity etc) and it still just doesn't work. My specs:

Code:
Processor: AMD Athlon(tm) II X4 630 Processor (4 CPUs), ~2.8GHz
Memory: 8192MB RAM
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600)
Card name: ATI Radeon HD 4800 Series
Are there other gamers that have solved the low fps problem?
 
Reply With Quote
Old 01-19-2011, 09:33 PM   #2
kaleckton
 
Guest
Posts: n/a
Quote:
Originally Posted by Kasumi_Ninja View Post
I've bought this game during the sale but I haven been able to play it because of the low fps problem. I've contacted both help desks (battlefront and 1c company) and they didn't have a solution

I have a decent pc capable of playing recent games with all settings maxed out on 1920x1080. But for some reason tow (1 and 2) doesn't get above 10-20 fps. I've tried all possible solutions (lasso, set affinity etc) and it still just doesn't work. My specs:

Code:
Processor: AMD Athlon(tm) II X4 630 Processor (4 CPUs), ~2.8GHz
Memory: 8192MB RAM
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600)
Card name: ATI Radeon HD 4800 Series
Are there other gamers that have solved the low fps problem?
Best advice i can think of off the bat is slowly turn down one or two of the settings in the TOW config utility. My system is intel myself quad core clocked at 2.5 each and the same amount of ram DDR2 with a gt 220 video card, with a FPS of 58. Almost can play with full settings, but i turned off shadows, lowered grass detail and turned off the use only one cpu in the settings. Also medium tree detail, and removed high landscape detail.
  Reply With Quote
Old 01-20-2011, 08:38 AM   #3
Kasumi_Ninja
 
Guest
Posts: n/a
Thanks for the suggestion. I've tried all settings from high to low. Fps remained the same though
  Reply With Quote
Old 01-30-2011, 03:58 PM   #4
PandaTickler
 
Join Date: Oct 2010
Reputation: 4
Posts: 68
In my expereince trying to get this thing to work, changing the graphics settings makes little to no difference at all, as it is a CPU bottleneck that causes the problem. I can have the game maxed out or with the settings on the lowest possible and the lag issue is still the same.

My gut feeling is that it is a 64bit OS issue, and a game not designed to run on recent hardware.
PandaTickler is offline   Reply With Quote
Old 02-05-2011, 11:58 PM   #5
mav61
 
Guest
Posts: n/a
Unhappy lag

Yep its the same ol same ol needs a patch...to tell you the truth i'm surprised they havn't released one yet, its been a issue for a lot of people...all i can say is memory memory the more you have the better it'll run...it wont run perfect well not until they release a update any how but at least you'll be able to play it...just remember if you have vista thats a resource hogger and you need to get more ram... windows 7 is good and XP is reasonable..or u might have to enlarge your virtual memory through [control panel-system-advanced settings]...enjoy

Last edited by mav61: 02-06-2011 at 12:03 AM.
  Reply With Quote
Old 02-11-2011, 03:29 AM   #6
bmickey
 
 
 
Join Date: Sep 2008
Reputation: 0
Posts: 50
I'm using a fairly decent laptop myself and knew that considering processor and graphics hardware I have every reason to expect these gmesrunning smoothly on my machine. Well, it turned out otherwise, so I've tried to lower graphics and such, but the performance improvement was marginal. So, I just unchecked the EAX support in the options menu, and lo and behold, the game began to run like it should be with decent framerates on the highest graphical level. I don't know if it would help you but I'd give this "solution" a try, maybe it can help you run the game properly.
I was also considering to abandon this game as well, but I'm glad I didn't because it's the best rts since the close combat series.
bmickey is offline   Reply With Quote
Old 02-11-2011, 12:02 PM   #7
Kasumi_Ninja
 
Guest
Posts: n/a
Quote:
Originally Posted by bmickey View Post
So, I just unchecked the EAX support in the options menu, and lo and behold, the game began to run like it should be with decent framerates on the highest graphical level. I don't know if it would help you but I'd give this "solution" a try, maybe it can help you run the game properly.
Thanks for the suggestion, unfortunately unchecking EAX support doesn't improve my frame-rate
  Reply With Quote
Old 03-01-2011, 02:47 PM   #8
kane1
 
Join Date: Jul 2009
Reputation: 8
Posts: 166
I started playing THEATRE OF WAR 2: AFRICA over a year ago. I would get some lag but not enough where the game wasn't fun. A couple months ago I started looking into getting THEATRE OF WAR 2: Kursk. I never planned on getting it because I didn't want to be disappointed in gameplay because of all the comments I've read about the lag and low fps. I thought I would have to upgrade my rig first. Well I got it anyway and was VERY happy to discover that even with the beautiful landscapes and more intense battles it almost plays better or at least the same. So my question is how bad is the lag getting so that the game is no longer fun for you?

Example #1,
http://www.youtube.com/watch?v=SYd-qCHG8mc
Example #2
http://www.youtube.com/watch?v=NnwQAjQTTqg

Try and look past the vids, their just examples.

Last edited by kane1: 03-02-2011 at 09:28 PM.
kane1 is offline   Reply With Quote
Old 03-16-2011, 06:02 PM   #9
Hokum
 
Join Date: Mar 2010
Reputation: 28
Posts: 213
Quote:
Originally Posted by PandaTickler View Post
My gut feeling is that it is a 64bit OS issue, and a game not designed to run on recent hardware.
No both TOW 1 and 2 run just as terribly on my Win XP 32 bit. I think they ran better on my old graphics card (9800GTX) than they do on my new one (GTX460). So it could still be a hardware/driver issue.

Last edited by Hokum: 03-16-2011 at 06:06 PM.
Hokum is offline   Reply With Quote
Old 02-16-2012, 11:12 PM   #10
Malakie
 
Join Date: Dec 2011
Reputation: 0
Posts: 62
Well 2012 now, I just bought the Theatre of War series without knowing about the FPS issue and now I am finding out about this being a known problem and being as bad as it is.. talk about being jarateed off right now.....

And before anyone says anything, it is NOT graphic settings and yes I tried them all. BUT the system I am running should have not a stutter in FPS and it runs everything else smooth at full settings.

Intel I7 4/8, 9 gig mem, Creative X-Fi Titanium Fatality Pro, Nvidia GTX590ti Video

Hopefully someone else that is thinking about this series sees my message before buying at this point because the game series is unplayable as it is.
Malakie is offline   Reply With Quote
Old 02-17-2012, 02:35 AM   #11
Sneaksie
 
Join Date: Sep 2010
Reputation: 13
Posts: 227
When you pause the game, does FPS skyrocket or is it still too low?
I would try the following

1) turn the option use only one cpu on (in options.exe)
2) set affinity to 1 core in task manager as well
3) set Max prerendered frames in nVidia control panel to 0 (its 3 by default)
4) disable EAX in options.exe
5) If this doesn't help (i think it should) turn sound off completely in options.exe to find out is it sound-related or not

Did you try ToW2 or ToW3? Do you have this problem only in ToW1?
Sneaksie is offline   Reply With Quote
Old 02-17-2012, 08:14 PM   #12
sandman2575
 
Join Date: Jul 2010
Reputation: 0
Posts: 10
Malakie -- I have exactly the problems you have with very low FPS and stutter. My setup's no where near as powerful as yours, but I know I have enough CPU/GPU/RAM power that should allow me to play ToW2 fluidly at medium-high settings.

I find the problem is definitely the worst on 'town-heavy' maps, in both Africa and Kursk. Cherkasskoe in "Kursk" runs like an absolute dog for me once my units start penetrating the 'residential' part of the map. Ditto in Africa on the first German-campaign mission -- runs reasonably well until the action gets into the village in the center of the map, then we're looking at 5-8 FPS. No matter gfx settings. When I pause, FPS shoots up to about 30-35 -- not great, but the game would be very playable if it would just stay even in this area.

Sneaksie -- I appreciate your help in the Battlefront forum. I have some questions that may be able to help Malakie and me if we can hash it out --

Quote:
Originally Posted by Sneaksie View Post

1) turn the option use only one cpu on (in options.exe)
2) set affinity to 1 core in task manager as well
This makes no difference for me in original ToW, which runs pretty consistently in the 30-35 FPS no matter what I do (this is fine performance by my standards). When I try to set affinity to one core via task manager in ToW2, the game actually performs worse. Sound effects become completely garbled and static-y in addition to terrible FPS.

Quote:
Originally Posted by Sneaksie View Post

3) set Max prerendered frames in nVidia control panel to 0 (its 3 by default)
Have definitely tried this -- but I get the sense that the ToW2 nVidia profile I've created has *no* effect on gameplay. I've tried pretty much every conceivable configuration in my profile to try to squeeze extra Frames. Disabling multithreading does nothing. Ditto Texture Filtering to 'high performance'. Forcing different SLI rendering modes also does nothing. Etc. etc. Does the nVidia profile for ToW2 actually override anything?? It really seems that it does not.


Quote:
Originally Posted by Sneaksie View Post

4) disable EAX in options.exe
Have tried, although I'm confused as to why this is recommended -- isn't *enabling* EAX supposed to *reduce* CPU load? (Manual page 12) - ?


Quote:
Originally Posted by Sneaksie View Post

5) If this doesn't help (i think it should) turn sound off completely in options.exe to find out is it sound-related or not
have tried -- does nothing unfortunately.
sandman2575 is offline   Reply With Quote
Old 02-18-2012, 11:32 AM   #13
Sneaksie
 
Join Date: Sep 2010
Reputation: 13
Posts: 227
I guess you and Malakie have different problems - he got abnormally low FPS in ToW1 while it runs well for you.

ToW2 and ToW1 engines differ in many parts, for example render in ToW2 is D3D instead of OpenGL. ToW2 take advantage of 2 cores, while ToW1 does not if i remeber right.

Your case of low FPS in town is more understandable since your FPS goes normal when paused, i think it's caused by pathfinding routine - many obstacles and dead ends in a small area with many units finding their way continiuosly (and tracing visibility to each other through all these obstacles). If your FPS is much higher when paused, this means your video card is sufficient and CPU is not. Well, it should be in fact sufficient, but for some reason it doesn't go to 100% load and you receive inadequate FPS. Back in the days of P4 the only solution was to switch to 0.5 game speed until CPU load lessen because of unit casualties, but i had hoped that new ones will handle the game with ease. Actually, Kursk plays very well on 3Ghz C2D, but unfortunately newer CPUs seem to have some incompatibility with the game.

I'm not an expert in CPU architecture differences, but its likely caused by a way how a CPU and OS distribute the load between cores since ToW2 engine does not do any fancy stuff by itself to my knowledge (if it finds a second core, it uses it for a number of tasks like pathfinding, without second core it just calculates everything on one core). Maybe the problem lies in synchronization between cores. I would try to turn off Hyperthreading in BIOS (i doubt many programs can use 8 cores anyway, 4 cores without additional virtual ones should be sufficient for any task today), then go to ToW2 properties in Steam library and type

\AFFINITY 0X3

into game launch options (it makes only 2 cores available for the game).

Also, the fact that your nVidia settings change nothing may be caused by a way the game functions. Executable that nVidia driver applies its settings to is just a launcher, the game itself is called Kursk1943.bin (or something else *.bin) in task manager. In addition, the game consists of Java main executable and C++ core.dll render so nVidia may be applying its settings to a wrong process. Try to change its settings globally instead of creating a profile and see if it helps. But the problem is in CPU utilization anyway, i think your video card performs as it should.

Did you try that Process Lasso software suggested by gooana, maybe it makes utilizing your CPU more effective?

Last edited by Sneaksie: 02-18-2012 at 11:40 AM.
Sneaksie is offline   Reply With Quote
Old 03-12-2012, 04:19 PM   #14
gooana
 
Join Date: Jul 2010
Reputation: 12
Posts: 114
For my 10c - I'm adding my findings on the FPS/CPU/GPU issues from my other post

Some of this goes against logic - enabling Vsync & AO actually improves FPs on my 400 series?!?! But it is working for me.
gooana is offline   Reply With Quote
Old 07-17-2012, 12:49 PM   #15
jan610
 
Join Date: Oct 2009
Reputation: 0
Posts: 46
I also have fps problems and I notice they dissapear when I turn off the sound.
But tbh I want to play with sound on, is there any way I can fix this?
I have the latest drivers and have no problems playing any other game.
jan610 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Theatre of War series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.