Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V > Steam Workshop for Skyrim

Reply
 
Thread Tools Display Modes
Old 02-19-2012, 02:22 AM   #16
Breton Warrior
 
 
 
Join Date: Apr 2011
Reputation: 280
Posts: 2,382
Quote:
Originally Posted by darkgriffin1986 View Post
I think it's mostly for legal reasons. They would be in major trouble legally if their game natively read third party code. Nothing is stopping anyone from building a virused exe and passing it off as a "mod loader" or "extender". (I'm not saying the current skyrim script extender is one, I'm just saying their layers would strongly advise against it.)

The mods themselves are limited to what the game exe itself can do, in other words, Beth can be safe knowing that no one can make a mod file that does anything besides corrupt skyrim's world data or saved data. Once you toss a code injector into the mix, things get pretty hairy from a legal standpoint. In a lot of places, they would be responsible for willingly coding such a security flaw into their game if it supported it out of the box.

The reason they are ok with us using the extender in the first place is because it so far hasn't done anything bad. They may support what we do inside their own offices, but if asked to make a legal statement about it, they have to stay silent and pretend they don't see the script extenders.
Ta for that, yea makes sense and very well written. BW
Breton Warrior is offline   Reply With Quote
Old 02-29-2012, 09:18 AM   #17
meior
 
 
 
Join Date: May 2010
Reputation: 6
Posts: 40
Would somebody be willing to upload one of the modded .exe's, just like the old one, but for the new Skyrim patch and SKSE? I just don't trust myself with that. :/ And I bet some of you have already done it.

Edit: With the new SKSE installed, and the newest patch, it still says my game version isnt supported. Is this an error on the SKSE-teams end?

Last edited by meior: 02-29-2012 at 09:20 AM.
meior is offline   Reply With Quote
Old 02-29-2012, 01:04 PM   #18
Siegfried22
 
Join Date: Dec 2011
Reputation: 0
Posts: 1
Quote:
Originally Posted by meior View Post
Would somebody be willing to upload one of the modded .exe's, just like the old one, but for the new Skyrim patch and SKSE? I just don't trust myself with that. :/ And I bet some of you have already done it.

Edit: With the new SKSE installed, and the newest patch, it still says my game version isnt supported. Is this an error on the SKSE-teams end?

Here it is:
https://feupload.fe.up.pt/get/Lwd5QRzaLfX8mVP

I was having some problems when I changed to TESV_.exe in the file so I kept the same number of elements in the string. So, just change TESV.exe to ESV2.exe in the Skyrim directory.
Siegfried22 is offline   Reply With Quote
Old 03-01-2012, 12:38 PM   #19
meior
 
 
 
Join Date: May 2010
Reputation: 6
Posts: 40
Thank you so much!
meior is offline   Reply With Quote
Old 03-20-2012, 06:23 PM   #20
jedediahpelland
 
Join Date: Nov 2010
Reputation: 20
Posts: 363
Hi, is there a new modified skse exe file yet for skse 1_04_14 (skyrim 1.5)? If so could someone please post a download link.

Last edited by jedediahpelland: 03-20-2012 at 06:33 PM.
jedediahpelland is offline   Reply With Quote
Old 03-22-2012, 12:32 PM   #21
Zaro27
 
Join Date: Sep 2008
Reputation: 21
Posts: 731
I, too, would like a modified .EXE file. Perhaps someone should make a sourceforge page for this.
Zaro27 is offline   Reply With Quote
Old 03-23-2012, 08:35 AM   #22
Trustingsoup
 
Join Date: Dec 2008
Reputation: 3
Posts: 25
Talking How to mod skse_loader.exe

This is how to launch SKSE with the default launcher.
  1. Just get a hex editor (XVI32 http://www.chmaas.handshake.de/delphi/freeware/xvi32/xvi32.htm#download is freeware one) and open skse_loader.exe with it.
  2. Search for TESV.exe and change it to ESV2.exe
  3. (Make sure you're not "inserting" any bytes, just overwrite empty(00) areas or skse may break)
  4. After that rename skse_loader.exe to TESV.exe
  5. Rename the original TESV.exe to ESV2.exe
  6. Copy Modded SKSE loader and other SKSE files into your Skyrim Data Directory.
This works with latest SKSE loader. Thanks kdh7807 & Siegfried22 !

Last edited by Trustingsoup: 03-23-2012 at 09:35 AM.
Trustingsoup is offline   Reply With Quote
Old 03-26-2012, 01:53 PM   #23
jedediahpelland
 
Join Date: Nov 2010
Reputation: 20
Posts: 363
Quote:
Originally Posted by Trustingsoup View Post
This is how to launch SKSE with the default launcher.
  1. Just get a hex editor (XVI32 http://www.chmaas.handshake.de/delphi/freeware/xvi32/xvi32.htm#download is freeware one) and open skse_loader.exe with it.
  2. Search for TESV.exe and change it to ESV2.exe
  3. (Make sure you're not "inserting" any bytes, just overwrite empty(00) areas or skse may break)
  4. After that rename skse_loader.exe to TESV.exe
  5. Rename the original TESV.exe to ESV2.exe
  6. Copy Modded SKSE loader and other SKSE files into your Skyrim Data Directory.
This works with latest SKSE loader. Thanks kdh7807 & Siegfried22 !
Awesome!! Worked great, thanx for the info! For those who have never used a hex editor, open the hex editor program, then at the top click file, open, search for the skse loader and open it. Then at top click the search button and type in TESV.exe, make sure the search is set to text string. It should take you to it and highlight it. Now Put you curser in front of the first letter which would be T like so |TESV.exe and type ESV2 and it will just type over the TESV close and save hex and follow the rest of the instructions in the post above. NOTE: DO NOT put your curser after the TESV.exe in hex editor and try to use backspace to delete it, it doesnt work that way. Another good hex editor to use is HxD I found this the easiest one to use.

Last edited by jedediahpelland: 03-26-2012 at 01:56 PM.
jedediahpelland is offline   Reply With Quote
Old 07-31-2012, 03:46 AM   #24
MaxSharp
 
Join Date: Feb 2012
Reputation: 0
Posts: 1
SKSE

Quick question...I have the current SKSE build successfully installed for Skyrim version 1.6.89.0. Since the 1.7 patch came out this obviously does not work anymore...Therefore I downloaded the beta build (http://skse.silverlock.org/beta/skse_1_05_10.7) that is supposedly compatible with Skyrim 1.7.7.0.

This Beta build is only One .dll plugin file (Plugin.The Elder Scrolls V Skyrim.dll). Where the heck do I put this file? Under the main Skyrim folder? Or possibly under the SKSE Plugin folder? I've tried both and it says my version of Skyrim is newer than my SKSE build...What the dilly?

~MaxSharp
MaxSharp is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V > Steam Workshop for Skyrim


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.