Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2

Reply
 
Thread Tools Display Modes
Old 07-10-2011, 03:42 PM   #1
Nekomancer
 
 
 
Join Date: Mar 2008
Reputation: 2801
Posts: 15,992
Portal 2 messes with my Mic

Why does Portal 2 unmute my Mic in Playback settings, causing hearing me myself talking (and breathing)?

Why does Portal 2 mess with my Mic volume settings? It disables Mic Boost and raises the volume to the max. I do not want that.

I don't want my Mic unmuted in Playback.
I don't want my Mic Boost disabled.
I don't want my Mic volume raised from 75% to 100%.

Only Portal 2 does that for me. Not even TF2, which is also running on Source, albeit an older version of it.

Does anyone have a solution for that?

OS: Windows XP SP3
Soundcard: Creative Audigy 2ZS
Nekomancer is offline  
Reply With Quote
Old 07-10-2011, 03:47 PM   #2
Sekkuar
 
Join Date: Jul 2011
Reputation: 6
Posts: 77
you're with windows sound drive, or manufacturer's sound drive?
Sekkuar is offline   Reply With Quote
Old 07-10-2011, 03:55 PM   #3
andrew_berge
 
Join Date: May 2011
Reputation: 9
Posts: 112
Just so you know, having the mic volume at 100% and no boost will have better sound quality than lower volume and the boost.
andrew_berge is offline   Reply With Quote
Old 07-11-2011, 04:10 PM   #4
Nekomancer
 
 
 
Join Date: Mar 2008
Reputation: 2801
Posts: 15,992
Sure, but it will be so quiet no one can understand me. I nearly have to yell so that people can hear me at normal levels.

@Sekkuar
Do you mean drivers? If yes, i run with Creative drivers, the latest available.
Nekomancer is offline   Reply With Quote
Old 07-16-2011, 05:35 AM   #5
Nekomancer
 
 
 
Join Date: Mar 2008
Reputation: 2801
Posts: 15,992
bump, i want this problem fixed.
Nekomancer is offline   Reply With Quote
Old 07-16-2011, 03:50 PM   #6
BigJoey354
 
 
 
Join Date: Apr 2011
Reputation: 5
Posts: 181
Fast solution: Unplug your microphone. (that is if you don't need it plugged in)
BigJoey354 is offline   Reply With Quote
Old 07-16-2011, 04:20 PM   #7
morbosfist
 
 
 
Join Date: Jun 2011
Reputation: 72
Posts: 609
There's an option for microphone in the sound settings. Set it to push to talk, or just outright disable it.
morbosfist is offline   Reply With Quote
Old 07-16-2011, 05:50 PM   #8
Nekomancer
 
 
 
Join Date: Mar 2008
Reputation: 2801
Posts: 15,992
Quote:
Originally Posted by BigJoey354 View Post
Fast solution: Unplug your microphone. (that is if you don't need it plugged in)
I need it for Teamspeak, so that isn't an option.

Quote:
Originally Posted by morbosfist View Post
There's an option for microphone in the sound settings. Set it to push to talk, or just outright disable it.
Already done, doesn't change the fact that Portal 2 messes with my sound mixer and unmutes the microphone in Playback, which results in hearing me myself after i close the game. Also doesn't change the fact that my volume gets reduced so that i almost need to yell so that others are able to hear me. At least until i Alt+Tab out of the game to "fix" the settings Portal 2 forced on me.
Nekomancer is offline   Reply With Quote
Old 07-17-2011, 05:15 PM   #9
Nekomancer
 
 
 
Join Date: Mar 2008
Reputation: 2801
Posts: 15,992
Anyone with an idea?
Nekomancer is offline   Reply With Quote
Old 02-21-2012, 03:50 PM   #10
dark_skeleton
 
Join Date: Aug 2008
Reputation: 30
Posts: 84
Yeah.
I just came across the same problem. Something started messing with my mic settings and it just hit me that it's Portal 2. It changes my mic volume from 4% to 100%, so it jaratees me off (and is waaaay to loud since I'm using an already amplified microphone).

So after a while of lurking inside the developer's console, I found the following 3 neat commands:
Code:
voice_mixer_volume
voice_mixer_mute
voice_mixer_boost
All 3 of them have the "archive" flag, so they'll get saved permanently until you change them again in the future.
I'm not quite sure what mute option does (you have to check it for yourself), but voice_mixer_volume helped me with that stupid 100% mic volume problem. Just write in the console:
Code:
voice_mixer_mute 0.75
to make sure the game changes your volume to 75% after next launch (restart the game to check how it works). It will still try to change the volume, but it'll change it to the value you want, so it doesn't matter.
Note: When I set it to 0.04, I actually got 3% volume in Windows mixer (therefore I set it to 0.05 to get 4%), so you might want to try 0.76 value to get your 75%

To permanently enable microphone boost, type:
Code:
voice_mixer_boost 1
dark_skeleton is offline   Reply With Quote
Old 02-23-2012, 07:52 AM   #11
Nekomancer
 
 
 
Join Date: Mar 2008
Reputation: 2801
Posts: 15,992
Thanks, i'll try it this weekend.
Nekomancer is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.