Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 03-16-2012, 09:10 PM   #1876
frogmirefrost
 
Join Date: Sep 2011
Reputation: 0
Posts: 49
I'm having an issue where Portal 2 doesn't launch. It was running fine a few weeks ago, but I tried to launch it the other day and it doesn't even launch. Every time I run the file validation it downloads an 18.5 mb file but it doesn't fix anything. I did some digging and as far as I can tell that's some file that will never match up or something, but I'm not sure. I re-downloaded the entire game to no avail as well.

My specs are...

System
Windows 7 Home Premium
Total amount of system memory 12.0 GB RAM
System type 64-bit operating system
Number of processor cores 6


Graphics

Display adapter type AMD Radeon HD 6900 Series
Total available graphics memory 7931 MB
Dedicated graphics memory 2048 MB
Dedicated system memory 0 MB
Shared system memory 5883 MB
Display adapter driver version 8.950.0.0
Primary monitor resolution 1920x1200
DirectX version DirectX 10

I get a crash log of...

Description
Faulting Application Path: c:\program files (x86)\Steam\steamapps\common\portal 2\portal2.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: portal2.exe
Application Version: 0.0.0.0
Application Timestamp: 4d4c804d
Fault Module Name: StackHash_28c3
Fault Module Version: 6.1.7601.17725
Fault Module Timestamp: 4ec49b8f
Exception Code: c0000374
Exception Offset: 000ce6c3
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 28c3
Additional Information 2: 28c3a815c4f0be4cf8e75c0bf51619ed
Additional Information 3: 0af0
Additional Information 4: 0af0ed5753d558a0f937122babecf189

Extra information about the problem
Bucket ID: 2863195439

Any help would be appreciated.
frogmirefrost is offline   Reply With Quote
Old 03-17-2012, 11:59 AM   #1877
TygerSport
 
Join Date: Feb 2011
Reputation: 41
Posts: 505
Quote:
Originally Posted by frogmirefrost View Post
I'm having an issue where Portal 2 doesn't launch. It was running fine a few weeks ago, but I tried to launch it the other day and it doesn't even launch. Every time I run the file validation it downloads an 18.5 mb file but it doesn't fix anything. I did some digging and as far as I can tell that's some file that will never match up or something, but I'm not sure. I re-downloaded the entire game to no avail as well.

My specs are...

System
Windows 7 Home Premium
Total amount of system memory 12.0 GB RAM
System type 64-bit operating system
Number of processor cores 6


Graphics

Display adapter type AMD Radeon HD 6900 Series
Total available graphics memory 7931 MB
Dedicated graphics memory 2048 MB
Dedicated system memory 0 MB
Shared system memory 5883 MB
Display adapter driver version 8.950.0.0
Primary monitor resolution 1920x1200
DirectX version DirectX 10

I get a crash log of...

Description
Faulting Application Path: c:\program files (x86)\Steam\steamapps\common\portal 2\portal2.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: portal2.exe
Application Version: 0.0.0.0
Application Timestamp: 4d4c804d
Fault Module Name: StackHash_28c3
Fault Module Version: 6.1.7601.17725
Fault Module Timestamp: 4ec49b8f
Exception Code: c0000374
Exception Offset: 000ce6c3
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 28c3
Additional Information 2: 28c3a815c4f0be4cf8e75c0bf51619ed
Additional Information 3: 0af0
Additional Information 4: 0af0ed5753d558a0f937122babecf189

Extra information about the problem
Bucket ID: 2863195439

Any help would be appreciated.
Is it shutting down right after showing "preparing to launch"? I'm having the same problem and I suspect it's something with the graphics driver update. I have a AMD Radeon HD 6xxx Series graphics card too.

Have you tried uninstalling your driver and reinstalling an older version? I haven't tried that yet because I just haven't had the time, but reply here and in this thread if it works, because a lot of people seem to have this problem. Steam tried telling me it may be a problem with Micro Trend, but I'm doubting that, considering it works on my laptop with the same security.
TygerSport is offline   Reply With Quote
Old 03-18-2012, 07:53 AM   #1878
pikamau5
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 1
possible movement issue, xbox single player

On Xbox 360, in single player mode, right after the level where you have to open a huge door, when i go through the door and after the next level has loaded, i find myself in a small rectangular room with doors on both ends, and i'm unable to move. Shooting portals and moving the camera etc works all fine. Loaded the game again but the problem persisted.
I have downloaded the latest patch.
pikamau5 is offline   Reply With Quote
Old 03-18-2012, 08:28 AM   #1879
flippyhtf
 
Join Date: Jul 2010
Reputation: 0
Posts: 76
I had a problem. Today, as always, I started Portal 2, and when I clicked Continue Game, it shut down. Also if I tried to create a new game, crashed again without a message error in both. I'm downloading it again and see if it was "repaired" or something, so please, if you know how to fix this, if it happends again, let me know-
flippyhtf is offline   Reply With Quote
Old 03-18-2012, 11:26 AM   #1880
Zepos
 
Join Date: Mar 2012
Reputation: 0
Posts: 4
Red face -BUG-

Bug: CRASH

Hardware:

Pentium(R) D CPU 3.00 GHz

Memory:
2.99 GHz, 2.00 GB of RAM
Physical Address System

OS:
Microsoft Windows XP
Media Center Edition
Version 2002
Service Pack 3

Graphics: NVIDIA GeForce 6800

Model: XPS 600

Problem:

In chapter "The Itch"

There is a level where there is a laser redirection cube. Whenever I try to pick it up, it closes as if I went to quit game, and closed it. Even the steam update comes up. I also get this crash at random times. Is it that my video driver is outdated?

-PROBLEM SOLVED-

Last edited by Zepos: 03-27-2012 at 06:16 PM.
Zepos is offline   Reply With Quote
Old 03-18-2012, 12:05 PM   #1881
V-Man
 
Join Date: Oct 2011
Reputation: 5
Posts: 72
I quit to desktop every time I hit the main menu, so I watch the intro videos, loading screens... And it just quits to desktop with no real explanation or error message.
Quote:
Processor Information:
Vendor: GenuineIntel
Speed: 3392 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Windows 7 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 323 0x0 0x0 0x0

Video Card:
Driver: AMD Radeon HD 6900 Series

DirectX Driver Name: aticfx32.dll
Driver Version: 8.950.0.0
DirectX Driver Version: 8.17.10.1119
Driver Date: 14 Feb 2012
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: AMD Radeon HD 6900 Series
VendorID: 0x1002
DeviceID: 0x6718
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 26.65" x 15.00" (30.55" diag)
67.7cm x 38.1cm (77.6cm diag)
Primary Bus Type Not Detected
Primary VRAM: -2048 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Speakers (2- Realtek High Defin

Memory:
RAM: 8174 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Media Type: DVD
Total Hard Disk Space Available: 928092 Mb
Largest Free Hard Disk Block: 350015 Mb
OS Install Date: Dec 31 1969
Game Controller: None detected
My specs.
V-Man is offline   Reply With Quote
Old 03-18-2012, 05:00 PM   #1882
TygerSport
 
Join Date: Feb 2011
Reputation: 41
Posts: 505
Quote:
Originally Posted by V-Man View Post
I quit to desktop every time I hit the main menu, so I watch the intro videos, loading screens... And it just quits to desktop with no real explanation or error message.

My specs.
http://forums.steampowered.com/forum....php?t=2587493

Saw problem, saw driver, this is probably your problem. Uninstall your graphics driver and reinstall version 11.12. I'm trying this myself next.
TygerSport is offline   Reply With Quote
Old 03-20-2012, 03:18 PM   #1883
galvan3754
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 1
Question Dropping it to close

When I press the "E" key to pick up something, it picks it up, but when I press "E" again to close it, it quits the game and takes me to my desktop. Anyone else getting this problem?
galvan3754 is offline   Reply With Quote
Old 03-20-2012, 06:12 PM   #1884
Zepos
 
Join Date: Mar 2012
Reputation: 0
Posts: 4
Quote:
Originally Posted by galvan3754 View Post
When I press the "E" key to pick up something, it picks it up, but when I press "E" again to close it, it quits the game and takes me to my desktop. Anyone else getting this problem?
This is happening to me aswell...
Zepos is offline   Reply With Quote
Old 03-21-2012, 02:44 AM   #1885
loanstar744
 
 
 
Join Date: Feb 2010
Reputation: 1
Posts: 153
Problem: Portal 2 runs horribly in multiplayer, running at about 5-10FPS with Settings maxed or all low, doesn't matter. Portal 2 Single Player runs a lot better but fairly choppy and hangs for a few seconds anytime there's an autosave or when dialogue plays and again settings don't matter it's choppy either way. Another thing is that when viewing Task Manager, Portal 2 only uses up anywhere from 10-20% of my CPU and DOES NOT go any higher when L4D1-2 uses about 30-60% under heavy load.

Hardware:
CPU: AMD FX-4100 Black Edition 3.6GHz 64-bit Quad Core AM3+
RAM: Corsair Vengeance Blue DDR3 2+4GB 1600MHz
MOBO: ASUS M5A88-V EVO
GPU: AMD Sapphire Radeon HD 6870 1GB GDDR5
OS: Windows 7 Professional 64x

Nothing is overclocked.

Other Things: All my other games play fine all settings maxed, including games like DiRT 3, GRID, TF2, HL2, HL2:EP1-2, L4D1-2, Portal, Killing Floor, UT3: Black and quite a few other games. All drivers are currently updated including my GPU. There is also NOTHING running in the background besides normal Win processes that are sitting idle, I've even restarted my PC as sometimes games run choppy right after being downloaded until a restart, but no success. I bought two copies of Portal 2, one for my main account and one for my second account, on my second account on my other PC it plays perfect at High settings and that PC's specs are:

CPU: AMD Sempron 3400+ 64-bit Single Core 1.8GHz AM2+
RAM: 1.5GB DDR2 Kingston
MOBO: Default HP Mobo
GPU: AMD Sapphire Radeon HD 5570 1GB DDR3
OS: Windows 7 Professional 64x

The only thing I can think of is that Portal 2 doesn't support my system, mainly my GPU and CPU considering how new they are, but I have found no way to fix this problem. Any help would be GREATLY appreciated as this problem makes the game UNPLAYABLE, though I have the game for Xbox 360 as well and have beaten Single and Multiplayer.

Last edited by loanstar744: 03-21-2012 at 03:52 PM.
loanstar744 is offline   Reply With Quote
Old 03-21-2012, 12:16 PM   #1886
V-Man
 
Join Date: Oct 2011
Reputation: 5
Posts: 72
Quote:
Originally Posted by TygerSport View Post
http://forums.steampowered.com/forum....php?t=2587493

Saw problem, saw driver, this is probably your problem. Uninstall your graphics driver and reinstall version 11.12. I'm trying this myself next.
Tried it, nothing doing. Same quit to desktop issue, no real change.

Edit: Problem solved. Avast anti-virus is exceptionally stupid.

Last edited by V-Man: 07-28-2012 at 05:45 PM.
V-Man is offline   Reply With Quote
Old 03-21-2012, 03:32 PM   #1887
loanstar744
 
 
 
Join Date: Feb 2010
Reputation: 1
Posts: 153
Quote:
Originally Posted by V-Man View Post
Tried it, nothing doing. Same quit to desktop issue, no real change.
Did you try verifying game cache? Another thing, do you have Xfire or any other external messaging application up while the game is running? I've had that problem where Xfire kept causing my games to return to the desktop. Another thing, is the game crashing? Try running the .exe directly through Portal 2's app folder, might give us a crash number, I've done this with multiple games but some might just start through Steam anyways.
loanstar744 is offline   Reply With Quote
Old 03-23-2012, 05:16 PM   #1888
smutas
 
Join Date: Oct 2011
Reputation: 0
Posts: 17
Problem:
I have graphic problem in co-op mode. In the 9th test of the 4th chapter "mp_coop_tbeam_end" i get all textures black (except lights).
Screen:
http://steamcommunity.com/profiles/7...431624?tab=all
Console:
Code:
No pure server whitelist. sv_pure = 0
Your .dll [bin\client.dll] differs from the server's.
Unable to load sprite material materials/sprites/gunsmoke.vmt!
Unable to load sprite material materials/sprites/bubble.vmt!
Can't find factory for entity: wearable_item
NULL Ent in UTIL_PrecacheOther
==== calling mapspawn.nut
Receiving uncompressed update from server
(97707453):Added listener class CPortalPlayerInventory
(97707453):Added listener class C_Portal_Player
(82593517):Added listener class CPortalPlayerInventory
(82593517):Added listener class C_Portal_Player
Shadow memory (m_ShadowDecals) growing [8192]
Shadow memory (m_ShadowSurfaces) growing [8192]
Redownloading all lightmaps
Can't use cheat cvar r_flashlightbrightness in multiplayer, unless the server has sv_cheats set to 1.
DLCMANAGER: RequestDlcUpdate has no new content.

Portal 2 Coop
Map: mp_coop_tbeam_end
Players: 2 (0 bots) / 2 humans
Build: 4710
Server Number: 2

(97707453):Remove listener class C_Portal_Player
(97707453):Remove listener class CPlayerInventory
(82593517):Remove listener class C_Portal_Player
(82593517):Remove listener class CPlayerInventory
SignalXWriteOpportunity(3)
No pure server whitelist. sv_pure = 0
Your .dll [bin\client.dll] differs from the server's.
Can't find factory for entity: wearable_item
NULL Ent in UTIL_PrecacheOther
==== calling mapspawn.nut
Receiving uncompressed update from server
(97707453):Added listener class CPortalPlayerInventory
(97707453):Added listener class C_Portal_Player
(82593517):Added listener class CPortalPlayerInventory
(82593517):Added listener class C_Portal_Player
Redownloading all lightmaps
[Sound] S_StartSound(): Failed to load sound 'player\ballbot\v2\ballbot_taunt_rps_count_intro_07.wav'. File is missing from disk/repository.
System:
Intel(R) Core(TM) i3 CPU M 350 @ 2.27GHz
3GB RAM
Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Intel(R) HD Graphics

I know this is bad laptop for gaming, but with Zhan Portal 2 config ( http://forums.tf2maps.net/showthread.php?t=16899 ) I was able to play P2 smoothly. I finished the whole single player and the co-op mode till the last test in 4th test series.

Last edited by smutas: 03-24-2012 at 10:26 AM.
smutas is offline   Reply With Quote
Old 03-24-2012, 01:17 PM   #1889
RioAlex
 
 
 
Banned
Join Date: Jan 2012
Reputation: 0
Posts: 25
i cant find this in topic so i post it
i just got portal 2 when i try to start it it just gives me "preparing to launch game" screen and nothing happens,from friend list for a sec i can see that it says In-game Portal 2

my pc is good since it can run it and mw3 and other games
pm me for help or just post here or im gonna loose it
RioAlex is offline   Reply With Quote
Old 03-27-2012, 04:47 PM   #1890
KalebGrace
 
Join Date: Apr 2011
Reputation: 0
Posts: 2
I'm unable to delete my manual/permanent saves. Even if I delete them in Windows, the Steam Cloud brings them back. If I turn off Steam Cloud before deleting them, turning on the Steam Cloud on later still brings them back.

I contacted Steam support months ago and have been going back and forth with "Support Tech Vince" since then, trying every suggestion he gave me to no avail. Last time he told me to install some shady 3rd party app to delete Steam registry settings, and that's when I decided things were going nowhere. I sent him a direct question about whether he could actually solve my problem or just give me a run around, then he replied, saying to "provide a screenshot of any error(s) you are seeing". Basically he's just ignoring me now.

Can somebody please let me know if they are having a similar problem? Also, if there are any Valve employees that can help me out, it would be appreciated.
KalebGrace is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2


Tags
p2 bug tracker

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.