Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Alien Shooter series

Reply
 
Thread Tools Display Modes
Old 02-06-2011, 05:55 PM   #1
luckyjim
 
Join Date: Dec 2009
Reputation: 17
Posts: 338
AS2: Reloaded Poor Performance

Hey all,

Not sure if anyone can help me with this problem, but I'm trying to play AS2 Reloaded and the game runs like crap. I turned shadows off and detail down to low, but it still runs pretty poorly.

I'm running a fresh install of Win 7 64-bit, Phenom X3 720, ATI 4870... latest drivers.

I recall this happening to me last time I tried the game, but I just gave up. I was hoping to find a fix this time since I really like this style of game.

Is there anything I can do? Oh, also I get a black screen when trying to quit and have to turn off my PC entirely...
luckyjim is offline  
Reply With Quote
Old 04-10-2011, 02:10 PM   #2
e3borealis
 
Join Date: Jun 2009
Reputation: 0
Posts: 21
If there are lags everywhere, I dont know, but if they are only when there are hundreds of monsters - its OK, this engine is unoptimised.
e3borealis is offline   Reply With Quote
Old 09-15-2011, 06:48 PM   #3
Hamster Gutz
 
 
 
Join Date: Oct 2010
Reputation: 4829
Posts: 1,349
AS2 runs badly for me as well. Whenever there are more than like 5 aliens on screen(which is almost all the time) the game gets all choppy. Bumping for possible help.
Hamster Gutz is offline   Reply With Quote
Old 09-19-2011, 11:53 AM   #4
SilentRequiem
 
 
 
Join Date: Jun 2010
Reputation: 27
Posts: 7
Try forcing Vsync off through the control panel for your videocard. I was having performance issues and this fixed it for me. Hope it works for you. Damn shame that the game doesn't have more resolution and video options.
SilentRequiem is offline   Reply With Quote
Old 09-21-2011, 09:14 AM   #5
Cunin
 
Join Date: Jan 2010
Reputation: 191
Posts: 1,317
I never had such a problem with that game, with a less powerful hardware than yours (Athlon 64 X2 5200+, Radeon HD4670, win7 x64), but my vsync is always set as "off, unless application specifies" in the drivers.
If setting vsync off will not work, try using a different version of the drivers.
Cunin is offline   Reply With Quote
Old 10-31-2011, 02:32 AM   #6
addictedto60fps
 
Join Date: Dec 2010
Reputation: 4
Posts: 160
I just downloaded the demo, and it's choppy as hell on mine, too, sadly. This is definitely a game I'd purchase, but since it runs like crap on my system, I'm going to have to pass. All the other shooter series (Zombie Shooter 1/2, Alien Shooter/Alien Revisited), they're all perfectly smooth. It's just this one, strangely.
addictedto60fps is offline   Reply With Quote
Old 03-30-2012, 01:17 AM   #7
addictedto60fps
 
Join Date: Dec 2010
Reputation: 4
Posts: 160
I swapped out my AMD 6970's and got a GTX 680. Problems are gone now. I wonder if this problem is specific to AMD cards? Anyway, problem solved and I can enjoy the game now!
addictedto60fps is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Alien Shooter series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.