Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V

Reply
 
Thread Tools Display Modes
Old 03-26-2012, 05:25 PM   #61
Boletus
 
Join Date: Aug 2006
Reputation: 30
Posts: 145
And for a more complete understanding, we need to realize that limiting the maximum fps will bring up the minimum fps, for a vid card that is capable of exceeding the maximum needed fps (e.g. 60 for a monitor with a refresh rate of 60 Hertz).

Realize that each computation your computer performs (yes, they are all just mathematical operations) occurs at a given instance in time. But these instances occur at the gigahertz level now. So the card might be able to render 20 fps for 0.000001 second, then 80 fps the next, etc., depending on the performance of the of the whole system (cpu. hd, ram...).

So someone with a monitor with a 12 ms response time and a vid card that pushes 30-40 fps might well ask, "What the hell are you brats griping about?" But you have to see it to understand. In this case, the lower end system can actually provide a better visual experience, believe it or not.
Boletus is offline   Reply With Quote
Old 03-28-2012, 11:48 PM   #62
anonymous321
 
Join Date: Jun 2010
Reputation: 60
Posts: 158
Quote:
Originally Posted by Deluxxe View Post
what's the diff between limiting framerate to 60, and just using vsync with a 60Hz monitor?
If the Skyrim game engine worked correctly, there would be no difference between limiting your vsync to 60fps and imposing vsync with a 60hz refresh rate. The reason there is a difference is a problem with the engine itself.

When vsync is enabled, the game should successfully cap at 60fps ALL THE TIME. But it doesn't. For sudden, brief moments the framerate will exceed 60fps inspite of the vsync cap. It is the "over-rendering" of frames inspite of vsync that causes the stutter. Using a framerate limiter successfully reinstates this cap that should've been there all along, smoothing out the game.

Belive it or not, there is actually a related phenomenon that occurs in ALL SOURCE ENGINE GAMES when vsync is enabled. Boot up any source engine game and type cl_showfps 1 in the console. Now, look at the frame rate closely as you walk around. For brief moments of time the framerate will skyrocket to well over 100fps, despite the supposed 60fps cap (Note you have to use the cl_showfps 1 command as programs like FRAPS do not have the precision to detect this). Everytime the frame jumps above 60fps, you get stutter from "over-render."
anonymous321 is offline   Reply With Quote
Old 03-29-2012, 06:21 AM   #63
Nfskingviper
 
Join Date: Nov 2011
Reputation: 0
Posts: 13
I have vsync enabled in the nvidia control panel. Works for me. However, I did have EXTREME screen tearing/stuttering prior to turning on vsync. It happened on my HD 6850 and my GTX 560 Ti, the problem was actually that I had too many FPS. I was hitting 250+ even with all settings maxed. Water would flicker, the screen would go black, trees would be distorted, etc. When Skyrim first came out, vsync caused a ton of problems. Now, vsync actually fixes problems.
Nfskingviper is offline   Reply With Quote
Old 04-01-2012, 12:14 AM   #64
anonymous321
 
Join Date: Jun 2010
Reputation: 60
Posts: 158
That's not really what I'm talking about. The "frame skipping/micro stutter" is a curious breed of sutter caused by "over-render". It's a problem with the engine. Use the all purpose fps limiter in the OP and you'll see the night and day difference.
anonymous321 is offline   Reply With Quote
Old 04-01-2012, 06:29 AM   #65
Zloth
 
Join Date: Apr 2009
Reputation: 86
Posts: 564
!? The solution to having FPS get too high is to turn on more eye candy! Especially in a game like this where FPS really isn't very important. Get all those HD textures and tweak your ini files up.
Zloth is offline   Reply With Quote
Old 04-01-2012, 07:54 AM   #66
theyarecoming4u
 
 
 
Join Date: Dec 2004
Reputation: 76
Posts: 1,935
This made no difference to me. I think it's because I have v-sync enabled and I'm using a GTX680, which automatically downclocks itself when it isn't needed. Even though I'm running at 2560x1600 with max setting it's still only at around 1000MHz, which is 200MHz less than the top speed on my overclock.
theyarecoming4u is offline   Reply With Quote
Old 04-01-2012, 09:42 AM   #67
anonymous321
 
Join Date: Jun 2010
Reputation: 60
Posts: 158
I can't speak for the Geforce GTX 680 because, well the thing is freaking sweet, plus I'm not 100% sure how it's new adaptive v-sync will interact with this game engine bug. As for the majority if not all high end hardware prior to that, Skyrim stutters with out a framerate limiter at 60fps. Try it!
anonymous321 is offline   Reply With Quote
Old 04-01-2012, 08:08 PM   #68
jackchortz
 
Join Date: Dec 2009
Reputation: 28
Posts: 101
beware, the MSI afterburner method doesn't work as well as the borderless window method. with afterburner, i still get some jerkyness indoors.
jackchortz is offline   Reply With Quote
Old 04-02-2012, 12:48 AM   #69
anonymous321
 
Join Date: Jun 2010
Reputation: 60
Posts: 158
For me, MSI Afterburner seems to work better, which makes sense, as running in a window receives less resouce attention from the computer.

What about you guys? Which method in the OP works better for you?
anonymous321 is offline   Reply With Quote
Old 04-02-2012, 11:12 AM   #70
Cougarific
 
Join Date: Oct 2010
Reputation: 383
Posts: 1,157
Is this a one-or-the-other deal? I already have SBW installed (it sorta works - removes stutter outdoors, adds stutter indoors) but want to try the frame limiter too - do I have to uninstall SBW before trying Afterburner?
Cougarific is offline   Reply With Quote
Old 04-02-2012, 07:11 PM   #71
anonymous321
 
Join Date: Jun 2010
Reputation: 60
Posts: 158
It doesn't have to be one or the other, but ideally it should be. The point of using the framerate limiter in the Afterburner BETA is so you can run in fullscreen mode, and hence get the associated performance gains (more dedicated resource and focus from the OS).

But, mess around, try it. Let me know how it works. What about everyone else? What kind of results are you getting when using the methods in the OP?

Last edited by anonymous321: 04-02-2012 at 07:19 PM.
anonymous321 is offline   Reply With Quote
Old 04-30-2012, 01:18 PM   #72
Vancatu
 
 
 
Join Date: Apr 2012
Reputation: 0
Posts: 2
You have provided the best solution for this annoying and unncecessary problem so far.

For me, both solutions initially reduced but not entirely solved the problem and after trying them both I've concluded that MSI Afterburner does a better job OVERALL. Running the game with the SBW mod for some reason makes the Whiterun area pretty laggy. I think it has to do with the system dedicating less resourches to running a game in window mode, is it not?

In any case, the FINAL 2.2 version of MSI Afterburner has just been released so the beta version is no longer needed. And the latest ADM 12.4 driver also improved running Skyrim and in combination with the afterburner it now almost entirely reduces the micro-stuttering for me.
Vancatu is offline   Reply With Quote
Old 05-12-2012, 10:57 AM   #73
topho
 
Join Date: May 2010
Reputation: 0
Posts: 23
Quote:
Originally Posted by topho View Post
Lol. and I just posted a topic entitled "slow down indoors"

I was already running MSI Afterburner on my GPUs OC, but turning on limit 60fps makes Skyrim a *totally* different game. Smoothed up many many many times over. Dark Brotherhood Sanc is silky now. Wow. Big difference. I haven't had an extended play session but a quick 2 minute walk through of the DarkBrotherhood sanc which was really unbearable is now silky smooth. CrazY!

What the f is the point of vsync?
I bet this helps Fallout New Vegas alot too, that game had problems similar.

At first I was like oh yeah another performance tweak I'm not gonna try cause it won't work anyhow. I was WRONG. I've played all of Mzinchaleft essentially locked at a actual and perceived 60fps.
Tried playing Skyrim lately...and my performance isn't as good as it was. Lots of lag in cities, which was never there before. Gonna downgrade from Catalyst 12.4 to 12.2, which I believe I was using when I made my original post.
topho is offline   Reply With Quote
Old 05-12-2012, 06:05 PM   #74
sarojz
 
Join Date: Jan 2008
Reputation: 159
Posts: 800
I've got a EVGA GTX590 dual gpu, I'm running the latest forceware drives 296.10s and after 950hrs plus of playtime I've noticed an amazing amount of hitching/stuttering has crepted into my gameplay. I was blessed for many months of not having to deal with this issue as others have and now I'm having a hard time pinpointing what triggers it. I leave from a dungeon or dwelling with no apparent problems but as soon as I start running anyplace or any direction outside within 10-15 secs I've got this incredibily annoying hitching, it's so noticable it sometimes causes me to run into trees or other objects, it yanks the screened images that hard. With fraps I've noticed my frames go from a low of about 38 all the way up to 200, how is that even possible with v-synch on? I've got a highend monitor capable of 2560x1600 but I run the game at 1920x1080/60hz. MSI after burner was reccomended to limit framerates and eliminate microstutter. I'm I dealing with microstuttering or some other issue? HD lag time?
In the control panel there is a setting called "Maximum pre-rendered frames" in which it limits the number of frames the cpu can prepare before the frames are processed by the GPU. So if you increase the value up from the default level of 3 you can acheive smoother framerates at the cost of lower FPS. It only works with DirectX and asetting too high can result in slow inputs from mice, controllers and keyboards. Does this setting accomplish the same effect as MSI afterburner? Sorry for the wall of text.
sarojz is offline   Reply With Quote
Old 05-14-2012, 02:56 PM   #75
oldskoolfool
 
 
 
Join Date: Jan 2011
Reputation: 0
Posts: 13
Thanks, was getting very annoyed that I was getting decent framerate but having stuttering, frame limiter on afterburner cleared that right up. +1 cheers
oldskoolfool is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.