Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 04-02-2012, 06:38 AM   #1906
quetzalcoalt_lp
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 5
Okay, thanks m8.
quetzalcoalt_lp is offline   Reply With Quote
Old 04-02-2012, 01:34 PM   #1907
Drizzt519
 
 
 
Join Date: Mar 2012
Reputation: 9
Posts: 6
For those having the problem where you get the "launching Portal 2" box but nothing happens after that, here is another fix to try that isnt rolling back your drivers. It worked for me and hasnt caused me any issues like rolling back drivers did.

http://forums.steampowered.com/forum....php?t=2626831

Look at the 3rd post.

Last edited by Drizzt519: 04-02-2012 at 01:37 PM.
Drizzt519 is offline   Reply With Quote
Old 04-04-2012, 02:33 PM   #1908
loanstar744
 
 
 
Join Date: Feb 2010
Reputation: 1
Posts: 153
Anyone having the same problems as I should update the BIOS for their motherboard, I run an ASUS M5A88-V EVO and updated to the newest release of BIOS 1103 and have not had a single problems with Portal 2. This might solve some of the other issues other users are having if they run an ASUS motherboard but could also be Portal 2 trying to use the onboard Graphics and could affect any MOBO so check it out and make sure your onboard GFX is disabled in BIOS then try Portal 2 before updating them and if that doesn't work, you should go ahead and update the BIOS.

My issue was that Portal 2 was extremely slow and laggy no matter what the settings were and on my system that just wasn't possible.

Portal 2 was trying to use the Integrated Graphics Card and display it through my HD 6870 even though I had the IGP disabled in BIOS and everything, so anyone who's having issues should try to update their BIOS for their MOBO BUT BE VERY CAREFUL, it's not for the non-techies, but ASUS makes it safer and easier with EZ Flash and the use of a Flash Drive.

EDIT: Anyone having the problem when Portal 2 won't launch but shows in Task Manager for a few seconds then disappears should uninstall Application Manager for Catalyst or Vision Engine in Add or Remove Programs, then restart your PC and launch Portal 2, fixes the problem.

Last edited by loanstar744: 04-06-2012 at 04:44 AM.
loanstar744 is offline   Reply With Quote
Old 04-12-2012, 01:51 PM   #1909
RaistlinZrg
 
 
 
Join Date: Apr 2012
Reputation: 0
Posts: 2
NOTE : i am not a natural english speaker, so be indulgent with my english

Hi

I just solved 2 bugs with my new computer and portal 2. I post my solutions here to help people who may have the same issue as me.

When i was launching the game, it closed almost instantly without any errors or announcement. I could see in the task manager the portal2.exe process launching and stopping without even seeing the title screen.

Some FAQ pointed that this problem was that some CPU can't support SSE witch is need for the source engine, but my CPU is fine to deal with SSE.

I found my first solution on the forum, saying that the ATI Catalyst Profile Manager was blocking the game. I uninstalled the Profile Manager and the game started until it crash at the title screen !

My second problem came with a BSOD at the title screen... witch was a problem with the stability of my mother card's bios (ASUS SABERTOOTH 990FX). It's seems that the bios (version 813) wasn't stable with some operation that the game use. With the update +901 (i used the last at that moment: version 1102) of my mother card's bios this issue was solved and i am now able to play portal 2 again !

TL TR : The ATI Catalyst Profile Manager is in conflict with Portal 2. You have to uninstall it to be able to play the game. The bios version under 901 of the ASUS SABERTOOTH 990FX isn't stable with some process portal 2 need to work. The update 901 and more of the bios solve this issue.

I hope this will help some people.

You can have some informations about my computer configuration below :

Quote:
Processors
-------------------------------------------------------------------------

Number of processors 1
Number of threads 8

Processors Information
-------------------------------------------------------------------------

Processor
Number of cores 8 (max 8)
Number of threads 8 (max 8)
Specification AMD FX(tm)-8150 Eight-Core
Package Socket AM3+ (942)
TDP Limit 124 Watts
Core Speed 4154.0 MHz
Stock frequency 3600 MHz
Instructions sets MMX (+), SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, SSE4A, x86-64, AMD-V, AES, AVX, XOP

DMI
-------------------------------------------------------------------------

DMI BIOS
vendor American Megatrends Inc.
version 1102
date 03/12/2012

DMI Baseboard
vendor ASUSTeK COMPUTER INC.
model SABERTOOTH 990FX
revision Rev 1.xx


Display Adapters
-------------------------------------------------------------------------

Name AMD Radeon HD 6700 Series
Name Radeon HD 5850

Software
-------------------------------------------------------------------------

Windows Version Microsoft Windows 7 (6.1) 64-bit Service Pack 1 (Build 7601)
DirectX Version 11.0
RaistlinZrg is offline   Reply With Quote
Old 04-19-2012, 02:11 PM   #1910
CowboysFan87
 
Join Date: Apr 2012
Reputation: 0
Posts: 1
After moving to a new PC with same video card, I too had the sudden close issue on Portal 2. I went to Nvidia and download a driver from November of 2011 and all my problems went away. My card is an Nvidia 9800GTX and the driver I'm using now is 280.26. (Side note, since this Left 4 Dead 2 no longer just crashes to the desktop at random either).
CowboysFan87 is offline   Reply With Quote
Old 04-26-2012, 01:51 PM   #1911
Comjuke
 
 
 
Join Date: Apr 2012
Reputation: 0
Posts: 41
When i start the game, I see the Valve logo, then the loading screen then it goes black and "Error, Portal 2 has stopped working now closing" and exits out of the game
Windows Vista is what I have
Comjuke is offline   Reply With Quote
Old 04-27-2012, 10:57 AM   #1912
zc_someone
 
Join Date: Jul 2010
Reputation: 0
Posts: 19
Quote:
Originally Posted by zc_someone View Post
Kk, then we'll just have to wait. Tnx for the info anyway.
Just reporting that the new drivers (ADM 12.4) fixed my issue. Game now works normally. Just like before.
zc_someone is offline   Reply With Quote
Old 05-01-2012, 09:16 AM   #1913
Alexander Bell
 
 
 
Join Date: Apr 2012
Reputation: 1328
Posts: 2,345
When I try to change the model of turrets to corrupted turrets in a level which doesn't have corrupted turrets, the game crashes... don't have the error message right now (I can reproduce it but cant get steam running now) but its something like "model not pre reached"... not sure if this is a bug or not.
Alexander Bell is offline   Reply With Quote
Old 05-01-2012, 06:37 PM   #1914
Spongebob1212
 
Join Date: Aug 2011
Reputation: 0
Posts: 47
Sometimes after you place a portal and it dissapears. The crossfire keeps saying that the 2 portals are there.
Spongebob1212 is offline   Reply With Quote
Old 05-02-2012, 01:44 PM   #1915
Saiyan1337
 
Join Date: May 2012
Reputation: 0
Posts: 1
Question Some kind of graphical problem.


Im not totally sure what to call this issue. i know its graphically but dont know a specific name for it.
Prior to me updating the drivers to the latest version, I've never seen this problem.

http://imgur.com/a/qhXS5#3 all the problems are in that album.

If someone can tell me what error that is, it would be appreciated The game still runs smooth though.

My Specs:
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1
Processor: AMD Turion(tm) II P560 Dual-Core Processor (2 CPUs), ~2.5GHz
Memory: 4096MB RAM

Card name: ATI Mobility Radeon HD 4200 Series
Manufacturer: Advanced Micro Devices, Inc.
Display Memory: 1914 MB
Dedicated Memory: 252 MB
Shared Memory: 1661 MB
Current Mode: 1366 x 768 (32 bit) (60Hz)

If this issue was reported earlier, im sorry. I didnt know what to look for in this thread.

Last edited by Saiyan1337: 05-02-2012 at 02:00 PM.
Saiyan1337 is offline   Reply With Quote
Old 05-02-2012, 02:37 PM   #1916
kbartlin18
 
 
 
Join Date: Apr 2012
Reputation: 0
Posts: 41
Quote:
Originally Posted by Teets View Post
Is anyone else getting the message that they're missing 1 file after verifying the integrity of the game cache through game properties? I get a message that says it will be "reacquired" but after verifying multiple times, I still get the same "1 file is missing" message.


Same here
kbartlin18 is offline   Reply With Quote
Old 05-02-2012, 06:53 PM   #1917
Spongebob1212
 
Join Date: Aug 2011
Reputation: 0
Posts: 47
Sometimes when you tab in coop with you in the partner's view. Your skin will dissapear. http://steamcommunity.com/id/goldtex...409?tab=public
Spongebob1212 is offline   Reply With Quote
Old 05-03-2012, 07:41 AM   #1918
Alexander Bell
 
 
 
Join Date: Apr 2012
Reputation: 1328
Posts: 2,345
When firing a rocket into water using fire_rocket_projectile, a sound will play (obviously an audio bug) of someone saying "aww fiddlesticks, what now?"... quite strange and obviously a bug, console says "
CSoundEmitterSystemBase::GetParametersForSound: No such sound WaterExplosionEffect.Sound"

I dont know how to get my specs.

Oh, and just btw the voice isn't a voice from anywhere in the game (not the announcer, cave, wheatley, glados, or turrets)
Alexander Bell is offline   Reply With Quote
Old 05-03-2012, 04:51 PM   #1919
Sonicfangamer2
 
 
 
Join Date: Apr 2011
Reputation: 0
Posts: 11
Red face Can't connect to Co-op!

When connecting with a randomly picked person for Co-op, The game takes forEVER to load (not sure if it's my PC), then 3-4 minutes later, the game finally loads (to the ATLAS/P-body structure screen), then the game just cuts and says "your friend disconnected" or something like that. I've retried 5 times, but it still happens!

EDIT: This happens to regular inviting as well.

Last edited by Sonicfangamer2: 05-12-2012 at 11:41 AM. Reason: Adding to the report
Sonicfangamer2 is offline   Reply With Quote
Old 05-05-2012, 03:50 AM   #1920
JasperCZE
 
Join Date: Jun 2010
Reputation: 136
Posts: 105
Hi, I have a problem with Portal 2 PeTI editor. Look at this screenshot. It seems that there is an issue with reflections on the water (fizzler, laser field, portals, observation room's window).

Am I the only one having this problem?
JasperCZE is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2


Tags
p2 bug tracker

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.