Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dear Esther

Reply
 
Thread Tools Display Modes
Old 04-15-2012, 06:26 PM   #1
MaRkYBoX
 
Join Date: Dec 2010
Reputation: 0
Posts: 16
Useful Tip: Binding Keys/mousewheel for 4-speed variable walk speed!!

I decided to buy this game (er, 'interactive story') because it has English subtitles, as I am deaf. I'm enjoying it so far, but one frustrating thing is when I fell down the wrong path, I had to start over again. Ugh, several lost minutes of repetitive boredom in an otherwise interesting land I liked exploring.

SOLUTION: Use the mousewheel for variable walk speed!

INSTRUCTIONS:
Edit your \Steam\steamapps\common\dear esther\dearesther\cfg\userconfig.cfg file and add these lines:

bind 1 "de_playerspeed 100"
bind 2 "de_playerspeed 200"
bind 3 "de_playerspeed 300"
bind 4 "de_playerspeed 400"
bind "W" "+forward"
bind "MOUSE1" "+forward"
bind "MOUSE2" "+zoom"
bind "MWHEELDOWN" "de_playerspeed 100"
bind "MWHEELUP" "de_playerspeed 200"
bind "MOUSE3" "de_playerspeed 400"

Then you can just lazily hold down the left mouse button to keep moving forward. No hands on keyboard needed. Also, you can use mousewheel up/down to speed up and slow down your walking. For turbo walk speed, just click the mousewheel. (Alternatively, just use the number 1,2,3,4 keys)

This "game" has a habit of resetting your speed back to walk speed, so the ability to change your walk speed back again, is quite useful to allevitate boredom....

You can even use a cordless mouse while lounging on the sofa in front of you HDTV to play this story - since the entire game can now be played without the keyboard (WASF), once the mouse buttons are bound as such.

Also, check my other thread:
BOOKS: Flip pages anytime...DVD: FastForward anytime...Esther: Fast walk/RUN! :-)
For a very _strong_ rationale why future storygames like these, MUST be able to be operated at variable speed, to skip boring/familiar parts (such as backtracking a long path to go down a different path)

Last edited by MaRkYBoX: 04-15-2012 at 07:16 PM.
MaRkYBoX is offline  
Reply With Quote
Old 08-27-2012, 02:40 PM   #2
simplen00b
 
Join Date: Aug 2012
Reputation: 0
Posts: 3
What am I doing wrong?

I've copied the code into the userconfig file (which was blank BTW) and it makes no difference. Is there some setting I need to change in the game options? I'd really like to get this to work!
simplen00b is offline   Reply With Quote
Old 09-27-2012, 02:38 PM   #3
GuardianAngel42
 
Join Date: May 2010
Reputation: 123
Posts: 650
Quote:
Originally Posted by simplen00b View Post
I've copied the code into the userconfig file (which was blank BTW) and it makes no difference. Is there some setting I need to change in the game options? I'd really like to get this to work!
Should probably be put in config.cfg instead, located in the same folder. Just a hunch, but that's where all the other settings are.
GuardianAngel42 is offline   Reply With Quote
Old 10-10-2012, 05:45 AM   #4
Nekociel
 
 
 
Join Date: Oct 2012
Reputation: 35
Posts: 18
Thumbs up

Thank you man! It really helps :P
Nekociel is offline   Reply With Quote
Old 10-15-2012, 09:44 AM   #5
simplen00b
 
Join Date: Aug 2012
Reputation: 0
Posts: 3
Any changes I make to the config.cfg file somehow get overwritten and changed back to what they were as soon as I start the game . Any ideas on how I can stop that happening?
simplen00b is offline   Reply With Quote
Old 10-15-2012, 06:22 PM   #6
Nekociel
 
 
 
Join Date: Oct 2012
Reputation: 35
Posts: 18
Quote:
Originally Posted by simplen00b View Post
Any changes I make to the config.cfg file somehow get overwritten and changed back to what they were as soon as I start the game . Any ideas on how I can stop that happening?
Right click on the file, select "properties" and then tick the box "read-only", now you can edit it :P
Nekociel is offline   Reply With Quote
Old 10-19-2012, 05:23 PM   #7
simplen00b
 
Join Date: Aug 2012
Reputation: 0
Posts: 3
Unfortunately that's not the problem. I can change the config file, save and close it, and if I open it again without starting the game, my changes are still there. However, if I open DE (just to the start menu - I don't even have to start playing) and then open the config file, it's somehow overwritten all the changes I've made and reverted back to the original. Any ideas?
EDIT: OK - think I've got it sorted; I added the lines to the config file and then made it read-only. Thanks again for the tip!

Last edited by simplen00b: 10-20-2012 at 12:54 PM.
simplen00b is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dear Esther


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.