Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Empire: Total War

Reply
 
Thread Tools Display Modes
Old 04-19-2012, 02:21 PM   #1
Angre_Leperkan
 
Join Date: Oct 2010
Reputation: 6
Posts: 202
Loading my saved games caused a CTD.

So mad right now.
I'm 172 turns into my campaign as Prussia. I've had a revolution, pretty much finished up the tech tree, built a large army/navy, and taken all of the territory (short of Italy and a province controlled by Spain) between France and part of Western Russia. All of a sudden, my game crashes.
It was okay, I had saved the turn before. I load that save game.
Get a crash to desktop during the load screen.
I try the autosave. Same problem.
My other saves? Work fine.
Apparently this is a common problem with ETW, but yet I haven't been able to find a solution in my research.
Does anybody know how to fix this? I have another save I made at 150, but I don't wanna start there since I'll lose so much progress (I dominated Poland and Russia in the time period between the turns).
If anybody could help that'd be awesome.

EDIT: Forgot to add my system specs, here they are.
Windows 7 Professional 64-bit
AMD Phenom II X4 965 Black Edition
EVGA GeForce 560 Ti
8Gb G-Skill RAM DDR3 1600
All of my drivers are up to date.

Last edited by Angre_Leperkan: 04-19-2012 at 02:42 PM. Reason: Adding of information.
Angre_Leperkan is offline  
Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Empire: Total War


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.