Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sins of a Solar Empire series > Trinity

Reply
 
Thread Tools Display Modes
Old 04-25-2012, 03:01 AM   #1
lioneln
 
Join Date: Jan 2011
Reputation: 0
Posts: 1
Can't connect to ICO

I've been playing multiplayer on Ironclad Online for a few months now. Last night I was playing, and my electricity went out for a split second at home, restarting my modem and router, so I lost connection to the game. Now, every time I try connecting to ICO for multiplayer, after a couple seconds I simply receive a message saying that I've been disconnected from Ironclad Online. I can't connect at all. I've waited a day, and the same thing is happening.

I reset my router. I also reinstalled the game. Still nothing. Very frustrating.

Any suggestions???
lioneln is offline  
Reply With Quote
Old 04-25-2012, 06:34 PM   #2
Whippersnapper
 
Join Date: Aug 2010
Reputation: 62
Posts: 268
Do you have a laptop you could install the game on? Would that connect? If so maybe you just need to do a fresh install on your desktop.

Also, you'll probably get more answers and better advice at the official Sins discussion forums:

http://forums.sinsofasolarempire.com
Whippersnapper is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sins of a Solar Empire series > Trinity


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.