Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2

Reply
 
Thread Tools Display Modes
Old 04-26-2012, 01:53 PM   #1
AceFront
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 9
Red face Portal 2 refuses to launch on PC.

Okay, I am having a problem launching Portal 2 recently. I've never in all my time owning the game have had this problem, but it's getting -QUITE- annoying.

So this is it: whenever I go to launch the game, it will go through the standard "Preparing to launch ____" procedure, but then it goes away REALLY fast, and the Steam client stays on screen, and the resolution dosen't go down to 1280x720. In fact, nothing happens. It says I'm "In Game" for about 10 seconds, then my screen moves for a split second, and it says I'm just "Online".

I've already tried BOTH Defragmentation of Cache Files, Verifying the Integrity of Cache Files, and even un-installing and re-installing the game. I have installed no mods on Portal 2, and have never had this problem on this or my other, much worse, computer in the past.

Any explanation?
AceFront is offline  
Reply With Quote
Old 04-26-2012, 02:40 PM   #2
metz10
 
Join Date: Dec 2011
Reputation: 15
Posts: 120
Try setting -autoconfig in Properties > Launch Options. This will ignore any changes to settings you have applied, possibly bypassing the issue.

Info: https://support.steampowered.com/kb_...1040-JWMT-2947
metz10 is offline   Reply With Quote
Old 04-26-2012, 02:55 PM   #3
AceFront
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 9
Unfortunately, no dice. It did the same thing.
AceFront is offline   Reply With Quote
Old 04-26-2012, 03:47 PM   #4
PELUXA1
 
 
 
Join Date: Dec 2010
Reputation: 1283
Posts: 9,009
Try checking this link...

https://support.steampowered.com/kb_...6218-USFX-5568


Also, computer specs?
PELUXA1 is offline   Reply With Quote
Old 04-26-2012, 04:17 PM   #5
AceFront
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 9
CPU: AMD A6 3400M Quad-Core Processor
GPU: AMD Radeon HD 6520G
4 GB DDR3 RAM (Plan on upgrading that to 8)
OS: Windows 7

It's a laptop, so nothing amazing, but if you need anything else, I'll tell.
AceFront is offline   Reply With Quote
Old 04-28-2012, 10:11 PM   #6
ffmadcow
 
Join Date: Mar 2010
Reputation: 0
Posts: 3
Same

I got my son Portal 2 and so we wanted to do some co-op. I tried to load it up, and same thing. Says it is launching, acts like it will, then nothing at all. I have tried defrag, uninstall and reinstall. Latest AMD drivers.

It's not like my computer is old:

CPU i7-950
12 GB DDR3 RAM
AMD 6970 GPU

The only thing I can imagine is a recent Steam update?

Last edited by ffmadcow: 04-28-2012 at 10:12 PM. Reason: subscribe
ffmadcow is offline   Reply With Quote
Old 04-29-2012, 04:36 AM   #7
skuzzbag
 
Join Date: Apr 2012
Reputation: 0
Posts: 2
Or maybe a recent windows update? When I get sudden strange issues I check the system restore points to see if one has been created recently due to an update. Sometimes they can go a bit wrong and restoring fixes it. The update will get applied again and chances are there won't be any problems that time around.
skuzzbag is offline   Reply With Quote
Old 04-29-2012, 04:17 PM   #8
ffmadcow
 
Join Date: Mar 2010
Reputation: 0
Posts: 3
Quote:
Originally Posted by skuzzbag View Post
Or maybe a recent windows update? When I get sudden strange issues I check the system restore points to see if one has been created recently due to an update. Sometimes they can go a bit wrong and restoring fixes it. The update will get applied again and chances are there won't be any problems that time around.
I will have to check. I know I have tried a few drivers to no avail. Running Win 7 Ultimate 64-bit and have tried it as an administrator and normal. It is perplexing as heck as my son finished Portal, bought Portal and wants to play co-op and I am out of luck on my beast of a rig.
ffmadcow is offline   Reply With Quote
Old 05-08-2012, 01:29 PM   #9
AceFront
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 9
Actually, I have 13 Windows 7 updates, so I'll just install those and see if anything's wrong.

EDIT: Still not working. I've tried so many times, it's ridiculous.

Last edited by AceFront: 05-08-2012 at 02:02 PM.
AceFront is offline   Reply With Quote
Old 05-08-2012, 01:36 PM   #10
jugularis
 
 
 
Join Date: Aug 2010
Reputation: 1
Posts: 69
Same problem here, after last update. Work without problem before patch. X6 1055, 16GB, 6870 1GB, Win 7 64bit
jugularis is offline   Reply With Quote
Old 05-08-2012, 03:21 PM   #11
cortez09
 
 
 
Join Date: Dec 2008
Reputation: 628
Posts: 3,830
Same with me i got an i5 750, 4gb ,5770hd

it seems most of us here have AMD GPUs so it might have to do with its drivers
cortez09 is offline   Reply With Quote
Old 05-08-2012, 03:57 PM   #12
jugularis
 
 
 
Join Date: Aug 2010
Reputation: 1
Posts: 69
Can someone from Valve take a look on this issue? Hammer now works, but game itself not. Other Source games without problem. Only P2 after this update. It redownload one 20MB file after each cache verification. It is funny, that my second computer with intel crap gpu (G860 based)works without any problem.
jugularis is offline   Reply With Quote
Old 05-08-2012, 04:01 PM   #13
AceFront
 
 
 
Join Date: Mar 2012
Reputation: 0
Posts: 9
Quote:
Originally Posted by jugularis View Post
It redownload one 20MB file after each cache verification.
IT DOES THE SAME THING FOR ME.

Nothing happens after. If a support mod. at Valve is reading this, please. PLEASE consider fixing this.
AceFront is offline   Reply With Quote
Old 05-08-2012, 08:59 PM   #14
Fixial
 
 
 
Join Date: Jul 2011
Reputation: 0
Posts: 3
Posting my "me too"
AMD Phenom II black
Radeon HD 5770
Win7 64
8GB ram
Fixial is offline   Reply With Quote
Old 05-09-2012, 02:24 AM   #15
OptimusHun
 
 
 
Join Date: Dec 2008
Reputation: 12
Posts: 574
I don't own Portal 2, but maybe it's an AMD issue? I read the specs and all of them have AMD config (CPU and/or GPU). Maybe the AMD dual-core driver needs an update or something?
Sadly I never used AMD. Just Intel/nVidia a decade.
OptimusHun is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.