Go Back   Steam Users' Forums > Dedicated Server Discussions > Source DS (Windows)

Reply
 
Thread Tools Display Modes
Old 05-06-2012, 06:48 PM   #1
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
Angry **PLEASE HELP** -TF2 SRCDS SERVER PORT NOT FORWARDING-

Hello, I am having some major issues with my TF2 server. Just a few months ago my server was working completely fine, then I kind of stalled the server and I recently made a new map, and I wanted to start the server back up on the map I made. To my surprise, my entire port forwarding was not working. For some reason, no matter how hard I try, I CAN NOT get the port 27015 to forward. It says in the console that that is the port I am running on, and I can't get it to forward. I have even forwarded all the ports used in source engine games (27000-27040). I HAVE edited my firewall settings, and even tried disabling my firewall completely. I am using http://canyouseeme.org/ to test if the port is open, and yes, I have the server running while I do this. The funny thing, though, is I can port forward 25565 (Minecraft) completely fine. I have tried changing the port that the server runs off of to 25565, and in that case, the port becomes visible by http://canyouseeme.org/, but NONE of my friends can join, even after putting ":25565" after the IP address. That's pretty much my story, extra info below....

Router:
WRT54G Linksys

Any answers?

PC Specs:
RAM - 8GB
Graphics - Nvidia GTX 580
Processor - Intel Core i5 650

Internet Speed:
Down - 21-25 Mbs
up - 3-4 Mbs

Things I have tried (and hit my desk because frustration over):
1. Upgrading router firmware, didn't work
2. Resetting router settings to factory preset. didn't work
3. Making the Minecraft port the default port. didn't work

Thanks, please reply.

Any answers?

Last edited by 43eyes: 05-07-2012 at 12:08 AM. Reason: Need more answers
43eyes is offline  
Reply With Quote
Old 05-06-2012, 08:04 PM   #2
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
bumb..
43eyes is offline   Reply With Quote
Old 05-06-2012, 09:35 PM   #3
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
Bump...
43eyes is offline   Reply With Quote
Old 05-06-2012, 10:12 PM   #4
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
Guys, I have been trying to figure this out ALL day. Please take the time to read and answer my question, maybe even research...
43eyes is offline   Reply With Quote
Old 05-06-2012, 11:09 PM   #5
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
C'mon guys...
43eyes is offline   Reply With Quote
Old 05-07-2012, 01:32 AM   #6
Seppuldura
 
Join Date: Aug 2004
Reputation: 70
Posts: 723
Looks like this website is using TCP for testing which isn't the right thing to use for a srcds gameserver as the gameserver runs on UDP.
Just make sure you've forwarded the right UDP port and your friends should be able to join via your WAN ip address.
Seppuldura is offline   Reply With Quote
Old 05-07-2012, 09:18 AM   #7
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
Quote:
Originally Posted by Seppuldura View Post
Looks like this website is using TCP for testing which isn't the right thing to use for a srcds gameserver as the gameserver runs on UDP.
Just make sure you've forwarded the right UDP port and your friends should be able to join via your WAN ip address.
Yes, I have tried every port testing website out there, NONE of them see any kind of connection with the port 27015 or I have even tried 27020, no luck with that either. You don't know how many times I told my friends to try and join...I asked so much they got annoyed, they diffidently can't join. They get that "failed after 4 retries" message. I forgot to mention that this server issue thing is affecting all of my VALVE games, Gmod, CS:S, etc. The funny thing is Portal 2 still works.
43eyes is offline   Reply With Quote
Old 05-07-2012, 11:34 AM   #8
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
Quote:
Originally Posted by Seppuldura View Post
Looks like this website is using TCP for testing which isn't the right thing to use for a srcds gameserver as the gameserver runs on UDP.
Just make sure you've forwarded the right UDP port and your friends should be able to join via your WAN ip address.
Are you gong to help me anymore?
43eyes is offline   Reply With Quote
Old 05-07-2012, 12:24 PM   #9
M33CROB
 
Join Date: Jul 2010
Reputation: 213
Posts: 1,096
This might be an issue with your client and your server fighting over port allocation. Keep in mind that only 1 device/service can use a port at a time. Try using a different port for your server. For example, use 28015 and make sure add "-port 28015" to your start up command in addition to forwarding the port.
M33CROB is offline   Reply With Quote
Old 05-07-2012, 01:07 PM   #10
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
Quote:
Originally Posted by M33CROB View Post
This might be an issue with your client and your server fighting over port allocation. Keep in mind that only 1 device/service can use a port at a time. Try using a different port for your server. For example, use 28015 and make sure add "-port 28015" to your start up command in addition to forwarding the port.
Didn't work....I think the problem is in the server not opening the port for some reason....the only port it has ever opened is 25565...and even then my friends couldn't join...it does say in cmd that whatever port the server is running on is "listening" when I type netstat -an |find /i

Last edited by 43eyes: 05-07-2012 at 01:09 PM. Reason: wrong info
43eyes is offline   Reply With Quote
Old 05-07-2012, 06:01 PM   #11
43eyes
 
Join Date: Jul 2011
Reputation: 0
Posts: 27
Quote:
Originally Posted by M33CROB View Post
This might be an issue with your client and your server fighting over port allocation. Keep in mind that only 1 device/service can use a port at a time. Try using a different port for your server. For example, use 28015 and make sure add "-port 28015" to your start up command in addition to forwarding the port.
HEY I FIGURED IT OUT! I just had to change the port it used Minecraft (25565). D For some reason it didn't work the first time.
43eyes is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Dedicated Server Discussions > Source DS (Windows)


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.