Go Back   Steam Users' Forums > Dedicated Server Discussions > Half-Life DS (Windows)

Reply
 
Thread Tools Display Modes
Old 04-02-2012, 01:37 PM   #1
hexi
 
Join Date: Jun 2011
Reputation: 0
Posts: 9
Problems with setting up an ag-server

Hello...

I tried to setup an dedicated server for AG (Adrenalin Gamer), so I downloaded the hlds tool over steam, but when I try to start the server, I cant choose ag. All other mods are available, but not ag. I installed ag for playing and it works fine. I tried to reinstall the whole steam with all my games (including ag and the hlds-tool) and tried to run the hlds again, but the problem is the same: I cant choose ag in hlds.

Anyone can help me please?

hexi.
hexi is offline  
Reply With Quote
Old 04-02-2012, 07:34 PM   #2
R4to0.exe
 
 
 
Join Date: Jan 2009
Reputation: 0
Posts: 34
Hi hexi. I run a AG Brazilian server, so i'll try help you (:

Did you copied the ag folder into hlds folder? (Steam\SteamApps\<accountname>\dedicated server or C:\path\to\hlserver folder for standalone) and don't forget to copy steam_appid.txt from valve folder to ag too.
R4to0.exe is offline   Reply With Quote
Old 04-03-2012, 08:57 AM   #3
hexi
 
Join Date: Jun 2011
Reputation: 0
Posts: 9
Thanks man! This solved my problem.

Next problem: I believe 70 isnt the right steam_appid, coz I cant find my own server. All Ive asked about said 70 is it for ag, but I dont think Ive found one of their servers without they give me the ip. And also: Ive found a site somewhere in inet that I dont remember, where it says some other number for the steam_appid for ag, but Im sorry I dont remember it and dont find the site again. Im pretty sure 70 is false, coz Ive run an ag-steam server in the past with that other appid and found it by myself in the serverbrowser, and with 70 I cant find it.
hexi is offline   Reply With Quote
Old 04-03-2012, 08:31 PM   #4
R4to0.exe
 
 
 
Join Date: Jan 2009
Reputation: 0
Posts: 34
70 is the correct appid for Half-Life and all mods. Try running a standalone hlds on a pc that has no Steam Client installed. Without that, will cause "STEAM Validation Rejected" but i think valve fixed that on 5408 hlds build.

It seems a bug that i was analyzing here. When you have Steam installed on a pc running hlds, it will not show up on server browser (type "setmaster" and you will see "current: none"). If uninstall steam client, everything will work (at least for me, i have 3 pcs and tested on all).

And check if you can connect manually ie favorities or client console "connect xxx.xxx.xxx.xxx:27015").

Regards.

Last edited by R4to0.exe: 04-03-2012 at 08:32 PM. Reason: fix typos
R4to0.exe is offline   Reply With Quote
Old 04-04-2012, 09:27 AM   #5
hexi
 
Join Date: Jun 2011
Reputation: 0
Posts: 9
Hm, ok, then tell me if u can see my server.
Hostname: "Testing hexi". Its setup for up to 5 players and will stay running.
hexi is offline   Reply With Quote
Old 05-09-2012, 03:31 AM   #6
hexi
 
Join Date: Jun 2011
Reputation: 0
Posts: 9
Would be cool if someone could tell me what Im doing wrong coz my server doesnt appear in the Serverlist. I forwarded udp port 27015 in my router, Gameserver is runnin about 10 hourz now but I still cant find it. And yes, in C:/programs x86/steam/steamapps/user123/dedicated server is the file steam_appid.txt with 70 in it. Changed the name of the server to "[MAN]s Bull Server | Arena stalkx 24/7 and nothing else".

Last edited by hexi: 05-09-2012 at 03:40 AM.
hexi is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Dedicated Server Discussions > Half-Life DS (Windows)


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 02:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.