Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 05-11-2012, 01:55 PM   #2026
Elrappy99
 
 
 
Join Date: Sep 2010
Reputation: 10
Posts: 37
My level doesn't build any more. It was building fine throughout the day. Now that I've finished it, the loading wheel reaches the end and then it is stuck there forever. The game is still responding as if I hover over the "cancel" button it eventually lights up a few seconds later.
Elrappy99 is offline   Reply With Quote
Old 05-11-2012, 01:55 PM   #2027
jabir667
 
Join Date: May 2012
Reputation: 0
Posts: 3
game fails to start. locks up and reboots pc. amd cpu. amd gfx.

would really like this fixed asap
jabir667 is offline   Reply With Quote
Old 05-11-2012, 01:59 PM   #2028
Sniper_John_Uk
 
 
 
Join Date: Oct 2006
Reputation: 1
Posts: 134
The ending elevator is incorrectly clip'd
This probably isnt noticeable in the main game, but in PTI maps, if theres a fulled pointed directly at the door, you float into the elevator tube

pic:
http://steamcommunity.com/id/Sniper_...27164154669223
Sniper_John_Uk is offline   Reply With Quote
Old 05-11-2012, 03:05 PM   #2029
hym
 
Join Date: Apr 2012
Reputation: 8
Posts: 20
I ran into 2 bugs with the Portal 2 Editor, both are related to lasers.

Reflection Cubes don't obey the laws of gravity when they are receiving an incoming laser. For example when an active Reflection Cube is on an Angled Panel and the platform is turned off the cube will remain where it was in mid air. This includes being able to get cubes stuck in their Dropper by pointing a laser at it. It seems to be purely a gravity problem I think because on an oscillating Track Platform an active Reflection Cube does respond to the physics and will shift side ways.

The second problem is with wall mounted Laser Relays, they don't activate with their corresponding Laser on the floor. It is however possible to turn them on by pushing a vertical Reflection Cube up against the wall to get the laser to be closer to the surface. But they should work because the distance of the relay from the floor or wall is equal and in the editor they are illustrated as making contact.

I have a room with examples of these bugs and pictures here:
http://steamcommunity.com/sharedfile...s/?id=71454601

Last edited by hym: 05-11-2012 at 06:42 PM.
hym is offline   Reply With Quote
Old 05-11-2012, 03:18 PM   #2030
SandyBridge666
 
 
 
Join Date: Jan 2012
Reputation: 0
Posts: 11
LB button from xbox controller in Co-op, needs a fix too >.<
SandyBridge666 is offline   Reply With Quote
Old 05-11-2012, 11:59 PM   #2031
WakeTheShark
 
 
 
Join Date: Mar 2010
Reputation: 0
Posts: 29
I just bought the game today and ran into an odd glitch at the first part of the game:

In the rest room you start out in, as Wheatley prepares the room to be moved my character flies up to the ceiling, from there I can jump and see through it and when Wheatley moves the room I'm left standing on nothing. D:
WakeTheShark is offline   Reply With Quote
Old 05-12-2012, 12:06 AM   #2032
Delphi
 
Join Date: May 2009
Reputation: 0
Posts: 7
Cursor Disappeared Recently

I hadn't been playing Portal 2 until the most recent update, but at the beginning of it it was fine, and at some point it's not.

A screenshot to this behavior is here: http://steamcommunity.com/id/gdelphi...01264258347951
  • This issue is a graphics issue.
  • I'm currently on Windows 7 (64-bit) with a Core i5-2500K, 16GB of RAM and an NVIDIA GeForce GTX 560 with driver version 296.10 (also tried the beta, 301.24).
  • The exact problem is that the blue/orange portal cursor is gone, and doesn't show up anymore. This happens everywhere, all the time.
  • The only references I've found on the internet relating to the cursor disappearing are when using something called "Eyefinity" but I don't think I have that. I've tried updating my graphics driver and messing with a few of the graphics settings in-game, but nothing's helped thusfar. But one of the settings, when I got back into the game, flickered the cursor ever so briefly, and then it went away.

Last edited by Delphi: 05-12-2012 at 12:09 AM. Reason: Adding screenshot link
Delphi is offline   Reply With Quote
Old 05-12-2012, 01:02 AM   #2033
RockManRespect
 
Join Date: May 2012
Reputation: 0
Posts: 16
Just to elaborate on what someone already said, when using an xbox 360 controller in co-op, trying to ping or gesture results in you getting stuck in a menu that you can never get out of and you have no choice but to quit the game. Please fix this soon.
RockManRespect is offline   Reply With Quote
Old 05-12-2012, 01:38 AM   #2034
Niesrind
 
 
 
Join Date: Jan 2008
Reputation: 6
Posts: 256
In the menu "Community Test Chambers", played levels don't appear in "My History".
Niesrind is offline   Reply With Quote
Old 05-12-2012, 02:53 AM   #2035
Tito Shivan
 
 
 
Join Date: Oct 2010
Reputation: 3384
Posts: 9,025
Probably been stated before but:
Cubes stop moving while in a excursion funnel intersection.
Unlike the player, who follows the new excursion funnel, cubes stop moving whenever they find an intersection of excursion funnels
Tito Shivan is offline   Reply With Quote
Old 05-12-2012, 03:19 AM   #2036
SDBSDBSDBSDB
 
Join Date: May 2012
Reputation: 0
Posts: 1
Quote:
Originally Posted by Floh View Post
Tried to play Coop .... but I always fail,
Portal tells me that the connection ist lost .... 3 friends have the same problem, and just a week ago I could play with them ^^
Quote:
Originally Posted by Shugo Takahashi View Post
Cross-platform co-op between PS3 and PC users is now broken. The PS3 side will load up fine and get to the "waiting for partner" screen, but the PC side loads halfway and then hangs.

The PS3 side eventually disconnects, leaving the PC side to either open the console to escape the stuck loading screen or open the Task Manager to kill the game.

I'm the one on PS3 and it failed to connect to both myself on PC (multiple times) and a friend on PC.
I'm surprised this isn't being mentioned more often, but this is definitely broken. When attempting to play co-op between a PC and PS3, the PS3 continues to load without a problem (blue dots on the loading screen all become yellow and the game starts waiting for the other player), and once that's done the PC side then starts loading, but the blue dots get half-way. The PS3 disconnects within a few seconds after this point.

This is exactly the same as posted above, so yet another confirmation that this is an issue. Co-op was working perfectly fine, even on May 8 just before I allowed the DLC to be installed, and since the DLC was installed this has not worked.

The PC is an i7-980x 3.33GHz with 24GB RAM, Radeon HD 5870 Eyefinity 2GB graphics card, etc. Both machines are on the same LAN, with a 100mbps connection to the Internet. Average latency to most steam servers in the area is under 10ms.

It's nice to have new test chambers in single player mode, but co-op is still the best part of the game for us and it's a shame it's now broken.
SDBSDBSDBSDB is offline   Reply With Quote
Old 05-12-2012, 03:53 AM   #2037
_replay
 
 
 
Join Date: Feb 2011
Reputation: 0
Posts: 17
Hello. I recently found a bug while playing Portal 2 Test Chambers Editor.

http://cloud.steampowered.com/ugc/59...3DC74546A5578/

When you have Pivot Cube on another cube and you remove the cube under Pivot Cube while it's powered by laser it stays frozen in air. It updates after unpowering laser or touching cube.

Another thing is that, laser automatically connect to nearest laser catcher. Even if it isn't at same height level.

http://cloud.steampowered.com/ugc/59...868844EBB28F6/

// EDIT.

Here you can test it :

http://steamcommunity.com/sharedfile...s/?id=71563172

That's what I've achived. Wanted to leave it as mini game but it was laggy as hell probably due to many lasers in chamber ...

http://cloud.steampowered.com/ugc/59...4ECBC6669B55A/

// ANOTHER BUG at menu. Got it randomly after leaving Test Chamber editor.

http://cloud.steampowered.com/ugc/59...3430F3D778D8C/

Last edited by _replay: 05-12-2012 at 04:48 AM.
_replay is offline   Reply With Quote
Old 05-12-2012, 05:57 AM   #2038
dylans
 
Join Date: May 2012
Reputation: 0
Posts: 1
I've got an issue since I downloaded the Perpetual Testing Initiative. Almost instantly when a map loads, items and objects "break". You see like black triangular holes appear in items such as companion cubes, buttons, doors, stairs, even the portal gun in the front.

Pic here http://www.flickr.com/photos/5948398...in/photostream

I've tried lowering texture and shading settings, but no matter what I do those holes keep appearing.
dylans is offline   Reply With Quote
Old 05-12-2012, 01:46 PM   #2039
Sniper_John_Uk
 
 
 
Join Date: Oct 2006
Reputation: 1
Posts: 134
Just had this happen when exiting
http://steamcommunity.com/id/Sniper_...437901?tab=all
I had been alt-tabbing alot, probably related to that
Sniper_John_Uk is offline   Reply With Quote
Old 05-12-2012, 01:59 PM   #2040
jmotuck
 
Join Date: Jan 2011
Reputation: 0
Posts: 2
I am having issues now with this new update hurting cross-platform play. When i try to use my ps3 version and connect to my friend who is on steam we get cut off at the end of the loading screen when we are trying to boot up. I get the error "Your partner has disconnected" while she gets " Different class tables". Not sure if this is an error with the ps3 or pc side but it is beginning to turn frustrating.
jmotuck is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2


Tags
p2 bug tracker

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.