Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Doom series

Reply
 
Thread Tools Display Modes
Old 12-29-2010, 01:58 AM   #1
chronox12
 
 
 
Join Date: May 2009
Reputation: 36
Posts: 619
Doom 3 Mouse Lag

I'm experiencing some severe mouse lag when playing Doom 3 and it's expansion. I have Googled it and done some reading and still haven't found any solution that works. Any help is appreciated.

Thanks.
chronox12 is offline  
Reply With Quote
Old 12-29-2010, 04:21 AM   #2
greyze
 
Join Date: Jan 2004
Reputation: 30
Posts: 338
Same here, just got the game in the sale and it seems completely pointless playing as the mouse is just horrific to use!
greyze is offline   Reply With Quote
Old 12-29-2010, 06:24 AM   #3
Primebeef
 
Join Date: Feb 2009
Reputation: 0
Posts: 45
Agreed, having my arm falling off after few minutes already, fix this .
Primebeef is offline   Reply With Quote
Old 12-29-2010, 07:19 AM   #4
Reynaerdinjo
 
Join Date: Jan 2010
Reputation: 0
Posts: 36
I can't test it right now but try switching vsync off.
Reynaerdinjo is offline   Reply With Quote
Old 12-29-2010, 08:05 AM   #5
Primebeef
 
Join Date: Feb 2009
Reputation: 0
Posts: 45
Vsync was off here, same still
Logitech driver running in the back though.
Primebeef is offline   Reply With Quote
Old 12-29-2010, 08:09 AM   #6
greyze
 
Join Date: Jan 2004
Reputation: 30
Posts: 338
Quote:
Originally Posted by Reynaerdinjo View Post
I can't test it right now but try switching vsync off.
Just tested this idea and "unfortunately" it does help disabling Vsync, but it only helps..

It seems that the mouse is totally buggered on the menu screens, giving very poor mouse movements and some times stop registering movements correctly.

In-game though, the mouse moves better, it moves alot better without Vsync on. But I cannot tolerate this, my monitor is huge and my PC has a crapload of power making this game look very nice but also causing severe flicking. Its horrible with Vsync turned off basically.

So, is there a solution to make the mouse better with Vsync on?

edit: I must mention though, while it is better with Vsync off, its still actually crap.
As the above poster mentioned his mouse driver.. I may aswell too, Logitech Mouse + Driver, G5 Laser Mouse.

Last edited by greyze: 12-29-2010 at 08:11 AM. Reason: Additions
greyze is offline   Reply With Quote
Old 12-29-2010, 08:26 AM   #7
AtlasRapture
 
Guest
Posts: n/a
Have you tried disableing the Logitch driver? Also any happen if you max out mouse smoothness in the games options?
  Reply With Quote
Old 12-29-2010, 09:29 AM   #8
ZeroSignal
 
Join Date: Feb 2005
Reputation: 92
Posts: 1,590
In every single FPS I have ever played, turning on vsync causes mouse lag. I can't think of a single game that doesn't have that problem.

I play Doom3 without vsync, and the mouse extremely responsive. Make sure you have mouse smoothing off, too. I hate that.

I don't use Logitech software, though I do have a Logitech MX518 mouse.
ZeroSignal is offline   Reply With Quote
Old 12-29-2010, 09:39 AM   #9
DIONightmare
 
Join Date: Dec 2008
Reputation: 5
Posts: 142
Try lowering "Flip Queue" value (if you use Radeon cards. You'll need Ati Tray Tools to access this setting) or "Frame Pre-Render Limit" (GeForce cards. Years ago it was available right in the driver control panel, but I'm not sure if it's still there (haven't used NVIDIA cards since 8800GT), so you may want to install RivaTuner).

Depending on what you consider a lag, try setting 2 or even 1 instead of 3 (default value). This will somewhat lower performance in OpenGL applications, but it's not like modern hardware can't run DOOM3 at hundreds of fps with any handicap

You may want to check what kind of AA is used by the game - with extremely high values (or maybe supersampling is activated) DOOM3 may still lag on some machines.
Run console by pressing CTRL+~
then enter
com_showfps 1
and press enter.

You may also want to disable Steam overlay for this game (Steam->Settings->In-Game and uncheck "Enable steam community in-game").
DIONightmare is offline   Reply With Quote
Old 12-29-2010, 07:05 PM   #10
XxLaVaxX
 
 
 
Join Date: Jul 2010
Reputation: 49
Posts: 378
set smooth mouse low
set sensitivity high
commands
in_mouse 0
and / or in_mouse -1
XxLaVaxX is offline   Reply With Quote
Old 10-02-2011, 04:48 PM   #11
Vincii
 
Join Date: Sep 2011
Reputation: 3
Posts: 40
Here's the fix for those of you using Logitech software:

Goto setpointII (or whatever it is you use) and disable "use OS accel and pointer speed". This worked for me and took out the mouse lag entirely.
Vincii is offline   Reply With Quote
Old 05-14-2012, 04:30 PM   #12
tornadoofsharks
 
 
 
Join Date: Oct 2010
Reputation: 5
Posts: 49
Vincii is right. Doom 3 was ignoring any mouse movement that was too slow, rather than being generally laggy or un-sensitive. I changed SetPoint to use its own implementation instead of 'OS Implementation' in the Game settings for the mouse and that fixed it. Funny thing is, I don't even use the Logitech mouse, just the keyboard. This was messing up the motion with my other, non-Logitech mouse.
tornadoofsharks is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Doom series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.