Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games

Reply
 
Thread Tools Display Modes
Old 05-12-2012, 06:08 PM   #1
shiroK
 
Join Date: Apr 2011
Reputation: 0
Posts: 16
TF2 & L4D2 unplayable performance on Mac, even on lowest settings

While I never got great performance on either TF2 or L4D2, I would still manage a decently playable 24-35 fps. However, whatever recent updates have occurred seem to have affected the Source engine underlying both games and caused them both to play now at near slide-show levels even at the absolute lowest game settings. I get a ton of gameplay lag and stutter, and the sound keeps breaking up constantly. If I simply stand still in the game, everything is fine, with only minor fps drop when looking around. However, the moment I try to move about or perform any action, the performance drops into the basement. I've tried turning off Vsync, and I've experimented with dropping to the absolute lowest settings. So far, nothing has made any improvement to the fps when in actual gameplay.

Anyone else getting this sort of problem lately with either of these games or other Source-based games? Anyone find a fix for it?

------

Mid-2008 Macbook Pro
2.5GHz Core 2 Duo
4GB RAM
Nvidia 8600M GT 512MB VRAM
500GB HDD (7200 rpm)
Mac OS X 10.6.8

Last edited by shiroK: 05-13-2012 at 09:14 AM. Reason: Date wrong on machine (O.L.D. Syndrome)
shiroK is offline  
Reply With Quote
Old 05-13-2012, 12:56 AM   #2
jeanlain
 
Join Date: Mar 2010
Reputation: 242
Posts: 967
Something's wrong with your specs. A 2009 Macbook Pro doesn't come with a Geforce 8600M. I suppose it's the 9600M.
I suggest:
make sure the Mac uses the 9600M and not the 9400M.
rebuild game cash
check CPU and memory usage while steam is idle (no game running)
check hard drive free space
repair permissions
jeanlain is offline   Reply With Quote
Old 05-13-2012, 08:55 AM   #3
shiroK
 
Join Date: Apr 2011
Reputation: 0
Posts: 16
Quote:
Originally Posted by jeanlain View Post
Something's wrong with your specs. A 2009 Macbook Pro doesn't come with a Geforce 8600M. I suppose it's the 9600M.
I suggest:
make sure the Mac uses the 9600M and not the 9400M.
rebuild game cash
check CPU and memory usage while steam is idle (no game running)
check hard drive free space
repair permissions
The 9600M did not come out until late 2009, around October/November. I had purchased mine before that time in about the summer of 2009. At that time, i.e. mid-2009, the graphics card was still at the 8600M (yes, I simply purchased at the wrong time).

Regardless, the specs I posted are the specs of the machine at time of purchase, with the exception of the hard drive, which I later upgraded from the stock 250GB 5400rpm drive.

Addendum: Okay, so I'm older and my memory has issues. The machine was purchased mid-2008. I do remember it was just before the switch to the 9600M, for which I was kicking myself, but at the time, I needed better than my then current machine. However, as I said, the specs I listed are, indeed, the specs of the machine.

Last edited by shiroK: 05-13-2012 at 09:09 AM.
shiroK is offline   Reply With Quote
Old 05-13-2012, 08:03 PM   #4
shiroK
 
Join Date: Apr 2011
Reputation: 0
Posts: 16
Playing around with settings, I've come across the following which seems to reduce, but not eliminate, the problem. First, the strangest, is to set the resolution to native screen resolution (in my case, this was 1920x1200). Normally, I play at a scaled down resolution to get a few more fps, but the problem is most pronounced at the lower resolutions (yes, I would actually get a lower effective fps because of all the stutter and lag at these resolutions). The second is to set all the advanced settings to their system recommended values. In addition, in order to bring up my baseline fps, I turned off the full-scene anti-aliasing and vert-sync. Finally, I had to set the sound quality to low (the higher sound qualities seemed to also have increased stutter and lag). These settings seemed to significantly reduce the problem for at least 30-69 minutes of gameplay before the problem started returning, though still not as badly as it would be otherwise.

Based on these findings, I would guess the problem lies in both the sound handling components and the frame buffer components. Also, given that the problem seems to build-up during play, there may be some memory issue, like memory not being handled in an optimized manner (such as constantly allocating and freeing memory on the heap with 'new' or 'malloc' rather than an explicit custom memory manager for high performance needs) or a memory leak of some sort. These are just my guesses; I don't guarantee their validity or veracity in any way. I also don't guarantee what works for my system on this issue will work for others.
shiroK is offline   Reply With Quote
Old 05-13-2012, 09:37 PM   #5
shiroK
 
Join Date: Apr 2011
Reputation: 0
Posts: 16
Did some more tweaks. Since I'm using 10.6.8, I decided to try the launch option '-gl_enable_scaled_resolve', in accordance to the sticky in the forums regarding multi-sampling on Nvidia hardware as of 10.6.5. This significantly improved fps, however, I had to have anti-aliasing turned on for it to be effective; otherwise I would get a lot of stutter and lag if I use this option. Also, I tried setting the heap size with '-heapsize 1048576'. Adding these two launch options, turning on anti-aliasing to recommended settings (in my case, 2X MSAA), and using the recommended settings elsewhere (sound quality still set to low), I experienced a significant gain fps over what I normally experienced prior.

There is still stutter and lag, causing fps to drop to low 10s and single digits at times, but it's not quite as bad as before; it only happens for brief moments rather than being more constant. However, there is still the problem that the stutter and lag does get progressively worse as I play, after about 30 minutes of play. In other words, it's still not great (gameplay still is not as smooth as before I started having this problem), but it's still better than what it has been of late.

Last edited by shiroK: 05-13-2012 at 09:43 PM. Reason: Clarification in the final statement and paragraphing
shiroK is offline   Reply With Quote
Old 05-13-2012, 10:50 PM   #6
shiroK
 
Join Date: Apr 2011
Reputation: 0
Posts: 16
One more tweak. I upped the heap size launch option from 1048576 (1GB) to 1572864 (1.5GB). This seemed to give some slight improvement and resulted in higher top fps (spikes up to 70 fps, up from 55-60). The stutter and lag is noticeably improved, at first, but does degrades over time after about 10-15 minutes of play. Even so, it does result in a slight overall improvement. FYI, I did try setting the heap size for 2GB, but that resulted in degraded performance over the 1GB setting. I was probably taking too much away from system resources and background processes with 2GB.
shiroK is offline   Reply With Quote
Old 05-31-2012, 05:53 PM   #7
somnomania
 
Join Date: Aug 2011
Reputation: 0
Posts: 2
I have almost the same specs, and almost the same problem. Mine isn't unplayable, per se, but it's certainly a little harder to deal with, and there's no way in hell I'm ever going to get L4D achievements that involve precise timing and aim, the framerate is too jerky for that.

2.4GHz Core 2 Duo
4GB RAM
Nvidia 8600M GT 256MB VRAM
500GB HDD (7200 rpm)
Mac OS X 10.6.8

It's a refurbished 17" Macbook Pro, bought a couple of years ago, but obviously an older model than that. I have all my settings on the lowest things possible, and it's still bad, even with no other programs open. I have a menu bar app that lets me free up memory when it's reading low; I average at 2GB of memory free while playing, with a slight decrease the longer I play, but even freeing it up doesn't help. Unfortunately I don't have a different machine to test on, but I wish I did.

Where is it that I can input the two commands you used, and also how do you set the resolution to the native screen resolution? I'd like to try these, to see if they help me at all.
somnomania is offline   Reply With Quote
Old 06-01-2012, 10:57 AM   #8
brim4brim
 
Join Date: Oct 2008
Reputation: 2
Posts: 46
I have a mid 2010 macbook and it fails horribly to run TF2 TBH.

I get better performance out of TF2 playing through PlayOnLinux on my PC.

So I've just installed Bootcamp today as I gave up on it last night when everything became a slideshow at best on lowest settings whenever I left spawn.

Ridiculously poor performance and it used to run better before latest updates but never that great but at least playable before.

Hope they work on optimisation shortly as the specs on Pc really went mad over what they originally were too. They should try to keep at least playable on the original recommended specs.
brim4brim is offline   Reply With Quote
Old 06-03-2012, 12:14 AM   #9
Canarinta
 
 
 
Join Date: Nov 2011
Reputation: 2
Posts: 59
TF2 is horrible on my i7 2011MBP w/ AMD 6750m.

If there's anything to complain about Valve, it's their Mac department.
Canarinta is offline   Reply With Quote
Old 06-10-2012, 10:21 AM   #10
somnomania
 
Join Date: Aug 2011
Reputation: 0
Posts: 2
Quote:
Originally Posted by Canarinta View Post
TF2 is horrible on my i7 2011MBP w/ AMD 6750m.

If there's anything to complain about Valve, it's their Mac department.
Yep, that does seem to be the problem. I finally installed steam and L4D2 on the Bootcamp side of things, and the game runs like a dream, highest settings and everything. The only place I've noticed any problems is when I'm playing with friends rather than in single player, but even there it's my internet, not the computer itself.

I just hope that with all their other awesomeness, Steam will eventually get things evened out between the Mac and PC versions of games. Their OWN games, if nothing else.
somnomania is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.