Go Back   Steam Users' Forums > Steam Tool Discussions > Source Filmmaker

Reply
 
Thread Tools Display Modes
Old 07-12-2012, 04:36 AM   #1
TheHoundGuy
 
Join Date: Jan 2012
Reputation: 0
Posts: 3
Slow Source Filmmaker is Slow :c

I have a problem with SFM since I installed it, the program is very slow everytime I create a new project. Even the most basic controls become annoying due to the slow reaction of the program.

But, this doesn't happen with "already begun" projects such as the Meet the Team .dmx files.I can move the cameras, enter in game mode... faster.

I use an Asus A72J from 2010 with an ATI Mobility Radeon HD 5145 graphic card, i5-450M processor and 4gb of RAM.

Is this problem normal in this computer?
How can I solve this (in case I can)?

I'll appreciate your help
TheHoundGuy is offline  
Reply With Quote
Old 07-12-2012, 04:38 AM   #2
Rosenzweigjcb
 
Join Date: Jul 2012
Reputation: 0
Posts: 28
Yeah, there are some issues with framerate. I think it resides with the loading of assets and such. Just give it a few minutes to load and everything should smooth out.
Rosenzweigjcb is offline   Reply With Quote
Old 07-13-2012, 04:26 PM   #3
TheHoundGuy
 
Join Date: Jan 2012
Reputation: 0
Posts: 3
I gave it time to load (the time to open the program and load the map/project,which takes a bit too much...about 4 mins more or less) and nothing did change, the framerate is 0.5/24.00 (without playing anything) while in mtt_heavy.dmx it's more than 24.00 fps and betweeen 7 and 9 when playing it (I was checking the fps on that file while writting this).

Well, since I can run the meet the files faster than a totally empty project I assume that this has nothing to do with my computer, but I still need to now why this works so slow and how to solve it. :C
TheHoundGuy is offline   Reply With Quote
Old 07-13-2012, 09:07 PM   #4
flamingdeathang
 
Join Date: Feb 2010
Reputation: 25
Posts: 171
Quote:
Originally Posted by TheHoundGuy View Post
I gave it time to load (the time to open the program and load the map/project,which takes a bit too much...about 4 mins more or less) and nothing did change, the framerate is 0.5/24.00 (without playing anything) while in mtt_heavy.dmx it's more than 24.00 fps and betweeen 7 and 9 when playing it (I was checking the fps on that file while writting this).

Well, since I can run the meet the files faster than a totally empty project I assume that this has nothing to do with my computer, but I still need to now why this works so slow and how to solve it. :C
just let it play through the scene once, this forces it to fully load everything.
the MTT videos are EXTREMELY optimized. the maps are MUCH smaller than anything you would ever play in, so it has much less map to ever render. they also tend to use dynamic lights VERY sparingly. I don't think i've seen an extra light that casts shadows in meet the heavy or engie.
the point is: their scenes are more optimized than yours are/can be (you don't have access to the source files so you can't chop out parts of the map you never see, or change the lighting in the map to be perfect so you don't need other lights) so i would suggest turning off lighting (if you use a lot of extra lights. a lot is more than 1 or just 1 extremely large one) and turning off progressive refinement. this stops SFM from making the frame look better when you leave it alone, by calculating motion blur and depth of field. this is good when checking on these things, but other than that, they are useless when editing.

side note: it used to run a lot faster, but now (i believe) it renders at a 720p size then downsizes to your viewport. when the beta was first released, i got a good 50 or so FPS during playback with everything on, now i'm lucky to get 5. but the new version can render much better, regardless of your screen size, so: it's not really a reason to downgrade just yet.

Last edited by flamingdeathang: 07-13-2012 at 09:10 PM.
flamingdeathang is offline   Reply With Quote
Old 07-13-2012, 09:32 PM   #5
episoder
 
Join Date: Aug 2011
Reputation: 112
Posts: 1,714
dunno if you know about performance profiles on laptops. sfm doesn't really trigger your graphics card to boost full flow. so... if you can and it works get the amd vision control center and set your graphics - "power play" - to performance. nonetheless your cpu should be fine. just running the regular power saving scheme.

i run a similar setup. so i hope the comparison makes it a help.
episoder is offline   Reply With Quote
Old 07-14-2012, 12:56 PM   #6
TheHoundGuy
 
Join Date: Jan 2012
Reputation: 0
Posts: 3
Quote:
Originally Posted by flamingdeathang View Post
just let it play through the scene once, this forces it to fully load everything.
the MTT videos are EXTREMELY optimized. the maps are MUCH smaller than anything you would ever play in, so it has much less map to ever render. they also tend to use dynamic lights VERY sparingly. I don't think i've seen an extra light that casts shadows in meet the heavy or engie.
the point is: their scenes are more optimized than yours are/can be (you don't have access to the source files so you can't chop out parts of the map you never see, or change the lighting in the map to be perfect so you don't need other lights) so i would suggest turning off lighting (if you use a lot of extra lights. a lot is more than 1 or just 1 extremely large one) and turning off progressive refinement. this stops SFM from making the frame look better when you leave it alone, by calculating motion blur and depth of field. this is good when checking on these things, but other than that, they are useless when editing.

side note: it used to run a lot faster, but now (i believe) it renders at a 720p size then downsizes to your viewport. when the beta was first released, i got a good 50 or so FPS during playback with everything on, now i'm lucky to get 5. but the new version can render much better, regardless of your screen size, so: it's not really a reason to downgrade just yet.
Playing the whole scene didn't work (a scene with only 1 camera and 1 model, btw) still lagging as hell. But I'm looking forward to try turning off the progressive refinement, the problem is that I don't know how to do it.

Also, thank you for the explanation of why the meet the files runs faster but I've checked that a file I made before the release (using a *cough*torrented*cough*version*cough*of SFM)doesn't have this problem too :/.

I also will try the amd vision control, episoder.
TheHoundGuy is offline   Reply With Quote
Old 07-14-2012, 01:13 PM   #7
chucklenuts
 
 
 
Join Date: Oct 2009
Reputation: 268
Posts: 1,542
Heave you turned off ambient occlusion?
Makes things much smoother for myself, moreso if you disable lights through most of the animation period.
chucklenuts is offline   Reply With Quote
Old 07-14-2012, 04:12 PM   #8
flamingdeathang
 
Join Date: Feb 2010
Reputation: 25
Posts: 171
Quote:
Originally Posted by TheHoundGuy View Post
Playing the whole scene didn't work (a scene with only 1 camera and 1 model, btw) still lagging as hell. But I'm looking forward to try turning off the progressive refinement, the problem is that I don't know how to do it.

Also, thank you for the explanation of why the meet the files runs faster but I've checked that a file I made before the release (using a *cough*torrented*cough*version*cough*of SFM)doesn't have this problem too :/.

I also will try the amd vision control, episoder.
yeah, the original beta ran a LOT smoother, because it was rendering at your view resolution, now it renders in 720p res, then downsizes, so it's a LOT laggier if you have a smaller monitor. so, it's best to just get used to it i guess. and to turn the things off: right click on viewport>click progrssive refinement and enable lighting
flamingdeathang is offline   Reply With Quote
Old 07-15-2012, 06:51 AM   #9
tmek
 
Join Date: Oct 2009
Reputation: 0
Posts: 13
I would also recommend trying different maps, and different sessions. The first session i created ran very slow (especially when crossing clips) for some reason. Since then I've done several other sessions and they all run perfect. I did a lot of time shifting and stretching in that first session also it was the cp_manor_event map. Then I did something similar on 2fort and it was silky smooth during playbacks.
tmek is offline   Reply With Quote
Old 11-01-2013, 07:38 PM   #10
Blue Badger
 
Join Date: Jul 2012
Reputation: 20
Posts: 63
Takes a half hour for me to load any maps.
Blue Badger is offline   Reply With Quote
Old 11-01-2013, 09:48 PM   #11
Haaselh0ff
 
 
 
Join Date: Dec 2011
Reputation: 991
Posts: 3,496
Quote:
Originally Posted by Blue Badger View Post
Takes a half hour for me to load any maps.
Depending on System specs(and the map) it could take you quiet some time, sometimes.
Haaselh0ff is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Tool Discussions > Source Filmmaker


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.