Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Anno series

Reply
 
Thread Tools Display Modes
Old 07-13-2012, 06:30 PM   #1
soccastar001
 
Join Date: Nov 2008
Reputation: 0
Posts: 13
Can't launch Anno 2070

I just bought Anno 2070 for Steam. When I start the game it first asks me if I want to configure my graphics settings. If I pick yes or no it crashes. Then if I launch it from the UPlay window it also crashes, even when I launch it in safe mode. I've tried uninstalling and reinstalling it and disabling my antivirus software (Kaspersky) and I still can't launch the game.
soccastar001 is offline  
Reply With Quote
Old 07-13-2012, 06:58 PM   #2
Strandly
 
Join Date: Oct 2011
Reputation: 25
Posts: 398
I dunno, update your video card drivers.
Strandly is offline   Reply With Quote
Old 07-14-2012, 10:32 PM   #3
ShenaniganNinja
 
Join Date: Mar 2010
Reputation: 0
Posts: 2
Mine also fails to launch, but it doesn't crash windows. It gives me an error saying make sure you aren't already running a game that uses Ubisoft Launcher. I have no other Ubisoft games installed on my computer.
ShenaniganNinja is offline   Reply With Quote
Old 07-14-2012, 11:12 PM   #4
css123
 
 
 
Join Date: Jul 2012
Reputation: 0
Posts: 9
If it gives an error on that it's already running up just have to stop it though the processes menu under task manager. That happened to me as well. I had a similar issue where it would crash upon starting and a quick reinstall fixed it for me. Hope I could help.
css123 is offline   Reply With Quote
Old 07-15-2012, 03:20 AM   #5
Stelly
 
Join Date: Jul 2009
Reputation: 34
Posts: 250
I had a similar problem caused by crossfire.
Disable crossfire in CCC or install cap12.7. This game sucks with either CF and SLI. They added all kinds of useless junk to the game and forgot to make sure the core of the engine was good.
Stelly is offline   Reply With Quote
Old 07-17-2012, 04:30 AM   #6
Amelor
 
 
 
Join Date: Nov 2011
Reputation: 0
Posts: 3
Try to enable Windows XP compatibility mode at uplay.exe and anno.exe, it works for me
Amelor is offline   Reply With Quote
Old 07-17-2012, 09:46 AM   #7
rojimboo
 
Join Date: Feb 2012
Reputation: 52
Posts: 494
Quote:
Originally Posted by soccastar001 View Post
I just bought Anno 2070 for Steam. When I start the game it first asks me if I want to configure my graphics settings. If I pick yes or no it crashes. Then if I launch it from the UPlay window it also crashes, even when I launch it in safe mode. I've tried uninstalling and reinstalling it and disabling my antivirus software (Kaspersky) and I still can't launch the game.
Something similar was happening to me last week, when I started playing Anno again. I had several tweaks (3D sound, SMAA, ini tweaks, and graphics driver tweaks) but the culprit ended up being Nvidia driver settings. I wish I had known before installing and downloading the game twice.

I must have upgraded the drivers at least twice since I last played Anno, during which time Nvidia must have modified the Anno 2070 profile.

As soon as I changed the Nvidia driver profile to default, I no longer got a CTD after launching the game. This was either through Nvidia CP, or more specifically if you do custom tweaks through Nvidia Inspector. You could extrapolate this to ati driver settings too perhaps.
rojimboo is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Anno series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.