Go Back   Steam Users' Forums > Dedicated Server Discussions > Source DS (Windows)

Reply
 
Thread Tools Display Modes
Old 08-01-2012, 12:22 AM   #1
Konyi
 
Join Date: Mar 2011
Reputation: 0
Posts: 28
Socket connection failed (WSAEADDRNOTAVAIL) in L4D

Hi!

I made an l4d dedicated server. I started it and it had worked perfect. Then I installed the sourcemod and metamod. I get this error every time.

Socket connection failed (WSAEADDRNOTAVAIL)
Unable to connect to remote server (0.0.0.0:0)


28.6 fps 0/18 on map l4d_airport01_greenhouse
#Console initialized.
#Unable to remove c:\szerver\l4d\left4dead\addonlist.txt!
#Game.dll loaded for "L4D - Co-op - Normal"
Server is hibernating
Queuing heartbeat send to legacy master server.
Game supporting (2) split screen players
maxplayers set to 18
Unable to remove c:\szerver\l4d\left4dead\addonlist.txt!
NET_GetBindAddresses found 78.92.31.173: 'Broadband Connection'
NET_GetBindAddresses found 169.254.129.21: 'Realtek PCIe GBE Family Controller'
Network: IP 78.92.31.173, mode MP, dedicated Yes, ports 27016 SV / 0 CL
---- Host_NewGame ----
Compact released 196608 bytes to the backing store
Host_NewGame on map l4d_airport01_greenhouse
Executing dedicated server config file
Commentary: Loading commentary data from maps/l4d_airport01_greenhouse_commentar
y.txt.
ServiceStart: started as Windows service
Queuing heartbeat send to steam master server updater.
Queuing heartbeat send to steam master server updater.
--------------------------------------------------------
sv_pure set to 1.
Note: Changes to sv_pure take effect when the next map is loaded.
--------------------------------------------------------
Server logging enabled.
Server logging data to file logs\L078_092_031_173_27016_201208010916_000.log
L 08/01/2012 - 09:16:46: Log file started (file "logs\L078_092_031_173_27016_201
208010916_000.log") (game "C:\Szerver\l4d\left4dead") (version "4716")
Adding master at 78.92.31.173
Writing cfg/banned_user.cfg.
Writing cfg/banned_ip.cfg.
Adding master server 208.64.200.65:27015
Adding master server 208.64.200.52:27011
Connection to Steam servers successful.
VAC secure mode is activated.
rcon password XXXX
Socket connection failed (WSAEADDRNOTAVAIL)
Unable to connect to remote server (0.0.0.0:0)


I can not be admin, the cmd not accept the passwords.
What is the problem? Sorry for my bad english.
Konyi is offline  
Reply With Quote
Old 08-01-2012, 02:38 PM   #2
pizzahut
 
 
 
Join Date: Jan 2003
Reputation: 1135
Posts: 4,681
You need an underscore. Enter in server console:

rcon_password "whatever"

Then when connecting to (joining) your server, type it in your client console, too:

rcon_password "whatever"

And then for actual commands, use a space, entered in the client console:

rcon status
rcon say test
rcon maps *

etc

For using SourceMod rcon isn't necessary though.
pizzahut is offline   Reply With Quote
Old 08-02-2012, 04:41 AM   #3
Konyi
 
Join Date: Mar 2011
Reputation: 0
Posts: 28
Everything is working now! Thanks for help!
Konyi is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Dedicated Server Discussions > Source DS (Windows)


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.