Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sleeping Dogs

Reply
 
Thread Tools Display Modes
Old 08-23-2012, 04:51 PM   #1
Keikogi
 
 
 
Join Date: Sep 2011
Reputation: 0
Posts: 5
Cool Fixed my micro stuttering, weird as f***

Ok so im gonna start and say the first day I got the game it worked great, flawless 120fps no lag or stutter at all. Then one day (in daytime in the game) I noticed a bit of lag, although my fps was at 57...usually this doesn't cause the game to stutter because 57 fps is fairly good, even for my 120hz monitor.

After hours of searching online NONE of the fixes worked (driver updates, turning off vsync.)

So after my many tests with different settings in NVCP, one time I ran the game and it suddenly wasn't stuttering, WHAT DID I CHANGE? nothing. I did nothing different, the game just decided to run nice.

After rebooting the game over 100 times in the past hour I started to press alt+enter at the games first logo screen (where it shows the havoc engine and all the other goodies involved in the game engine)

So heres how I fixed it, and im still trying to wrap my head around this.

1. Run sleeping dogs
2. After the white screen and the first logo screen pops up, hit alt+enter to go into windowed mode.
3. Wait 1-2 seconds (while still looking at the first logo screen) hit alt+enter again to go into fullscreen mode.
4. Unless my hardware config is completely messed up you should have a game with NO DAYTIME MICRO STUTTER.

Hope this helps and im honestly not trolling this worked for me and my game is flawless and beautiful, the stuttering was totally killing the experience for me. I hope the devs see this board so they can figure out wtf is wrong.

Heres my rig:
Intel i5 2500k ~3.7ghz
GeForce GTX 680
8GB DDR3 1866mhz
Windows 7 Ultimate x64

HOPE THIS HELPS AND IM STILL CONFUSED WHY THIS FIXES IT!!!

Last edited by Keikogi: 08-23-2012 at 04:57 PM.
Keikogi is offline  
Reply With Quote
Old 08-23-2012, 06:04 PM   #2
-RecluSe-
 
Join Date: Aug 2012
Reputation: 0
Posts: 31
Quote:
Originally Posted by Keikogi View Post
Ok so im gonna start and say the first day I got the game it worked great, flawless 120fps no lag or stutter at all. Then one day (in daytime in the game) I noticed a bit of lag, although my fps was at 57...usually this doesn't cause the game to stutter because 57 fps is fairly good, even for my 120hz monitor.

After hours of searching online NONE of the fixes worked (driver updates, turning off vsync.)

So after my many tests with different settings in NVCP, one time I ran the game and it suddenly wasn't stuttering, WHAT DID I CHANGE? nothing. I did nothing different, the game just decided to run nice.

After rebooting the game over 100 times in the past hour I started to press alt+enter at the games first logo screen (where it shows the havoc engine and all the other goodies involved in the game engine)

So heres how I fixed it, and im still trying to wrap my head around this.

1. Run sleeping dogs
2. After the white screen and the first logo screen pops up, hit alt+enter to go into windowed mode.
3. Wait 1-2 seconds (while still looking at the first logo screen) hit alt+enter again to go into fullscreen mode.
4. Unless my hardware config is completely messed up you should have a game with NO DAYTIME MICRO STUTTER.

Hope this helps and im honestly not trolling this worked for me and my game is flawless and beautiful, the stuttering was totally killing the experience for me. I hope the devs see this board so they can figure out wtf is wrong.

Heres my rig:
Intel i5 2500k ~3.7ghz
GeForce GTX 680
8GB DDR3 1866mhz
Windows 7 Ultimate x64

HOPE THIS HELPS AND IM STILL CONFUSED WHY THIS FIXES IT!!!
Doesn't work for me, still getting framerate drops during the day. Even if I drop all the settings and lower the resolution I still get crappy peformance during the day time :|, specs are below.

Windows 7 64-bit,Intel i5 2500k 4.5 GHz,PowerColor HD 7870 PCS+,Corsair 8GB DDR3 1600Mhz,Crucial 256GB M4 SSD
-RecluSe- is offline   Reply With Quote
Old 08-23-2012, 06:13 PM   #3
Keikogi
 
 
 
Join Date: Sep 2011
Reputation: 0
Posts: 5
Sorry to hear, maybe keep trying?

When I turned on my PC this morning and ran the game it was stuttering, so I quit and tried this and its working again. This wasn't really a jump to conclusions fix, but im almost positive that its an issue with the fullscren mode because it runs perfect in windowed mode otherwise.
Keikogi is offline   Reply With Quote
Old 08-23-2012, 06:18 PM   #4
-RecluSe-
 
Join Date: Aug 2012
Reputation: 0
Posts: 31
Hopefully theres a patch that improves it or maybe with the drivers, i'm getting a 670 next week so maybe i'll have more luck. Having said that ive seen many people like yourself with a 670/680 who have the same issues. So i won't hold my breath.
-RecluSe- is offline   Reply With Quote
Old 08-23-2012, 07:21 PM   #5
elpibepiola
 
Join Date: Jul 2012
Reputation: 97
Posts: 626
alt + enter s me up in a lot of games. mp3 had this issue, everytie i did alt + enter i would og down to 15 fps. sleeping dogs doesnt seem to have that issue from my exp but good find OP some people dont realize these things. ive learned the hard way
elpibepiola is offline   Reply With Quote
Old 08-27-2012, 09:32 AM   #6
jerroldsimb
 
 
 
Join Date: Jul 2012
Reputation: 0
Posts: 10
Nope the only way i fixed micro stuttering in Sleeping Dogs was to disable my other Radeon 6970 (or run in windowed mode booo)

CF in this game is bad - need new profiles soon

I still get constant 60fps w/ under 1ms variation at 2560x1440 with all things maxed except HBAO (high) Ambient Occlusion and Normal AA (FXAA normal, No MSAA) - so pretty smooth with one card

Luckily at that that resolution for my 27" display (0.2331mm ^ 2 pixel area, or about 20% tighter) jaggies are pretty minimal and HBAO is hardly noticable in for me, especially in motion.
jerroldsimb is offline   Reply With Quote
Old 08-31-2012, 07:16 PM   #7
ExcessiveGBH
 
Join Date: Jul 2012
Reputation: 0
Posts: 5
This worked for me. 2 x680's driver 306.02
ExcessiveGBH is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sleeping Dogs


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.