Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Left 4 Dead 2

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 09-13-2012, 08:18 PM   #331
superdog_5678
 
 
 
Join Date: Aug 2009
Reputation: 6032
Posts: 839
Quote:
Originally Posted by vmxgroove View Post
... I'm open to any suggestions that you may have.
Here are entires from November 2010 right up to us with the same problem. Look to see if there are any fixes you haven't tried.

Link.

I recommend the easier ones first:
  • Verify integrity
  • Remove launch options
  • Launch from Library
  • Delete addons
  • Delete game and L4D2 files and reinstall
superdog_5678 is online now   Reply With Quote
Old 09-13-2012, 11:03 PM   #332
vmxgroove
 
Join Date: Aug 2012
Reputation: 23
Posts: 20
Quote:
Originally Posted by superdog_5678 View Post
Here are entires from November 2010 right up to us with the same problem. Look to see if there are any fixes you haven't tried.

Link.

I recommend the easier ones first:
  • Verify integrity
  • Remove launch options
  • Launch from Library
  • Delete addons
  • Delete game and L4D2 files and reinstall
OK I understand. I'll try all this stuff again. Thank you for the information. I'll let ya know if any of this works.
vmxgroove is offline   Reply With Quote
Old 09-14-2012, 12:04 AM   Click here to go to the next staff post in this thread.   #333
chetf
 
chetf's Avatar
 
Valve
Join Date: Jan 2005
Reputation: 1310
Posts: 340
Quote:
Originally Posted by POLICEMATRIX View Post
this is a disgrace still not fixed and lots of updates for a free game come on..... people paid good money here
The issue has been fixed. I have messaged vmxgroove numerous times, he has another issue preventing him from connecting to certain servers, it has nothing to do with the initial problem noted in this thread.

Thanks
chetf is offline   Reply With Quote
Old 09-14-2012, 12:37 AM   #334
POLICEMATRIX
 
 
 
Join Date: Nov 2011
Reputation: 545
Posts: 3,230
Quote:
Originally Posted by chetf View Post
The issue has been fixed. I have messaged vmxgroove numerous times, he has another issue preventing him from connecting to certain servers, it has nothing to do with the initial problem noted in this thread.

Thanks
well thank you , and thats just what we needed some official word , also any news about what the update originally was for ?
POLICEMATRIX is offline   Reply With Quote
Old 09-14-2012, 09:36 AM   #335
kacper4646
 
 
 
Join Date: Aug 2012
Reputation: 4
Posts: 3
Quote:
Originally Posted by chetf View Post
The issue has been fixed.
Thanks
I still get that error when I use quick game. There is no problem while connecting form lobby, but when I get disconnected from the server I joined through lobby I am unable to reconnect because of VAC-addons-error. I use some custom models, kaizen config and some boot parameters (recently i redownloaded whole game but no change). I used all these custom things before update so they should not be a problem. Any advice on that beside the obvious "reinstal / delete all/ don't use addons ? Perhaps the issue is not completely fixed?
kacper4646 is offline   Reply With Quote
Old 09-14-2012, 09:54 AM   #336
Sgt_Svg101
 
Join Date: Aug 2012
Reputation: 4
Posts: 27
Quote:
Originally Posted by POLICEMATRIX View Post
...any news about what the update originally was for ?
Well, apparently this is the update that started the whole mess:


25 Aug 2012Left 4 Dead 2 - Authoring Tools Update Released
Product Update - Valve
Updates to Left 4 Dead 2 - Authoring Tools have been released. The updates will be applied automatically when your Steam client is restarted. The major changes include:
- Added handlers for two crash types that weren't getting picked up by our crash reporting system

The original thread is below
http://store.steampowered.com/news/?appids=550
Sgt_Svg101 is offline   Reply With Quote
Old 09-14-2012, 11:06 AM   #337
vmxgroove
 
Join Date: Aug 2012
Reputation: 23
Posts: 20
Quote:
Originally Posted by chetf View Post
The issue has been fixed. I have messaged vmxgroove numerous times, he has another issue preventing him from connecting to certain servers, it has nothing to do with the initial problem noted in this thread.

Thanks
That's incorrect. Actually, it has been the same issue all along. Since the Steam Client update in question, many of us continue have the same error. For the record, you and I only have 3 messages between us. NOT numerous as you have indicated. Please don't spin this. I can post our messages if you'd like. At this point, it appears that the initial update caused corruption of the Steam Client installed on my system. This is why I cannot connect.
vmxgroove is offline   Reply With Quote
Old 09-14-2012, 11:28 AM   #338
vmxgroove
 
Join Date: Aug 2012
Reputation: 23
Posts: 20
Quote:
Originally Posted by POLICEMATRIX View Post
well thank you , and thats just what we needed some official word , also any news about what the update originally was for ?
I agree with POLICEMATRIX. We just needed someone to help us fix this. NOT just pretend that it is all fixed. IT IS NOT... As of today I still have the exact same issue that started with the Steam Client update. All of the people that played on my Local Server last night are still having the same problem. I know this because I ask them when they join. The problem isn't the mistake. It's the lack of information and attempt to discount our reports that it is still occuring. Bad customer service.
vmxgroove is offline   Reply With Quote
Old 09-14-2012, 04:58 PM   #339
vmxgroove
 
Join Date: Aug 2012
Reputation: 23
Posts: 20
OK, problem resolved. Yes it was in fact a corruption caused by the update. I don't get why only some of us were affected, but that's what happened. If anybody is still experiencing this error, you MUST do the following:

1) Back up your game, including your spray if you have one

2) Uninstall Steam and L4D2

3) Delete ANY files left behind

4) Reboot your computer

5) Reinstall Steam and then L4D2

6) Re-import your spray. For whatever reason the backup misses that.

7) Get online and kill some Zombies! They deserve it.
vmxgroove is offline   Reply With Quote
Old 09-15-2012, 04:12 AM   #340
kacper4646
 
 
 
Join Date: Aug 2012
Reputation: 4
Posts: 3
Lightbulb

Quote:
Originally Posted by vmxgroove View Post
OK, problem resolved. Yes it was in fact a corruption caused by the update. I don't get why only some of us were affected, but that's what happened. If anybody is still experiencing this error, you MUST do the following:

1) Back up your game, including your spray if you have one

2) Uninstall Steam and L4D2

3) Delete ANY files left behind

4) Reboot your computer

5) Reinstall Steam and then L4D2

6) Re-import your spray. For whatever reason the backup misses that.

7) Get online and kill some Zombies! They deserve it.
I confirm. It worked for me. Thank you.
kacper4646 is offline   Reply With Quote
Old 09-23-2012, 09:33 PM   #341
gwales
 
Join Date: Apr 2010
Reputation: 0
Posts: 8
Valve doesn't give a , right? I don't want, and shouldn't have, to reinstall, etc. There are all kinds of potential problems here for non-expert computer users.

I have been using Steam since its beginning, and I find this an inexplicable and contemptible treatment of users. Reminds me of Apple at its worst.
gwales is offline   Reply With Quote
Old 09-23-2012, 09:46 PM   #342
gwales
 
Join Date: Apr 2010
Reputation: 0
Posts: 8
So I uninstalled Steam and ALL my files were deleted.
gwales is offline   Reply With Quote
Old 09-23-2012, 10:10 PM   Click here to go to the next staff post in this thread.   #343
chetf
 
chetf's Avatar
 
Valve
Join Date: Jan 2005
Reputation: 1310
Posts: 340
If you are still having this issue - can you pm me with the steps you have taken and where you are located? Please also include your steam account name if you don't link to it already.

The original issue is resolved - the unsigned binaries are signed - that's what is in the depot. It should be working. We cannot replicate it not working. Some people are either not getting the binaries updated or something else is happening - so please, pm me.

thanks
chetf is offline   Reply With Quote
Old 09-25-2012, 11:58 PM   This is the last staff post in this thread.   #344
chetf
 
chetf's Avatar
 
Valve
Join Date: Jan 2005
Reputation: 1310
Posts: 340
If you are still having this issue - please check to see if you are running with -insecure in your launch line. Please remove it.

If you are running that way and try to connect to a dedicated server you can get the "remove plug-ins" message instead of saying you need to run in a secure method. We will have a message change in the next update to help clarify the issue you are having.

Reinstalling just worked because it wiped your command line launch options.
chetf is offline   Reply With Quote
Old 11-06-2012, 10:43 AM   #345
Gurluas
 
Join Date: Jun 2006
Reputation: 45
Posts: 1,078
This is still not working for me. Is Metamod and Sourcemod no longer authorized?
Gurluas is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Left 4 Dead 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.