Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Just Cause series

Thread Tools Display Modes
Old 09-11-2012, 05:16 PM   #1
Join Date: Apr 2012
Reputation: 0
Posts: 1
Angry Fatal DirectX Error! Code 3

So I have recently upgraded to windows 8, and I'm loving it. It can run all my games and everything at a faster speed then windows 7 did, except for just cause 2. Whenever I open it, I get this error:

Fatal DirectX error!
Result: 0x887A0002: DXGI_ERROR_NOT_FOUND

The game will now exit. Try starting the game with /failsafe if the problem persists.

Now the game was working on windows 7 before, and yes, I'm almost positive all my graphics cards and Direct X drivers are up to date.
I have read forums where people have been saying that just cause 2 works flawlessly on windows 8, and I cant even get it to run.
Anyone know whats going on?
SooperPsycho is offline  
Reply With Quote
Old 09-12-2012, 09:13 AM   #2
Join Date: Jul 2012
Reputation: 693
Posts: 3,234
Try starting it with /failsafe as it said.

Also, Windows 8 is just preview, I really hope you installed it virtually/dualboot. It doesn't work correctly yet, and probably won't work with all hardware.

Just use Windows 7.
Maverick is offline   Reply With Quote
Old 10-02-2012, 08:42 AM   #3
Join Date: Sep 2012
Reputation: 0
Posts: 4
I am having the same issue. I got it to work once but subsequent runs have thrown this error. No matter what updates I do or direct x fixes I try. Every other game runs perfectly fine!
ha1o2surfer is offline   Reply With Quote
Old 10-14-2012, 07:27 PM   #4
Join Date: Aug 2012
Reputation: 0
Posts: 2
I'm having the same problem. I downloaded the demo after playing it on my friend's PS3, but I'm getting the same error as you except it says Code 15 and E_INVALIDARG instead of DXGI_ERROR_NOT_FOUND. How do I start it with /failsafe? I went to the Properties and Set Launch Options and typed /failsafe but it still didn't work. I'm on Windows 7, by the way.
galactic11 is offline   Reply With Quote
Old 10-22-2012, 10:15 AM   #5
Join Date: Sep 2012
Reputation: 0
Posts: 4
Right click on the game title and click the properties option. Then under the General Tab, at the bottom, click Set Launch Options. Then type /failsafe.
ha1o2surfer is offline   Reply With Quote
Old 10-23-2012, 10:03 PM   #6
Join Date: Feb 2011
Reputation: 0
Posts: 9
Same issue

Hey there, I've had the same issue ever since I got my current laptop. I have a Dell XPS L701x with an Nvidia GeForce 435m. I'm running the final build of Windows 8 as well right now, yet I have also had this problem on multiple different installations of Windows 7. I am 100% confident that all of my drivers are up to date and that all dependencies have been fulfilled, yet the problem persists. I have looked into this issue on more than one occasion over the past year and have not yet found a solution to rectify this error. I'm surprised to see such a new post! Hope we find a fix soon, this game looks awesome.

Edit: adding /failsafe to the launch options through Steam did nothing.
thejakenixon is offline   Reply With Quote
Old 10-25-2012, 06:37 PM   #7
Join Date: Sep 2012
Reputation: 0
Posts: 4
ok, after a lot of searching and almost giving up... The newest beta driver has solved my issues!!!


be sure to do a clean install of the driver. SOOO HAPPY!! Just Cause 2 works perfectly!!

FYI, I Run Windows 8 x64 on my W110ER, 3630QM and the GT650m in Optimus.
ha1o2surfer is offline   Reply With Quote
Old 01-10-2013, 06:44 AM   #8
Join Date: Jan 2013
Reputation: 0
Posts: 3
try this it worked for me:
cat2tiger1 is offline   Reply With Quote

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Just Cause series

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -7. The time now is 09:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2015, All Rights Reserved.